Community discussions

 
gotsprings
Forum Veteran
Forum Veteran
Topic Author
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Forcing my TV back to 5Ghz

Tue Jun 26, 2018 12:18 am

I have an OLED TV that has a tendency to jump on the 2.4 radio for wireless. It is about 18Feet away from the access point... and as its a TV... it doesn't move around.

I made and access list entry to try to keep it on the 5Ghz radio.
Well I found that the TV would decide it wanted to be on the 2.4 radio and if it couldn't get on... it gave up. It no longer TRIED to get on the 5Ghz radio.

I saw the TV was off line in the wireless client table. So I allowed it to join 2.4. Got right on. Then I "kicked the TV off" by using the - in the registration table.

So here is my idea for a work around.

Check every 10 minutes if the TV is on the 2.4 radio. If it is... issue the remove command. This has caused the TV to select the 5Ghz radio and connect every time I tested it by force.
/system scheduler
add interval=10m name=OLEDRadio on-event=OLED policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
/system script
add name=OLED owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":local Radio [/interface wireless regi\
    stration-table get [find comment~\"OLED\"] interface]\r\
    \n#:log info \$Radio\r\
    \n\r\
    \n:if (\$Radio =\"wlan2\") do={\r\
    \n    #:log info \"Its on the Right Radio\"\r\
    \n} else= {\r\
    \n    :log info \"Get off the 2.4 RADIO!!!\"\r\
    \n    /interface wireless registration-table remove [find comment~\"OLED\"]\r\
    \n}" 
    
Hopefully this can help someone else.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: Forcing my TV back to 5Ghz

Tue Jun 26, 2018 5:13 pm

Or you could just create VAP with different SSID’s for 2.4 and 5.8 in addition to the common SSI. And just connect to the 5.8 SSID.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: Forcing my TV back to 5Ghz

Tue Jun 26, 2018 8:04 pm

Why not create a connect list rule that disallows the TV from the 2 GHz radio? Then it will not have a choice but to use the 5 GHz.

I have found that all of the ChromeOS-based devices in my home (not just computers...) jump around a lot when there are multiple 5 GHz APs available with the same SSID, especially when they have a similar Rx signal strength at the station location.

To prevent this from happening, I have set the connect list rule, and I have also turned off 2 GHz altogether. Right now I'm doing the latter as I only have 2 devices in the house that need 2 GHz anyway. So I have one 2 GHz AP enabled that is far away from most stations, and it is disabled on all other APs.

If you cannot get your TV to connect to 5 GHz after trying these two approaches, you might just need to hard power cycle your TV (by the power cord, not just off/on), or even do a factory reset. (Unrelated, but I used to have to factory reset my old Vizio TV every 6-9 months or the apps would just stop working. Sigh.)
 
gotsprings
Forum Veteran
Forum Veteran
Topic Author
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: Forcing my TV back to 5Ghz

Tue Jun 26, 2018 9:16 pm

2Frogs and yottabit.

As i stated... the TV decides it doesn't want to be on 5 and drops back to the 2.4. When i denied it access to the 2.4... it stopped trying to connect to the 5 UNTIL it got back on the 2.4.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: Forcing my TV back to 5Ghz

Tue Jun 26, 2018 10:28 pm

2Frogs and yottabit.

As i stated... the TV decides it doesn't want to be on 5 and drops back to the 2.4. When i denied it access to the 2.4... it stopped trying to connect to the 5 UNTIL it got back on the 2.4.
Because the AP can kick the device - but it has no way to tell it what to do next. Your tv likes 2,4GHz better, and hate 5GHz. Don't know why.

Do what was suggested: create a Virtual AP, with another SSID, and connect the TV in it. This Virtual Ap will be 5GHz only. Forget about kicking the TV - there will be only a 5GHz AP for it to access.

If even then this doesn't work, then You have another problem in your hands.

Who is online

Users browsing this forum: No registered users and 27 guests