Page 1 of 1

Sharing Motel WiFi

Posted: Sun Aug 19, 2018 1:13 am
by neutronlaser
Is it possible to connect a MikroTik to a wifi hotspot with login (e.g. motel wifi), and the Mikrotik then make its own wifi network that multiple devices could use? Perhaps with double NATing?

Re: Sharing Motel WiFi

Posted: Sun Aug 19, 2018 1:28 am
by BartoszP
Yes.
Use any dual band device. Use one WiFi interface as WAN and the second connect to LAN bridge.

Re: Sharing Motel WiFi

Posted: Sun Aug 19, 2018 1:32 am
by neutronlaser
Can it be done with a single band device? I understand it would be transmitting and receiving on the same channel.

Re: Sharing Motel WiFi

Posted: Sun Aug 19, 2018 8:51 pm
by axo
I used to do this with plain end home user APs, just set them up as AP client bridges, but if you want to make your own lan i would use a router with the separate channels as previously suggested.

Re: Sharing Motel WiFi

Posted: Mon Aug 20, 2018 8:06 am
by Jotne
Can it be done with a single band device? I understand it would be transmitting and receiving on the same channel.
No, you need two radios.
One that is connected to the Hotel WIFI, and one that you do connect to.

If you like to only use 2.4GHz, you need to boxes.
With one dual ban box, you can connect to Hotel Wifi using 2.4GHz and then the 5GHz to connect to your device.

So you can use 2 x hAP Mini (total cost 40USD)
Or one hAP ac lite (2.4 and 5GHz) ( total cost 49USD)

If you do not need to connect your device to wifi, you can connect to an ethernet port on a hAP Mini (total cost 20USD)

Re: Sharing Motel WiFi

Posted: Wed Aug 22, 2018 9:11 pm
by AlainCasault
Wrong, Wrong, wrong.

It CAN be done with a single radio.

Wlan1 is setup as a WiFi ( and dhcp) client. Then, create a vap that is an AP (with all regular configs).

I do this with a mAP or mAP lite, but all WiFi models will do it also. The mAPs are just very portable.

So yes, it can be done.

Sent from Tapatalk


Re: Sharing Motel WiFi

Posted: Wed Aug 22, 2018 9:27 pm
by Jotne
So with one radio you can setup two SSID. One that connects to the network, and one that you connects to?

Could you please post the config?

Re: Sharing Motel WiFi

Posted: Wed Aug 22, 2018 10:02 pm
by AlainCasault
Most definitely.

I'm not in front of a router right now but look up VAP ( virtual access point) if you're in a hurry.

Real easy once you know (like everything else in life :D ).

I suggest you configure wlan1 as a client first since you'll know right away if you have hotspot connectivity.

The rest is vap. I'll try to post a config asap.

Cheers,

Sent from Tapatalk


Re: Sharing Motel WiFi

Posted: Wed Aug 22, 2018 11:13 pm
by neutronlaser
AlainCasault, do you know how to make the VAP match the channel of the access point it is connecting to, automatically?

Re: Sharing Motel WiFi

Posted: Wed Aug 22, 2018 11:50 pm
by mkx
When you configure VAP, there's setting which binds VAP to "master" AP (master-interface=wifi1). VAP essentially inherits "master" AP physical settings (frequency, band, channel width, ...), other settings (such as SSID, security profile, mode of operation, even MAC address) are its own. This means that "master" AP can be set as "station" while VAP can be "ap bridge" ... which is what OP wants to have.

Re: Sharing Motel WiFi

Posted: Thu Aug 23, 2018 9:00 pm
by AlainCasault
@Jotne
Here's my (partial) config as requested.

/interface wireless
###BASIC WLAN1 SETUP. BOGUS SECURITY PROFILE TO PREVENT ROUTER FROM CONNECTING TO ANY "OPEN" WI-FI. NOTE ALSO EMPTY SSID.
set [ find default-name=wlan1 ] antenna-gain=1 band=2ghz-onlyn country=canada \
    default-forwarding=no disabled=no distance=indoors frequency=auto \
    frequency-mode=regulatory-domain radio-name=mAP-Alain security-profile=\
    Bidon ssid="" wireless-protocol=802.11

###VAP HERE. VAP BROADCASTS HOME SSID WITH SAME SECURITY PROFILE. WE DON'T HAVE TO RECONFIGURE OUR DEVICES WHILE ON THE ROAD.
add disabled=no keepalive-frames=disabled mac-address=4E:5E:0C:6C:64:0C \
    master-interface=wlan1 multicast-buffering=disabled name=[b]wlan2 [/b]\
    security-profile=MAISON ssid=DSWLAN wds-cost-range=0 wds-default-cost=0 \
    wps-mode=disabled

###CONNECT LISTS TO SPECIFY SSIDs TO CONNECT AND SECURITY PROFILES TO USE
/interface wireless connect-list
add comment="Park Lane Inn & Suites" interface=wlan1 security-profile=default ssid=Park_Lane_Guest_WiFi wireless-protocol=802.11
add comment="Country Inn Lexington VA" interface=wlan1 security-profile=default ssid=country wireless-protocol=802.11
add comment="Grand Times Hotel" interface=wlan1 security-profile=times ssid=Times wireless-protocol=802.11
ETC.

### 
###VAP AND ONE ETHERNET ARE ON LAN BRIDGE. PRETTY STANDARD SETUP FROM THERE
###
/interface bridge
add admin-mac=4C:5E:0C:6C:64:0B auto-mac=no name=LAN

/interface bridge port
add bridge=LAN interface=ether2
add bridge=LAN interface=wlan2

/ip address
add address=192.168.255.1/24 comment=LAN interface=LAN network=192.168.255.0
/ip dhcp-client
add comment="default configuration" default-route-distance=5 dhcp-options= hostname,clientid disabled=no interface=wlan1
add comment="default configuration" default-route-distance=5 dhcp-options=hostname,clientid disabled=no interface=ether1

/ip pool
add name=pool-LAN ranges=192.168.255.10-192.168.255.254
/ip dhcp-server
add address-pool=pool-LAN disabled=no interface=LAN name=dhcp-LAN
/ip dhcp-server network
add address=192.168.255.0/24 comment=LAN dns-server=192.168.255.1 gateway=192.168.255.1

###
FIREWAL FILTERS, NAT, ROUTING AND OTHER PARAMETERS OMITTED FOR SIMPLICITY'S SAKE
###

With this setup, I can now connect all my devices as if I was at home from any hotel, Starbucks or McDonald's. I also benefit from a firewall as I don't trust public hotspots. I also configured L2TP/IPSec to home so that I can manage my home network while I'm away.

Hope this helps.

Cheers!

Re: Sharing Motel WiFi

Posted: Thu Aug 23, 2018 10:22 pm
by Jotne
I also benefit from a firewall as I don't trust public hotspots.

Thanks. I will test it out.

All time I am connected to a public WIFI, I always user L2TP/IPSEC to my MT at home. Do not trust any open site. :)

How do I setup the security profile?
security-profile=Bidon

Re: Sharing Motel WiFi

Posted: Fri Aug 24, 2018 3:50 pm
by AlainCasault
I also benefit from a firewall as I don't trust public hotspots.

Thanks. I will test it out.

All time I am connected to a public WIFI, I always user L2TP/IPSEC to my MT at home. Do not trust any open site. :)

How do I setup the security profile?
security-profile=Bidon

Same as you would for any non-VAP setup. That's the beauty of it, it seems hard, but it's not :)
Wireless --> Security profile