Community discussions

 
Askey307
newbie
Topic Author
Posts: 49
Joined: Fri Sep 29, 2017 10:20 am
Location: South Africa
Contact:

RB2011 Wireless Performance Troubleshoot

Wed Sep 12, 2018 3:38 pm

Good Day Everyone

Need help with improving the throughput on this board's wireless. Currently, next to it (2m radius), people get maximum 34mbps download and 15mbps upload. One device at a time. After 10 meters one barely get 1mbps download. This test has been conducted in high interference areas (-98 noise) and low interference (-113 noise). Same results. Please see the current config below. I work as the technical oak in a big distributor, we get a lot of complaints about the wireless performance of the RB2011, thus me and my team set out to test the complaints with 7 RB2011's. Same results.

Topology are as follow:

1000mbps business fiber line coming in. The line going into Port1 under a bridge setup. Using 9 different phones to test and 4 laptops. The bridge is set up with Fast Forward.

Here is a basic wireless setup that we use to test.

# jan/01/2002 01:52:49 by RouterOS 6.43
# model = 2011UiAS-2HnD

/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
management-protection=allowed mode=dynamic-keys name=profile1 \
supplicant-identity="" wpa-pre-shared-key=Nullvoid_Death \
wpa2-pre-shared-key=Nullvoid_Death
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn country="south africa" \
disabled=no mode=ap-bridge security-profile=profile1 ssid=Redavour \
tx-power=27 tx-power-mode=all-rates-fixed wireless-protocol=802.11
/interface bridge port
add bridge=bridge1 interface=all trusted=yes
/ip dns
set allow-remote-requests=yes
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=\
established,related
add action=accept chain=forward connection-state=established,related
/system routerboard settings
set silent-boot=no
 
User avatar
nest
Forum Veteran
Forum Veteran
Posts: 811
Joined: Tue Feb 27, 2007 1:52 am
Location: UK
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Wed Sep 12, 2018 4:04 pm

I can see the problem immediately. You are running far too high a transmitter power, setting all data rates to use the same high power regardless of MCS rate and as a result the transmissions are all going out distorted (google EVM) causing even short distance and nearby located devices from not working at high data rates and therefore having to drop to lower MCS data rates to enable any reliable communications. Try running this on your pre-configured RB2011 to reduce the Tx power levels and to make sure some other settings are right...

/interface wireless
set [ find default-name=wlan1 ] distance=indoors frequency-mode=regulatory-domain country="south africa" antenna-gain=2 scan-list=2412,2437,2462 channel-width=20mhz wireless-protocol=802.11 rx-chains=0,1 tx-chains=0,1 ampdu-priorities=0,1
Ron Touw - Mikrotik Certified Trainer
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/category/166
Largest Official UK MikroTik Distributor
IRC channel: #routerboard on irc.z.je (IPv4), 6.irc.z.je (IPv6)
 
Askey307
newbie
Topic Author
Posts: 49
Joined: Fri Sep 29, 2017 10:20 am
Location: South Africa
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Thu Sep 13, 2018 9:28 am

I can see the problem immediately. You are running far too high a transmitter power, setting all data rates to use the same high power regardless of MCS rate and as a result the transmissions are all going out distorted (google EVM) causing even short distance and nearby located devices from not working at high data rates and therefore having to drop to lower MCS data rates to enable any reliable communications. Try running this on your pre-configured RB2011 to reduce the Tx power levels and to make sure some other settings are right...

/interface wireless
set [ find default-name=wlan1 ] distance=indoors frequency-mode=regulatory-domain country="south africa" antenna-gain=2 scan-list=2412,2437,2462 channel-width=20mhz wireless-protocol=802.11 rx-chains=0,1 tx-chains=0,1 ampdu-priorities=0,1
Default config has been used, default rates has been used, lower tx rates have been used, even filling out the Antenna gain fields. All give the same result. I never touch the TX power on our High sites or with our clients. Never had to. All rates fixed on this board is for testing purposes only.

Via the LAN we get a full 997mbps throughput.
This config I've used on the CAP Lite, RB951, RB941, RB931, RB951G, RB962 as well as on aRB922 with an Omni on. Each one of them performs seamlessly (Default TX Power), even the RB931 gives better wireless performance and distance. We have 7 RB2011's next to each other. Each gives the same bad results. One of the things I think is that the board is not properly optimized to perform with 2x 4db antennas.
 
Askey307
newbie
Topic Author
Posts: 49
Joined: Fri Sep 29, 2017 10:20 am
Location: South Africa
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Thu Sep 13, 2018 9:35 am

We also found yesterday that a cheap TP-Link and Tenda router with 2db antennas have better signal strength when connecting to another "Unnamed Router" with a 1.5db antenna as a bridge connection over 43 meters. With a latency of 1-2ms and signal strength of -59 where 2011 connects at -72 with 11-49ms erratic latency. The one client who asked us to test this is a client who buys every month more than 900 routerboards(RB941, RB951, RB952's) and a lot other wisp hardware from us. Major ISP which still grows. Thus I would like to help them out because the entire ISP is running Mikrotik only, from CCR's, CRS's, RB's and CSS. 13x42U server racks filled. Thus I do not want to let them down. They're scared the new RB4011 might follow the same route as the 2011. I assured them that the board will be a huge improvement.
 
Askey307
newbie
Topic Author
Posts: 49
Joined: Fri Sep 29, 2017 10:20 am
Location: South Africa
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Fri Oct 12, 2018 10:52 am

Ok so after upgrading from 6.43 to 6.43.2 the problems ceased. It gets decent throughput and performance but still not compared to a RB941's throughput performance with the exact same settings and firmware.
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1110
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Mon Oct 15, 2018 2:08 pm

Ok so after upgrading from 6.43 to 6.43.2 the problems ceased. It gets decent throughput and performance but still not compared to a RB941's throughput performance with the exact same settings and firmware.
Have you actually tried Nest's suggestion? What that guy doesn't know about WiFi isn't worth knowing!
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
Askey307
newbie
Topic Author
Posts: 49
Joined: Fri Sep 29, 2017 10:20 am
Location: South Africa
Contact:

Re: RB2011 Wireless Performance Troubleshoot

Mon Oct 15, 2018 2:18 pm

Ok so after upgrading from 6.43 to 6.43.2 the problems ceased. It gets decent throughput and performance but still not compared to a RB941's throughput performance with the exact same settings and firmware.
Have you actually tried Nest's suggestion? What that guy doesn't know about WiFi isn't worth knowing!
I've done that before his post. I usually cross test will all settings and document my findings on each. Currently it's running on the default tx and for some reason I found that when I changed the Antenna gain from 0 to 4 it propagated better. I've never had to change the default antenna gain from 0 - 4. His explanation is quite detailed and much appreciated:). Still the 2011 does not get the same performance via wireless in high interference area as the 941. I'll make use of the same settings as the 941 and switch off the 941 when using the 2011 and on 15 meters with -93db noise on all channels I get 8.3mbps throughput on 941 and 3.7mbps on 2011.

Who is online

Users browsing this forum: No registered users and 7 guests