Community discussions

 
invader zog
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Wed Jan 03, 2007 9:04 pm

Multiple APs + seamless + wired backbone

Sat Dec 01, 2018 3:56 am

I'm not a Mikrotik noob and have spent *many* hours digging through threads and wiki posts to no avail.

I have 3 MTs.
Each of them runs an AP.
One of them is connected to my internet connection
The other two have wired and wireless ports bridged and connect back to a switch that all three devices communicate on
All are using the same SSID but using different frequencies.

Moving from room to room is a poor experience and our devices (mostly apple) will have a hard time. I have disconnect rules on signal strength in place.

I tried adding RSTP into the mix by configuring it on each of my bridges hoping that would help w/ some layer-2 hand-offs
I also tried WDS:dynamic
I haven't tried converting my configurations into CAPSman...

So far I was better off when I just gave each room a different SSID.

I'd like to think that this is a fairly common problem that someone would want solved ... but I would really appreciate a sample configuration or a tutorial that covers this scenario before I give up and only use a single MT as my firewall and buy a new set of APs...
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Thu Jun 21, 2018 9:29 pm

Re: Multiple APs + seamless + wired backbone

Sat Dec 01, 2018 2:02 pm

RTSP or WDS is completely unrelated to your problem.
I had some ARP issues that disappeared as soon as I set multicast-helper on the wireless interfaces to "full", you might try if that helps your usecase.
In order to support your client devices in roaming you should rather lower the tx-power of your APs (by setting higher antenna-gain in routeros) than forcefully disconnecting devices with access rules.
 
sebastia
Long time Member
Long time Member
Posts: 684
Joined: Tue Oct 12, 2010 3:23 am

Re: Multiple APs + seamless + wired backbone

Sat Dec 01, 2018 9:15 pm

Hi

Based on your description, you don't seem to have loops in your network, then there is no need for xSTP.

Regarding wifi, there are quite a bit of threads here about roaming.
In general:
* you want to make sure that you can connect to all stations
* make sure they don't interfere / overlap ex 40MHz bands in 2.4Ghz range
* reduce transmit power: to not "scream" at the clients and to ensure that they will switch to a closer AP. This can be done by increasing the antenna gain value.
 
invader zog
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Wed Jan 03, 2007 9:04 pm

Re: Multiple APs + seamless + wired backbone

Wed Dec 05, 2018 10:51 pm

Thanks for the suggestions. I'll back out my efforts w/ RSTP.

In order to more easily troubleshoot what was going on, I setup a virtual AP on each of the three with a unique SSID and configured my phone to use these. This makes it a lot easier to tell which AP the phone is connected to (i.e. vs. digging through wifi settings and checking mac addresses).

My issue doesn't seem to be that the phone is hanging onto the wrong AP but when it cuts over to the new AP (i.e. with high signal strength) that it will sometimes sit for a chunk of time (i.e. not just a few seconds) with no network connectivity.

I'm mostly using 5G and the APs are not overlapping each other. One is 20/40/80 and the other two are 20/40eC.

As my issues seem to be related to when the device connects to the new AP and I don't have any signal overlap, I therefore don't think that transmit power is related to my issue. FYI - At one point I was playing w/ manual TX power ...not sure if it is better to do that than do add gains.

I am using dynamic keys. WPA2 PSK only. AES CCM as the only cipher. My preamble mode is set to "both". I believe I have the defaults for disconnect timeout and on fail retry time (3 seconds and .1).

FYI - the devices in question are new iPhones. We have plenty of other wireless devices in our home, but they don't roam.

Thanks for your feedback and suggestions :)

Who is online

Users browsing this forum: gotsprings and 18 guests