Community discussions

 
flynno
Member Candidate
Member Candidate
Topic Author
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

PPPoE Possible MTU Issues

Tue Jan 22, 2019 9:50 pm

Hey guys,

I have a LHG XL 5 ac with ROS package v6.42.11 on clients premises.
LHG XL 5 ac upgraded with v6.42.11
Client speed is set to 20M download 5M upload download but cannot pass 10MB on the speedtest.net app or website.

Bandwidth tests from CPE to Main router show 20M download 5 Upload, so no issue with speeds to the main router.
Client has issues with working remotely and testing download speeds using app or website.

TX / RX signal Strength -55/-52 dBm
CCQ 80/83 %
Protocol 802.11
5745/20-Ceee/ac(33dBm)
Noise Floor -105 dBm
Signal to Noise 52 dB

Wireless Interface
Wireless MTU 1524 << This is normally set 1500 on other CPE's
L2 MTU 1600

Wireless is in station mode connected to Remote Site AP
CPE connects with pppoe over the wireless interface

PPPoE is WAN
ether1 is LAN DHCP 192.168.88.1/24

PPPoE Status on CPE
MTU 1480
MRU 1504 (It automatic sets to 1504 not sure why, I have changed it to 1480 but still same results)
PPP Profile Change TCP MSS set to yes

Main Router PPPoE Server
Change TCP MSS set to yes
Queue Type set to wireless-default

I have tried using mangle rule below but still same issues
chain=forward action=change-mss new-mss=clamp-to-pmtu passthrough=yes tcp-flags=syn protocol=tcp

Anyone having similar problem with any solution?


Thanks in advance
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1435
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: PPPoE Possible MTU Issues

Tue Jan 22, 2019 10:25 pm

Have you checked the client's Ethernet sync speed?
MTCNA, MTCTCE, MTCRE & MTCINE
 
flynno
Member Candidate
Member Candidate
Topic Author
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: PPPoE Possible MTU Issues

Tue Jan 22, 2019 10:33 pm

Hey CZFan,

I forgot to mention that it also goes lower than 10MB also, so it's a high 10M - 11M or can be as low as 3M etc... but never higher than 12M
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1435
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: PPPoE Possible MTU Issues

Tue Jan 22, 2019 11:14 pm

Can you provide a diagram of network, note on drawing where client is and where data is that he is downloading?

Just want to see where the possible problem areas might be
MTCNA, MTCTCE, MTCRE & MTCINE
 
flynno
Member Candidate
Member Candidate
Topic Author
Posts: 241
Joined: Wed Aug 27, 2014 8:11 pm

Re: PPPoE Possible MTU Issues

Wed Jan 23, 2019 12:46 am

Ok see image of network, R4 is router that client is connected to that is having the speed issues
You do not have the required permissions to view the files attached to this post.
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1435
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: PPPoE Possible MTU Issues

Thu Jan 24, 2019 3:53 pm

If speed varies, then I doubt it is ethernet syc related.

Majority of problems experienced with MPLS, etc is usually MTU related, but what I would suggest is go and have a cup of coffee with the client, then test from his connection and capture / sniff some packets to see if any excessive fragmentation occurs, etc. and take it from there
MTCNA, MTCTCE, MTCRE & MTCINE

Who is online

Users browsing this forum: No registered users and 31 guests