Community discussions

MUM Europe 2020
 
econst
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Thu Jan 24, 2008 10:33 pm

Alix board does not want to upgrade

Sat Jan 26, 2019 2:10 am

Built an AP using an Alix board. It been working for some time and was able to upgrade it to 6.37.3. It seems like after that version it won't upgrade to any other version. When I look at the "Files" list, I can see the 6.43.8 files and a 6.42.6 files that I had tried to install, however after the reboot, if I check for updates again it seems that I can download and Install again. Also on top of the winbox screen it still shows the old version 6.37.3 on X.86. Is it possible to upgrade?
 
mkx
Forum Guru
Forum Guru
Posts: 3595
Joined: Thu Mar 03, 2016 10:23 pm

Re: Alix board does not want to upgrade

Sat Jan 26, 2019 4:58 pm

Anything in log right after reboot? Also check the list of packages installed, if there are any duplicates upgrade will not be possible until you resolve that problem.
BR,
Metod
 
econst
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Thu Jan 24, 2008 10:33 pm

Re: Alix board does not want to upgrade

Sat Jan 26, 2019 5:44 pm

Thanks for the response. At this time I am unable to see anything in the log related to the upgrade because the log has been overwritten by other events that are being logged.
In the "Files" list I can see two versions of each file, a 6.42.6 ver and a 6.43.8 ver. The system seem to be running 6.37.3 X.86. How do I clear the "Files" list and try again?
 
mkx
Forum Guru
Forum Guru
Posts: 3595
Joined: Thu Mar 03, 2016 10:23 pm

Re: Alix board does not want to upgrade

Sat Jan 26, 2019 6:00 pm

Check the list of installed packages using
/system package print

You can delete files using
/file
print
remove <number>
<number> is the one at the beginning of corresponding line in file print output. After you delete one file, make new print to refresh numbers ...
BR,
Metod
 
econst
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Thu Jan 24, 2008 10:33 pm

Re: Alix board does not want to upgrade

Sat Jan 26, 2019 11:59 pm

Ok I think i see a possible problem. Router OS and IP V6 are running on ver 6.37.3 while everything else is running 6.42.3.

i had removed files for 6.42.6 and 6.43.8, rebooted and tried again to upgrade, but it still did not upgrade.
 
mkx
Forum Guru
Forum Guru
Posts: 3595
Joined: Thu Mar 03, 2016 10:23 pm

Re: Alix board does not want to upgrade

Sun Jan 27, 2019 3:26 pm

Can you post output of command /system package print (keep the formatting, so paste output to [ code ] environment)?
BR,
Metod
 
econst
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Thu Jan 24, 2008 10:33 pm

Re: Alix board does not want to upgrade

Sun Jan 27, 2019 6:31 pm

#   NAME                     VERSION                     SCHEDULED              
 0   user-manager             6.42.3                                             
 1   system                   6.42.3                                             
 2   hotspot                  6.42.3                                             
 3   ntp                      6.42.3                                             
 4   mpls                     6.42.3                                             
 5   security                 6.42.3                                             
 6   routeros-x86             6.37.3                                             
 7 X system                   6.37.3                                             
 8   ipv6                     6.37.3                                             
 9 X ups                      6.37.3                                             
10 X wireless                 6.37.3                                             
11 X hotspot                  6.37.3                                             
12 X dhcp                     6.37.3                                             
13 X mpls                     6.37.3                                             
14 X routing                  6.37.3                                             
15 X ppp                      6.37.3                                             
16 X security                 6.37.3                                             
17 X advanced-tools           6.37.3                                             
18   dhcp                     6.42.3                                             
19   wireless                 6.42.3                                             
20   ups                      6.42.3  

Not sure this is the correct way, but that in Info i received.
 
mkx
Forum Guru
Forum Guru
Posts: 3595
Joined: Thu Mar 03, 2016 10:23 pm

Re: Alix board does not want to upgrade

Sun Jan 27, 2019 7:17 pm

It seems that somehow you ended up with many individual packages version 6.42.3 installed. In addition to that you have ROS bundle version 6.37.3 with most packages disabled.

First of all, make backup and configuration export and save the two files off device.

Then try to uninstall "package" routeros-x86 ... if that works, you'll get rid of most of old packages. Then upload only ipv6 package version 6.42.3 (you can get individual package files from "other packages" ZIP, available in MT's download page). If you fail to get that package of particular version, you can uninstall ipv6, upgrade to 6.42.11 (last long-term) and install ipv6 ...

Another possibility is to disable 6.42.3 packages and enable 6.37.3 counterparts. After reboot you should be able to uninstall all 6.42.3 packages.

If uninstallation of one of ROS versions doesn't succeed, then I'm affraid you'll have to netinstall the device. I'm not sure how that goes for x86.
The last thing: it seems that MT is shifting from bare-metal x86 towards virtual environmenrs (CHR) ... you might want to ask support@mikrotik.com about possibility to transfer ROS license from x86 to CHR.
BR,
Metod
 
econst
Member Candidate
Member Candidate
Topic Author
Posts: 152
Joined: Thu Jan 24, 2008 10:33 pm

Re: Alix board does not want to upgrade

Wed Jan 30, 2019 7:55 pm

Sorry for the delayed reply but thanks for the response.
I tried your suggestions and other thinks but none worked. I guess I will have to try a netinstall at a later date.


Thanks again.

Who is online

Users browsing this forum: DSK and 23 guests