Community discussions

 
f38eb
just joined
Topic Author
Posts: 10
Joined: Sat Aug 18, 2012 9:36 pm

wireless network with authentication of user+password

Sat Feb 02, 2019 1:18 pm

I need to connect to a wifi network from Mikrotik as client. This has not been a problem previously (with WPA2 Pre Shared Key), but this time the network is asking for user+password of 8 characters.
How can I define that in MT?
Capture.JPG
https://www.proximus.be/support/en/id_s ... tspot.html
You do not have the required permissions to view the files attached to this post.
 
Pea
Member Candidate
Member Candidate
Posts: 191
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: wireless network with authentication of user+password

Sat Feb 02, 2019 2:21 pm

First connect by laptop and login with username and password.
Then change your Mikrotik wlan1 MAC to your laptop MAC.
And then try to connect your Mikrotik as client to the wifi network.
 
f38eb
just joined
Topic Author
Posts: 10
Joined: Sat Aug 18, 2012 9:36 pm

Re: wireless network with authentication of user+password

Sat Feb 02, 2019 3:24 pm

First connect by laptop and login with username and password.
Then change your Mikrotik wlan1 MAC to your laptop MAC.
And then try to connect your Mikrotik as client to the wifi network.
sorry, but this does not sound seriously.
p.s. changic MAC address (as well IMEI for mobile phones) is forbidden in certain countries

isn't mikrotik supporting this type of authentication?
I should be able to define it somehow on wireless security profile.
 
Pea
Member Candidate
Member Candidate
Posts: 191
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: wireless network with authentication of user+password

Sat Feb 02, 2019 4:29 pm

IMHO it's not illegal to change a MAC address.
It's only illegal to change a MAC address to do something illegal.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: wireless network with authentication of user+password  [SOLVED]

Sat Feb 02, 2019 5:25 pm

Does this thread help, involving these properties?
 
f38eb
just joined
Topic Author
Posts: 10
Joined: Sat Aug 18, 2012 9:36 pm

Re: wireless network with authentication of user+password

Sun Feb 03, 2019 12:18 pm

Does this thread help, involving these properties?
Thank's, this helped a lot.

If anyone needs, here is the Mikrotik config export for Belgium Proximus Smart WI-FI:
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan2ghz
/interface wireless security-profiles
add authentication-types=wpa-eap,wpa2-eap eap-methods=eap-ttls-mschapv2 \
    management-protection=allowed mode=dynamic-keys mschapv2-password=\
    P@ssw0rd mschapv2-username=yourusername@proximuswifi.be name=\
    smartwifi supplicant-identity=auto@proximuswifi.be tls-mode=\
    dont-verify-certificate
/interface wireless
set [ find default-name=wlan1 ] disabled=no name=wlan2ghz security-profile=smartwifi ssid="Proximus Smart Wi-Fi"
 
Gau28
just joined
Posts: 5
Joined: Mon Dec 18, 2017 2:11 pm

Re: wireless network with authentication of user+password

Tue Jul 30, 2019 3:11 pm

Hello f38eb,

I use a similar configuration, with an AP connect to a Proximus smart-wifi. It was working good up to middle of july. But now, It can't connect to the smart-wifi router. The message I get on client log is "lost connection, group key exchange timeout".
Did you get the same problem ?
 
f38eb
just joined
Topic Author
Posts: 10
Joined: Sat Aug 18, 2012 9:36 pm

Re: wireless network with authentication of user+password

Tue Jul 30, 2019 3:33 pm

Hi,

I was using it for few months as temporary solution until Proximus installed permanent DSL connection.
The router now is used for other purpose, so I don't have that config, neither have ability to test it.

Probably they have changed something on their side.
Does it work from laptop? (so to be sure your user+pw is correct)
Do you have latest MT version? Have you tried stable and long-term? Maybe try some older version prior july? (sometimes MT updates break some things ... )
You can try to enable additional logging (debug), to see some additional stuff.

edit:
btw, I remember that some time ago (maybe last few months, maybe earlier) Proximus sent some kind of e-mail regarding Smart wifi, that they are changing something... but can't find it now, probably I have deleted it (as it's not the monthly bill :))
 
Gau28
just joined
Posts: 5
Joined: Mon Dec 18, 2017 2:11 pm

Re: wireless network with authentication of user+password

Mon Aug 12, 2019 12:06 pm

Hello,
I confirm it comes back good for me toolast week, I think there was some problem with the smart-wifi network and/or my neighbor's modem.
 
f38eb
just joined
Topic Author
Posts: 10
Joined: Sat Aug 18, 2012 9:36 pm

Re: wireless network with authentication of user+password

Mon Aug 12, 2019 1:45 pm


btw, I remember that some time ago (maybe last few months, maybe earlier) Proximus sent some kind of e-mail regarding Smart wifi, that they are changing something... but can't find it now, probably I have deleted it (as it's not the monthly bill :))
That was SMS :)
Dear Proximus customer, final reminder. Smart Wi-Fi will soon be replaced by Public Wi-Fi. Don’t forget: to continue surfing on Wi-Fi for free with your device when you're not at home, you must activate Public Wi-Fi via proximus.be/publicwifi before 15/08/2019. As you will see, it's really easy. Thanks and bye for now!

Who is online

Users browsing this forum: No registered users and 15 guests