Community discussions

 
dhecar
just joined
Topic Author
Posts: 4
Joined: Sat Sep 01, 2018 7:43 pm

Mirkotik keepalive-timeout and freeradius server

Tue Feb 05, 2019 1:39 pm

Hello, I have configured mikrotik RB2011 v6.43.4 as caps manager, and freeradius as aaa controler.

We need that the users don't have to put the user/pass so often, by that i changed the keepalive-timeout value to 7d 00:00:00 for the default user. The most users are actived for 7 days without the needed to put the user/pass, but for some reason , there are users that are disconected with radius info --> Lost service.

this is real log for one of these users in the radius part.

Mon Feb 4 10:06:10 2019
Acct-Status-Type = Start
NAS-Port-Type = Ethernet
Calling-Station-Id = "08-C5-E1-3E-76-B0"
Called-Station-Id = "hotspot1"
NAS-Port-Id = "AP-CAPITANIA"
User-Name = "T10570T@cnps"
NAS-Port = 2147483718
Acct-Session-Id = "80000046"
Framed-IP-Address = 172.100.255.238
Mikrotik-Host-IP = 172.100.255.238
Event-Timestamp = "Feb 4 2019 10:06:10 CET"
NAS-Identifier = "RB-2011"
Acct-Delay-Time = 0
NAS-IP-Address = 192.168.20.1
Acct-Unique-Session-Id = "96596150f4490ab82970b38dd14d252e"
Realm = "CNPS"
SQL-User-Name = "T10570T@cnps"
Timestamp = 1549271170

Mon Feb 4 14:59:23 2019
Acct-Status-Type = Stop
Acct-Terminate-Cause = Lost-Service
NAS-Port-Type = Ethernet
Calling-Station-Id = "08-C5-E1-3E-76-B0"
Called-Station-Id = "hotspot1"
NAS-Port-Id = "AP-CAPITANIA"
User-Name = "T10570T@cnps"
NAS-Port = 2147483718
Acct-Session-Id = "80000046"
Framed-IP-Address = 172.100.255.238
Mikrotik-Host-IP = 172.100.255.238
Event-Timestamp = "Feb 4 2019 14:59:23 CET"
Acct-Input-Octets = 4363378
Acct-Output-Octets = 22836245
Acct-Input-Gigawords = 0
Acct-Output-Gigawords = 0
Acct-Input-Packets = 20635
Acct-Output-Packets = 26507
Acct-Session-Time = 17593
NAS-Identifier = "RB-2011"
Acct-Delay-Time = 0
NAS-IP-Address = 192.168.20.1
Acct-Unique-Session-Id = "96596150f4490ab82970b38dd14d252e"
Realm = "CNPS"
SQL-User-Name = "T10570T@cnps"
Timestamp = 1549288763

And the Mikrotik configuiration:


name="hsprof1" hotspot-address=172.100.0.1 dns-name="wifi.cnps.cat" html-directory=hotspot html-directory-override="" rate-limit=""
http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=http-chap split-user-domain=no use-radius=yes radius-accounting=yes
radius-interim-update=20m nas-port-type=ethernet radius-default-domain="" radius-location-id="" radius-location-name=""
radius-mac-format=XX:XX:XX:XX:XX:XX


0 * name="default" idle-timeout=none keepalive-timeout=1w status-autorefresh=1m shared-users=2 add-mac-cookie=yes mac-cookie-timeout=3d
address-list="" transparent-proxy=no


Whats the problewm with this??

Thanks too much

Who is online

Users browsing this forum: Bing [Bot] and 33 guests