Community discussions

MikroTik App
 
marting
Member Candidate
Member Candidate
Topic Author
Posts: 173
Joined: Thu Aug 21, 2014 2:07 pm

cAP ac: center button

Thu Feb 21, 2019 7:38 pm

Received my first cAP ac today and realized how large it is in contrast to the cAP lite :-) Really wondered as the sepcs are not sooo different.

And I also realized that it has a center button (only clickable with the round enclosure). What's this button for? At first try it seems I can switch off LEDs with it but it could be by chance. After switching to CAPs Mode, it does no longer seem to do anything. So can you tell me what's the reason for this button and why it is only usable with round enclosure? I'm sure it's described somewhere but I did not find.

And: should the small circle be illuminated? The small circle is made of transparent plastic, so I would think so.

Cheers Martin
Last edited by marting on Fri Feb 22, 2019 7:20 am, edited 1 time in total.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5943
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: cAP ac:

Thu Feb 21, 2019 8:41 pm

Perusing the downloads is fairly easy to master.
Two important points gleaned......

(1) Reset button (the pinhole one)
The reset button has three functions:
• Hold this button during boot time until LED light starts flashing, release the button to reset
RouterOS configuration (total 5 seconds).
• Keep holding for 5 more seconds, LED turns solid, release now to turn on CAPs mode for
managing the unit from a CAPsMAN server (total 10 seconds).
• Or Keep holding the button for 5 more seconds until until LED turns off, then release it to make the
RouterBOARD look for Netinstall servers (total 15 seconds).

(2) The cAP ac is a feature packed device with a sleek enclosure, that can become inconspicuous with
the push of a button - the customizable mode button in the device center will turn off all lights and
sounds at it’s default configuration, but can be reconfigured to launch any RouterOS script.


One could conclude that keeping the round enclosure would be required for that functionality.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
Ferrograph
Frequent Visitor
Frequent Visitor
Posts: 85
Joined: Wed Mar 07, 2012 4:05 am

Re: cAP ac: center button

Thu Dec 31, 2020 12:40 am

I was just baffled why a customer reported that the center button did nothing. Their cAP AC's are in caps mode configured out the box by holding the reset button for caps mode which is great quick way to set them up.

I checked the default configuration script and it does include dark mode even for caps configuration done this way - I can only assume that the out-the-box version perhaps didnt have this, but it shows in the current default config script because they were upgraded to a version that does include it immediately on connecting to capsman.

I simply ran the appropriate lines from the script in terminal and dark-mode by button was restored.
/system routerboard mode-button set enabled=yes
/system routerboard mode-button set on-event=dark-mode
/system script add name=dark-mode comment="defconf" source={
    :if ([system leds settings get all-leds-off] = "never") do={
         /system leds settings set all-leds-off=immediate 
        } else={
         /system leds settings set all-leds-off=never 
               }
        }
    }

Who is online

Users browsing this forum: Google [Bot] and 53 guests