Community discussions

 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Mikrotik WLAN & CAPsMAN - Bad download perfomance

Thu Feb 21, 2019 9:50 pm

The problem is - and I don't really have any idea what causes it - wireless speed is cut roughly by HALF from what it is supposed to be.
The picture is:
NAS -gigabit> Mikrotik CSS326 -gigabit+PoE> wAP AC -wireless conn 802.11ac 2x2> PC with realtek 8822BE wireless module.
RB3011 is connected to CSS326.

The issue itself? For example, I'm trying to download from NAS a movie - a whole videofile, MKV packed, 30GB size. But instead of 60 MB/s, I have only 30MB/s. And I really don't know what causing the issue - and that drives me mad. Moreover, connection itself is super-stable - it just looks like something caps it at 30-40MB/s.

Next things I've tried:
1) Wired connection gives me ~900 Mbps. So switch is out of question, as well as maybe RB3011.
2) wAPs powered by PoE - cable cat 5e, 8 wires/4pairs. Everything is in working condition.
3) Aside of 8822BE, I've tried killer chipset and Intel AC-9560 - all the same, it just stucks at 25-40 MB/s.
4) Also tried making simulatenous workload for wAP, by downloading the same file on two devices (Killer and Realtek, Intel and Realtek) - speed just divided by half, giving 15-16 MB/s for each device.
5) Local storages are non-issue here - NAS works with two SATAIII HDDs, united in RAID0. Both client devices have NVMe drives with 3GB/s sequential write.
6) As well as it's non computing issue - NAS CPU is barely loaded, not even mentioning the PC's.

All in all, here's the screenshot - I guess, it would help to make thing even more clear, than I could writing all the stuff down....


And here's my expectations, or should I say, just "wish" - Intel 9560 + UBNT AC-SHD
http://piccy.info/view3/13040178/113032 ... 10364e022/
Last edited by RobCo on Tue May 21, 2019 3:44 pm, edited 6 times in total.
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Thu Jun 21, 2018 9:29 pm

Re: CAPsMAN poor wireless speed

Mon Feb 25, 2019 6:36 pm

How do you decide how fast your wireless speed is supposed to be?

My hap ac2 802.11ac 2x2 speed with capsman and local forwarding is indeed about half of what you would expect from the standard under perfect conditions, until now I've been blaming it on cheap hardware and poor drivers. But considering the various routeros wifi bugs, which have been fixed in the past months, I wouldn't be surprised if that difference between theoretical and practical speed was really caused by some hidden bug. As long as there is no fix we will never know :)
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Wed Mar 06, 2019 12:47 am

I suggest my speed from these factors:

1) Both Tx and Rx have 2 chains working simultaneously in 2 streams - thus making 866 mbps real. wAP AC and Realtek 8822BE - you can find specs for both. 2x2:2, what can go wrong?
2) Since mikrotik admit their wireless protocols far from ideal, thus output is around 50-65% - it makes 500 mbps real.
3) All wired conncetion rated at 1 Gbps.
4) I've made channel reconnaissance and setup, so no overlapping channels, NOT EVEN CLOSE.
5) Registration table reports, device is connected at 866 Mbps rate, with 2 streams up and perfect signal strenght : -30-40 dBm.

So, I think there's no doubts left that download speed MUST be at least arount 60 MB/s. It better be 100 MB/s really, since 802.11ac states 866mbps for 2x2:2 configuration, and I have nearly ideal/perfect conditions, so I don't really get why mikrotik can't provide at least 90% of full 802.11ac potential. :?
 
zeusca
just joined
Posts: 6
Joined: Fri Feb 01, 2019 7:35 pm

Re: CAPsMAN poor wireless speed

Wed Mar 06, 2019 6:32 pm

Have you tried local forwarding vs capsman forwarding to see if there's a difference?
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Fri Mar 08, 2019 2:49 pm

Have you tried local forwarding vs capsman forwarding to see if there's a difference?
Of course I did - and the matter of fact - I ALWAYS use local forwarding enabled, cause capsman forwarding gives me like 10% of wireless perfomance.

I've tried disabling other CAPs, both 2.4 and 5, I've tried removing all the clients from tested CAP - no use, nothing helped.
 
zeusca
just joined
Posts: 6
Joined: Fri Feb 01, 2019 7:35 pm

Re: CAPsMAN poor wireless speed

Fri Mar 08, 2019 4:16 pm

Personally, I get > 100Mbps using wAP AC + RB3011 running CAPsMAN, local forwarding.

How crowded is the wireless around your place?
Are APs locked to CAPsMAN and using encryption?
 
DSK
newbie
Posts: 28
Joined: Sat Jun 30, 2018 12:57 am

Re: CAPsMAN poor wireless speed

Fri Mar 08, 2019 7:46 pm

Could you post a screenshot of winbox CAPSMAN-Channels?
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Thu Jun 21, 2018 9:29 pm

Re: CAPsMAN poor wireless speed

Fri Mar 08, 2019 10:45 pm

Personally, I get > 100Mbps using wAP AC + RB3011 running CAPsMAN, local forwarding.
But you shouldn't you expect > 500Mbps with three chains on 5GHz ac? I consider 100Mbps with that hardware pretty slow, that speed is already achievable with 2.4GHz dual chain n.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Wed Mar 13, 2019 12:42 pm

Personally, I get > 100Mbps using wAP AC + RB3011 running CAPsMAN, local forwarding.

How crowded is the wireless around your place?
Are APs locked to CAPsMAN and using encryption?
I live in suburban area, big house, closest neighbout is literally ~100m away. Not corwded at all - area is "crowded" by only me, myself and I.
No encryption, and no, CAPs don't locked on CAPsMAN - does it positively affect the perfomance?
Could you post a screenshot of winbox CAPSMAN-Channels?
MAIN2.png
But you shouldn't you expect > 500Mbps with three chains on 5GHz ac? I consider 100Mbps with that hardware pretty slow, that speed is already achievable with 2.4GHz dual chain n.
That's what I'm talking about - and I've metnioned it already (no?) - that using dual-chain 2.4Ghz band with 802.11n protocol, I can't even beat through Internet channel! 100mbps are being choked by poor wireless perfomance. I mean, I'm experiencing overall wifi perfomance drop, not only PC and 5Ghz 802.11ac connection.


And the most desperate thing about all this - I've tired reseting all the stuff, leaving onyl default configuration by mikrotik, and making fast provisioning for caps, just ot ensure it's not my fault by too overcomplicated settings - aaaand all the same, 300 mbps cap in 802.11ac5GHz, and 50-70 mbps cap in 802.11n2.4Ghz .
5 MB/s by air with 802.11n 2stream is waaay to bad.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 896
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: CAPsMAN poor wireless speed

Wed Mar 13, 2019 1:10 pm

Looking at your first screen shot in your first post, I'd say that's a decent connection.
You're connected at VHT MCS 7 with two spatial streams and short guard interval resulting in 650MBps connection rate at 80MHz.
Keeping in mind that actual real-life throughput is roughly 50...65% of the w/l connected rate, you're in a pretty good shape.
Increasing throughput further from here from here would ideally be a different wireless client supporting three spatial streams which would give you 975MBps @ VHT MCS 7, resulting in roughly 500...650 MBps real-life throughput.

-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
DSK
newbie
Posts: 28
Joined: Sat Jun 30, 2018 12:57 am

Re: CAPsMAN poor wireless speed

Wed Mar 13, 2019 1:28 pm

Could you post a screenshot of winbox CAPSMAN-Channels?
MAIN2.png

CAPsMAN-Channel. Control Channel under CAPsMAN is what I need to see it should be in auto mode.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Wed Mar 13, 2019 1:33 pm

Looking at your first screen shot in your first post, I'd say that's a decent connection.
You're connected at VHT MCS 7 with two spatial streams and short guard interval resulting in 650MBps connection rate at 80MHz.
Keeping in mind that actual real-life throughput is roughly 50...65% of the w/l connected rate, you're in a pretty good shape.
Increasing throughput further from here from here would ideally be a different wireless client supporting three spatial streams which would give you 975MBps @ VHT MCS 7, resulting in roughly 500...650 MBps real-life throughput.

-Chris
When I lived in the city, I've used to have 1Gbps internet channel. Though, it was roughly 1 Gbps - more like 900 mbps at night (best), and down to 600-700 mbps daily. And asus RT-AC66U as a router - no complicated wifi stuff, just a a swetpot with 3 antennas.
I've had 450 mbps on my current iPhone 6S result in speedtest, in 5Ghz ac band. I don't know if it has 1S or 2S - and I remember that device is 1st wave ac, so 2x2:2 40Mhz at best.
So I don't feel THIS like "pretty good" at all.
Could you post a screenshot of winbox CAPSMAN-Channels?
MAIN2.png

CAPsMAN-Channel. Control Channel under CAPsMAN is what I need to see it should be in auto mode.
What, do you mean frequency? No way, it gonna throw overlapping ones in.
Or channel width? But is there any difference between I manually set 20MHz + Ceee, or I just disable that tab, leaving Ceee?
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Mon Mar 25, 2019 7:21 pm

Ok, so I've checked streams, leaving 1 stream per test phase - so far, I've managed to discover it IS streams issue.
Thus, when leaving only 1 chain activated and 1 stream flow, I get the same 30 MB/s - 270mbps. So wireless perfomance is stucked at this point no matter what - whether I turn on all chains available (and possible), leaving 3, or 2, or 1 - it looks like it always works within 1 stream. And that's a real issue.

I'm 99% confident it's mikrotik's side flaw - for that matter, I found PCE-AC68 adapter for a good price, so I'll be able to write down my final verdict soon - but that's how it is for now.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Thu Mar 28, 2019 12:47 am

Aaannd....what needed to be prooved. I've just received my AC68 unit, plug-it in, up-to-date drivers, of course - and I get the SAME goddamn speeds. With 3 streams up now....

P.S. And don't tell me that's ok (if you read this at all, mikrotik support), that it's only "50%" etc, etc...
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Thu Jun 21, 2018 9:29 pm

Re: CAPsMAN poor wireless speed

Thu Mar 28, 2019 10:03 am

So MIMO is broken in some way that prevent any speed gain from additional chains? Interesting observation, let's hope that this is reproducible and fixable by mikrotik.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: CAPsMAN poor wireless speed

Thu Mar 28, 2019 12:31 pm

So MIMO is broken in some way that prevent any speed gain from additional chains? Interesting observation, let's hope that this is reproducible and fixable by mikrotik.
Yeah, seems like it. Furthermore, as I mentioned before (here or in support ticket?), MIMO seems to be broken broad - "at all" - if I can say so - because I really can't imagine how it can be broken.
Both, with CAPsMAN involved and without it, in regular AP mode, 2.4GHz or 5 GHz band, 802.11 ac or n or b - doesn't matter, MIMO doesnt work.

It's even more confusing that I was unable to restore previous state of things even downgrading down to 6.38 versions - does it mean it's low-level hardware related?
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Mon Apr 01, 2019 9:26 pm

So, anyone? 6.45beta, still all the same - can't be only me experiencing this stuff. Or can I?
 
User avatar
zlobster
newbie
Posts: 39
Joined: Sun Nov 20, 2016 2:47 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Tue Apr 02, 2019 10:12 pm

Hi RobCo,

I really feel your pain, I do.

Although I'm not convinced my post will help you, it may spark some insight in you.

1st thing - are you sure your clients are actually WIRED with 2 separate antennae?

2nd thing - for MIMO to work well one needs a good spatial separation for all spatial streams, i.e. there should be no correlation between the 2 spatial streams. This is hard to achieve with ordinary antennae and LoS between AP and client.

You could also try iw phy from most Linux boxes to check if your client WiFi cards support MIMO.On Windows you can try netsh wlan show wirelesscapabilities from admin CMD.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Wed Apr 03, 2019 12:48 pm

Hi RobCo,

I really feel your pain, I do.

Although I'm not convinced my post will help you, it may spark some insight in you.

1st thing - are you sure your clients are actually WIRED with 2 separate antennae?

2nd thing - for MIMO to work well one needs a good spatial separation for all spatial streams, i.e. there should be no correlation between the 2 spatial streams. This is hard to achieve with ordinary antennae and LoS between AP and client.

You could also try iw phy from most Linux boxes to check if your client WiFi cards support MIMO.On Windows you can try netsh wlan show wirelesscapabilities from admin CMD.
yeah, np mate, any idea is good!
Though I'm not a guru, and really have no idea at this moment whether it's hardware has it's flaws and works worse despite all specs available for public, or.... it's just me.
Anyway, I can only relate to software I have - so, as you can get it, you can't trust it 100% -> can't be sure 100%.

1st, Physically, all chains are active, all antennas wired. The reality is - I don't know for sure :D
What I see in registration table (screenshot attached), it sees 3 spatial streams though it's really doubtfull info, suggesting from rates it shows and the real world throughput I get
client.png
Regarding the cmd promt - even within administrative mode, it shows almost nothing usefull:
For AC68 usefull info is missing at all - either "value not available" or "not supported", even if it IS and I know it. But still, no info regarding "number of antennas", "max number of channels, simultaneously", no info about regular MIMO at all, etc.

For 8822BE, a little bit more, but still not enough - no info regarding antennas, channels aswell - but at least it shows it does support MU-MIMO (no info regarding MIMO), number of Tx Spatial Streams = 2, Rx spatial streams = 2, concurrent channels = 1.

Regarding 2nd - really no idea about the built quality or engineering idea behind all of this mate - and I don't know any mean way to tweak these for wireless clients.
LoS is....well, ATM of testings, it's around 2-3m. No obstacles, no metal construction.
I've tried stepping off a little, 10-15m, a thick brick wall 15cm in-between - but no improvements. Moreover, I have feeling like the signal itself is great, it holds those 300mbps and 50mbps really good - for a wireless solution, almost like a wire.
Dunno, maybe I want too much - though the things I want from this hardware are not stellar. And also I've decided to check bandwith with iperf so people would get something more understandable, than messy "I download a movie from NAS"
So here it is: AC68
AC68.png
8822BE
8822BE.png
Strange, isn't it? I mean, 1st - no difference between 2x2:2 and 3x3:3 client? I know Realtek chipset is much newer than asus - but asus is way more powerfull device. 2nd - well you can say that 5GHz perfomance is good, but shouldn't it be much better with 3x3? Like, let's say 800ns AC1170/2 = 585 mbps at least? Damn, I agree for 500, but 300? And what about 2.4GHz?
 
User avatar
zlobster
newbie
Posts: 39
Joined: Sun Nov 20, 2016 2:47 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Wed Apr 03, 2019 9:27 pm

Yes, you're totally running @ 1 spatial stream, i.e. 1 chain.

Also, you're not wanting too much of your HW, you're just wanting what you paid for, which according to MT's own page is 1300 (or 900Mbps if you consider the real life). What you get is a far cry from the advertised speeds...

Check this out - https://www.cisco.com/c/dam/en/us/produ ... c383047840

According to the link from this renowned manufacturer of networking equipment above, you're not even getting 256QAM! 256QAM should yield ~433MMbps.

Honestly, I don't know what else to suggest for troubleshooting. Had we some fancy test equipment things would have been easy. Maybe if you can temporary get another wAP for testing, you could try setting up a WiFi network between those 2, and see how they play it out?
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Wed Apr 03, 2019 9:51 pm

Yes, you're totally running @ 1 spatial stream, i.e. 1 chain.

Also, you're not wanting too much of your HW, you're just wanting what you paid for, which according to MT's own page is 1300 (or 900Mbps if you consider the real life). What you get is a far cry from the advertised speeds...

Check this out - https://www.cisco.com/c/dam/en/us/produ ... c383047840

According to the link from this renowned manufacturer of networking equipment above, you're not even getting 256QAM! 256QAM should yield ~433MMbps.

Honestly, I don't know what else to suggest for troubleshooting. Had we some fancy test equipment things would have been easy. Maybe if you can temporary get another wAP for testing, you could try setting up a WiFi network between those 2, and see how they play it out?
Yup, that's what I'm talking about.
Already have 3 - I'll think it out, just always lack of time. Wish things just always would work as intended (wanted)
 
User avatar
zlobster
newbie
Posts: 39
Joined: Sun Nov 20, 2016 2:47 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Wed Apr 03, 2019 10:08 pm

Wish things just always would work as intended (wanted)
Wish things just always would work as advertised. FTFY

When you went to the store, did the seller tell you "I'll charge you either $15 or $89, depending on whether it runs fine or not"? Nope, he didn't. He wanted a hefty amount of your hard earned cash no matter how the product performs.

As for the test, here is what I suggest:
- connect one wAP to some PC;
- connect another wAP on to some other PC;
- get rid of all other 5GHz airwave polluters;
- set one of the wAP as PTP Bridge AP;
- set the other one as PTP Bridge CPE;
- make sure you have a good 5-10 meters between them;
- run iperf3 between the 2 PC, which are behind your newly set PTP Bridge;

I'm by no means a MT expert, so there may be a more lean and appropriate way to do this, but we both depend on someone else to guide us.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Thu Apr 04, 2019 11:24 pm

Well, it's not rate issue or MIMO issue - Viesturs reminded me about multi-stream option in iperf - at least benchmark gives out 500mbps when using 3 or more streams.
2.png
Max result was somthing about 500-530 mbps.
On the other hand, I've managed - with a little tweaks - rise rates up to MCS9-80Mhz figures. Unfortunately, 0 impact on a real bandwith.
1.png
Additionally, I've swapped "server" and "client" - so server became a PC connected wirelessly, and client became a laptop with Gbps wired connection - and perfomance was capped at 350 mbps even with 3-5-10-15 streams at the same time.

And, as always, IRL speed when downloading/uploading smth between real clients is always around 300-350 mbps.

So, basically its not MIMO fault or anything - it's just "poor" perfomance. I mean, anybody can call me nuts calling 350mbps "poor", but as zlobster said - I've paid for some real outstanding perfomance, and I have some hardware to get at least 50% of it.
That's what you say about WiFi, right? "Divide it by two - and You get IRL perfomance" ?
So, I'm not getting it in AC band. Unfortunately.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 879
Joined: Sun Oct 01, 2006 11:44 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Sat Apr 06, 2019 3:43 pm

The wAP AC CPU is likely maxing out at that bandwidth.
 
User avatar
zlobster
newbie
Posts: 39
Joined: Sun Nov 20, 2016 2:47 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Sat Apr 06, 2019 8:31 pm

Getting ~500Mbps with multi-stream iperf3 means all WiFi technologies are kicking in, i.e. they are working.

What R1CH says may be the truth, sadly... Can you start profiling on the wAP AC and see how much the CPU gets loaded during iperf?
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Mon Apr 29, 2019 3:34 pm

The wAP AC CPU is likely maxing out at that bandwidth.
Getting ~500Mbps with multi-stream iperf3 means all WiFi technologies are kicking in, i.e. they are working.

What R1CH says may be the truth, sadly... Can you start profiling on the wAP AC and see how much the CPU gets loaded during iperf?
Hey guys, sorry for the delay.

Yeah, regarding your question - and it's kinda odd really - AT this moment, CPU at wAPs loaded roughly at 40-60% mark, with temp being around 62-68C, so no throttling either. BUT!, it local forwarding mode enabled. With CAPsMAN forwarding, with totally the same load applied, wAPs go insane 80-90% load, wireless speed drop a little too. I can't really understand it, since, shouldn't it be other way round?

But yeah, while getting highest speed, CPU load barely hits 70%, mostly 40-60%.


Another thing for the past month - I made some tweaks with CAPsMAN wireless and Rates configuration:
got rid of slow 802.11a/b basic rates, I've decided to leave indusrty reliable >12mb, plus some Hw. and preamble tweaks,
and I've got this:
123.png
And seems like without any other device or distance loss.

But I still don't like it - spatial stream tech is not working at full capacity ATM, not even close. I DO know about cointerference, that I won't get that much efficieny as I get with 1, free of any obstacle antenna. But still I hoped for something like 50% per each stream, when using 2 or 3 SS client.
So far, I've observed SS perfomance - with 1 chain I get 30MB/s (250-260Mbps) easily.
With 2 chains, as you see screenshot - 1.5x improvement, almost 50 MB/s (420-460 mbps), which is good. I mean, it's not 60MB/s that I can see within other AC network, but still.
Still get 0 improvement with 3 spatial streams, 3 chains working between wAP AC client and Asus AC68 unit. And I don't really get why is it so bad - while testing, I'm sure I have only and only 1 client sitting at 5GHz/AC band, not only within tested wAP access point, but within whole wireless network!
This is what I get with AC68
1234.png
Top speed is a liiiiiitle bit higher - rare ~52MB/s to 50MB/s, vs 48-50MB/s with Realtek 8822BE. But drops with AC adapter are more significant - while I get stable connection with realtek, AC68 gives me time-to-time drops up to 2x-3x times - though, they are rare and perfomance is quickly re-established.


So many questions....
 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Mon Apr 29, 2019 9:20 pm

... it local forwarding mode enabled. With CAPsMAN forwarding, with totally the same load applied, wAPs go insane 80-90% load, wireless speed drop a little too. I can't really understand it, since, shouldn't it be other way round?
If local forwarding, wAP's CPU only needs to copy packets from wireless interface (which alone is a CPU-intensive operation on RBs) to ethernet interface. Gateway (for simplicity's sake let's say it's CAPsMAN device) takes those packets off ethernet and routes them to WAN.
And everything in reverse order for packets from WAN towards wireless client.

If CAPsMAN forwarding, wAP's CPU needs to get packets from wireless interface (which alone is a CPU-intensive operation on RBs), encrypt them into a CAPsMAN tunnel (a pretty CPU-intensive operation) and push them to ethernet interface. Then CAPsMAN device fetches them from ethernet interface, decrypts them from CAPsMAN tunnel (CPU-intensive operation as well, usually slightly less than encryption though) and routes them to WAN.
And everything in reverse order for packets from WAN towards wireless client.

Do you still think that CAPsMAN forwarding should perform better (with lower CPU load) than local forwarding?
BR,
Metod
 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Mon Apr 29, 2019 9:38 pm

Still get 0 improvement with 3 spatial streams, 3 chains working between wAP AC client and Asus AC68 unit.
To have MIMO (multiple spatial streams) working, those streams have to be well separated (radio-wise) from each other. A great separation technique is use of two orthogonal polarizations (if usual stick-shaped antennae are used it means having them oriented at angle of 90° between them ... but that only works for a pair of antennae). A good technique is to have antennae separated spatially ... by at least a few wavelengths. Wavelength at 2.4GHz is around 12.5 cm, so those antennae should be at least 30 cm (a foot) apart (this is a bare minimum, more than half a metre would be better). It is easier to get enough spatial separation at higher frequencies, hence higher number of spatial streams on 5.xGHz band (wavelength of less than 6 cm, hence same 30 cm separation is pretty good).

And that must be done on both ends of a radio link ... or else things don't work as (naively) expected.
BR,
Metod
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik wireless LAN - WiFi - MIMO not working

Mon Apr 29, 2019 11:19 pm

Still get 0 improvement with 3 spatial streams, 3 chains working between wAP AC client and Asus AC68 unit.
To have MIMO (multiple spatial streams) working, those streams have to be well separated (radio-wise) from each other. A great separation technique is use of two orthogonal polarizations (if usual stick-shaped antennae are used it means having them oriented at angle of 90° between them ... but that only works for a pair of antennae). A good technique is to have antennae separated spatially ... by at least a few wavelengths. Wavelength at 2.4GHz is around 12.5 cm, so those antennae should be at least 30 cm (a foot) apart (this is a bare minimum, more than half a metre would be better). It is easier to get enough spatial separation at higher frequencies, hence higher number of spatial streams on 5.xGHz band (wavelength of less than 6 cm, hence same 30 cm separation is pretty good).

And that must be done on both ends of a radio link ... or else things don't work as (naively) expected.
Well.... you know, this stuff relates to my problem as bad as it can be at all
Last edited by RobCo on Sun May 12, 2019 8:13 am, edited 2 times in total.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik WLAN & CAPsMAN - Spatial stream perfomance issue

Sat May 11, 2019 11:46 pm

I guess, it's just poor 5GHz wireless support from MT and CPU limitations - things I somewhat forget and kept knocking wall with my head.
Last edited by RobCo on Tue May 21, 2019 3:43 pm, edited 1 time in total.
 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Mon May 27, 2013 3:05 pm

Re: Mikrotik WLAN & CAPsMAN - Spatial stream perfomance issue

Wed May 15, 2019 5:33 am

The 40-60% processor load in your wAP ac is an average. Due to latency at various internal points (wireless microprocessor, kernel scheduler, hardware interrupts), the wAP ac processor is a limiting factor here. As the MIPSBE SoC is older and cost-optimised, some of the internal datapaths may be a bit limited too.

You'd be in much better position with an (overkill) RB4011 WiFi and RouterOS 6.45, which enables all four chains correctly. I really wish Mikrotik had a dual-core >1GHz processor ARM AP with spatially-diverse 3-chain 5GHz and 2-chain 2.4GHz radios.

Finally, I suggest measuring WiFi throughput with iperf UDP, so you can decouple TCP congestion control.
 
r00t
Member Candidate
Member Candidate
Posts: 159
Joined: Tue Nov 28, 2017 2:14 am

Re: Mikrotik WLAN & CAPsMAN - Spatial stream perfomance issue

Wed May 15, 2019 4:49 pm

You'd be in much better position with an (overkill) RB4011 WiFi and RouterOS 6.45, which enables all four chains correctly.
RB4011 have it's own set of quirks and issues, 5GHz WIFI is very much broken as you can see here: RB4011: wlan1 disabling itself
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik WLAN & CAPsMAN - Spatial stream perfomance issue

Sat May 18, 2019 3:41 pm

Due to latency at various internal points (wireless microprocessor, kernel scheduler, hardware interrupts), the wAP ac processor is a limiting factor here. As the MIPSBE SoC is older and cost-optimised, some of the internal datapaths may be a bit limited too.

You'd be in much better position with an (overkill) RB4011 WiFi and RouterOS 6.45, which enables all four chains correctly. I really wish Mikrotik had a dual-core >1GHz processor ARM AP with spatially-diverse 3-chain 5GHz and 2-chain 2.4GHz radios.

Finally, I suggest measuring WiFi throughput with iperf UDP, so you can decouple TCP congestion control.
UPD: Ok, seems like it, I've managed to get 530 Mbps upload from PC to NAS using WLAN. Still, download is much worse.
You do not have the required permissions to view the files attached to this post.
 
RobCo
just joined
Topic Author
Posts: 21
Joined: Thu Feb 21, 2019 9:33 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Tue May 21, 2019 5:48 pm

Ok, so I was wrong and it was unfair to say "MIMO doesn't work", etc, etc...

MIMO works! I've made couple of IRL tests (not iperf) - so far, even 3x3:3 makes sense. And note that AC68 is not in the best position - bandwith rate is around 877-1300mbps, jumping around due to close distance - adapter is too powerfull to work in 1,5m from wAP, so I think if I get better position for it, I could hit stable 700-800 mbps over WiFi.

And that's said, while having 700mbps in ultra-brilliant condition, it means I can have 500mbps easily achieveble by any client in any circumstances (well, my circumstances, at least, won't state that about some really crowdy office or stadium).

Anyway, download speed still an issue, like 2x times. Smth like this:
AC68_UPLOAD.png
AC68_DOWNLOAD.png
You do not have the required permissions to view the files attached to this post.
 
Bivvy
newbie
Posts: 31
Joined: Sat Feb 04, 2017 1:36 am

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 10:07 am

Ok, so I was wrong and it was unfair to say "MIMO doesn't work", etc, etc...

MIMO works! I've made couple of IRL tests (not iperf) - so far, even 3x3:3 makes sense. And note that AC68 is not in the best position - bandwith rate is around 877-1300mbps, jumping around due to close distance - adapter is too powerfull to work in 1,5m from wAP, so I think if I get better position for it, I could hit stable 700-800 mbps over WiFi.

And that's said, while having 700mbps in ultra-brilliant condition, it means I can have 500mbps easily achieveble by any client in any circumstances (well, my circumstances, at least, won't state that about some really crowdy office or stadium).

Anyway, download speed still an issue, like 2x times. Smth like this:
AC68_UPLOAD.png
AC68_DOWNLOAD.png
@RobCo can you share your config file please? I'm only just beginning to experiment with CAPsMAN - running on MT HAP AC with hardwired AP's. I've enabled CAPS on the HAP as well so clients can connect to it's wireless or one of the remote AP's.
I've noticed a considerable drop in the WiFi throughout on the HAP when using CAP, when compared with the native WiFi.
Will double check if I'm using local forwarding.

Attached is the script I'm using to enable CAPsMAN / CAPs on the HAP (pasted below - can't get the Tapatalk app to attach the file on my phone...)

Thanks

# CAPsMAN Setup (v1.2)
#
# Script sets up CAPsMAN on main router ready to provision any (hardwired) slave devices.
# If local radios also to be controlled via CAPsMAN the firewall also needs to be updated with following line
#
# add action=accept chain=input comment="F4RN Local CAPS Access to CAPsMAN" dst-address-type=local src-address-type=local
#
# before the "Drop All" filter on the input chain.
# See bottom of this file
#

#
# First work out what the existing WiFi settings are.
#

:local SSID [/interface wireless get wlan1 ssid ];
:local SSID2 [/interface wireless get wlan2 ssid ]
:local PSK [/interface wireless security-profiles get default wpa-pre-shared-key ];

:local key
:set key 0
:put "F4RN CAPsMAN SetUp script"
:put "========================="
:put "This script will setup CAPSsMAN on the Client routers"
:put "and place the router WiFi under CAPS control using the following parameters:"
:put ""
:put (" 2GHz SSID: ".$SSID)
:put (" 5GHz SSID: ".$SSID2)
:put (" WiFI Password: ".$PSK)
:put ""

:put "Are you happy to proceed?"
:set key ([:terminal inkey])

:if ($key!=89 and $key!=121) do {
:error "Run script again"
}


#
# Set up CAPsMAN
#

#
# Set WiFi channels
# Reselect-interval - look for clearer channel at regular intervals
# 2G Channels: 2412, 2437, 2462
#

/caps-man channel
add band=2ghz-b/g/n name=2g reselect-interval=1d
add band=5ghz-a/n/ac name=5g reselect-interval=1d


/caps-man interface
add disabled=no mac-address=00:00:00:00:00:00 master-interface=none name=cap-master radio-mac=00:00:00:00:00:00

/caps-man datapath
add bridge=bridge name=BridgeDP

/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-key-update=1h name=CAPS-Security passphrase=$PSK

/caps-man configuration
add channel=2g channel.frequency=2412,2437,2462 comment=\
"2.4 GHz Channel 1,6 and 11" country="united kingdom" datapath=BridgeDP \
datapath.bridge=bridge name=2GHz rx-chains=0,1 security=CAPS-Security ssid=\
$SSID tx-chains=0,1
add channel=5g country="united kingdom" datapath=BridgeDP datapath.bridge=\
bridge name=5GHz rx-chains=0,1 security=CAPS-Security ssid=$SSID2 \
tx-chains=0,1

#
# Force weakly connected clients off the AP in an attempt to steer them onto a closer AP
#

/caps-man access-list
add action=accept interface=all signal-range=-80..120 allow-signal-out-of-range=10s
add action=reject interface=all signal-range=-120..-81

/caps-man manager
set enabled=yes

/caps-man manager interface
set [ find default=yes ] forbid=no
add disabled=no interface=bridge

/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=5GHz
add action=create-dynamic-enabled comment="2GHz provisioning of ch 1,6,11" \
hw-supported-modes=gn master-configuration=2GHz


#
# Put the local WiFi under CAPsMAN control
#

/interface wireless cap
set bridge=bridge discovery-interfaces=bridge enabled=yes interfaces=wlan1,wlan2

#
# Adjust firewall for CAPS
# NOTE - this rule needs to be moved above the Drop All Input rule
#

/ip firewall filter
add action=accept chain=input comment="F4RN Local CAPS Access to CAPsMAN" dst-address-type=local src-address-type=local


:put "CAPsMAN SetUp script complete"
:put "============================="
:put ""
:put "IMPORTANT - remember to adjust order of Firewall Rules so that CAPS can run in local machine"
:put ""




Sent from my ONEPLUS A6003 using Tapatalk

 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 5:28 pm

@Bivvy: when datapath is configured to use capsman's bridge, this usually becomes a srrious bottleneck. If you don't have a good reason not to, set datapath to local-firwarding=yes ... and the rest of appropriate settings.
BR,
Metod
 
freemannnn
Long time Member
Long time Member
Posts: 655
Joined: Sun Oct 13, 2013 7:29 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 5:57 pm

@Bivvy: when datapath is configured to use capsman's bridge, this usually becomes a srrious bottleneck. If you don't have a good reason not to, set datapath to local-firwarding=yes ... and the rest of appropriate settings.

does this count if we have a heavy duty ros hardware? i mean like ccr or rb1100x4?
does this count for internet traffic only? my bandwidth providers lines are about 20mbps to 50mbps vdsl lines.
i prefer to use capsman forwarding to observe traffic in main router in every cap.
 
Bivvy
newbie
Posts: 31
Joined: Sat Feb 04, 2017 1:36 am

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 6:12 pm

@Bivvy: when datapath is configured to use capsman's bridge, this usually becomes a srrious bottleneck. If you don't have a good reason not to, set datapath to local-firwarding=yes ... and the rest of appropriate settings.
Thanks @mkx
I'll turn on local-forwarding.
Any other tweaks I should consider?
 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 6:33 pm

does this count if we have a heavy duty ros hardware?
I never tested the difference myself ... but from other people's observations it hits cAPs as well. Beefy capsman HW makes things a tad easier, at least in DL direction.
BR,
Metod
 
freemannnn
Long time Member
Long time Member
Posts: 655
Joined: Sun Oct 13, 2013 7:29 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 6:37 pm

what confuse me is if capsman local vs forward affects "simple internet usage" like a hotel hotspot vs home/office local traffic between various devices like laptop to laptop to transfer big size files.

i mean in a hotel hotspot for example a user is downloading or uploading from his mobile device. why capsman forwarding can take a hit? upload or download has to pass always from the main router (capsman).

but for example in an office laptop1 has to sent a 10gb file to laptop2. (laptops are in the same room connected to same cap)
with capsman forwarding what i understand is that the file has to go like this laptop1 -> cap -> capsman -> cap -> laptop2 .
with local forwarding will go from laptop1 - > cap -> laptop 2

am i right?
Last edited by freemannnn on Sun Jun 02, 2019 10:24 pm, edited 3 times in total.
 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 10:11 pm

You understand right. The missing puzzle is that the cap datapath is a tunnel (never checked, but might even be encrypted one) which multiplies amount of CPU cycles spent to pass it further. Even if a device doesn't pump up CPU usage to 100%, this does add some delay which almost always translates to lower throughput.
BR,
Metod
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 747
Joined: Mon May 14, 2012 9:30 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jun 02, 2019 11:54 pm

Done a bunch of Caps-man installs at this point.

Found a lot of "hard limits"... That Mikrotik wireless is "crippled by".

As long as I stayed with in the lines... Most installs went ok.

Have better than 300 Meg's WAN to LAN. No Mikrotik wireless.

Really busy wireless airtime. No Mikrotik wireless.

I love being able to use private psk. Disable radios based on gateway status. Look at one interface to see everything from routing to wireless clients ..

But let's face it... The radio performance is not that good.

And the money I save the client by using cheap wireless just results in annoyed calls... All the time.

Have a problem and Mikrotik's wireless team not only can't help you... But send one email per month as "support". (No they don't solve the issue in 3 months of back and forth.)
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
lilw
newbie
Posts: 28
Joined: Sun Jan 21, 2018 5:31 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Mon Jun 17, 2019 7:07 am

I have cAP for couple months, I've setup it with CAPsMAN. At that time my ISP internet is only 30mbps so I test it and got around there so I didn't care much. But then, I upgraded to 200mbps internet and I found that my cAP is always around 30mbps. I hardly choose 40Mhz for my cAP because it will get channel not support(?) in CAPsMAN setup. I only config it with channel, datapaths, security, configurations for it to work. If I setup cAP as AP without CAPsMAN, it can work with 40Mhz and I can reach to 80mbps. What is wrong with CAPs or I missing something?
 
mkx
Forum Guru
Forum Guru
Posts: 2598
Joined: Thu Mar 03, 2016 10:23 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Mon Jun 17, 2019 8:28 am

I hardly choose 40Mhz for my cAP because it will get channel not support(?) in CAPsMAN setup.

This puzzles me as it's different if configured through capsMan than if it's configured directly on device. But it works for me if I set up like this:
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=XX <and the rest of settings like frequency list etc.>
This way devices see a 40MHz channel.

You can set any valid control/extension channel pattern (Ce, eC, XX) feasible for 40MHz channel.
BR,
Metod
 
lilw
newbie
Posts: 28
Joined: Sun Jan 21, 2018 5:31 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Mon Jun 17, 2019 5:31 pm

This puzzles me as it's different if configured through capsMan than if it's configured directly on device. But it works for me if I set up like this:
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=XX <and the rest of settings like frequency list etc.>
This way devices see a 40MHz channel.

You can set any valid control/extension channel pattern (Ce, eC, XX) feasible for 40MHz channel.
thanks for this tip, save me big time.
 
toxicfusion
Member Candidate
Member Candidate
Posts: 134
Joined: Mon Jan 14, 2013 6:02 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Fri Jul 05, 2019 6:58 am

sigh... I"m experiencing the same exact issues and limitations! Using CAPsMAN as well with the WAPS. Very annoying. Love MikroTik - perhaps too much of a fanboy. But when UBT wireless kicks their ass... just hate their software and constant changes. But their cloud controller aspect is sweet - able to see all WAPS visually.

Ruckus far superior, but price difference. Not to hijack thread or get locked. But MikroTik needs to put R&D Back into wireless. Think their focus been more on 60Ghz?

Even if they raise prices of their new WAP's and wifi performance and MIMO WORKS! Then that is OK!!

I just had a client return 5+ CAP AC's.......... their WAN was 500+Mbps, Wireless AC on MikroTik with -50 to -70 performance was a Joke 100Mbps-180Mbps. Most was 280Mbps.. Made me sad, a lot of frustrated calls.
 
TPF1963
newbie
Posts: 33
Joined: Sun Jun 23, 2019 4:56 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Sun Jul 07, 2019 12:51 am

Hello,

I'm sorry to say that I just bought several Microtik equipment a few days ago and I'm having similar performance issues with the Wireless Disk LHG60.

I've been browsing the forums for several days and googling a few hours a day looking for solutions.

From what I'm seeing so far, in the official forums most of the Microtik technicians happen to participate and they should not have much idea of ​​the wireless technology and the performance problems between their wireless equipment and not much desire to get wet in the resolution of problems (perhaps because they know that they can be inherent problems to the design and therefore without solution). So for another occasion we have to buy something for Wireless customers, Microtik is prohibited.

I hope that in terms of routers and switches are better because I bought some equipment of that type more.

I wish you the best for the resolution of your problem, but - without doubt - some Microtik equipment does not meet the promised specifications.

Best regards,
 
derr12
Member
Member
Posts: 411
Joined: Fri May 01, 2009 11:32 pm

Re: Mikrotik WLAN & CAPsMAN - Bad download perfomance

Wed Aug 07, 2019 8:13 pm

Its been a pretty mixed bag for wifi access over mikrotik for us (great for small-scale, not so great for density). Nstream/nv2 ptmp and p2p has been good so far. As a basic router for pppoe or nat/firewall, and rate limiting... very good. Switching has been good. Media converters and fiber stuff , excellent.

The biggest problem has been trying to use the more interesting features. capsman, usermanager, hotspot, etc.

We love the dude, wish they would throw some money at it so we could throw money at mikrotik. I would be happy to pay for it.

Who is online

Users browsing this forum: No registered users and 14 guests