Page 1 of 1

Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Feb 27, 2019 9:03 am
by TimurA
There is a problem on RB4011 on wifi 5Ghz. CAPSMAN mode or not.

When a client transitions from RB4011 wifi 5ghz to another device, the physical interface 5ghz crash. Enable only reload.

While seen only with the iPhone XS, XS Max, new iPad Pro. This is a problem only on RB4011.

So it was up to 6.44. You have not fixed this problem. Sent you the supout.rif file to the support@mikrotik.com, Ticket#2019022722003126

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Feb 27, 2019 10:02 am
by netispguy
Can you please explain the issue a bit more? I have upgraded all of my devices to 6.44 except our core router. 5GHz @ 80 MHz xxxx is now enabled on all APs. I have only one RB4011 (which happens to be located in my office). I have been moving in and out of 9 AP zones from being attached to the RB4011, and have not noticed anything abnormal. Maybe I am not looking in the right place, but no interface crash is apparent. Using an XsMax.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Feb 27, 2019 10:12 am
by TimurA
Can you please explain the issue a bit more? I have upgraded all of my devices to 6.44 except our core router. 5GHz @ 80 MHz xxxx is now enabled on all APs. I have only one RB4011 (which happens to be located in my office). I have been moving in and out of 9 AP zones from being attached to the RB4011, and have not noticed anything abnormal. Maybe I am not looking in the right place, but no interface crash is apparent. Using an XsMax.
Good day,

I noticed it this morning. My iPhone XS Max was connected to RB4011 5ghz. I went with him to another room where the RB962 stands. The phone logs successfully switched.
When I returned to the RB4011 coverage area, I found that the 5ghz interface had fallen on wifi network monitoring. He was active in the system.
Then I overloaded RB4011 and repeated the experiment, the same thing happened, 5ghz on RB4011 crash.
RB4011 operated at a frequency of 5300, RB962 at a frequency of 5180.
After I removed RB4011 from CAPSMAN and tested it again. The situation repeated - 5ghz crash. I took the dump and sent it to mikrotik.

I discovered the following, if RB4011 and RB962 are set to the same frequency, the interface of RB4011 does not crash.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 11:20 am
by TimurA
Mikrotik, what news?

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 12:41 pm
by Chupaka
TimurA, what news? Did you get an email response?

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 2:14 pm
by TimurA
TimurA, what news? Did you get an email response?
Chupaka, Silence, no answer.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 7:03 pm
by netispguy
I have not seen this issue in my environment. We only have one RB4011 (w/ radios and running 6.44 stable), and 9 various other Mikrotik APs. I don’t see anything in the logs that suggest an interface has crashed.

Has anyone else been able to reproduce this problem?

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 7:24 pm
by TimurA
I have not seen this issue in my environment. We only have one RB4011 (w/ radios and running 6.44 stable), and 9 various other Mikrotik APs. I don’t see anything in the logs that suggest an interface has crashed.

Has anyone else been able to reproduce this problem?
This only happens with iPhone XS, XS Max, iPad Pro 2018, when it reconnects from a separate device to another. RB4011 5Ghz is falling.
@normis said create a new topic. (radios and running 6.44)

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Mar 04, 2019 11:26 pm
by netispguy
I should have mentioned that I am not seeing this on our iPhones XsMax or Xs. I just moved from being connect to an hAP to our RB4011, then into an area with a cAP and back to the RB4011. I did not see anything unusual.

Maybe I am not looking in the proper place.

Can you show me what the log entry looks like when the interface crashes?

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 1:51 am
by netispguy
I just did a test:::...

All examples using 5Ghz 20/40/80Mhz A/N/AC, XXXX center channels and everything running at 6.44 stable. The SSID name (WB-AP) is the same for all. Tested with an iPhone XsMax (IOS 12.1.4)

I started off connecting to an OmniTIk (RBOmniTIKPG-5HacD). No problem. Then I connected to a hAP (RBwAPG-5HacT2HnD). No problem. Then I connected to a cAP (RBcAPGi-5acD2nD), still no problem. Finally I connected to an RB4011 (RB4011iGS+5HacQ2HnD-IN-US)... no problem. I did not do anything but move into the range of each device so that my iPhone would disconnect from one and connect to the next one... The RB4011 log does not show anything abnormal.

If there is an issue, I am not personally able to reproduce it... so I need to understand what you are seeing a little better.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 6:30 am
by TimurA
I just did a test:::...

All examples using 5Ghz 20/40/80Mhz A/N/AC, XXXX center channels and everything running at 6.44 stable. The SSID name (WB-AP) is the same for all. Tested with an iPhone XsMax (IOS 12.1.4)
Make a different frequency on the RB4011, different from other devices. See how the interface crashes on RB4011. And IPv6, dual-stack on iPhone XS Max
if you need video of the interface crash, I can send it to the mail. Do not publicly spread.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 7:24 am
by TimurA
I should have mentioned that I am not seeing this on our iPhones XsMax or Xs. I just moved from being connect to an hAP to our RB4011, then into an area with a cAP and back to the RB4011. I did not see anything unusual.

Maybe I am not looking in the proper place.

Can you show me what the log entry looks like when the interface crashes?
RB4011 frequency 5260, RB962 frequency 5180. iPhone XS Max switched to RB962, then switches to RB4011 and 5ghz falls. My computer also shuts down from RB4011. If you use the range in the network 5180-5240 - the departure does not occur. Something with a central channel on RB4011. RB962 insures the central channel is obtained if you use 5180-5240 frequency. If RB4011 use different central channel of RB962 then 5ghz on RB4011 crash.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 8:21 am
by TimurA
Now in capsman RB4011 stood at 5240, RB962 stood at 5180. After 10 minutes of operation, RB4011 fell. IPv4 / IPv6.
So it's not a problem in the central channel.
RB4011 only works steadily if RB962 and RB4011 are on the same channel.

the screen shows that 5ghz from RB4011 is not, crash.

In general - the problem device RB4011. I do not recommend, already tired of being a tester for 2 months.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 9:01 am
by netispguy
I see what you are saying.

We have a full dual stack environment as well. All of our radios are set to "auto" for the frequencies and auto (XXXX) for the center channels. Maybe that is why we are not having any issues? We are stuck with US channel space.

What app are you using on your Mac to scan the frequencies?

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 9:22 am
by TimurA
I see what you are saying.

We have a full dual stack environment as well. All of our radios are set to "auto" for the frequencies and auto (XXXX) for the center channels. Maybe that is why we are not having any issues? We are stuck with US channel space.
Tested in XXXX and carried the channel Ceee, eCeee - in different ways. The frequency of the channel is fixed set, without auto.
I was looking for any compromise, but the RB4011 is stable, then when the frequency coincides with the device from another room
What app are you using on your Mac to scan the frequencies?
use this link - https://itunes.apple.com/us/app/wifi-ex ... d494803304

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 11:27 am
by TimurA
Run netinstall 6.44 on RB4011, did not help. The problem is either in ROS or in the device.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 05, 2019 8:35 pm
by a575606
Well, I have a much more simple environment than @TimurA and I am having issues with the rb4011 wifi as well. I haven't yet been able to isolate the cause but I get similar entries in my logs as it seems you experience when it happens.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Mar 06, 2019 7:20 pm
by netispguy
I now agree. I am seeing strange behavior on the RB4011, but only with the new Apple devices. uggggg......

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Tue Mar 12, 2019 12:52 pm
by TimurA
I now agree. I am seeing strange behavior on the RB4011, but only with the new Apple devices. uggggg......
👍🏻😡😡

Today, the MSI laptop on Windows 10, when copying a large amount of data, has crash 5ghz, four times in a row.

terrible device RB4011, and no timing fixes.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Mar 13, 2019 7:39 am
by TimurA
funny, RB962 doesn't have such problems, if RB4011 crashes even with Windows 10, then RB962 at 5ghz does the same thing without any problems. No matter Apple, Microsoft.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Thu Mar 14, 2019 7:57 pm
by chukinsun
it seem 6.44 problem and Iphone iOS .
try to fall back to 6.43.12 and select 20/40 MHz Ce and fixed channel 5180.
I am stable wifi connection in iPhone X (iOS 12.1.4)

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Sat Mar 16, 2019 7:21 am
by TimurA
It can be summed up, the problem is in QCA9984, after reading the forums on the chip, we can conclude that the problem lies in it - in its firmware. Otherwise, the device can withstand the routing load much better than the RB3011.
Only open the question when they fix 5ghz.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Apr 22, 2019 7:15 pm
by estas
Hi,

I have same problem with my rb4011igs+5hacq2hnd-in. 5Ghz crash anytime.
6.43.14 (Long-term) or 6.44.2 (Stable) not metter.
20/40 MHz Ce and fixed channel 5180 not fix this problem.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Apr 22, 2019 7:51 pm
by TimurA
Hi,

I have same problem with my rb4011igs+5hacq2hnd-in. 5Ghz crash anytime.
6.43.14 (Long-term) or 6.44.2 (Stable) not metter.
20/40 MHz Ce and fixed channel 5180 not fix this problem.
Hi, yes, the same thing.
The only thing that makes this device work is if another MikroTik access point, works on the same frequency.
As crazy as it sounds.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Fri May 24, 2019 7:44 pm
by iprok
Hello!
I've also faced with the problem. Today I've upgraded my rb4011 to routeros 6.45beta50 and I have reason to think that it fixed the issue. I'm still testing, but for several hours without any usage of interface everything is ok. I think that the problem was here:
(from the changelog)
"rb4011 - fixed MAC address duplication between sfp-sfpplus1 and wlan1 interfaces (wlan1 configuration reset required); "
If you face this issue, then please compare MAC address on wlan and sfp interface on your router and if they are same, then try upgrading to ros 6.45beta50 , then
/interface wireless reset-configuration wlan1
(5GHz wifi interface), then set it up and it should be fixed.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Sat Jun 01, 2019 7:23 am
by TimurA
Hello!
I've also faced with the problem. Today I've upgraded my rb4011 to routeros 6.45beta50 and I have reason to think that it fixed the issue. I'm still testing, but for several hours without any usage of interface everything is ok. I think that the problem was here:
(from the changelog)
"rb4011 - fixed MAC address duplication between sfp-sfpplus1 and wlan1 interfaces (wlan1 configuration reset required); "
If you face this issue, then please compare MAC address on wlan and sfp interface on your router and if they are same, then try upgrading to ros 6.45beta50 , then
/interface wireless reset-configuration wlan1
(5GHz wifi interface), then set it up and it should be fixed.
Hello!

no, 5ghz is down again on 6.45beta54 -

64 bytes from 172.26.0.1: icmp_seq=1233 ttl=64 time=4.788 ms
64 bytes from 172.26.0.1: icmp_seq=1234 ttl=64 time=1.234 ms
64 bytes from 172.26.0.1: icmp_seq=1235 ttl=64 time=5.089 ms
64 bytes from 172.26.0.1: icmp_seq=1236 ttl=64 time=5.801 ms
64 bytes from 172.26.0.1: icmp_seq=1237 ttl=64 time=3.442 ms
64 bytes from 172.26.0.1: icmp_seq=1238 ttl=64 time=1.719 ms
64 bytes from 172.26.0.1: icmp_seq=1239 ttl=64 time=2.384 ms
Request timeout for icmp_seq 1240
Request timeout for icmp_seq 1241
Request timeout for icmp_seq 1242
Request timeout for icmp_seq 1243
Request timeout for icmp_seq 1244
Request timeout for icmp_seq 1245
Request timeout for icmp_seq 1246
Request timeout for icmp_seq 1247
Request timeout for icmp_seq 1248
Request timeout for icmp_seq 1249
Request timeout for icmp_seq 1250
Request timeout for icmp_seq 1251
Request timeout for icmp_seq 1252
Request timeout for icmp_seq 1253
Request timeout for icmp_seq 1254
Request timeout for icmp_seq 1255
Request timeout for icmp_seq 1256
Request timeout for icmp_seq 1257
Request timeout for icmp_seq 1258
Request timeout for icmp_seq 1259
Request timeout for icmp_seq 1260
Request timeout for icmp_seq 1261

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Sun Jun 02, 2019 8:19 am
by TimurA
I can confirm that when adaptive noise immunity is disabled at 5ghz, everything has become stable on 6.45beta54.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Jun 03, 2019 12:07 am
by gotsprings
While I have about 150 Mikrotiks out there as wireless devices... I just can't do it anymore.

Just a waste of my time trying to get support to figure out what wrong with their gear.

Much like I would never expect a Sony speaker to be worth a $h!+... Mikrotik wireless has let me down too many times at this point.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Wed Sep 04, 2019 2:54 pm
by Nirox
While I have about 150 Mikrotiks out there as wireless devices... I just can't do it anymore.

Just a waste of my time trying to get support to figure out what wrong with their gear.

Much like I would never expect a Sony speaker to be worth a $h!+... Mikrotik wireless has let me down too many times at this point.
I agree with you. I also buy RB4011 with WiFi, worst decision in a year.

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Oct 07, 2019 9:16 pm
by tiandrei
Hello all,
Is this fixed now?
Is this the only fix so far : "The only thing that makes this device work is if another MikroTik access point, works on the same frequency." ?
I am looking to replace my 750Gr3 (router) , 750GL (switch) and RB951Ui-2HnD (ap and switch) with RB4011iGS+5HacQ2HnD-IN while also keeping my hap ac as an AP and switch.
Thanks

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Mon Oct 07, 2019 10:52 pm
by anuser
Have you tried latest RouterOS V7 beta2? => viewforum.php?f=1

Re: Mikrotik RB4011iGS+5HacQ2HnD and WiFi 802.11AC crash interface

Posted: Thu Oct 31, 2019 10:50 am
by TimurA
The interface 5ghz on beta59 will no longer crash. Thanks to the mikrotik team and Reinis for the great work done!