Page 1 of 1

ip address issue

Posted: Fri Mar 23, 2007 3:44 pm
by infinet
hello i have the following configuration:
eth1:192.168.1.1/24
eth2:10.0.0.2/24
wlan1:192.168.2.0/24

when i connect to ap using a ap client, i can ping the radio and used the internet, but when i put on my pc the address 10.0.0.3, which is the address for my internet doesn't work, but when in my pc has the address 192.168.2.15 it works, my ap client is configure bridge mode.

Posted: Fri Mar 23, 2007 3:53 pm
by janisk
wlan1:192.168.2.0/24

are you sure about that?

Posted: Fri Mar 23, 2007 4:20 pm
by infinet
yes. also in the eth2 the gateway is 10.0.0.1/24 witch is the dsl moden

Posted: Fri Mar 23, 2007 6:19 pm
by tneumann
192.168.2.0 is the network base address of 192.168.2.0/24 and therefore should not be the configured address of an interface.

--Tom

Posted: Sat Mar 24, 2007 5:41 am
by infinet
ok, but i remove the address from eht1, now i trying to access my dsl service using the address 10.0.0.3, gw 10.0.0.1, but i not able, however when i have the address 192.168.2.15 gw 192.168.2.1, it works fine, what is the solution for this issue

Posted: Mon Apr 02, 2007 2:21 am
by cmacneill
If I read you correctly your PC is connected via a Wireless adapter? If so then it has to have an IP address on the same subnet as wlan1, i.e. 192.168.2.x.

If you just arbitrarily change the PC's IP address you won't get anything, you are transmitting on one subnet and the AP is listening on another.

If it's working on 192.168.2.x why change to 10.0.0.x?

I think you need to give more details for anyone to have any chance of understanding what you're trying to achieve.