Community discussions

 
sterit
just joined
Topic Author
Posts: 1
Joined: Thu Mar 28, 2019 10:50 am

DHCP issue on client behind hAP mini

Thu Mar 28, 2019 3:58 pm

Hello,

I have changed a Linksys Router (works as AP) with a Mikrotik hAP mini and I can't get a ip-address on an client which is connected behind a TP-Link WR702N in client mode.

Scenario:
WAN <-> Fritzbox as router with dhcp <cable> hAP mini )))<wifi>((( TP-Link WR702N <-> Audio Receiver

FritzBox is router and dhcp server. The hAP mini is used as AP, ether1 - 3 and wlan1 is in the same default bridge, firewall and nat rules and dhcp-server are deleted.

When I use the LinkSys AP the Audio Receiver get the IP-Address from the Fritzbox. With the hAP it doesn't get an IP. By adding the ip and gateway static the connection works.

I have other wifi clients connected to the hAp directly (over wifi) and they works fine.

The TP-Link ist configurated in client mode, no dhcp and static ip. How mentioned when connected to the wifi from LinkSys or FritzBox it does relay the dhcp addresses.

Thank you,
Steven

Config of hAP mini:
===============

<ether1> fritzbox
<ether2> connected to pc for test / configuration, get ip over dhcp
<ether3> not connected

# mar/28/2019 14:36:46 by RouterOS 6.44.1
# model = RB931-2nD

/interface bridge
add admin-mac=B8:69:F4:XX:XX:XX auto-mac=no name=bridge protocol-mode=none

/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=2ghz-g/n country=germany disabled=no frequency-mode=regulatory-domain mode=ap-bridge ssid=SSID1 

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=secret

/interface bridge port
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=wlan1
add bridge=bridge interface=ether1

/ip neighbor discovery-settings
set discover-interface-list=LAN

/interface list member
add interface=bridge list=LAN

/ip address
add address=192.168.100.97/24 interface=bridge network=192.168.100.0

/ip dns
set allow-remote-requests=yes

/ip dns static
add address=192.168.00.1 name=router.lan

Who is online

Users browsing this forum: No registered users and 13 guests