Community discussions

 
bosko1333
just joined
Topic Author
Posts: 5
Joined: Mon Jun 03, 2019 9:16 pm

Slow Wifi - RB2011UiAS-2HnD r2

Mon Jun 03, 2019 9:44 pm

Hello there!
I cannot find solution to my problem with RB2011UiAS-2HnD r2 wireless connection.
So the problem is in limited download and upload speed (cca. 10 - 20mbps). My WAN connection speed is 200mbps download and 40 upload. Wired LAN is working flawlessly.
Software version: 6.44.3
CPU load: 2%
There is not any other significant strong ap-s in my area, so I do not think it is channel interference problem. I also tried every band combination from b/g/n to "only N" setup, changed channel width from 20mhz to 20/40mhz, and there were no changes.

Is there something wrong with my router? Am I missing something in configuration? I am not sure if it is the case, but speed has decreased after update.

Thank you for any help!
 
bosko1333
just joined
Topic Author
Posts: 5
Joined: Mon Jun 03, 2019 9:16 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 2:12 pm

I found solution by myself!
It was something with tx/rx chains.
Before:
Tx Chains: chain0 chain1
Rx Chains: chain0 chain1
After:
Tx Chains: chain0
Rx Chains: chain1

Now I get cca. 50/40mbps speed, whitch is ok for me.

Can somebody please explain what happened when I changed those parameters?
 
mkx
Forum Guru
Forum Guru
Posts: 2944
Joined: Thu Mar 03, 2016 10:23 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 2:24 pm

You switched off MIMO and set your RB to use one antenna for Tx and another one for Rx. Which doesn't really explain why this solves your problem unless there's some HW problem with RB (duplexer malfunctioning) or your wireless client(s) don't support MIMO (802.11n devices should support it). In the later case problem would be also solved by simply switching off one of Tx chains and either keeping both Rx chains or having same chain used for both Tx and Rx.
BR,
Metod
 
bosko1333
just joined
Topic Author
Posts: 5
Joined: Mon Jun 03, 2019 9:16 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 2:40 pm

You switched off MIMO and set your RB to use one antenna for Tx and another one for Rx. Which doesn't really explain why this solves your problem unless there's some HW problem with RB (duplexer malfunctioning) or your wireless client(s) don't support MIMO (802.11n devices should support it). In the later case problem would be also solved by simply switching off one of Tx chains and either keeping both Rx chains or having same chain used for both Tx and Rx.
Maybe you are right. Because if switch chains from tx-0/rx-1 to tx-1/rx-0, speed falls below 20mbps again. That means I have HW issue, right?
 
mkx
Forum Guru
Forum Guru
Posts: 2944
Joined: Thu Mar 03, 2016 10:23 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 5:17 pm

Which speed does drop, UL, DL or both? If DL, then it's probably the RF power amplifier on Tx-1 chain. If UL, then it might be pre-amplifier of Rx-0. If both speeds suck when using same chain for Tx and Rx (0 or 1), then may be the antenna is the cause of trouble. Or cable between the board and case connector. Or duplexer (which is most probably integral part of RF chip).
BR,
Metod
 
bosko1333
just joined
Topic Author
Posts: 5
Joined: Mon Jun 03, 2019 9:16 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 6:30 pm

Multiple TX/RX speed test results (5 meters away + 1 wall):
Phone:
Both on chain 0: DL-51,1 / UL-40,8 average
Both on chain 1: DL-16,2 / UL-40,4 average

Laptop:
Both on chain 0: DL-95,3, / UL-40,8 average
Both on chain 1: DL-21,5 / UL-38,4 average

This is it...
 
mkx
Forum Guru
Forum Guru
Posts: 2944
Joined: Thu Mar 03, 2016 10:23 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2  [SOLVED]

Sun Jun 09, 2019 6:43 pm

So it seems that Tx chain 1 is busted (hopefuly another ROS updrade will un-bust it). I'd keep both chains active for Rx, it might help with UL.

A thought: did you only upgrade ROS or routerboot as well? If you haven't, you might wanna try.
BR,
Metod
 
bosko1333
just joined
Topic Author
Posts: 5
Joined: Mon Jun 03, 2019 9:16 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 9:55 pm

So it seems that Tx chain 1 is busted (hopefuly another ROS updrade will un-bust it). I'd keep both chains active for Rx, it might help with UL.

A thought: did you only upgrade ROS or routerboot as well? If you haven't, you might wanna try.

I think it is already on last version... Also I tried to run upgrade command and there were no changes.
Firmware Type ar9344
Factory Firmware 3.41
Current Firmware 6.44.3
Upgrade Firmware 6.44.3
 
mkx
Forum Guru
Forum Guru
Posts: 2944
Joined: Thu Mar 03, 2016 10:23 pm

Re: Slow Wifi - RB2011UiAS-2HnD r2

Sun Jun 09, 2019 10:56 pm

Just another thought: does degraded performance of Tx-1 correlate with lower signal strength, measured by client at the refference spot? Personnaly I often use "WiFi analyzer" on android gadgets, but similar software for other platforms/OSes exists as well ...
BR,
Metod

Who is online

Users browsing this forum: No registered users and 24 guests