Community discussions

 
Chiara
newbie
Topic Author
Posts: 40
Joined: Thu Jul 23, 2015 3:47 pm

mAPlite as wifi to ethernet adapter

Tue Jun 04, 2019 4:32 pm

I want to allow the DHCP client PC (A) connected to ETH1 port of the mAPlite (B) to an existing DHCP server (C)in accessible by the LAN where the WLAN interface of the mAPlite is connected.
But I cannot get the IP from the DHCP server, with Torch I see the requests but no response.
If I enable the DHCP on the mAPlite the PC get an address from it but not from external DHCP server.

DHCP CLIENT A >>>> eth1 of B
wlan1 of B >>>> C DHCP SERVER

Ideally A should get address from C.
I've bridged ETH1 and WLAN, no rules on firewall or NAT.

With Torch on the bridge I can see the DHCP client requests coming from A.
Can someone please say me what's missing?
 
mkx
Forum Guru
Forum Guru
Posts: 2472
Joined: Thu Mar 03, 2016 10:23 pm

Re: mAPlite as wifi to ethernet adapter

Tue Jun 04, 2019 7:37 pm

Wifi is not made for bridging wired parts of LAN transparent in L2 sense. Vendors introduced incompatible solutions and later came WDS (which itself is a small mess).

So it is important to know how both wireless devices are configured - you mentioned mAP lite, but not the other end of wireless connection.
BR,
Metod
 
Chiara
newbie
Topic Author
Posts: 40
Joined: Thu Jul 23, 2015 3:47 pm

Re: mAPlite as wifi to ethernet adapter

Wed Jun 05, 2019 9:52 am

Thank you for answering, both are MIKROTIK routerboard. I don't know if this is correct but this seems to work:
# jan/02/1970 00:15:28 by RouterOS 6.44.3
# software id = Y6VQ-AHV4
#
# model = RouterBOARD mAP L-2nD
/interface bridge
add comment=defconf name=bridge
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys \
    name=ssidtoconnect supplicant-identity="" wpa-pre-shared-key=pass \
    wpa2-pre-shared-key=pass
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 band=2ghz-b/g/n channel-width=\
    20/40mhz-Ce country=italy disabled=no distance=indoors frequency=auto \
    frequency-mode=regulatory-domain mode=station-bridge security-profile=\
    ssidtoconnect ssid=ssidtoconnect station-roaming=disabled wireless-protocol=802.11 \
    wps-mode=disabled
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether1 trusted=yes
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    bridge
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" disabled=yes \
    ipsec-policy=out,none out-interface-list=WAN
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
ervcese
just joined
Posts: 2
Joined: Tue Feb 05, 2019 4:36 pm

Re: mAPlite as wifi to ethernet adapter

Wed Jun 05, 2019 10:19 am

You don't need dhcp client or server on station bridge device, just assign ip address from your first router LAN network to the Bridge on the second router. First router wlan must be in ap-bridge mode and if dhcp-server is on bridge, then wlan interface must be in the same bridge. Everything must work and the PC must receive IP address from first routers dhcp network.
 
Pea
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: mAPlite as wifi to ethernet adapter

Wed Jun 05, 2019 7:55 pm

Try this, works perfectly:

On your main Mikrotik router (C DHCP SERVER)
/interface wireless
set mode=ap-bridge ssid=YOUR-SSID wds-default-bridge=bridge-local wds-mode=static-mesh
/interface wireless wds
add disabled=no master-interface=wlan1 wds-address=xx.xx.xx.xx.xx.xx (wifi MAC of remote Mikrotik = DHCP CLIENT A)

On your remote Mikrotik (DHCP CLIENT A)
clean/remove setup (especially disable DHCP, NAT, edit/remove firewall) and put all interfaces to bridge, set DHCP client on bridge and add your security profile and change wifi mode:
/ip dhcp-client
add interface=bridge-local
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk wpa2-pre-shared-key=YOUR-PASSWORD
/interface wireless
set frequency=auto mode=station-wds ssid=YOUR-SSID

All LAN ports on remote Mikrotik are now wireless connected to your LAN.

Who is online

Users browsing this forum: No registered users and 7 guests