Community discussions

 
xunil76
newbie
Topic Author
Posts: 43
Joined: Fri May 20, 2011 12:48 am

wireless bridge problems

Sun Sep 15, 2019 1:05 am

hey guys, i have 2x MikroTik RBSXTsq5nD-US's as remote bridge devices, and a single RBMetalG-52SHPacn-US as the root device, and i'm having issues with getting the two remote SXT's to connect to the root RBMetal at the same time.

i can plug in one or the other SXT and it will connect to the RBMetal just fine...but when i power on both SXT's, only the first one that is powered on will connect to the RBMetal. only one device at a time will show up in the Registration tab of the RBMetal. i can unplug the one that is connected, and almost immediately the other one will get registered wirelessly, and everything behind that device works perfectly. then i swap which one is powered on, and everything behind that device works fine.

the configuration of the two SXT's is identical with the exception of the IP address used on each one. until today, there was only one SXT remote device, and the 2nd remote SXT was previously the root device. the RBMetal was installed as the root device, and the former root SXT is now the 2nd remote device.

for configuration, i did an export of the original remote SXT, changed the last octet of the IP address, and loaded it to the 2nd remote SXT after resetting defaults on it (no backups or default config left on it). i also made 100% sure to remove anything that specified a MAC address before loading the config to the 2nd SXT (so where it says admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no, that part was removed prior to loading it to the 2nd SXT).

here is the config that is on both of the SXT's (again, the only thing different between the 2 remote SXT's is the last octet of the IP address, and of course the MAC addresses):
# dec/03/1970 13:29:48 by RouterOS 6.45.6
# software id = xxxxxxxxxxxxxxxx
#
# model = RouterBOARD SXTsq 5nD
# serial number = xxxxxxxxxxxxxxxx
/interface bridge
add admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no name=<BRIDGE NAME HERE> protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=profile1 supplicant-identity="" \
    wpa2-pre-shared-key=<WPA2 PASSWORD HERE>
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n channel-width=20/40mhz-Ce \
    disabled=no mode=station-bridge security-profile=profile1 ssid=<SSID HERE>
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0
/interface bridge port
add bridge=<BRIDGE NAME HERE> hw=no interface=ether1
add bridge=<BRIDGE NAME HERE> interface=wlan1
/ip address
add address=192.168.11.<LAST OCTET CHANGED ON EACH SXT>/24 interface=<BRIDGE NAME HERE> network=192.168.11.0

and here is the config for the RBMetal root device:
# jan/02/1970 02:01:10 by RouterOS 6.45.6
# software id = xxxxxxxxxxxxxxxx
#
# model = Metal G-52SHPacn
# serial number = xxxxxxxxxxxxxxxx
/interface bridge
add admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no name=<BRIDGE NAME HERE> protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] speed=100Mbps
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=profile1 supplicant-identity="" \
    wpa2-pre-shared-key=<WPA2 PASSWORD HERE>
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n channel-width=20/40mhz-Ce \
    disabled=no hide-ssid=yes mode=bridge security-profile=profile1 ssid=\
    <SSID HERE> wps-mode=disabled
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=<BRIDGE NAME HERE> hw=no interface=ether1
add bridge=<BRIDGE NAME HERE> interface=wlan1
/ip address
add address=192.168.11.<LAST OCTET DIFFERENT FROM BOTH SXT'S>/24 interface=<BRIDGE NAME HERE> network=192.168.11.0
i have made sure that there are no IP conflicts on the network to cause any issues. however, even if there were an IP conflict, the wireless registration should still occur, it would just have problems communicating over that wireless link.
 
2frogs
Long time Member
Long time Member
Posts: 540
Joined: Fri Dec 03, 2010 1:38 am

Re: wireless bridge problems

Sun Sep 15, 2019 1:22 am

On the RBMetal, change mode=bridge to mode=ap-bridge, mode=bridge only allows 1 connected client.
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n channel-width=20/40mhz-Ce \
    disabled=no hide-ssid=yes mode=ap-bridge security-profile=profile1 ssid=\
    <SSID HERE> wps-mode=disabled
 
xunil76
newbie
Topic Author
Posts: 43
Joined: Fri May 20, 2011 12:48 am

Re: wireless bridge problems

Sun Sep 15, 2019 3:05 am

i knew it had to be something really stupid and simple...that fixed the issue, thanks!

Who is online

Users browsing this forum: No registered users and 21 guests