Community discussions

 
User avatar
floeff
newbie
Topic Author
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

macOS, wifi and changed IPv6 temporary address

Mon Sep 30, 2019 2:43 pm

Hello,

I've been experiencing issues with packet loss only in a specific combination, as it seems:

The device is a MacBook Air Late-2013 model, running macOS 10.14.6.
The CAPs manager is a RB750Gr3 with RouterOS 6.44.5.
As CAP client/access point, I've been trying both the cAP, as well as the wAP ac, running RouterOS 6.44.5 with respective firmware.
Currently I run only one CAP client, so handover can't be the issue.

I experience between 5-10% of packet loss per hour, usually peaking at a specific time, sometimes leading to hiccups in the e-mail client as well as disconnects from IRC (no route to host), but only when all extension channels are enabled. Other local devices do not seem to experience this problem, from what I could tell. The wifi environment is rather clean here, not massively polluted.

I first assumed the macOS location service being the culprit. While it might help to trigger the issue, turning these off completely doesn't solve the problem.

Here's a WORKING configuration:

name="MyWifi5" mode=ap ssid="MyWifi" country=germany installation=indoor security.authentication-types=wpa2-psk security.encryption=aes-ccm security.group-encryption=aes-ccm security.passphrase="MyPassword" security.disable-pmkid=yes datapath.client-to-client-forwarding=yes datapath.bridge=br-lan channel.control-channel-width=20mhz channel.band=5ghz-a/n/ac channel.extension-channel=XX

Here's a NOT WORKING configuration, differences marked in bold:

name="MyWifi5" mode=ap ssid="MyWifi" country=germany installation=indoor security.authentication-types=wpa2-psk security.encryption=aes-ccm security.group-encryption=aes-ccm security.passphrase="MyPassword" security.disable-pmkid=yes datapath.client-to-client-forwarding=yes datapath.bridge=br-lan channel.control-channel-width=20mhz channel.band=5ghz-a/n/ac channel.extension-channel=XXXX

I also tried setting XXXX to specific values like Ceee, to no avail.

Possibly I messed something up with the channel width and channel extensions, but am a bit lost at the moment as to where to problem could be. Anyone has an idea? ;)

Thanks,
Florian
Last edited by floeff on Wed Oct 09, 2019 2:26 pm, edited 1 time in total.
 
Zacharias
Member
Member
Posts: 420
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: 5 GHz packet loss w/ MacBook only with extension channels

Mon Sep 30, 2019 3:34 pm

When you set the extention channel to XXXX can you confirm that unsupported channel appears on the capsman configuration tab?
What is your frequency?
 
User avatar
floeff
newbie
Topic Author
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: 5 GHz packet loss w/ MacBook only with extension channels

Mon Sep 30, 2019 5:07 pm

Thanks for the fast reply!
It seems that even with "XX" the connection drops every once in a while, as I've just discovered - but seems in much larger intervals (6 hours now vs. 1-2 hours otherwise).
When you set the extention channel to XXXX can you confirm that unsupported channel appears on the capsman configuration tab?
What is your frequency?
I don't see any mention of unsupported - where would it be? Directly on the channel tab?
Frequency is 5240/20-eC/ac/P(23dBm)

Florian
 
Zacharias
Member
Member
Posts: 420
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: 5 GHz packet loss w/ MacBook only with extension channels

Mon Sep 30, 2019 5:15 pm

You mean you are disconnected from the wifi?
If yes what does the log say? That will help a lot...
It would be on the capsman's first tab..
Select XX but don't choose any frequency....
Because:
Channel widths with XX and XXXX extensions automatically scan for a less crowded control channel frequency based on the number of concurrent devices running in every frequency and chooses the “C” - Control channel frequency automatically.
https://wiki.mikrotik.com/wiki/Manual:I ... e/Wireless
 
User avatar
floeff
newbie
Topic Author
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: 5 GHz packet loss w/ MacBook only with extension channels

Mon Sep 30, 2019 5:36 pm

Sorry for being a bit inaccurate - I am not disconnected from the wifi, there is just some packet loss, but that packet loss is enough to e.g. disconnect IRC. The wifi connection to the access point itself is up all of the time. It's also not related to my internet connectivity, as a ping to the router itself shows the same packet loss.
 
Zacharias
Member
Member
Posts: 420
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: 5 GHz packet loss w/ MacBook only with extension channels

Mon Sep 30, 2019 5:38 pm

Can you give it a try without capsman? Just configure a simple AP on your device and see how it goes?
I would try that...
 
User avatar
floeff
newbie
Topic Author
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: 5 GHz packet loss w/ MacBook only with extension channels

Wed Oct 02, 2019 9:59 am

Thanks, I will give it a try indeed.
 
User avatar
floeff
newbie
Topic Author
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

macOS, wifi and changed IPv6 temporary address

Wed Oct 09, 2019 2:26 pm

I managed to chase down the problem a bit more, and it has - contrary to my assumption - nothing to do with 5 GHz or extension channels.
It seems that when on wifi, my all Macs (10.14, not the recent Catalina) change their temporary IPv6 address in intervals ranging from 20 minutes to 3 hours, thus breaking the connection. It does not seem to be a problem with IPv4 only, and it is no problem on the wired connection either.

I tried different settings so far to no avail and do not see any wifi disconnection in the logs at all. ifconfig -L correctly shows the 1d and 4w intervals that are configured with /ipv6 nd

I will try with a spare third-party access point to rule out that part and will also double-check on other operating systems, how they behave in this regard. My take is that it's related to macOS, but I couldn't find anything so far.

Who is online

Users browsing this forum: No registered users and 2 guests