Community discussions

MUM Europe 2020
 
ottofuks
just joined
Topic Author
Posts: 3
Joined: Tue Apr 30, 2019 12:37 pm

rbm11g + r11e-lte - strange issues in work

Tue Jan 14, 2020 3:04 pm

hi there

i have a problem. i`ve got rbm11g and r11e-lte connected together and i have a couple of sim cards from various operators with different coverage in my spot (i.e. - LTE and 3g).
i`ve configured rbm11g with r11e-lte with some sim-card, modem connected to cellular network and all works fine until i reboot rb (it does not matter how - with /sys reboot or by just plugging out the poe cable) for couple times. and after that modem can`t connect to cellular network. it even can`t see anything in lte scanner. AT+reset, usb power reset, or power reset of rb do nothing, modem still can`t see any cellular network. i changed sim cards and apn profiles - no work.
but, if i remove modem from rb`s mpcie slot, attach it again and just power it up - everything works fine! until 3 to 5 reboots.
succesfull connection looks like:
12:16:05 lte,async lte1: sent AT E0 V1
12:16:05 lte,async lte1: rcvd OK
12:16:05 lte,async lte1: sent AT+CGMI
12:16:05 lte,async lte1: rcvd +CGMI: "MikroTik"
12:16:05 lte,async lte1: sent AT+CGMM
12:16:05 lte,async lte1: rcvd +CGMM: "R11e-LTE"
12:16:05 lte,async lte1: sent AT+CGMR
12:16:05 lte,async lte1: rcvd +CGMR: "MikroTik_CP_2.160.000_v013"
12:16:05 lte,async lte1: sent AT+CGSN
12:16:05 lte,async lte1: rcvd +CGSN: 355654091842091
12:16:05 lte,async lte1: sent AT+CFUN?
12:16:05 lte,async lte1: rcvd +CFUN: 1
12:16:05 lte,async lte1: sent AT+CFUN=4
12:16:06 lte,async,event ^SRVST: 2
12:16:06 lte,async,event +CGEV: ME DETACH
12:16:06 lte,async,event +CGEV: EPS PDN DEACT 5
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CFUN?
12:16:06 lte,async,event ^SRVST: 0
12:16:06 lte,async lte1: rcvd +CFUN: 4
12:16:06 lte,async lte1: sent AT+CMEE=2
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CREG=2
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CGREG=2
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CEREG=2
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CGEREP=2,0
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CMGF=0
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CNMI=1,1,0,1,0
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+EEMOPT=1
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT*MRD_SN?
12:16:06 lte,async lte1: rcvd *MRD_SN:723C037009D4
12:16:06 lte,debug lte serial: *MRD_SN:723C037009D4
12:16:06 lte,async lte1: sent AT+CFUN=4
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT*CGDFLT=0,"IP","APN.name",,,,,,,,,,1,0,,,,,,,1
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT*CGDFAUTH=0,2,"username","password"
12:16:06 lte,async lte1: rcvd OK
12:16:06 lte,async lte1: sent AT+CPIN?
12:16:06 lte,async lte1: rcvd +CPIN: READY
12:16:10 lte,async lte1: sent AT+CPMS="SM","SM","SM"
12:16:10 lte,async lte1: rcvd +CPMS: 5,5,5,5,0,0
12:16:10 lte,async lte1: sent AT+CFUN?
12:16:10 lte,async,event +MMSG: 0, 1
12:16:10 lte,async,event ^SMMEMFULL: SM
12:16:10 lte,async lte1: rcvd +CFUN: 4
12:16:10 lte,async lte1: sent AT+ICCID?
12:16:10 lte,async lte1: rcvd +ICCID: 89701010050339040743
12:16:10 lte,async lte1: sent AT+CNUM
12:16:10 lte,async lte1: rcvd +CME ERROR: 100
12:16:10 lte,async lte1: sent AT+CIMI
12:16:11 lte,async lte1: rcvd 250015033904074
12:16:11 lte,async lte1: sent AT+CPIN?
12:16:11 lte,async lte1: rcvd +CPIN: READY
12:16:11 lte,async lte1: sent AT*BAND=15,78,147,160,524487,1,2,0
12:16:11 lte,async lte1: rcvd OK
12:16:12 lte,async lte1: sent AT+COPS=0
12:16:12 lte,async lte1: rcvd OK
12:16:12 lte,async lte1: sent AT+CFUN=1
12:16:12 lte,async lte1: rcvd OK
12:16:12 lte,async lte1: sent AT+COPS=3,0
12:16:12 lte,async lte1: rcvd OK
12:16:12 lte,debug lte1: config ok
12:16:12 lte,async,event +NITZ: PLMN Long Name: cellular net RUS,
12:16:12 lte,async,event +NITZ: PLMN Short Name: cellular net RUS,
12:16:12 lte,async,event +NITZ: 20/01/14,11:40:47+12,0
12:16:13 lte,debug lte1: network access technology: Evolved 3G (LTE)
12:16:13 lte,info lte1: registered home
12:16:13 lte,async,event +CGEV: EPS PDN ACT 5
12:16:13 lte,async,event +CGEV: NW MODIFY 5,3
12:16:14 lte,async lte1: sent AT+CGDCONT?
12:16:14 lte,async lte1: rcvd +CGDCONT: 5,"IP","APN.name.mnc001.mcc250.gprs"
,"10.80.64.2",,,80211004010010810600000000830600000000,
12:16:14 lte,async lte1: sent AT+CGCONTRDP=5
12:16:14 lte,async lte1: rcvd +CGCONTRDP: 5,5,"APN.name.mnc001.mcc250.gprs",
"10.80.64.2","","","","","","","0","0"
12:16:14 interface,info lte1 link up

and unsuccesfull one

12:20:22 lte,async lte1: sent AT E0 V1
12:20:22 lte,async lte1: rcvd OK
12:20:22 lte,async lte1: sent AT+CGMI
12:20:22 lte,async lte1: rcvd +CGMI: "MikroTik"
12:20:22 lte,async lte1: sent AT+CGMM
12:20:22 lte,async lte1: rcvd +CGMM: "R11e-LTE"
12:20:22 lte,async lte1: sent AT+CGMR
12:20:22 lte,async lte1: rcvd +CGMR: "MikroTik_CP_2.160.000_v013"
12:20:22 lte,async lte1: sent AT+CGSN
12:20:22 lte,async lte1: rcvd +CGSN: 355654091842091
12:20:22 lte,async lte1: sent AT+CFUN?
12:20:22 lte,async lte1: rcvd +CFUN: 1
12:20:22 lte,async lte1: sent AT+CFUN=4
12:20:24 lte,async,event ^SRVST: 0
12:20:24 lte,async,event +CGEV: ME DETACH
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CFUN?
12:20:24 lte,async lte1: rcvd +CFUN: 4
12:20:24 lte,async lte1: sent AT+CMEE=2
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CREG=2
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CGREG=2
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CEREG=2
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CGEREP=2,0
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CMGF=0
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CNMI=1,1,0,1,0
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+EEMOPT=1
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT*MRD_SN?
12:20:24 lte,async lte1: rcvd *MRD_SN:723C037009D4
12:20:24 lte,debug lte serial: *MRD_SN:723C037009D4
12:20:24 lte,async lte1: sent AT+CFUN=4
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT*CGDFLT=0,"IP","APN.name",,,,,,,,,,1,0,,,,,,,1
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT*CGDFAUTH=0,2,"username","password"
12:20:24 lte,async lte1: rcvd OK
12:20:24 lte,async lte1: sent AT+CPIN?
12:20:24 lte,async lte1: rcvd +CPIN: READY
12:20:28 lte,async lte1: sent AT+CPMS="SM","SM","SM"
12:20:28 lte,async lte1: rcvd +CPMS: 5,5,5,5,0,0
12:20:28 lte,async lte1: sent AT+CFUN?
12:20:28 lte,async,event +MMSG: 0, 1
12:20:28 lte,async,event ^SMMEMFULL: SM
12:20:28 lte,async lte1: rcvd +CFUN: 4
12:20:28 lte,async lte1: sent AT+ICCID?
12:20:28 lte,async lte1: rcvd +ICCID: 89701010050339040743
12:20:28 lte,async lte1: sent AT+CNUM
12:20:28 lte,async lte1: rcvd +CME ERROR: 100
12:20:28 lte,async lte1: sent AT+CIMI
12:20:29 lte,async lte1: rcvd 250015033904074
12:20:29 lte,async lte1: sent AT+CPIN?
12:20:29 lte,async lte1: rcvd +CPIN: READY
12:20:29 lte,async lte1: sent AT*BAND=15,78,147,160,524487,1,2,0
12:20:29 lte,async lte1: rcvd OK
12:20:30 lte,async lte1: sent AT+COPS=0
12:20:30 lte,async lte1: rcvd OK
12:20:30 lte,async lte1: sent AT+CFUN=1
12:20:30 lte,async lte1: rcvd OK
12:20:30 lte,async lte1: sent AT+COPS=3,0
12:20:30 lte,async lte1: rcvd OK
12:20:30 lte,debug lte1: config ok

i tried sim-cards and apn with no password - and got the same trouble.

just after unsuccessfull connect modem responce in at-chat (i can send, for example, CFUN=1 or 4 and receive "ok"), but in couple minutes it discontinue to responce and reboot itself (i see in log things i posted higher), but stops exactly on line "config ok".

do somebody have any idea?

Who is online

Users browsing this forum: bpwl, freemannnn, LSan83 and 55 guests