Community discussions

MikroTik App
 
ilja
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 56
Joined: Thu Feb 22, 2018 1:15 pm

Super slow WiFi speed on default configuration

Sat Feb 22, 2020 1:19 pm

Hey all.

Can please someone help me understand what could be the problem in my simple configuration, when my WiFi is incredibly slow?
Came to a point of replacing home router to Mikrotik RB2011uias-2hnd-in (RouterOS v6.46.3 (stable)).
Did a factory configuration reset and have just set SSID and WEB2 password for WiFi.

Provider promises 100 Mbit/s.

My LAN ubuntu server (using speedtest-cli) shows:
Hosted by KeFF Networks (Kista) [4.78 km]: 2.076 ms
Testing download speed.........................................................a.......................
Download: 95.84 Mbit/s
Testing upload speed......................................................................................................
Upload: 2.93 Mbit/s
Which is promising :wink:

My WiFi ubuntu laptop (using speedtest-cli) on a distance on 4m from router shows:
Hosted by Tele2 (Kista) [4.71 km]: 9.398 ms
Testing download speed................................................................................
Download: 36.59 Mbit/s
Testing upload speed......................................................................................................
Upload: 3.64 Mbit/s
Which is 3 times slower :o :shock:

While my iPhone 7+ (using speedtest iOS app) on a distance on 4m from router shows:
Download - 18.1 Mbit/s
Upload - 9.41 Mbit/s

And friend's Galaxy S10+ (using speedtest Android app) same 4m distance gives:
Download- 33.3 Mbit/s
Upload - 7.62 Mbit/s

Can someone please help me to understand the bottleneck and how do I properly make a home network?
My goal is to have a stable WiFi in apartment(3 rooms apartment) with about max 10-15 devices connected simultaneously (a few phones, laptops, and Philips smart bulbs)

Here is my Mikrotik config export:
[admin@MikroTik] > /export 
# feb/22/2020 12:18:18 by RouterOS 6.46.3
# software id = 63WL-9G9C
#
# model = 2011UiAS-2HnD
# serial number = 467304B1DBAF
/interface bridge
add admin-mac=4C:5E:0C:43:D6:3E auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX country=sweden disabled=no distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid="The Apartment" wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=Kollektiv! wpa2-pre-shared-key=Kollektiv!
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
/ip dhcp-client
add comment=defconf disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/lcd interface pages
set 0 interfaces=wlan1
/system clock
set time-zone-name=Europe/Stockholm
/system routerboard settings
set auto-upgrade=yes cpu-frequency=700MHz silent-boot=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Thank you in advance for any help
 
erlinden
Long time Member
Long time Member
Posts: 694
Joined: Wed Jun 12, 2013 1:59 pm

Re: Super slow WiFi speed on default configuration

Sat Feb 22, 2020 2:42 pm

Default wireless configuration is like not really optimized...

To get best performance:

- use 20MHz bandwidth
- choose channel manually, either 2412/2437/2462 (perform a scan to get least used channel)
- set encryption on aes-ccm

Besides...what are you expecting? And what made you choose the RB2011 (with 2G only)?
First the problem, then the solution
 
ilja
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 56
Joined: Thu Feb 22, 2018 1:15 pm

Re: Super slow WiFi speed on default configuration

Sat Feb 22, 2020 4:42 pm

Default wireless configuration is like not really optimized...

To get best performance:

- use 20MHz bandwidth
- choose channel manually, either 2412/2437/2462 (perform a scan to get least used channel)
- set encryption on aes-ccm

Besides...what are you expecting? And what made you choose the RB2011 (with 2G only)?
Thank you for your answer and help, @erlinder.

I have put all suggested optimizations, but it didn't seem to change much.
My expectation would be to get 90+ mbps/s on WiFi, when operator promises 100 mbps/s on cable. Is that a realistic expectation at all?
By “2G only” you mean the router with 2GHz alone? Honestly, I didn’t have much choice when getting it, but I was aware that I would want to add 5GHz band, so my idea was to get a more less powerful “core”(RB2011) and then add an access point which would support 5GHz down the road
 
rudidxc
just joined
Posts: 22
Joined: Mon Aug 27, 2018 10:27 am

Re: Super slow WiFi speed on default configuration

Wed Nov 11, 2020 11:04 am

Hi. Did you ever figure this out? I'm sitting in the same boat at the moment.
 
erlinden
Long time Member
Long time Member
Posts: 694
Joined: Wed Jun 12, 2013 1:59 pm

Re: Super slow WiFi speed on default configuration

Wed Nov 11, 2020 11:34 am

Hi. Did you ever figure this out? I'm sitting in the same boat at the moment.
I think the conclusion not to expect too much wirelessly of this device as it is 2.4GHz only answers your question...
First the problem, then the solution
 
jimfizz
just joined
Posts: 1
Joined: Mon Jan 18, 2021 10:53 am

Re: Super slow WiFi speed on default configuration

Mon Jan 18, 2021 10:55 am

I had the same issue... resulted in me sending the device back for a refund.
Last edited by jimfizz on Mon Jan 18, 2021 4:21 pm, edited 1 time in total.
 
Msosa
just joined
Posts: 9
Joined: Sat Jun 17, 2017 3:39 am

Re: Super slow WiFi speed on default configuration

Mon Feb 01, 2021 6:06 am

Hi guys, it seems to be a good performance for a 2.4Ghz WiFi. If need fly faster you should buy a RB with 5Ghz antenna.

By other hand the default WiFi config it's not working well for me. I'm just getting 10Mbps on 2.4 WiFi. Really bad!!

Limiting AMSDU to 2048 I get a non stable improvement on performance.
 
santyx32
Member Candidate
Member Candidate
Posts: 159
Joined: Fri Oct 25, 2019 2:17 am

Re: Super slow WiFi speed on default configuration

Tue Feb 02, 2021 1:51 am

Hi guys, it seems to be a good performance for a 2.4Ghz WiFi. If need fly faster you should buy a RB with 5Ghz antenna.

By other hand the default WiFi config it's not working well for me. I'm just getting 10Mbps on 2.4 WiFi. Really bad!!

Limiting AMSDU to 2048 I get a non stable improvement on performance.
MT's non wave2 WiFi sucks but it's also true that you can't get fast 2.4GHz if you are on a crowded environment. When I was living on the suburbs I used to get 100-110Mbps with an old router on 2.4GHz (20MHz) using a 2x2 client but on the city I can only get 70Mbps at best using OpenWrt or 25Mbps with ROS on hAP ac2, 5GHz is fast on both but ROS WiFi has always been unreliable for me.

Who is online

Users browsing this forum: No registered users and 35 guests