Community discussions

MikroTik App
 
NielsP
just joined
Topic Author
Posts: 3
Joined: Sat May 26, 2018 10:19 pm

Impact of regulatory domain setting on TX power / overall WiFi stability (hAP ac)

Wed Mar 25, 2020 7:18 pm

A long whole ago, after replacing my previous outdated draft-n WiFi router with the Mikrotik hAP ac we noticed that the Mikrotik had a much less "powerful" WiFi signal, and sometimes we were losing connectivity even while within 5 meters (1 floor higher, Mikrotik close to ceiling of floor below) of the access point. After a lot of Googling around I noticed I was not the only one getting a "weak" signal, and I ended up disabling 5GHz WiFi which improved the WiFi connection stability, but not the range.

Today, before upgrading the firmware of my hAP ac, I read the changelogs and found some changes had been done on WiFi stability. After applying the update I again started playing around with the settings on the 2.4GHz interface. I found that when I unset the country, switch to manual TX power, but keep the antenna gain and other settings the same, suddenly my WiFi range improves and I no longer have an issue connecting to the WiFi from our second floor. How is it possible to see such a difference even though antenna gain is not changed, frequency is not changed, and manual TX power settings are not changed? If the manual TX power table doesn't reflect actual TX power when regulatory domain is configured, how can we see actual TX power?

Initial settings:
name="wlan1" mtu=1500 l2mtu=1600 mac-address=<removed> arp=enabled disable-running-check=no interface-type=Atheros AR9300 radio-name=<removed> mode=ap-bridge ssid=<removed> area="" frequency-mode=regulatory-domain country=belgium installation=indoor antenna-gain=3 frequency=2452 band=2ghz-g/n channel-width=20mhz secondary-channel="" scan-list=default wireless-protocol=802.11 rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 distance=indoors tx-power-mode=default noise-floor-threshold=default nv2-noise-floor-offset=default vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none wds-default-cost=100 wds-cost-range=50-150 wds-ignore-ssid=no update-stats-interval=disabled bridge-mode=disabled default-authentication=yes default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 wmm-support=disabled hide-ssid=no security-profile=default wps-mode=disabled station-roaming=enabled disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both compression=no allow-sharedkey=no station-bridge-clone-mac=00:00:00:00:00:00 ampdu-priorities=0 guard-interval=any ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 tx-chains=0,1,2 rx-chains=0,1,2 amsdu-limit=8192 amsdu-threshold=8192 tdma-period-size=2 nv2-queue-count=2 nv2-qos=default nv2-cell-radius=30 nv2-security=disabled nv2-preshared-key="" nv2-mode=dynamic-downlink nv2-downlink-ratio=50 nv2-sync-secret="" hw-retries=7 frame-lifetime=0 adaptive-noise-immunity=none hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 frequency-offset=0 rate-selection=advanced multicast-helper=default multicast-buffering=enabled keepalive-frames=enabled
Allowed channels:
channels: 2412/20/gn(17dBm),2417/20/gn(17dBm),2422/20/gn(17dBm),2427/20/gn(17dBm),2432/20/gn(17dBm),2437/20/gn(17dBm),2442/20/gn(17dBm),2447/20/gn(17dBm),2452/20/gn(17dBm),2457/20/gn(17dBm),2462/20/gn(17dBm),2467/20/gn(17dBm),2472/20/gn(17dBm)
Manual TX power table:
name="wlan1" manual-tx-powers=1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17
, 
                 HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17 
Modified settings:
name="wlan1" mtu=1500 l2mtu=1600 mac-address=<removed> arp=enabled disable-running-check=no interface-type=Atheros AR9300 radio-name=<removed> mode=ap-bridge ssid=<removed> area="" frequency-mode=manual-txpower country=no_country_set installation=indoor antenna-gain=3 frequency=2452 band=2ghz-g/n channel-width=20mhz secondary-channel="" scan-list=default wireless-protocol=802.11 rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 distance=indoors tx-power-mode=default noise-floor-threshold=default nv2-noise-floor-offset=default vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none wds-default-cost=100 wds-cost-range=50-150 wds-ignore-ssid=no update-stats-interval=disabled bridge-mode=disabled default-authentication=yes default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 wmm-support=disabled hide-ssid=no security-profile=default wps-mode=disabled station-roaming=enabled disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both compression=no allow-sharedkey=no station-bridge-clone-mac=00:00:00:00:00:00 ampdu-priorities=0 guard-interval=any ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 tx-chains=0,1,2 rx-chains=0,1,2 amsdu-limit=8192 amsdu-threshold=8192 tdma-period-size=2 nv2-queue-count=2 nv2-qos=default nv2-cell-radius=30 nv2-security=disabled nv2-preshared-key="" nv2-mode=dynamic-downlink nv2-downlink-ratio=50 nv2-sync-secret="" hw-retries=7 frame-lifetime=0 adaptive-noise-immunity=none hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 frequency-offset=0 rate-selection=advanced multicast-helper=default multicast-buffering=enabled keepalive-frames=enabled
Allowed channels (limit of 17dBm no longer shown):
channels: 2412/20/gn,2417/20/gn,2422/20/gn,2427/20/gn,2432/20/gn,2437/20/gn,2442/20/gn,2447/20/gn,2452/20/gn,2457/20/gn,2462/20/gn
Manual TX power table prints exactly the same as with original settings.
 
User avatar
bpwl
Member
Member
Posts: 302
Joined: Mon Apr 08, 2019 1:16 am

Re: Impact of regulatory domain setting on TX power / overall WiFi stability (hAP ac)

Wed Mar 25, 2020 8:23 pm

The tx-power limit is dependent on country set (and antenna gain). You must set the country you are in to be legally correct. Also "no_country_set" has a reduced number of channels.
Those limits are mandatory for all manufacturers and users. (but old devices were not always compliant, today they cannot be sold)

See CLI:
[admin@Mikrotik] /interface wireless info> country-info
country: no_country_set
ranges: 2402-2472/b,g,gn20,gn40(30dBm)
2417-2457/g-turbo(20dBm)
5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(17dBm)/indoor
5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/dfs,passive
5735-5835/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(30dBm)/outdoor
5190-5230/a-turbo(17dBm)/dfs,indoor
5230-5310/a-turbo(23dBm)/dfs,passive
5740-5820/a-turbo(30dBm)/dfs,outdoor
5180-5260/a-turbo(17dBm)
5260-5300/a-turbo(23dBm)/dfs,passive
5745-5825/a-turbo(30dBm)
902-927/b,g,g-turbo,gn20,gn40(30dBm)

[admin@Mikrotik] /interface wireless info> country-info
country: belgium
ranges: 2402-2482/b,g,gn20,gn40(20dBm)
2417-2457/g-turbo(20dBm)
5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive,indoor
5170-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive,indoor
5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive,indoor
5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
5190-5310/a-turbo(20dBm)/dfs
5180-5300/a-turbo(20dBm)/dfs
5520-5680/a-turbo(27dBm)/dfs,passive
5510-5670/a-turbo(27dBm)/dfs,passive
902-927/b,g,g-turbo,gn20,gn40(30dBm)


The Txpower is limited by the regulations. This power includes the antenna gain. (EIRP means I=isotropic radiation, the calculation takes the strongest direction and assumes it radiates in all directions with that value). As the antenna gain is 3 dBi, the max TX power for the radio is 20-3= 17 dBm.
When setting "no_country_set" then the maximum radio TXpower for 2.4 GHz is 30-3=27dBm. That is an upper limit, your manual power did set it lower.

The used power limit can be seen in the wireless interface "Status" ("current TX power" is missing for some 5 GHz radio's)
Last edited by bpwl on Wed Apr 01, 2020 4:00 pm, edited 1 time in total.
 
User avatar
bpwl
Member
Member
Posts: 302
Joined: Mon Apr 08, 2019 1:16 am

Re: Impact of regulatory domain setting on TX power / overall WiFi stability (hAP ac)

Wed Mar 25, 2020 9:09 pm

Modified settings:
name="wlan1" mtu=1500 l2mtu=1600 mac-address=<removed> arp=enabled disable-running-check=no interface-type=Atheros AR9300 radio-name=<removed> mode=ap-bridge ssid=<removed> area="" frequency-mode=manual-txpower country=no_country_set installation=indoor antenna-gain=3 frequency=2452 band=2ghz-g/n channel-width=20mhz secondary-channel="" scan-list=default wireless-protocol=802.11 rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=2007 distance=indoors tx-power-mode=default noise-floor-threshold=default nv2-noise-floor-offset=default vlan-mode=no-tag vlan-id=1 wds-



You are using "default" for TX power: tx-power-mode=default not manual. So your manual TX power table is not used.
Selecting "manual" for tx-power-mode is not always possible.
This setting in a wAP ac gives me 25 dBm in "Current TX power" .... illegal
 
NielsP
just joined
Topic Author
Posts: 3
Joined: Sat May 26, 2018 10:19 pm

Re: Impact of regulatory domain setting on TX power / overall WiFi stability (hAP ac)

Wed Apr 01, 2020 2:10 pm

Thank you for the clarification. I didn't know how to check current TX power -- now I've found it in Webfig in the "advanced mode".

Belgium:
TX-power-BE.png
No country set:
TX-power-NCS.png
This explains the sudden improvement in signal strength -- and also shows the "no country set" shouldn't be used. I cannot configure TX power mode manually; Webfig complains my wireless interface doesn't support that.

Are there any other ways I can improve the signal strength on the floor which is (literally) on top of the existing WiFi AP, other than by adding a new WiFi AP?
You do not have the required permissions to view the files attached to this post.
 
User avatar
macsrwe
Forum Veteran
Forum Veteran
Posts: 895
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: Impact of regulatory domain setting on TX power / overall WiFi stability (hAP ac)

Thu Apr 02, 2020 12:43 am

You could try physically tilting the AP... but that might not solve your underlying problem anyway.

If your router is having problems penetrating to the floor above, your devices on the floor above are likely to have exactly the same problems penetrating to the router on the floor below.

Who is online

Users browsing this forum: zandhaas and 80 guests