Community discussions

MikroTik App
 
petterg
Member Candidate
Member Candidate
Topic Author
Posts: 210
Joined: Wed Sep 16, 2009 2:55 pm

CAPS not provisioned

Wed Mar 25, 2020 9:31 pm

After two years of not working with networking I'm feeling like a noob when returning. I'm probably missing some details in the config.
I've setup a capsman (3011) and some caps. All caps behave the same, so I focus on one of them, a cAP. The cap is connecting to capsman, but it (they) does not get any configuration. Also, the caps only shows two interfaces, it should be 14 (7 ssid's/vlan with two radios). To me it seems like the caps connects, but for some reason it does not find it's configuration. It does not make a difference if I empty the Identity Regexp in capsman provisioning.

EDIT: removing all lines of config except for those that caused trouble
Capsman config:
/caps-man configuration
add channel.reselect-interval=1d country=norway datapath=datapath40 mode=ap name=wlan40 security=sec40 ssid=wlan40
add country=norway datapath=datapath41 mode=ap name=wlan41 security=sec41 ssid=wlan41
add country=norway datapath=datapath42 mode=ap name=wlan42 security=sec42 ssid=wlan42
add country=norway datapath=datapath43 mode=ap name=wlan43 security=sec43 ssid=wlan43
add country=norway datapath=datapath44 mode=ap name=wlan44 security=sec44 ssid=wlan44
add country=norway datapath=datapath45 mode=ap name=wlan45 security=sec45 ssid=wlan45
add country=norway datapath=datapath46 mode=ap name=wlan46 security=sec46 ssid=wlan46
/caps-man provisioning
add action=create-dynamic-enabled identity-regexp="^al[h|w|c]ap[0-9]*" master-configuration=wlan40 name-format=prefix-identity name-prefix=cap \
slave-configurations=wlan41,wlan42,wlan43,wlan44,wlan45,wlan46
Last edited by petterg on Thu Mar 26, 2020 6:52 pm, edited 2 times in total.
 
petterg
Member Candidate
Member Candidate
Topic Author
Posts: 210
Joined: Wed Sep 16, 2009 2:55 pm

Re: CAPS not provisioned  [SOLVED]

Thu Mar 26, 2020 6:46 pm

Solved!
It turns out that the naming of the capsman configurations was the problem. A wlan configuration named "wlan40", "wlan41", ... causes some conflicts.

Feature request: Give a error when a conflicting name is set. (just the same way as when trying to create a firewall rule with an invalid ip/subnet)

Who is online

Users browsing this forum: Fl3tch, MSN [Bot] and 71 guests