Community discussions

MikroTik App
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

wAP AC - 5Ghz wireless very slow

Tue Apr 28, 2020 11:06 pm

Hello,

I am wondering why my 5Ghz wireless speed is so much slower than it should be? When I setup the wAP AC device the absolute maximum I can push in a momentary spike is 399Mbps, but average is around ~200-240Mbps regardless of the device I use.

The router is setup as an AP only and all routing is handled by a Debian box which is 10Gbit capable and, using a Cisco AP, can push up to 800Mbps without issue. There is a simple default bridge with all interfaces attached.

Here is a 30-second iPerf from my MacBook to the Debian gateway (you can see how it drops off)

[ 4] 0.00-1.00 sec 47.5 MBytes 399 Mbits/sec
[ 4] 1.00-2.00 sec 37.9 MBytes 318 Mbits/sec
[ 4] 2.00-3.00 sec 37.4 MBytes 313 Mbits/sec
[ 4] 3.00-4.00 sec 38.1 MBytes 320 Mbits/sec
[ 4] 4.00-5.00 sec 31.7 MBytes 265 Mbits/sec
[ 4] 5.00-6.00 sec 33.2 MBytes 279 Mbits/sec
[ 4] 6.00-7.00 sec 27.9 MBytes 234 Mbits/sec
[ 4] 7.00-8.00 sec 30.2 MBytes 254 Mbits/sec
[ 4] 8.00-9.00 sec 29.5 MBytes 247 Mbits/sec
[ 4] 9.00-10.00 sec 30.1 MBytes 252 Mbits/sec
[ 4] 10.00-11.00 sec 30.1 MBytes 252 Mbits/sec
[ 4] 11.00-12.00 sec 27.7 MBytes 233 Mbits/sec
[ 4] 12.00-13.00 sec 32.2 MBytes 270 Mbits/sec
[ 4] 13.00-14.00 sec 29.6 MBytes 249 Mbits/sec
[ 4] 14.00-15.00 sec 30.4 MBytes 255 Mbits/sec
[ 4] 15.00-16.00 sec 30.3 MBytes 254 Mbits/sec
[ 4] 16.00-17.00 sec 29.9 MBytes 250 Mbits/sec
[ 4] 17.00-18.00 sec 35.2 MBytes 297 Mbits/sec
[ 4] 18.00-19.00 sec 29.3 MBytes 246 Mbits/sec
[ 4] 19.00-20.00 sec 29.8 MBytes 250 Mbits/sec
[ 4] 20.00-21.00 sec 29.3 MBytes 246 Mbits/sec
[ 4] 21.00-22.00 sec 29.7 MBytes 249 Mbits/sec
[ 4] 22.00-23.00 sec 26.6 MBytes 223 Mbits/sec
[ 4] 23.00-24.00 sec 24.9 MBytes 209 Mbits/sec
[ 4] 24.00-25.00 sec 30.5 MBytes 256 Mbits/sec
[ 4] 25.00-26.00 sec 29.4 MBytes 247 Mbits/sec
[ 4] 26.00-27.00 sec 27.5 MBytes 231 Mbits/sec
[ 4] 27.00-28.00 sec 27.4 MBytes 230 Mbits/sec
[ 4] 28.00-29.00 sec 28.7 MBytes 240 Mbits/sec
[ 4] 29.00-30.00 sec 26.6 MBytes 224 Mbits/sec


Here is my AP config:

[admin@MikroTik] > /export hide-sensitive
# apr/28/2020 17:50:24 by RouterOS 6.46.6
# software id = BSFU-364V
#
# model = RBwAPG-5HacT2HnD
# serial number = BED90B00DCF6
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
mode=dynamic-keys supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=\
allowed mode=dynamic-keys name=profile1 supplicant-identity=""
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX \
country=canada2 disabled=no frequency=auto mode=ap-bridge security-profile=\
profile1 ssid=MikroTik wireless-protocol=802.11
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan2
/ip dhcp-client
add disabled=no interface=bridge1



Additional notes:
1.) There is very little interference where I live and there are only 1 client connected.
2.) Test results are taken from 4 meters away, line of sight.
3.) I have changed channels, regulatory domains and have reset the device several times and still see the same results. Never over ~300 consistently.
 
brg3466
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Aug 01, 2015 7:29 am

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 4:19 am

I have the same issue. I have wap ac and cap ac connected to the router with capsman. Never exceed 300mbps on WiFi although I have 1Gbps connection from ISP.
 
erlinden
Member Candidate
Member Candidate
Posts: 286
Joined: Wed Jun 12, 2013 1:59 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 9:33 am

Couple of suggestions:
  • Turn of a, only use n/ac
  • Don't use anything other then WPA2-AES
  • Distance Indoors (if used indoors)
  • Turn on WMM
  • Rates: 12/24 (basic) and 12 - 54 (supported)
  • Choose channel manually
  • Lower (max) transmission power by 3dB
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 11:34 am

Thanks for your reply!

I did all of this and the average did seem to increase by 20-30mbps, but still not where I am hoping to see this.

I'm starting to wonder if this AP can even handle 400-600mbps, which is what I would have really liked to see. I did notice at 280mbps the CPU is at 42%, so I don't think the CPU is what is causing the problem.
 
erlinden
Member Candidate
Member Candidate
Posts: 286
Joined: Wed Jun 12, 2013 1:59 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 12:20 pm

At what speed is the MB connected? Is it 3x3 capable?
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 12:55 pm

Yes, both testing devices are connected devices are 3x3 capable.

Macbook = 780Mbps-80MHz/3S/SGI
Mac Mini = 975Mbps-80MHz/3S/SGI

Also, if I try to use both to run iPerf at the same time, the throughput is the same or worse than from a single device.

The same devices, connected at the same speed to a Cisco AP or Hitron AP, hit 800mbps.
 
erlinden
Member Candidate
Member Candidate
Posts: 286
Joined: Wed Jun 12, 2013 1:59 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 1:12 pm

Are both devices connected wirelessly while running iPerf?
In that case, can you at least have one device connected through cable?
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 1:21 pm

The clients are running iPerf connecting to the gateway running iperf (debian firewall/router, connected to LAN). I've also tried public iPerf servers (I have 1GBit connection) and same result.

When doing the exact same tests, in the same location of the room and with the routers plugged in side by side (1 at a time, to avoid interference) I can double my iPerf results.

Thanks a lot for helping me out here - appreciate it.
 
brg3466
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Aug 01, 2015 7:29 am

Re: wAP AC - 5Ghz wireless very slow

Wed Apr 29, 2020 9:35 pm

Couple of suggestions:
  • Turn of a, only use n/ac
  • Don't use anything other then WPA2-AES
  • Distance Indoors (if used indoors)
  • Turn on WMM
  • Rates: 12/24 (basic) and 12 - 54 (supported)
  • Choose channel manually
  • Lower (max) transmission power by 3dB
@erlinden,could you please let me know where in CAPsMAN to set the WMM ? I did the rest you suggested but cannot find WMM set up. thank you !
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

Re: wAP AC - 5Ghz wireless very slow

Thu Apr 30, 2020 12:04 am

If you're using caps, your speed will be significantly less than it would be otherwise.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 553
Joined: Mon Apr 08, 2019 1:16 am

Re: wAP AC - 5Ghz wireless very slow

Sat May 23, 2020 2:25 am

Couple of suggestions:
  • Turn of a, only use n/ac
  • Don't use anything other then WPA2-AES
  • Distance Indoors (if used indoors)
  • Turn on WMM
  • Rates: 12/24 (basic) and 12 - 54 (supported)
  • Choose channel manually
  • Lower (max) transmission power by 3dB
@erlinden,could you please let me know where in CAPsMAN to set the WMM ? I did the rest you suggested but cannot find WMM set up. thank you !
CAPSMAN sets WMM, it can not be turned off (says Uldis: viewtopic.php?f=2&t=125152)
Worse, WMM is probably only overhead if there are no mangle rules to set the priority.
MCS5 and MCS7 are not the top speed for the "ac" interface rate. Check "registration" for CCQ and retransmits. (it wastes time, lowers the MCS rate).
The % bandwidth you get from an interface depends on aggregation. If there are many retransmits the A-PMDU with smaller A-MSDU should be preferred above A-MSDU at max size.
Tuning is then lowering hw_retry=3, set max VHT MCS, A-MSDU=2048, even going to 2X2 .... all steps that each lower the capacity considerably, but one of them might still give better results.
All of them together would be a very drastic reduction. Don't use them if no gain in throughput.
 
jcbhltz909
just joined
Topic Author
Posts: 10
Joined: Tue Apr 28, 2020 10:49 pm

Re: wAP AC - 5Ghz wireless very slow

Mon May 25, 2020 10:42 am

Thanks for the reply!

I've decided to use different hardware, but still would like to know what that maximum realistic throughput of these devices would be in an ideal situation.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 553
Joined: Mon Apr 08, 2019 1:16 am

Re: wAP AC - 5Ghz wireless very slow

Mon May 25, 2020 12:38 pm

Performance numbers, not so easy to find

Mikrotik only gives ethernet performance numbers of the QCA9556: https://mikrotik.com/product/RBwAPG-5Ha ... estresults
The wireless is done by the QCA9880 on a miniPCIe card.https://datasheetspdf.com/pdf-file/9447 ... /QCA9880/1
Those performance numbers are not available, at least I didn't find them, except a very old user test: viewtopic.php?t=86846#p435669

Wifi performance depends on the client characteristics and match. Signal strength must be at least -65dBm, and clean. MCS9 as VHT interface rate, 802.11ac only. No CAPsMAN. No retransmits (CCQ=100). A-MSDU and A-PMDU must be active at the max.values.
https://www.duckware.com/tech/wifi-in-the-us.html
 
whatever
Member Candidate
Member Candidate
Posts: 132
Joined: Thu Jun 21, 2018 9:29 pm

Re: wAP AC - 5Ghz wireless very slow

Mon May 25, 2020 1:12 pm

[...] but still would like to know what that maximum realistic throughput of these devices would be in an ideal situation.
It think you already reached the maximum expectable single stream TCP throughput with mikrotik wifi. You might be able to get 10-20% improvements with careful tuning of parameters, but with current software it will never reach anywhere near your Cisco's 800Mbps.

Btw: The latest stable and long-term release made a huge improvement for single-chain clients, I am now able to get up to 250 Mbps with these which is great. Unfortunately the performance just doesn't scale well with multiple chains/antennas.

Who is online

Users browsing this forum: No registered users and 44 guests