Community discussions

MikroTik App
 
yel
just joined
Topic Author
Posts: 2
Joined: Fri May 01, 2020 1:33 pm

Disable WLan Interface with button on CAP AC with CAPsMAN

Fri May 01, 2020 2:15 pm

Hi
I want to use the buttons on the Cap AC to enabled/disable WLan. The ACs are managed by CAPsMAN from a HEX router.
Because of that If I want to disable wlan1 or 2 by script on the device it says "failure: interface managed by CAPsMAN"

How must the script look like? Do I need one per AC to access CAPsMAN and enable/disable it from there?
Can I access the routerboard of the managed ACs via CAPsMAN to programm scripts centrally?

Thanks for your help in advnce!
 
yel
just joined
Topic Author
Posts: 2
Joined: Fri May 01, 2020 1:33 pm

Re: Disable WLan Interface with button on CAP AC with CAPsMAN

Wed May 06, 2020 5:07 pm

any idea? is it not possible?
 
seb13
just joined
Posts: 4
Joined: Mon Sep 12, 2016 10:11 pm

Re: Disable WLan Interface with button on CAP AC with CAPsMAN

Sat Jan 02, 2021 9:24 pm

Hi,

I wrote the following script for the same purpose. It's working fine for some time now. Still working on 6.48.

:log info message=("mode button was pressed");
:local i

:if ([/int wir cap get enabled] = true) do={
  /interface wireless cap set enabled=no;
  :if ( [/int wir get 0 disabled ] = false ) do={
    :foreach i in= [ /int wir find ] do={ :int wir disable $i };
  }
} else={
  /interface wireless cap set enabled=yes
}

You can also find it on my github gists: https://gist.github.com/sebastian13/565 ... acbb640c48

Who is online

Users browsing this forum: No registered users and 38 guests