Community discussions

MikroTik App
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

[Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 6:32 am

My devices:
Router is CCR1009-7G-1C-1S+ (tile), 5 APs are RBwAPG-5HacT2HnD.

My network toplogy:
Image

Even PCs or Mobiles link speed is 866Mbps, but actually speed only 200Mb,


below is mobile to LAN server:
Image

Image

CAPsMAN config:
Image

Image

Image

Image

Image

Image


My ISP bandwith is 1000Mb, but test max <200Mb, as below:
Image
 
sasparilla
newbie
Posts: 28
Joined: Thu Nov 16, 2017 11:17 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 11:28 am

hello,

why do you have so many configs in capsman? one for 2,4 and 5 ghz each should be enough? (auto channel)
Regarding speeds in capsman: you should enable local forwarding, otherwise all traffic gets routed to the capsman-controller, wich can be a bottleneck.
This way the load will be distributed accross all your caps.

Note that with local forwarding you will need to create local bridges on all of your caps.
 
sasparilla
newbie
Posts: 28
Joined: Thu Nov 16, 2017 11:17 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 11:32 am

note also that wap ac is not the fastest, max net-throughput with local bridge in my experience is around 300 mbit/s (wich is not bad for a device in this price-point)
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 1:09 pm

note also that wap ac is not the fastest, max net-throughput with local bridge in my experience is around 300 mbit/s (wich is not bad for a device in this price-point)
thank you.
I have tried use Local Bridge but the same result, max dowload 200Mb.

about channels, firsttime I try use manual channels and now use auto channels: only channel2.4 and channel5 is using.
 
biomesh
Member
Member
Posts: 395
Joined: Fri Feb 10, 2012 8:25 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 1:14 pm

In real life (no matter what hardware you use) you will generally get up to 1/2 the transfer speeds with regards to your link speeds.

As for your config, can you post an export from your capsman manager device? This provides more details to be able to help.
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 1:40 pm

In real life (no matter what hardware you use) you will generally get up to 1/2 the transfer speeds with regards to your link speeds.

As for your config, can you post an export from your capsman manager device? This provides more details to be able to help.
please see below, APs MAC address I replace with 'xxx':

[howard@SK-RouterOS] /caps-man> export
# sep/02/2020 18:34:46 by RouterOS 6.47.2
# software id = JPEQ-ZDET
#
# model = CCR1009-7G-1C-1S+
# serial number = 91500A426B08
/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz frequency=2412 name=channel1-2.4
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=XXXX \
frequency=5180 name=channel36-5
add band=2ghz-g/n control-channel-width=20mhz frequency=2437 name=channel6-2.4
add band=2ghz-g/n control-channel-width=20mhz frequency=2462 name=channel11-2.4
add band=2ghz-g/n control-channel-width=20mhz frequency=2422 name=channel3-2.4
add band=2ghz-g/n control-channel-width=20mhz frequency=2452 name=channel9-2.4
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=XXXX \
frequency=5240 name=channel48-5
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=XXXX \
frequency=5200 name=channel40-5
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=XXXX \
frequency=5220 name=channel44-5
add band=5ghz-n/ac control-channel-width=20mhz frequency=5260 name=\
channel52-5-dfs
add band=5ghz-n/ac control-channel-width=20mhz frequency=5320 name=\
channel64-5-dfs
add band=5ghz-n/ac control-channel-width=20mhz frequency=5280 name=\
channel56-5-dfs
add band=5ghz-n/ac control-channel-width=20mhz frequency=5300 name=\
channel60-5-dfs
add band=2ghz-g/n control-channel-width=20mhz extension-channel=disabled name=\
channel2.4
add band=5ghz-n/ac control-channel-width=20mhz extension-channel=XXXX name=\
channel5
/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm group-encryption=\
aes-ccm name=security1 passphrase=SuperK2018
/caps-man access-list
add action=accept allow-signal-out-of-range=10s disabled=no signal-range=\
-70..120 ssid-regexp=""
add action=reject allow-signal-out-of-range=10s comment=\
"drop low signal devices" disabled=no signal-range=-120..-71 ssid-regexp=""
/caps-man configuration
add channel=channel1-2.4 datapath=datapath1 mode=ap name=cfg1-2.4 security=\
security1 ssid=wintaiwoo2.4
add channel=channel36-5 datapath=datapath1 mode=ap name=cfg36-5 security=\
security1 ssid=wintaiwoo5
add channel=channel3-2.4 datapath=datapath1 mode=ap name=cfg3-2.4 security=\
security1 ssid=wintaiwoo2.4
add channel=channel40-5 datapath=datapath1 mode=ap name=cfg40-5 security=\
security1 ssid=wintaiwoo5
add channel=channel6-2.4 datapath=datapath1 name=cfg6-2.4 security=security1 \
ssid=wintaiwoo2.4
add channel=channel44-5 datapath=datapath1 mode=ap name=cfg44-5 security=\
security1 ssid=wintaiwoo5
add channel=channel9-2.4 datapath=datapath1 name=cfg9-2.4 security=security1 \
ssid=wintaiwoo2.4
add channel=channel48-5 datapath=datapath1 mode=ap name=cfg48-5 security=\
security1 ssid=wintaiwoo5
add channel=channel52-5-dfs datapath=datapath1 mode=ap name=cfg52-5 security=\
security1 ssid=wintaiwoo5
add channel=channel56-5-dfs datapath=datapath1 mode=ap name=cfg56-5 security=\
security1 ssid=wintaiwoo5
add channel=channel11-2.4 datapath=datapath1 mode=ap name=cfg11-2.4 security=\
security1 ssid=wintaiwoo2.4
add channel=channel2.4 country=china datapath=datapath1 mode=ap name=cfg2.4 \
security=security1 ssid=wintaiwoo2.4
add channel=channel5 country=china datapath=datapath1 mode=ap name=cfg5 \
security=security1 ssid=wintaiwoo5
/caps-man datapath
add bridge=bridge1-192.168.1.0 client-to-client-forwarding=yes name=datapath1
/caps-man interface
add comment="Big meeting room" configuration=cfg2.4 disabled=no l2mtu=1600 \
mac-address=CC:2D:E0:xxx master-interface=none name=cap1-2.4g \
radio-mac=CC:2D:E0:xxx radio-name=CC2DE0Cxxx
add configuration=cfg5 disabled=no l2mtu=1600 mac-address=CC:2D:E0:xxx \
master-interface=none name=cap1-5g radio-mac=CC:2D:E0:xxx radio-name=\
CC2DE0Cxxx
add comment=Boss configuration=cfg2.4 disabled=no l2mtu=1600 mac-address=\
CC:2D:E0:xxx master-interface=none name=cap2-2.4g radio-mac=\
CC:2D:E0:xxx radio-name=CC2DE0xxx
add configuration=cfg5 disabled=no l2mtu=1600 mac-address=CC:2D:E0:xxx \
master-interface=none name=cap2-5g radio-mac=CC:2D:E0:xxx radio-name=\
CC2DE0xxx
add comment=Jake configuration=cfg2.4 disabled=no l2mtu=1600 mac-address=\
74:4D:28:xxx master-interface=none name=cap3-2.4g radio-mac=\
74:4D:28:xxx radio-name=744D28xxx
add configuration=cfg5 disabled=no l2mtu=1600 mac-address=74:4D:28:xxx \
master-interface=none name=cap3-5g radio-mac=74:4D:28:xxx radio-name=\
744D28xxx
add comment=Chunyang configuration=cfg2.4 disabled=no l2mtu=1600 mac-address=\
74:4D:28:xxx master-interface=none name=cap4-2.4g radio-mac=\
74:4D:28:xxx radio-name=744D28xxx
add configuration=cfg5 disabled=no l2mtu=1600 mac-address=74:4D:28xxx \
master-interface=none name=cap4-5g radio-mac=74:4D:28:xxx0 radio-name=\
744D28xxx
add comment=Irene configuration=cfg2.4 disabled=no l2mtu=1600 mac-address=\
74:4D:28:xxx master-interface=none name=cap5-2.4g radio-mac=\
74:4D:28:xxx radio-name=744D28xxx
add configuration=cfg5 disabled=no l2mtu=1600 mac-address=74:4D:xxx \
master-interface=none name=cap5-5g radio-mac=74:4D:28:xxx radio-name=\
744D28xxx
/caps-man manager
set enabled=yes package-path=/ap-upgrade upgrade-policy=suggest-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge1-192.168.1.0
/caps-man provisioning
add action=create-enabled disabled=yes master-configuration=cfg1-2.4
add action=create-enabled disabled=yes master-configuration=cfg36-5
add action=create-enabled disabled=yes master-configuration=cfg3-2.4
add action=create-enabled disabled=yes master-configuration=cfg40-5
add action=create-enabled disabled=yes master-configuration=cfg6-2.4
add action=create-enabled disabled=yes master-configuration=cfg44-5
add action=create-enabled disabled=yes master-configuration=cfg9-2.4
add action=create-enabled disabled=yes master-configuration=cfg48-5
add action=create-enabled disabled=yes master-configuration=cfg11-2.4
add action=create-enabled disabled=yes master-configuration=cfg52-5
add action=create-enabled master-configuration=cfg2.4 name-prefix=MikroTik
add action=create-enabled master-configuration=cfg5 name-prefix=MikroTik
 
biomesh
Member
Member
Posts: 395
Joined: Fri Feb 10, 2012 8:25 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 02, 2020 2:12 pm

I don't really see anything wrong with the config, but I would definitely see if capsman forwarding is your issue. Check the cpu on your ap and router while doing iperf speed tests.

You might want to see if you have overlapping channels too close to one another since you are using 80MHz channels. Many times going from 80 to 40 will help if there is a lot of inference. The link rates will be lower, but the speeds will be more consistent.

If you set the data path to be local forwarding=yes, be sure to delete the cap interface and reprovision the radio via capsman.
 
Shy
Member Candidate
Member Candidate
Posts: 243
Joined: Sat Jun 13, 2020 8:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 03, 2020 1:02 am

Following
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 03, 2020 4:40 am

I don't really see anything wrong with the config, but I would definitely see if capsman forwarding is your issue. Check the cpu on your ap and router while doing iperf speed tests.

You might want to see if you have overlapping channels too close to one another since you are using 80MHz channels. Many times going from 80 to 40 will help if there is a lot of inference. The link rates will be lower, but the speeds will be more consistent.

If you set the data path to be local forwarding=yes, be sure to delete the cap interface and reprovision the radio via capsman.
thanks.

I'll try set the channel to xx.

and try again use 'Local forwarding".
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 8:52 am

I don't really see anything wrong with the config, but I would definitely see if capsman forwarding is your issue. Check the cpu on your ap and router while doing iperf speed tests.

You might want to see if you have overlapping channels too close to one another since you are using 80MHz channels. Many times going from 80 to 40 will help if there is a lot of inference. The link rates will be lower, but the speeds will be more consistent.

If you set the data path to be local forwarding=yes, be sure to delete the cap interface and reprovision the radio via capsman.
one more question about this "If you set the data path to be local forwarding=yes, be sure to delete the cap interface and reprovision the radio via capsman."
you mean delete cap interface from CAPsMAN - configurations ?
 
Shy
Member Candidate
Member Candidate
Posts: 243
Joined: Sat Jun 13, 2020 8:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 9:57 am

Yes and then to reprovision it will recreate it

Sent from my SM-A705FN using Tapatalk

 
erlinden
Forum Veteran
Forum Veteran
Posts: 895
Joined: Wed Jun 12, 2013 1:59 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 10:40 am

Don't use wpa-psk as authentication-types. Ever. Only use wpa2-psk.
Don't use overlapping channels (also on 5GHz) and use specific extension channels (use Ceee instead of XXXX).
First the problem, then the solution
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 11:35 am

Yes and then to reprovision it will recreate it

Sent from my SM-A705FN using Tapatalk
thank you.
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 11:36 am

Don't use wpa-psk as authentication-types. Ever. Only use wpa2-psk.
Don't use overlapping channels (also on 5GHz) and use specific extension channels (use Ceee instead of XXXX).
thank you, I'll try...
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 9245
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 04, 2020 3:57 pm

In real life (no matter what hardware you use) you will generally get up to 1/2 the transfer speeds with regards to your link speeds.

As for your config, can you post an export from your capsman manager device? This provides more details to be able to help.
First for the OP, where do you see this 866 speed that you keep stating and specifically what does this have to do with wifi throughput??
Reading the spec sheet, the 2.4 speed is stated as 300, and the 5ghz speed is rated at 1300.
I do note they say AC1600 which seems nothing more to me that 300+1300=1600

If you are talking the advertised WIFI speeds then you havent paid attention or have been duped by marketing.
Typically one will see TWO WAY speeds advertised while we as users tend to think one way, up or down.
So, lets say for the 5AC, as biomesh pointed out the expectation should be a starting point of 1300/2= 650 one way speed for the 5ghz network.
However that is theoretical and doesn't take into account normal propagation losses through air, cabling etc,"
Then we have to factor in any walls or physical obstacles in the way of the signal
Then we have to factor in any electrical appliances and lighting or currents in the house that may affect/interfere with signal
Then we have to factor in any competing devices such as other WIFI radios.

The best rule of thumb is the 1/3 rule. 1300/3= 433 should be what you are seeing give er take on the device.
In your case then, there is definitely some issues. With a LOS connectivity you should reasonable expect to get +400Mbps.

I have a capac and through two walls and one cabinet(solid wood) and all the other issues about 40down and 30 up on 2.4ghz and 15 down and 10 up on 5ghz.
and yet the unit drawing a straight line is not that far from the receiving unit (firestick).
867/3= 289 is what I should be able to reasonably get for 5ghz
300/3= 100 is what I should be able to reasonably get for 2ghz
Which goes to show you cannot overcome physics magically of obstructions and interference.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 5:12 am

In real life (no matter what hardware you use) you will generally get up to 1/2 the transfer speeds with regards to your link speeds.

As for your config, can you post an export from your capsman manager device? This provides more details to be able to help.
First for the OP, where do you see this 866 speed that you keep stating and specifically what does this have to do with wifi throughput??
Reading the spec sheet, the 2.4 speed is stated as 300, and the 5ghz speed is rated at 1300.
I do note they say AC1600 which seems nothing more to me that 300+1300=1600

If you are talking the advertised WIFI speeds then you havent paid attention or have been duped by marketing.
Typically one will see TWO WAY speeds advertised while we as users tend to think one way, up or down.
So, lets say for the 5AC, as biomesh pointed out the expectation should be a starting point of 1300/2= 650 one way speed for the 5ghz network.
However that is theoretical and doesn't take into account normal propagation losses through air, cabling etc,"
Then we have to factor in any walls or physical obstacles in the way of the signal
Then we have to factor in any electrical appliances and lighting or currents in the house that may affect/interfere with signal
Then we have to factor in any competing devices such as other WIFI radios.

The best rule of thumb is the 1/3 rule. 1300/3= 433 should be what you are seeing give er take on the device.
In your case then, there is definitely some issues. With a LOS connectivity you should reasonable expect to get +400Mbps.

I have a capac and through two walls and one cabinet(solid wood) and all the other issues about 40down and 30 up on 2.4ghz and 15 down and 10 up on 5ghz.
and yet the unit drawing a straight line is not that far from the receiving unit (firestick).
867/3= 289 is what I should be able to reasonably get for 5ghz
300/3= 100 is what I should be able to reasonably get for 2ghz
Which goes to show you cannot overcome physics magically of obstructions and interference.
hello, as you said, then my case speed is 867Mbps the really speed is 867/3=289 and it's normal?
 
User avatar
krafg
Forum Veteran
Forum Veteran
Posts: 821
Joined: Sun Jun 28, 2015 7:36 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 6:04 am

hello, as you said, then my case speed is 867Mbps the really speed is 867/3=289 and it's normal?
Link speed is 867Mbps but real throughput is normally around 1/3 of it.
If you want to know my network, you can find it here. (AMD64 Computers Outdated - Update is comming).

Telegram: @krafgrgi

Image
 
heidarren
Member Candidate
Member Candidate
Posts: 134
Joined: Mon Aug 05, 2019 9:56 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 8:17 am

In real life (no matter what hardware you use) you will generally get up to 1/2 the transfer speeds with regards to your link speeds.

As for your config, can you post an export from your capsman manager device? This provides more details to be able to help.
First for the OP, where do you see this 866 speed that you keep stating and specifically what does this have to do with wifi throughput??
Reading the spec sheet, the 2.4 speed is stated as 300, and the 5ghz speed is rated at 1300.
I do note they say AC1600 which seems nothing more to me that 300+1300=1600

If you are talking the advertised WIFI speeds then you havent paid attention or have been duped by marketing.
Typically one will see TWO WAY speeds advertised while we as users tend to think one way, up or down.
So, lets say for the 5AC, as biomesh pointed out the expectation should be a starting point of 1300/2= 650 one way speed for the 5ghz network.
However that is theoretical and doesn't take into account normal propagation losses through air, cabling etc,"
Then we have to factor in any walls or physical obstacles in the way of the signal
Then we have to factor in any electrical appliances and lighting or currents in the house that may affect/interfere with signal
Then we have to factor in any competing devices such as other WIFI radios.

The best rule of thumb is the 1/3 rule. 1300/3= 433 should be what you are seeing give er take on the device.
In your case then, there is definitely some issues. With a LOS connectivity you should reasonable expect to get +400Mbps.

I have a capac and through two walls and one cabinet(solid wood) and all the other issues about 40down and 30 up on 2.4ghz and 15 down and 10 up on 5ghz.
and yet the unit drawing a straight line is not that far from the receiving unit (firestick).
867/3= 289 is what I should be able to reasonably get for 5ghz
300/3= 100 is what I should be able to reasonably get for 2ghz
Which goes to show you cannot overcome physics magically of obstructions and interference.
hello, as you said, then my case speed is 867Mbps the really speed is 867/3=289 and it's normal?
1/3 speed is normal for MT, 2/3 speed is normal for others
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 9:59 am

@heidarren @krafg

thanks for your help.
maybe the time to change to orthers WiFi devices.
 
erlinden
Forum Veteran
Forum Veteran
Posts: 895
Joined: Wed Jun 12, 2013 1:59 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 10:47 am

maybe the time to change to orthers WiFi devices.
Not sure what requirements (and expectations) you have, I get a solid (little over) 400 Mbps on my cAP ac.
First the problem, then the solution
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 11:29 am

maybe the time to change to orthers WiFi devices.
Not sure what requirements (and expectations) you have, I get a solid (little over) 400 Mbps on my cAP ac.
which one cAP you'r using?
 
Shy
Member Candidate
Member Candidate
Posts: 243
Joined: Sat Jun 13, 2020 8:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 12:01 pm

Not good....

Sent from my SM-A705FN using Tapatalk

 
heidarren
Member Candidate
Member Candidate
Posts: 134
Joined: Mon Aug 05, 2019 9:56 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 12:04 pm

maybe the time to change to orthers WiFi devices.
Not sure what requirements (and expectations) you have, I get a solid (little over) 400 Mbps on my cAP ac.
I’m able to get about 480mbps from my cAP ac, Audience and hAP AC2, 3 of them has the same maximum speed.....
 
RobCo
newbie
Posts: 36
Joined: Thu Feb 21, 2019 9:33 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 12:56 pm

Hah, get used to it, it's "pretty" decent for mikrotik to give you 200mbps for 866 clients.
Wanna wireless better - search for other options. That's as it is.

P.S. And don't believe these ones upahead telling about 400-480 mbps - I've reached 750 mbps with wAP AC for 1300mbps client - but that was only !once, for a couple of minutes and I couldn't repeat that result, no matter what.
Now it's only ~260-280 mbps, with the same client, same wifi card, same wAP AC and the same settings. Because mikrotik wifi perfomance depends on moon phase, weather...everything!
 
erlinden
Forum Veteran
Forum Veteran
Posts: 895
Joined: Wed Jun 12, 2013 1:59 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 12:59 pm

P.S. And don't believe these ones upahead telling about 400-480 mbps - I've reached 750 mbps with wAP AC for 1300mbps client - but that was only !once, for a couple of minutes and I couldn't repeat that result, no matter what.
Now it's only ~260-280 mbps, with the same client, same wifi card, same wAP AC and the same settings. Because mikrotik wifi perfomance depends on moon phase, weather...everything!
Please speak for yourself...these results I have since a very long time. WiFi is a shared medium, you can't compare to other situations based on personal experience.
First the problem, then the solution
 
RobCo
newbie
Posts: 36
Joined: Thu Feb 21, 2019 9:33 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 1:12 pm

P.S. And don't believe these ones upahead telling about 400-480 mbps - I've reached 750 mbps with wAP AC for 1300mbps client - but that was only !once, for a couple of minutes and I couldn't repeat that result, no matter what.
Now it's only ~260-280 mbps, with the same client, same wifi card, same wAP AC and the same settings. Because mikrotik wifi perfomance depends on moon phase, weather...everything!
Please speak for yourself...these results I have since a very long time. WiFi is a shared medium, you can't compare to other situations based on personal experience.
I know that yours 400 mbps doesn't mean anything, since I've had 42-48 MB/s couple of months ago, then it degradated to 30 MB/s, now it's only 10MB/s - and nothing literally changed in the area these wAPs are operating!
So just wait half-a-year when you have maximum 280mbps, afterwards firmware bugs will come...
 
heidarren
Member Candidate
Member Candidate
Posts: 134
Joined: Mon Aug 05, 2019 9:56 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 1:14 pm

Hah, get used to it, it's "pretty" decent for mikrotik to give you 200mbps for 866 clients.
Wanna wireless better - search for other options. That's as it is.

P.S. And don't believe these ones upahead telling about 400-480 mbps - I've reached 750 mbps with wAP AC for 1300mbps client - but that was only !once, for a couple of minutes and I couldn't repeat that result, no matter what.
Now it's only ~260-280 mbps, with the same client, same wifi card, same wAP AC and the same settings. Because mikrotik wifi perfomance depends on moon phase, weather...everything!
Agree, u may get very high speed for a moment, then dropped to a much lower speed, it has nothing to do with setting, no magic here.
 
erlinden
Forum Veteran
Forum Veteran
Posts: 895
Joined: Wed Jun 12, 2013 1:59 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 2:28 pm

I know that yours 400 mbps doesn't mean anything, since I've had 42-48 MB/s couple of months ago, then it degradated to 30 MB/s, now it's only 10MB/s - and nothing literally changed in the area these wAPs are operating!
So just wait half-a-year when you have maximum 280mbps, afterwards firmware bugs will come...
Besides your personal frustration presented as being the standard situation, you mix up units.
I'm not trying to have a discussion, I'm just telling you that your experience is...your experience. I.e., I'm running this site since December 2019, and tested a lot of firmwares and settings.

As my daughters shirt nicely states: "nothing changes if nothing changes"
First the problem, then the solution
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Mon Sep 07, 2020 6:52 pm

"Because mikrotik wifi perfomance depends on moon phase, weather...everything!"

No it's not depending on that. It's depending on the specs of your client device, on the AP settings, on the environment, and on the electromagnetic field around. And it might depend on your tests (testing towards cloud based servers is testing the whole connection chain, not your wifi performance)

client device: to get 1300Mbps you need 3 spatial streams and MCS9 encoding and 80MHz channel width. Most client devices are 2 spatial stream capable. So 866 Mbps interface data rate is then the max.

AP settings: many try things, learn and copy from others, that come from totally different conditions, and ruin their wifi performance. To tune this you must understand what it means if you set something. You must understand the wifi extreme large overhead (indeed very often 50%, for small packets over 90%). You must understand the scarcest resource: "air time". How co-channel interference works, how aggregation is absolutely needed for high speed and low overhead. How adjacent or overlapping channel interference is just totally killing your performance.

environment: And there is still that diffraction/absorption/reflection by walls, objects or persons around. And the non-wifi 2.4GHz and also 5 GHz sources. Even TX power and received signal strength can be of a major influence. And stronger is not always better! It will all reduce the TX/RX CCQ, and make wifi step down in encoding and interface rate. (CCQ is related to the number of retransmits. Retransmits reduce the net data rate also.)

electromagnetic field: yes there are many other sources in those bands that you do not see with a SCAN. Using "Snooper" is already an eye opener and this is still understandable wifi. "Freq usage" is another tool to check.

If you use "XXXX" as setting on the channel selected, you didn't get it yet. You don't care what channel is used, because you have no control this way. And you just allow statistics define whatever your performance will be one day, different from the other day. The number of possible 80MHz wide free channels is VERY limited. And wifi interference happens at a much lower signal level (-96dBm) than non-wifi noise interference (-86dBm)

Wifi performance does not depend on the moon phase, but it does depend on the Solar Cycle. But most of all depends on loosely defined configurations, and use of irrelevant tuning hints. (And no, "auto" is not giving you the best wifi experience, not even close, it can be very contra productive for its own and even other nearby wifi performances)
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 08, 2020 7:48 pm

If you want to see what wifi overhead is for a small packet (no-aggregation) , and how it even gets as big as 99% for a 90 byte packet when having 866Mbps interface data rate. (That's is 8 Mbps payload data rate in the best possible wifi condition, and limited to one direction!). For high throughput: aggregation needs to be turned on. (Not clear where numbers are hidden in RouterOS for 802.11ac)

https://www.youtube.com/watch?v=6zijK9Rs1LE&t=600s
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 9245
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 08, 2020 7:58 pm

Nice link bpwl. Couldnt help notice that HELP and CAPsMAN are in the same sentence, seems way to frequent for a mature product or useable product of code. Is it the software, lack of clear guidance in writing, or something else....
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
anuser
Long time Member
Long time Member
Posts: 557
Joined: Sat Nov 29, 2014 7:27 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 08, 2020 10:31 pm

E.g. On a wAP ac with RouterOS 6.47.2 on 5 GHz (80MHz, 5180) and a Windows 10 laptop with Intel AX200 which is right next to the wAP ac (<20 cm) and is connected at 866 Mbit/s, the maximum download is 287 Mbit/s and maximum upload is 171 Mbit/s. Those are the maximum values I get with iPerf3 after some runs to a local 2nd computer which is connected to the same switch as the wAP ac. WPA2 PSK with AES is being used with default settings on the wAP ac.
That´s without CAPsMAN.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 09, 2020 9:52 am

I think CAPsMAN is designed/tuned for the environment with multiple AP's and quite some clients attached, using moderate speed and stable response time. I see things as MSDU=2048, HW-retries=3, MPDU only on priority 0, no guidelines for VHT setting in wiki nor MUM presentations .... . It handles some interference and the hand-off if too many clients are on one AP. Every tuning is a trade off.

If I use the "car" metaphor, this is a SUV with soft suspension, automatic gearbox, AWD (not FWD), large load capacity, 2000kg idle weight. But then we test it as a racing car. (MAX PHY interface data rate, wide channel, single AP, single client ... to get most throughput out of 866Mbps interface data rate).

Would love to know where RouterOS has it's counters for aggregation ... as this explains most of the statements here ... varying test throughput from 20% till 70%. And if it is not tested in 1 AP- 1 client radiosignal free environment, but real all day deployment, then that value will drop very deep and be very volatile.

http://ceur-ws.org/Vol-1689/paper7.pdf

(Draytek counters ...)
Klembord-2.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by bpwl on Wed Sep 09, 2020 6:25 pm, edited 1 time in total.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 9245
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 09, 2020 6:15 pm

MT Wifi = Mystery
Mystery = Lack Confidence
Lack Confidence = Less Sales
Less Sales = Normis Cannot afford mercedes
Normis Cannot afford mercedes = Normis' partner dumps him and finds another
Normis' partner dumps him and finds another=Normis depressed
Normis depressed=Normis sees shrink
Normis sees shrink=Shrink determines the root problem is wifi
Shrink determines the root problem is wifi=Normis finally deciding to fix wifi
Normis finally deciding to fix wifi=Normis hiring bpwl on MT Wifi Team
Normis hiring bpwl on MT Wifi Team=Improved WIFI Performance/Documentation/Tuning/Stability
Improved WIFI Performance/Documenation/Tuning/Stability=Increased Confidence
Increased Confidence=More Sales
More Sales=Normis can afford mercedes
Normis can afford mercedes=Normis' ex-partner does not come back.

The moral of the story is that if MT hires bpwl now!!!, ubiquiti will go out of business and Normis will be able to keep his partner!!
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
santyx32
Member Candidate
Member Candidate
Posts: 217
Joined: Fri Oct 25, 2019 2:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 10, 2020 3:53 am

Sometimes I think Normis and 3-5 other guys are the entire Mikrotik workforce
 
User avatar
xvo
Forum Guru
Forum Guru
Posts: 1244
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 10, 2020 10:26 am

Sometimes I think Normis and 3-5 other guys are the entire Mikrotik workforce
Not 3-5 of course, but only ~300 employees total.
 
anuser
Long time Member
Long time Member
Posts: 557
Joined: Sat Nov 29, 2014 7:27 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 10, 2020 6:14 pm

The moral of the story is that if MT hires bpwl now!!!, ubiquiti will go out of business and Normis will be able to keep his partner!!
MikroTik is hiring: https://translate.google.com/translate? ... 2Fdarbs%2F:
There is still hope:
C / C ++ programmer
Duties:

MikroTik RouterOS software development;
research and implementation of data communication protocols.

Requirements:

higher education in the field of IT;
very good C / C ++ programming skills;
experience working with Unix / Linux;
excellent knowledge of Latvian and English.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 10, 2020 9:05 pm

MT Wifi = Mystery
At least MikroTik Wifi is "wysinwyg" . ("n"=not) This gives many mysterious performance results.
Just remembered that the (very) old "Microsoft Network Monitor 3.4" does show the Beacon content for the channel used. Wireshark requires a special dedicated wifi interface in Windows to see more than the payload. But you can do it with the old Microsoft software. (it adds a driver to the wireless interface ...). It dates from Windows Vista, but works well in Windows 10.
Klembord-6.jpg
This could lift the tip of the veil somewhat.

Take this as an example ...(2.4GHz)

wireless data rate default versus configured. Only the selection default is changed to configured. The default settings are left untouched.
Klembord-2.jpg

Klembord-3.jpg

But the rate at which the beacons are sent changes from 6Mbps to 1 Mbps, even with mode "n-only" ... taking 6 times more airtime. (Airtime for beacons ... there is a calculator that learns that 16 SSID on AP's (e.g. 4 AP with 4 SSID each) at 1 Mbps beacon rate, take 50% of all the airtime of that channel) http://www.revolutionwifi.net/revolutio ... lator.html
All this reduces the wifi throughput if multiple AP's are in reach/ just can be decoded. (I see that ALL ISP delivered modems in my neighborhood transmit at 1 Mbps, and every house has one !)
Klembord-4.jpg
Changed rate from default to configured on Mikrotik-waP , and this acts on its slave interface guest30 as well.

Klembord-5.jpg

So I'm very curious now what else can be revealed from that beacon ..... And, oh yes, one can explain why the beacon rate changed, only, it was unexpected behavior.
Klembord-7.jpg
You do not have the required permissions to view the files attached to this post.
 
anuser
Long time Member
Long time Member
Posts: 557
Joined: Sat Nov 29, 2014 7:27 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 10, 2020 10:59 pm

But the rate at which the beacons are sent changes from 6Mbps to 1 Mbps, even with mode "n-only"
Try setting
1. the basic rate to 12 Mbit/s
2. mode g/n.
3. disable all b rates (supported+basic)
5. activate all supported rates >= 12 Mbit/s

Let´s see what beacon information you get afterwards.
 
CTSsean
newbie
Posts: 26
Joined: Fri Sep 15, 2017 12:56 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Sat Sep 12, 2020 12:22 am

I agree with everyone here Getting 'good' to 'great' performance with Mikrotik Wifi is a bear. Compared to say generic Comcast modem, where its instantly connects and has high throughput, I could play with Mikrotik for weeks and not get the same performance. I've been putting wifi networks together for years from Mikrotik, UBNT, Ruckus, Meraki, and every generic consumer brand you can think of, and Mikrotik just isn't one of the top contenders. I don't know if its hardware, software, or the combination there of... but seriously, the wifi documentation for a 'best practice' install for SMB or Enterprise is so lacking, I'd never install Mikrotik APs outside the home unless it was a point to point scenario.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 9245
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Sat Sep 12, 2020 3:01 am

Nice summation and captures my sentiments.
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Sat Sep 12, 2020 11:22 am

But the rate at which the beacons are sent changes from 6Mbps to 1 Mbps, even with mode "n-only"
Try setting
1. the basic rate to 12 Mbit/s
2. mode g/n.
3. disable all b rates (supported+basic)
5. activate all supported rates >= 12 Mbit/s

Let´s see what beacon information you get afterwards.
I know what to expect.

But even then, other things are very confusing.default<->configured
Beacon is at 6 Mbps with default, drops to 1 Mbps with configured if allowed.
Looking in the registration-table CLI print

/interface wireless registration-table print stats

default: tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x SGI:1x HT:0-7"
configured: tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x SGI:1x HT:0-7"
configured with b-rates removed: tx-rate-set="OFDM:6-54 BW:1x SGI:1x HT:0-7"
default but with b-rates removed in configured: tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x SGI:1x HT:0-7"

configured for 12Mbps as basic rate (and minimal supported rate.): tx-rate-set="OFDM:12-54 BW:1x SGI:1x HT:0-7"

Beacon as expected, (and neighbors ISP AP's as well, decoded on channel 12 !!! (=co channel interference, 20 dB more sensitive for interference than adjacent channel/noise))...
Klembord-2.jpg

PS: If you do want Microsoft Network Monitor 3.4 you better hurry. Microsoft removed the install file from their archive. Softpedia still has it .... NM34_xxxx.exe
You do not have the required permissions to view the files attached to this post.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 15, 2020 1:50 am

Well , I have done my homework. Enjoyed reading beacons from some AP's around me. And all falls into its logical place.
That old Microsoft Network Monitor cannot decode the ac beacons, but the capture file is readable and decoded by wireshark.

It's easy to analyse the internal workings of an otherwise closed (no info in the admin interface) or foreign AP's.

What I have learned is just explaining the wifi performance. Go back and see the importance of aggregation in a way to avoid the 99+% overhead, and then see the numbers.
I compared the MKT wAPac, hAPac2 with a similar cost old/obsolete Draytek router 2132ac.
We have A-MSDU (or MPDU) size, and A-MPDU size as parameters for aggregation capabilities. HT and VHT are different according the standards. What do the AP beacons tell us?

MKT 5 GHz ac is a superset of the 2.4 GHz n (HT) set. The HT sets are identical.

MKT HT: : A-MSDU limit = 3839 bytes , A-MPDU limit = 65535 bytes
MKT VHT: MPDU limit= 3895 bytes , A-MPDU limit = 262143 bytes

Draytek HT: A-MSDU limit = 7935 bytes, A-MPDU limit= 65535 bytes
Draytek VHT: MPDU limit = 11454 bytes, A-MPDU limit= 1048575 bytes

That 8192 number in the default setting in RouterOS for A-MSDU is somewhat misleading.
Like going to b-rates for "onlyN" mode basic rates is not intuitive. It is in the wiki, but not expected, as g/n correctly avoids b-rates.
Klembord-2.jpg
EDIT: even the "onlyg" is as inconsistent as "onlyn".
You do not have the required permissions to view the files attached to this post.
Last edited by bpwl on Wed Sep 16, 2020 1:24 am, edited 1 time in total.
 
venhow
newbie
Topic Author
Posts: 38
Joined: Fri Sep 30, 2016 8:44 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 15, 2020 10:57 am

Aha, nice discussion...
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1706
Joined: Mon Apr 08, 2019 1:16 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 15, 2020 11:22 am

But .... don't jump to conclusions. The slower throughput is not directly proportional to these numbers.
If you drop them in the calculators, then all is fine as long as A-MPDU is above 32768 bytes. A-MPDU is the ultimate payload, that goes in airtime competition with the overhead.
To drop the theoretical throughput on an 866 Mbps interface to 290 Mbps as absolute max, limiting A-MPDU to 16000bytes will be exactly what is needed.

So maybe the 3839 byte limit is not a problem as long as A-MPDU compensates for the smaller MPDU(A-MSDU). However the control over A-MPDU in RouterOS is minimal. Only 8 toggles on/off for each of the 8 user-priority values. And by default only set for priority "0" , luckily by default all data packets are just user-priority "0". What on the other hand limits the WMM functionality. (By the way the WMM Contention Window and other values in the beacon are just the standard values. Again RouterOS interface gives no viiew or control over this.)

https://gjermundraaen.com/thewifiairtimecalculator/
http://www.arubanetworks.com/assets/vrd ... RD_V2.xlsx (there is an excel error in scenario 2 not using the set interface rate)

https://howwirelessworks.com/wp-content ... _Guide.pdf ... a very interesting Theory guide, applied for high density but the theory is always valid, so it can be applied to the file transfer, streaming and speedtest context. And the practical examples make me wonder ..." The MPDU-per-TXOP ratio is approximately 60 at 1 STA, ...", or how many MSDU's would be sent in a payload/TXOP/A-MSDU with RouterOS. 64 MSDU? An A-MSDU of 262000bytes ??

This part (the overhead mitigation) was missing in the earlier youtube presentation .... it's not used in the high density scenario, but the theory applies.
Klembord-2.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by bpwl on Wed Sep 16, 2020 1:14 am, edited 1 time in total.
 
santyx32
Member Candidate
Member Candidate
Posts: 217
Joined: Fri Oct 25, 2019 2:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Tue Sep 15, 2020 9:19 pm

My laptop WiFi card doesn't supports monitor mode on Windows 10, I used Winfi app to gather some data from my hAP ac2 running OpenWRT

HT:
Maximum Rx A-MPDU Length: 0x03 (65536[Bytes])
HT Max A-MSDU length: 7935 bytes

VHT:
Maximum MPDU Length: 11 454 (0x02)
Max A-MPDU Length Exponent: 1 048 575 (0x07)
MU Beamformer Capable: Supported
 
santyx32
Member Candidate
Member Candidate
Posts: 217
Joined: Fri Oct 25, 2019 2:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 16, 2020 3:19 am

According to the dev who helped to port OpenWRT (Robimarko) to the hAP ac2 and other IPQ4018 Mikrotik products they're using QCA drivers but their AP implementation it's not standard compliant and lacks the wave 2 feature set.

https://forum.openwrt.org/t/can-open-so ... s/72832/40

I think they haven't migrated to something like hostapd to avoid deprecating all their propietary stuff like Capsman, hotspot, NV2, nstreme and so on (most of those can be rewritten to support the new implementation).

PD: I know I can just enjoy my OpenWRT powered ac2 and leave this forum but advanced routing features (like VLANs) are more polished on ROS.
 
anuser
Long time Member
Long time Member
Posts: 557
Joined: Sat Nov 29, 2014 7:27 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Wed Sep 16, 2020 7:12 pm

According to the dev who helped to port OpenWRT (Robimarko) to the hAP ac2 and other IPQ4018 Mikrotik products they're using QCA drivers but their AP implementation it's not standard compliant and lacks the wave 2 feature set
One posting later it says:
It´s hard to believe, but MikroTik really writes their own wireless driver. MikroTik regularly confirms this in it´s forum, e.g.:

viewtopic.php?t=145047#p713800
"You are right, that MikroTik made wireless driver doesn't have Wave2 support, so new chipset benefits are not there. We are working on a new driver."

They use their own wireless driver package, which is independent from the linux kernel:
viewtopic.php?t=153685#p761102
"Since at the moment v6 and v7 uses identical driver and software for wireless, your observation is most likely a coincidence. The performance should be the same, signals also."

viewtopic.php?f=2&t=145047&p=742089&hil ... mo#p741741 2
"Most of the features are implemented, but MU-MIMO is WIP"
 
santyx32
Member Candidate
Member Candidate
Posts: 217
Joined: Fri Oct 25, 2019 2:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 17, 2020 2:07 am

According to the dev who helped to port OpenWRT (Robimarko) to the hAP ac2 and other IPQ4018 Mikrotik products they're using QCA drivers but their AP implementation it's not standard compliant and lacks the wave 2 feature set
One posting later it says:
It´s hard to believe, but MikroTik really writes their own wireless driver. MikroTik regularly confirms this in it´s forum, e.g.:

viewtopic.php?t=145047#p713800
"You are right, that MikroTik made wireless driver doesn't have Wave2 support, so new chipset benefits are not there. We are working on a new driver."

They use their own wireless driver package, which is independent from the linux kernel:
viewtopic.php?t=153685#p761102
"Since at the moment v6 and v7 uses identical driver and software for wireless, your observation is most likely a coincidence. The performance should be the same, signals also."

viewtopic.php?f=2&t=145047&p=742089&hil ... mo#p741741 2
"Most of the features are implemented, but MU-MIMO is WIP"
Spiderman pointing meme.jpg
 
anuser
Long time Member
Long time Member
Posts: 557
Joined: Sat Nov 29, 2014 7:27 pm

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Thu Sep 17, 2020 9:26 am

PD: I know I can just enjoy my OpenWRT powered ac2 and leave this forum but advanced routing features (like VLANs) are more polished on ROS.
We really need to get hAP ac2 into official OpenWrt branch...
 
santyx32
Member Candidate
Member Candidate
Posts: 217
Joined: Fri Oct 25, 2019 2:17 am

Re: [Help] Mikrotik CAPsMAN Wireless download speed max 200Mb, but PC's /Mobile's link speed is 866Mbps

Fri Sep 18, 2020 2:40 am

PD: I know I can just enjoy my OpenWRT powered ac2 and leave this forum but advanced routing features (like VLANs) are more polished on ROS.
We really need to get hAP ac2 into official OpenWrt branch...
I don't know embedded device programming :(

Who is online

Users browsing this forum: Baidu [Spider] and 10 guests