Community discussions

MikroTik App
 
NovaProspekt
just joined
Topic Author
Posts: 3
Joined: Tue Nov 17, 2020 4:17 pm

Can't exceed 200mbps on WiFi cAP ac

Fri Nov 20, 2020 10:06 pm

I just upgraded from a Linksys all in one wireless router to a Mikrotik hAP ac2 plus cAP ac setup. Wireless is disabled on the hAP - it is routing only. All wireless connections are configured on the cAP ac.

I have a 400mpbs down 20mbps up connection from my ISP. Plugging a PC via ethernet into the hAP results in speed tests of 450/25. Speed testing over 5ghz WiFi is capping out at about 175mbps download, even when I am standing 10 feet from the cAP ac with clear line of sight. This same limitation is observed on an iPhone 7 and on a laptop running a Linksys USB 802.11ac adapter. Moving a few rooms away drops the throughput down into the 40s. My Linksys dumb router would speed test at 200mbps over 5ghz anywhere in the house even when it was running in a closet.

I've been experimenting with different frequency and control channel configurations, nothing I do seems to let me get WiFi throughput over 175-200mbps. I've been reading on the forums here, experience seems hugely mixed with some people claiming 400mbps+ and others stating worse than what I'm getting. I've monitored the cAP ac's CPU usage in Winbox during speedtests, it never gets out of the single digits.

Any thoughts/suggestions?

Here is my cAP's config:
[Edwin@AccessPoint] > export hide-sensitive
# jan/06/1970 06:17:38 by RouterOS 6.47.3
# software id = SLTG-ZWU9
#
# model = RBcAPGi-5acD2nD
# serial number = B9330BCDEA75
/interface bridge
add frame-types=admit-only-vlan-tagged ingress-filtering=yes name=cAP vlan-filtering=yes
/interface vlan
add interface=cAP name=MGMT vlan-id=90
/interface list
add name=Manage
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name="Trusted WiFi" supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name="Guest WiFi" supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name="IoT WiFi" supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n disabled=no frequency=auto installation=indoor mode=ap-bridge name=Trusted_2G security-profile="Trusted WiFi" ssid=Ashwin_2G wireless-protocol=802.11 \
    wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-onlyac channel-width=20/40/80mhz-eCee disabled=no frequency=5200 mode=ap-bridge name=Trusted_5G security-profile="Trusted WiFi" ssid=Ashwin_5G wireless-protocol=\
    802.11 wps-mode=disabled
add default-forwarding=no disabled=no keepalive-frames=disabled mac-address=C6:AD:34:D0:A0:12 master-interface=Trusted_2G multicast-buffering=disabled name=Guest_2G security-profile="Guest WiFi" ssid=\
    AshwinGuest_2G wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add default-forwarding=no disabled=no keepalive-frames=disabled mac-address=C6:AD:34:D0:A0:13 master-interface=Trusted_5G multicast-buffering=disabled name=Guest_5G security-profile="Guest WiFi" ssid=\
    AshwinGuest_5G wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=C6:AD:34:D0:A0:14 master-interface=Trusted_2G multicast-buffering=disabled name=IoT security-profile="IoT WiFi" ssid=Ashwin_IoT wds-cost-range=0 \
    wds-default-cost=0 wps-mode=disabled
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=cAP frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=ether1
add bridge=cAP frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=Trusted_2G pvid=10
add bridge=cAP frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=Trusted_5G pvid=10
add bridge=cAP frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=Guest_2G pvid=20
add bridge=cAP frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=Guest_5G pvid=20
add bridge=cAP frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=yes interface=IoT pvid=30
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface bridge vlan
add bridge=cAP tagged=cAP,ether1 vlan-ids=90
add bridge=cAP tagged=ether1 untagged=Trusted_2G,Trusted_5G vlan-ids=10
add bridge=cAP tagged=ether1 untagged=Guest_2G,Guest_5G vlan-ids=20
add bridge=cAP tagged=ether1 untagged=IoT vlan-ids=30
/interface list member
add interface=MGMT list=Manage
/interface wireless cap
set bridge=cAP discovery-interfaces=cAP interfaces=Trusted_2G,Trusted_5G
/ip address
add address=10.10.90.2/24 interface=MGMT network=10.10.90.0
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh address=10.10.90.0/24
set api disabled=yes
set winbox address=10.10.90.0/24
set api-ssl disabled=yes
/system identity
set name=AccessPoint
/tool mac-server
set allowed-interface-list=Manage
/tool mac-server mac-winbox
set allowed-interface-list=Manage
/tool mac-server ping
set enabled=no
[Edwin@AccessPoint] > 
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5758
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Can't exceed 200mbps on WiFi cAP ac

Sat Nov 21, 2020 5:07 am

5ghz speed on the capac is 867 two way added without losses taken into affect.
Basic 1/3 shows that you should be able to get around 290Mbps with Direct LOS connectivity.
Not sure what your issue may be.........
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
erlinden
Long time Member
Long time Member
Posts: 568
Joined: Wed Jun 12, 2013 1:59 pm

Re: Can't exceed 200mbps on WiFi cAP ac

Sat Nov 21, 2020 10:29 am

In addition to your settings I also set things like rates and WMM spupport:
set [ find default-name=wlan2 ] band=5ghz-a/n/ac basic-rates-a/g=12Mbps \
    channel-width=20/40/80mhz-Ceee country=netherlands disabled=no frequency=\
    5500 mode=ap-bridge rate-set=configured security-profile=Profile \
    ssid=MY-SSID station-roaming=enabled supported-rates-a/g=\
    12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps wireless-protocol=802.11 \
    wmm-support=enabled wps-mode=disabled
How did you mount the cAP ac?
First the problem, then the solution
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1092
Joined: Mon Apr 08, 2019 1:16 am

Re: Can't exceed 200mbps on WiFi cAP ac

Sat Nov 21, 2020 2:36 pm

But the actual performance of the wifi is in the "Registration" table .
Look at TX-rate, RX-rate and TX/RX-CCQ (or compare frames with hw-frames), and check "Freq Usage".

Rate should be something like 867Mbps-80Hz/2S/SGI , for the best rate. If only 40 MHz bandwidth is selected or used it will be 400mbps-40MHz/2S/SGI. Anything that deviates from this max value is due to signal strength (SNR value) , or is because of signal quality (deformation, reflection, interference...) to be seen in the CCQ (should be above 98%). CCQ is calculated from the transmissions (hw-frames needed to send the number of frames).

Throughput will be between 40% and 75% of this "usefull = interface rate * CCQ%", when using one direction. (That Throughput % depends on packet size and the aggregation of packets.) But It also only can use the 'free' airtime for the channels selected.)

So it is more something like (dataspeed = 50% * interface rate * CCQ% * airtime%).

("Freq usage" will show (100-free airtime%), you need all used channels to be free at the same time to be allowed to transmit!).
Sometimes you get only one stream (1S) this halves the interface rate.

If your throughput is lower than this, it's not due to wifi.

Who is online

Users browsing this forum: Bing [Bot] and 71 guests