Community discussions

MikroTik App
 
ullensJ
just joined
Topic Author
Posts: 2
Joined: Fri Oct 30, 2020 5:33 pm

Hotspot constantly asks to sign-in when switching AP to Mikrotik Router Wifi

Sun Nov 22, 2020 9:04 am

Hi everyone. I'm fairly new to Mikrotik. I configured Hotspot in both Mikrotik Router Wifi and also in LAN connecting to other AP (2 secondary router). Problem: Mikrotik main router WIFI asks everytime to sign in when switching from any other AP. But when switching between 2 AP it connects flawlessly without asking to sign-in. What do I do?
# nov/22/2020 12:34:29 by RouterOS 6.40.4
# software id = 0QSJ-S2UN
# model = 951Ui-2nD
/interface ethernet
set [ find default-name=ether5 ] name=LAN
set [ find default-name=ether1 ] name=WAN
set [ find default-name=ether2 ] master-port=LAN
set [ find default-name=ether3 ] master-port=LAN
set [ find default-name=ether4 ] master-port=LAN
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto mode=ap-bridge name=WLAN ssid=JASON-JACK
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
add dns-name=wifi.JASON.JACK.com.np hotspot-address=10.5.50.1 html-directory=flash/hotspot login-by=http-chap name=hsprofWIFI
add dns-name=wifi.JASON.JACK.com.np hotspot-address=20.20.20.1 html-directory=flash/hotspot login-by=http-chap name=hsprofLAN
/ip pool
add name=hs-pool-WIFI ranges=10.5.48.1-10.5.50.0,10.5.50.2-10.5.51.254
add name=hs-pool-LAN ranges=20.20.20.2-20.20.23.254
/ip dhcp-server
add address-pool=hs-pool-WIFI disabled=no interface=WLAN lease-time=1h name=dhcp1
add address-pool=hs-pool-LAN disabled=no interface=LAN lease-time=1h name=dhcp-LAN
/ip hotspot
add address-pool=hs-pool-WIFI addresses-per-mac=1 disabled=no idle-timeout=none interface=WLAN name=hs-WLAN profile=hsprofWIFI
add address-pool=hs-pool-LAN addresses-per-mac=1 disabled=no idle-timeout=none interface=LAN name=hs-LAN profile=hsprofLAN
/ip hotspot user profile
add address-pool=hs-pool-WIFI !idle-timeout keepalive-timeout=1d2m name=uprofWIFI shared-users=300 status-autorefresh=6h1m
add address-pool=hs-pool-LAN !idle-timeout keepalive-timeout=1d6h2m name=uprofLAN shared-users=300 status-autorefresh=6h1m
/ip address
add address=192.168.1.5/24 interface=WAN network=192.168.1.0
add address=10.5.50.1/22 comment="hotspot network" interface=WLAN network=10.5.48.0
add address=20.20.20.1/22 comment="hotspot network" interface=LAN network=20.20.20.0
/ip dhcp-server network
add address=10.5.48.0/22 comment="hotspot network" gateway=10.5.50.1
add address=20.20.20.0/22 comment="hotspot network" gateway=20.20.20.1
/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=10.5.48.0/22
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=20.20.20.0/22
/ip hotspot user
add name=JACK profile=uprofWIFI server=hs-WLAN
add name=JACK profile=uprofLAN server=hs-LAN
/ip route
add distance=1 gateway=192.168.1.254
/system clock
set time-zone-name=Asia/Kathmandu
/system identity
set name=JASON-JACK
/system ntp client
set enabled=yes primary-ntp=217.79.179.106 secondary-ntp=90.155.73.34 server-dns-names=0.pool.ntp.org,1.pool.ntp.org

Who is online

Users browsing this forum: No registered users and 56 guests