Community discussions

MikroTik App
 
swisstico
just joined
Topic Author
Posts: 14
Joined: Sat Dec 12, 2015 6:10 am
Contact:

Wi-Fi connection disconnect and desapear for a while

Thu Dec 17, 2020 3:57 am

Hello!

We have a strange wireless issue that we couldn't find the origin.

In some devices (appeared on Linux, Android and iOS so far, we didn't have a feedback of the issue on Windows), the wireless connection is disconnected, and the wireless (AP and virtual AP) disappear from the list of available wireless AP for a while (some minutes) and then come back.

So far we could see theses conditions:
  • Does the same issue on RB951G-2HnD and hAP ac
  • The issue is present only on 2.4 GHz, the devices that have issues in 2.4 GHz don't have any issue with the 5 GHz (hAP ac)
  • The issue was found on multiple RB951G-2HnD devices not only a specific one
  • Not sure, but we didn't see the issue with CAPsMAN, only when it's a unique router
Maybe it's our configuration (they are similar in all our devices), any idea?

To help, this is our configuration:
/interface wireless print advanced
name="wlan01-home" mtu=1500 l2mtu=1600 mac-address=4C:5E:0C:XX:XX:XX arp=reply-only disable-running-check=no interface-type=Atheros AR9300 radio-name="Home" mode=ap-bridge ssid="WiFi-Home" area="" frequency-mode=regulatory-domain country=OurCountry installation=any antenna-gain=3 frequency=auto band=2ghz-onlyn channel-width=20mhz secondary-channel="" scan-list=default wireless-protocol=802.11 rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps basic-rates-a/g=6Mbps max-station-count=20 distance=dynamic tx-power-mode=default noise-floor-threshold=default nv2-noise-floor-offset=default vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none wds-default-cost=100 wds-cost-range=50-150 wds-ignore-ssid=no update-stats-interval=disabled bridge-mode=enabled default-authentication=no default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 wmm-support=enabled hide-ssid=no security-profile=security-wpa2pskaes wps-mode=disabled station-roaming=enabled disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both compression=no allow-sharedkey=no station-bridge-clone-mac=00:00:00:00:00:00 ampdu-priorities=0 guard-interval=any ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 tx-chains=0,1 rx-chains=0,1 amsdu-limit=8192 amsdu-threshold=8192 tdma-period-size=2 nv2-queue-count=2 nv2-qos=default nv2-cell-radius=30 nv2-security=disabled nv2-preshared-key="" nv2-mode=dynamic-downlink nv2-downlink-ratio=50 nv2-sync-secret="" hw-retries=7 frame-lifetime=0 adaptive-noise-immunity=none hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 frequency-offset=0 rate-selection=advanced multicast-helper=default multicast-buffering=enabled keepalive-frames=enabled


/interface wireless security-profiles print detail
name="security-wpa2pskaes" mode=dynamic-keys authentication-types=wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key="WPA2SecretKey" supplicant-identity="MikroTik" eap-methods=passthrough tls-mode=no-certificates tls-certificate=none mschapv2-username="" mschapv2-password="" disable-pmkid=yes static-algo-0=none static-key-0="" static-algo-1=none static-key-1="" static-algo-2=none static-key-2="" static-algo-3=none static-key-3="" static-transmit-key=key-0 static-sta-private-algo=none static-sta-private-key="" radius-mac-authentication=no radius-mac-accounting=no radius-eap-accounting=no interim-update=0s radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username radius-called-format=mac:ssid radius-mac-caching=disabled group-key-update=5m management-protection=allowed management-protection-key="ManagementSecretKey"
Wireless Keys are in /interface wireless access-list

Thanks for your help!
 
WeWiNet
Member
Member
Posts: 488
Joined: Thu Sep 27, 2018 4:11 pm

Re: Wi-Fi connection disconnect and desapear for a while

Thu Dec 17, 2020 6:49 pm

What ever you set in 2.4Ghz, the interface itself should never "disappear" (unlike in 5G with DFS).
it should always "transmit" and when close to the AP you should be able to get at least the beacons (SSID) when you scan the
frequency...

Can you share the EXPORT of wireless interface? Its easier to compare what you changed than with the PRINT function.

Best explanation would be the frequency is very crowded and some other AP transmits with higher/better/closer power on same frequency.
or some smart people think they do want only 11n data rates, but then when connection quality goes bad (high distance between AP and client) they are screwed.
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? or maybe I am just crazy :lol: !!!
 
gotsprings
Forum Guru
Forum Guru
Posts: 1039
Joined: Mon May 14, 2012 9:30 pm

Re: Wi-Fi connection disconnect and desapear for a while

Sat Dec 19, 2020 3:54 pm

If you are in a noisy or crowded environment... Abandon all hope.

Mikrotik 2.4 radios do not do well in dense environments causing 2.4 clients to appear to connect and disconnect constantly.

The email support sent me said that it was purely my environment. Problem is... Most of my jobs are similar environments. So I had to give up on Mikrotik wireless.

Considering how they can't even get MU-MIMO working 5 years after ratification... And everyone else moving to wifi 6... I would be doing a disservice to customer to not switch vendors.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
WeWiNet
Member
Member
Posts: 488
Joined: Thu Sep 27, 2018 4:11 pm

Re: Wi-Fi connection disconnect and desapear for a while

Sat Dec 19, 2020 4:23 pm

Here is your problem:

band=2ghz-onlyn

Ok, you made your own problem...

Solution is to keep DEFAULT (all modes).
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? or maybe I am just crazy :lol: !!!
 
swisstico
just joined
Topic Author
Posts: 14
Joined: Sat Dec 12, 2015 6:10 am
Contact:

Re: Wi-Fi connection disconnect and desapear for a while

Thu Dec 24, 2020 1:57 am

Here is the export just in case it can help:
# RouterOS 6.47.8
# software id = 4DDX-6SU4
# model = 951G-2HnD
/interface wireless security-profiles
set [ find default=yes ] authentication-types="" disable-pmkid=no \
    eap-methods=passthrough group-ciphers=aes-ccm group-key-update=5m \
    interim-update=0s management-protection=disabled mode=none \
    mschapv2-username="" name=default radius-called-format=mac:ssid \
    radius-eap-accounting=no radius-mac-accounting=no \
    radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" \
    group-ciphers=aes-ccm group-key-update=5m interim-update=0s \
    management-protection=allowed mode=dynamic-keys mschapv2-username="" \
    name=security-wpa2pskaes radius-called-format=mac:ssid \
    radius-eap-accounting=no radius-mac-accounting=no \
    radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=none allow-sharedkey=\
    no ampdu-priorities=0 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=\
    3 area="" arp=reply-only arp-timeout=auto band=2ghz-onlyn \
    basic-rates-a/g=6Mbps basic-rates-b=1Mbps bridge-mode=enabled \
    channel-width=20mhz compression=no country=etsi default-ap-tx-limit=0 \
    default-authentication=no default-client-tx-limit=0 default-forwarding=no \
    disable-running-check=no disabled=no disconnect-timeout=3s distance=\
    dynamic frame-lifetime=0 frequency=auto frequency-mode=regulatory-domain \
    frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mc\
    s-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,m\
    cs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-2\
    3" hw-fragmentation-threshold=disabled hw-protection-mode=none \
    hw-protection-threshold=0 hw-retries=7 installation=any \
    interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 \
    mac-address=4C:5E:0C:6A:FD:41 max-station-count=10 mode=ap-bridge mtu=\
    1500 multicast-buffering=enabled multicast-helper=default name=\
    wlan01-office noise-floor-threshold=default nv2-cell-radius=30 \
    nv2-downlink-ratio=50 nv2-mode=dynamic-downlink nv2-noise-floor-offset=\
    default nv2-qos=default nv2-queue-count=2 nv2-security=disabled \
    nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=both \
    radio-name=ROUTER rate-selection=advanced rate-set=default rx-chains=0,1 \
    scan-list=default secondary-channel="" security-profile=\
    security-wpa2pskaes skip-dfs-channels=disabled ssid=Office \
    station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=disabled \
    supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
    supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 \
    tx-chains=0,1 tx-power-mode=default update-stats-interval=disabled \
    vlan-id=10 vlan-mode=use-tag wds-cost-range=50-150 wds-default-bridge=\
    none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled \
    wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless manual-tx-power-table
set wlan01-office manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mb\
    ps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17\
    ,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT2\
    0-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:\
    17,HT40-7:17"
/interface wireless nstreme
set wlan01-office disable-csma=no enable-nstreme=no enable-polling=yes \
    framer-limit=3200 framer-policy=none
/interface wireless
add area="" arp=reply-only arp-timeout=auto bridge-mode=enabled \
    default-ap-tx-limit=0 default-authentication=no default-client-tx-limit=0 \
    default-forwarding=no disable-running-check=no disabled=no hide-ssid=no \
    interworking-profile=disabled keepalive-frames=disabled l2mtu=1600 \
    mac-address=4E:5E:0C:6A:FD:41 master-interface=wlan01-office \
    max-station-count=128 mode=ap-bridge mtu=1500 multicast-buffering=\
    disabled multicast-helper=default name=wlan01-guests security-profile=\
    security-wpa2pskaes ssid=Guests station-bridge-clone-mac=\
    00:00:00:00:00:00 station-roaming=disabled update-stats-interval=disabled \
    vlan-id=20 vlan-mode=use-tag wds-cost-range=0 wds-default-bridge=none \
    wds-default-cost=0 wds-ignore-ssid=no wds-mode=disabled wmm-support=\
    enabled wps-mode=disabled
/interface wireless access-list
add allow-signal-out-of-range=10s ap-tx-limit=0 authentication=yes \
    client-tx-limit=0 comment=Office disabled=no forwarding=yes interface=\
    wlan01-office mac-address=00:00:00:00:00:00 private-algo=none \
    signal-range=-120..120 !time vlan-id=1 vlan-mode=default
add allow-signal-out-of-range=10s ap-tx-limit=0 authentication=yes \
    client-tx-limit=0 comment=Guests disabled=no forwarding=no interface=\
    wlan01-guests mac-address=00:00:00:00:00:00 private-algo=none \
    signal-range=-120..120 !time vlan-id=1 vlan-mode=default
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
    00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
    frames-per-second=25 receive-all=no ssid-all=no
/interface wireless cap
set bridge=none caps-man-addresses="" caps-man-certificate-common-names="" \
    caps-man-names="" certificate=none discovery-interfaces="" enabled=no \
    interfaces="" lock-to-caps-man=no static-virtual=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
    multiple-channels=no only-headers=no receive-errors=no streaming-enabled=\
    no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
 
swisstico
just joined
Topic Author
Posts: 14
Joined: Sat Dec 12, 2015 6:10 am
Contact:

Re: Wi-Fi connection disconnect and desapear for a while

Thu Dec 24, 2020 2:01 am

Here is your problem:

band=2ghz-onlyn

Ok, you made your own problem...

Solution is to keep DEFAULT (all modes).
Thanks WeWiNet, but can you explain why "only N" can be an issue if all my devices are N compatible and work perfectly at different times (the same devices that loose the Wi-Fi connection sometimes) ?
 
WeWiNet
Member
Member
Posts: 488
Joined: Thu Sep 27, 2018 4:11 pm

Re: Wi-Fi connection disconnect and desapear for a while

Thu Dec 24, 2020 9:37 am

N is the "best" transmission capability of 2.4Ghz (in Wifi 5 and 6 you have additional ones).
This is perfectly fine for GOOD conditions. BUT in bad conditions those modulation rates (N rates)
won't make it from the AP to the station and vice versa. For such situation you also need B/G rates etc...

For example with lot of interference or long distance between AP and client, or walls etc, the N rate encoded
data will just not make it. The lower rates are more "robust". If you exclude this you won't be able to connect to the AP.
Its like having connections only when sun is shining... ;-)

While it's tempting to say 11ac only or 11n only, there are situations where you need the slower data rates to keep the connection.
The AP in theory tries to always use the highest available/usable data rates. While Mtik driver might not be that good (but still better than fixing the rates)
the new Wifiwave2 package will do that definitely...
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? or maybe I am just crazy :lol: !!!
 
swisstico
just joined
Topic Author
Posts: 14
Joined: Sat Dec 12, 2015 6:10 am
Contact:

Re: Wi-Fi connection disconnect and desapear for a while

Wed Dec 30, 2020 8:11 pm

Thanks WeWiNet for the explication. :-)

We will try as you said and see what happen.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1231
Joined: Mon Apr 08, 2019 1:16 am

Re: Wi-Fi connection disconnect and desapear for a while

Wed Dec 30, 2020 10:08 pm

N is the "best" transmission capability of 2.4Ghz (in Wifi 5 and 6 you have additional ones).
This is perfectly fine for GOOD conditions. BUT in bad conditions those modulation rates (N rates)
won't make it from the AP to the station and vice versa. For such situation you also need B/G rates etc...

Quite surprised with this explanation. The connection must be very bad for this to happen!
MCS0 in the N-rate is 6Mbps , just as the lowest g-rate is 6 Mbps. The transmit power and the receive sensitivity (-93dBm) is the same for g-6Mbps and MCS0. N mode combines even the antenna's.
The 1Mbps b-rate goes down till -96 dBm receive sensitivity.
Even more , when only-N is used, the beacons are send at 1 Mbps. (Actually something you want to avoid, but for a very strange reason Mikrotik uses 6 Mbps if g/n is used.)
You don't want B rates in your wifi environment. The encoding is different, and you need RTS/CTS to avoid conflicts.

OK mixed mode may step down to g and even b. But at least one should check the wireless "Registration" entries, to see if there are very low signal levels in use (Below -90 dBm), or if connections lead to a bad TX/RX CCQ.
Beacons and management frames use the "basic rates" , not the high N-rates. I see no elimination in the config for the lower basic rates or supported rates. So the SSID cannot disappear because of only high N-rates used.

Additional to the "Registration" entries the second check is using the extended Logging for wireless events (/ system logging add topics=wireless action=memory )

A "Snooper" and "Freq Usage" scan of the environment is the 3th check.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1231
Joined: Mon Apr 08, 2019 1:16 am

Re: Wi-Fi connection disconnect and desapear for a while

Wed Dec 30, 2020 10:18 pm

ARP on reply-only? Can be tricky. Android, IOS, and lately Windows10 (64 bit) started to connect with random local administered MAC addresses. To capture these you need "ARP=enabled" on the wireless interfaces.
 
maigonis
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 20, 2019 8:16 pm

Re: Wi-Fi connection disconnect and desapear for a while

Thu Dec 31, 2020 5:07 pm

I had simmilar issue. Try latest long-term version. I had this issue on latest stable and testing release. After rolling all devices to long-term issue was gone.
 
swisstico
just joined
Topic Author
Posts: 14
Joined: Sat Dec 12, 2015 6:10 am
Contact:

Re: Wi-Fi connection disconnect and desapear for a while

Mon Jan 11, 2021 8:41 pm

Hi everyone,

From the time we wrote this post, we investigated deeply how Wi-Fi works, created some labs, etc.

We really recommend these 2 videos of Ron Touw, from MUM, we understood our mistakes, fixed our configurations and issue is fixed :-)
CAPsMAN WiFi Layer 1 Optimisation
Common MikroTik WiFi mistakes and how to avoid them

For the moment, we didn't have any issue due to ARP=reply-only, but we will be aware of that if we still have issues in the future.

Thanks everyone for your help!

Who is online

Users browsing this forum: Baidu [Spider] and 74 guests