Community discussions

MikroTik App
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 12:22 pm

I have a CAPsMAN with a single 2.4Ghz configuration.

I have connected a HAP AC2 device. The CAP master interface shows this:
Flags: M - master, D - dynamic, B - bound, X - disabled, I - inactive, R - running
 0 MDBR name="caps03-hapac2-1" mac-address=48:8F:5A:A1:AB:30 arp-timeout=auto radio-mac=48:8F:5A:A1:AB:30 master-interface=none
        radio-name="488F5AA1AB30" configuration=caps-laci-2.4 l2mtu=1600 current-state="running-ap" current-channel="2452/20-Ce/gn(20dBm)"
        current-rate-set="OFDM:12-54 BW:1x-2x SGI:1x-2x HT:0-15" current-basic-rate-set="OFDM:12 BW:1x HT:0-7" current-registered-clients=1
        current-authorized-clients=1
I do speedtest with this and I get about 60Mbps download speed.

Then I removed the HAP AC2 and connected a HAP Lite device. The CAP master interface shows this:
Flags: M - master, D - dynamic, B - bound, X - disabled, I - inactive, R - running
 0 MDBR name="caps02-1" mac-address=48:8F:5A:6C:9B:33 arp-timeout=auto radio-mac=48:8F:5A:6C:9B:33 master-interface=none radio-name="488F5A6C9B33"
        configuration=caps-laci-2.4 l2mtu=1600 current-state="running-ap" current-channel="2452/20-Ce/gn(20dBm)"
        current-rate-set="OFDM:12-54 BW:1x-2x SGI:1x-2x HT:0-15" current-basic-rate-set="OFDM:12 BW:1x HT:0-7" current-registered-clients=1
        current-authorized-clients=1
I do speedtest with this and I get about 30Mbps download speed.

Some facts:

* Both devices are on the same desk, side by side, connected to the same switch.
* Both devices are running the same OS version 6.48
* Both devices were factory reset with no default config. There is nothing configured on them except a bridge, a dhcp client and /interface wireless cap.
* No firewall rules at all.
* The client used for testing the speed is the same phone, located at the exact same location about ~1m away from the devices.
* The HAP AC2 (RBD52G-5HacD2HnD-TC) has a 2.4Ghz 802.11b/g/n radio with 2 chains, max data date 300Mbps, antenna gain 2.5dBi
* The HAP Lite (RB941-2nD) has a 2.4Ghz 802.11b/g/n radio with 2 chains, max data date 300Mbps, antenna gain 1.5dBi
* Both devices are using the exact same frequency, same bandwidth, same basic and supported bitrates.
* The conditions are close to ideal: indoor usage, weak interference from other APs (they are below -70dB), nothing is blocking signal between testing client and APs etc.
* There was almost zero CPU load on the devices while I performed the tests.

What I did is that I deleted one provisioned interface and provisioned the other manually, and did a test. Then I switch quickly and do another test. I have repeated these tests multiple times, and they were very consistent. The HAP AC2 always did 60Mbps on average (sometimes 80+), and the HAP Lite never did better than 30Mbps.

The only difference (apart from the wifi chip) is the antenna gain, but it should not make any difference, because the signal strength is -29dBi for the HAP AC2, and -33dBi for the HAP Lite (on average). They are both excellent, and the difference is negligible. It cannot explain the difference in download speed.

So why can't I get 60Mbps speed out of the HAP Lite?
 
erlinden
Long time Member
Long time Member
Posts: 658
Joined: Wed Jun 12, 2013 1:59 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 12:37 pm

What speed is the client connected on both CAP's?
First the problem, then the solution
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 1:06 pm

What speed is the client connected on both CAP's?
The phone shows 144 Mbps for both CAPs and rx signal strength between -30 and -40 dBm
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 1:52 pm

I have two HAP Lite devices. I just tried the other one. Same result: 30Mbps actual maximum speed. The phone shows that the connection is 144Mbps at -35 dBm.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 3:16 pm

I cannot explain the speed difference. (CPU load on the SMIPS processor ????)
What is in the wireless registration table of the AP? Looks like : TX rate= 144Mbps/40Mhz/1s/SGI

But still some general remarks.

All your AP's will delay transmission as long as it sees wifi transmissions above "noise+6dBm", or something like above -96 dBm. (-70 dBm is the usable wifi strength, wifi co-channel interference goes many times further)

Freq 2452 is channel 9. 20-Ce is 40 MHz wide (not recommended with 2.4 GHz band) . It is Ce so the extra 4 channels are on the upper freq side. So you use (7)-8-9-10-(11)-12-13-14-(15) !?!?
I hope this is OK for your country as regulatory domain, which must allow channel 1-13.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 4:59 pm

Thanks for your comments. I already left the office, I can only check these tomorrow. I think that these frequencies are allowed, I have selected the correct country.

I understand that other APs can cause interference but this still does not explain the difference in average speed. Especially that all settings are the same on the two devices.

I will have to re-check the CPU load again. Otherwise, I'm clueless.
 
mkx
Forum Guru
Forum Guru
Posts: 5272
Joined: Thu Mar 03, 2016 10:23 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Thu Dec 24, 2020 7:36 pm

My experience testing different MT wifi APs is that any wireless traffic hits CPU pretty hard. Generally downlink (AP transmits) is harder on CPU than uplink. CAPsMAN forwarding adds another layer of burden on CPU because AP has to encapsulate and decapsulate packets for sending it to (and receiving from) manager. If this envolves encryption, then UL will hammer AP more than DL.

That being said: hAP ac2 has a beast of a CPU compared to hAP lite ...
BR,
Metod
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 12:30 am

That being said: hAP ac2 has a beast of a CPU compared to hAP lite ...
Maybe I accidentally looked at the wrong profiler when I was testing the HAP Lite? I can believe that this will be the root of the problem. I did not pay enough attention to the CPU. I was using WPA2 + AES encryption, so yes that can be a problem. I'm going to try this without encryption (unsecured wifi) tomorrow, just to confirm that the CPU is the bottleneck.

It answers my question, but this is sad. It is a very bad idea to operate an AP without encryption. It is not even legal in some countries and I'll certainly not use it that way. WEP is not much faster and it is vulnerable. TKIP is also vulnerable. In other words: if it turns out to be a CPU bottleneck, then I'll probably put these two devices on the self and not use them at all. I might use them later for an IoT project, but I don't think that I could use them for anything else.

I think that the official page for the product is a bit misleading. The 300Mbps speed is advertised on the official page for HAP Lite ("max data rate") with big friendly letters. Everybody knows that 2.4Ghz is crowded, and nobody expects to react 300Mbps. But in this case, the max. rate may be limited to 30Mbps under ideal conditions. I'm not saying that the specification is lying about the max data rate of the radio unit itself. But I believe that the max. speed achiveable under normal conditions is much more important than the theoretical data rate of a single component inside the product. If the wireless speed is so limited (e.g. 1/10th of what the radio can do), then it should be shown on the "test results" tab. Yes, I know that the actual speed depends on many factors, and cannot be determined in advance. But a theoretical CPU bound 30Mbps upper limit is not something that "depends on many factors". The customers deserve to know that, before they buy the product. I also believe that many users are buying these devices for creating access points, and this speed limit is much more important than the "4 port routing test with 25 firewall rules".

I'm also not saying that this is a bad device in any way. For this amount of money, it can do fantastic things. I'm just saying that not showing such important limitations is bad practice.
 
mducharme
Trainer
Trainer
Posts: 1128
Joined: Tue Jul 19, 2016 6:45 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 1:00 am

I'm also not saying that this is a bad device in any way. For this amount of money, it can do fantastic things. I'm just saying that not showing such important limitations is bad practice.
Make sure you are using local forwarding, not CAPsMAN forwarding. You will get the highest data rate with local forwarding. CAPsMAN forwarding involves tunneling all traffic back to the CAPsMAN which adds a lot of overhead. Local forwarding is a CAPsMAN setting, you'll find it in the "Datapaths" tab.
 
erlinden
Long time Member
Long time Member
Posts: 658
Joined: Wed Jun 12, 2013 1:59 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 10:59 am

Make sure you are using local forwarding, not CAPsMAN forwarding. You will get the highest data rate with local forwarding. CAPsMAN forwarding involves tunneling all traffic back to the CAPsMAN which adds a lot of overhead. Local forwarding is a CAPsMAN setting, you'll find it in the "Datapaths" tab.
That makes sense (can't believe WPA2 AES is the bottleneck). Can you please share your CAPsMAN configuration, @nagylz?
/caps-man export (and paste it here in code tags)
First the problem, then the solution
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 12:07 pm

To soften a bit the sadness about the hAP Lite. The 300 Mbps is the PHY rate of the interface. It is never the payload, the data throughput, of a 802.11 wifi connection, whatever brand or model of AP.. The wifi overhead is known to be a very important part of the airtime available. With large packets it's between 25 and 75%. Overhead can be 99% for smaller packets. The higher the PHY rate the higher the 802.11 overhead. And this is even in ideal conditions. https://www.ekahau.com/wp-content/uploa ... sis_WP.pdf

Mikrotik has limited packet aggregation and the hAP Lite has limited RAM to buffer/aggregate. (I think even CAPsMAN reduces the A-MSDU to 2048 by default, not sure as I never use CAPsMAN, as I'm heading for maximum performance.)

And CAPsMAN is adding another layer of overhead, that will further reduce the throughput.

The marketing numbers are all misleading: they combine all PHY rates (all radio's, all streams) and present this as capacity.(AC300, AC1200, ....)
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 3:33 pm

I'm using local forwarding. I'm going to post the config here in the evening. I still could not get into the office.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 6:07 pm

All right, I have arrived to the office. I did a quick test and re-checked the CPU usage. /tool profile shows 9% max cpu0 usage and 10% max wireless usage on the HAP Lite. The HAP AC2 actually used more CPU during the test: about 14% main CPU (7%+7%, two cores used simultaneously), and 10% wireless.

* The HAP Lite still does not go above 30Mbps
* The HAP AC2 can do 60MBps on average, but sometimes as much as 90Mbps.

Then I did another test, using unencrypted channels (security profile removed), and the result was the same: 30Mbps for HAP Lite and 60-80Mbps for HAP AC2.

So the speed is not limited by the main cpu, or at least the profiler does not show that.

Here is my caps-man configuration, as promised. Very basic setup.
/caps-man channel
add band=2ghz-onlyn extension-channel=Ce frequency=2452 name=channels-laci-2.4
/caps-man datapath
add bridge=bridge l2mtu=1600 local-forwarding=yes mtu=1500 name=datapath-caps-laci
/caps-man rates
add basic=12Mbps name=rates-laci-2.4 supported=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
/caps-man configuration
add channel=channels-laci-2.4 country=hungary datapath=datapath-caps-laci installation=any name=caps-laci-2.4 rates=rates-laci-2.4 ssid=lacinet
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=security-caps-laci passphrase=abcd12345678
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes upgrade-policy=suggest-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=caps-laci-2.4 name-format=identity
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 6:56 pm

To soften a bit the sadness about the hAP Lite. The 300 Mbps is the PHY rate of the interface. It is never the payload, the data throughput, of a 802.11 wifi connection, whatever brand or model of AP.. The wifi overhead is known to be a very important part of the airtime available. With large packets it's between 25 and 75%. Overhead can be 99% for smaller packets. The higher the PHY rate the higher the 802.11 overhead. And this is even in ideal conditions. https://www.ekahau.com/wp-content/uploa ... sis_WP.pdf
I just went through this article. It was a very interesting read. I think that this can hardly explain the 100% speed difference. Here is why:

* I was using speedtest.net. That downloads a huge test file over https.
* Sending a big chunk of data sequentially will always use very long packets, equal or close to MTU.
* The MTU was maximized by the configuration. I don't think that packet aggregation is allowed to exceed this limit.
* So the framing overhead must be low, and while packet aggregation can increase speed, I believe that it cannot increase it by 100% in this very specific case.

I might be wrong, I'm not an expert... Just it seems to me that the 100% speed difference cannot be explained with a different aggregation size.
Mikrotik has limited packet aggregation and the hAP Lite has limited RAM to buffer/aggregate. (I think even CAPsMAN reduces the A-MSDU to 2048 by default, not sure as I never use CAPsMAN, as I'm heading for maximum performance.)

And CAPsMAN is adding another layer of overhead, that will further reduce the throughput.
These are all invariant. Both devices were using the same CAPsMAN with the same settings. This does not explain the difference in speed.
The marketing numbers are all misleading: they combine all PHY rates (all radio's, all streams) and present this as capacity.(AC300, AC1200, ....)
This is why we have specifications and published test results. All manufacturers do their marketing with the max theoretical rates, and I don't blame MikroTik that they do the same. They have to do it, because many customers won't go further than the marketing material. But the test result tab should include wireless transfer speed test results for any device with a radio in it. I wish MikroTik published ideal maximum wireless transfer rates on that tab. Then I would have bought HAP AC2 devices instead, and everybody (including MikroTik) would have been happier. I don't mind spending more on a device that I need. But I really mind spending any money on a device that I don't need and can't use. Do you see my point? This is bad for everyone.

Oh and by the way, I think that HAP Mini. mAP Lite and cAP Lite are all using the very same QCA9533 CPU and the same radio. I cannot try this now, but I believe that I would get the same disappointing results with those. Those devices are purpose built to be access points. Shouldn't we have their wireless speed test results on the test results tab? Even if they are measured in ideal conditions, we should have at least something. Frankly, who is interested in the 100M ethernet single port routing test of an access point with a single ethernet port?
 
mducharme
Trainer
Trainer
Posts: 1128
Joined: Tue Jul 19, 2016 6:45 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 8:51 pm

/caps-man channel
add band=2ghz-onlyn extension-channel=Ce frequency=2452 name=channels-laci-2.4
/caps-man datapath
add bridge=bridge l2mtu=1600 local-forwarding=yes mtu=1500 name=datapath-caps-laci
/caps-man rates
add basic=12Mbps name=rates-laci-2.4 supported=12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
/caps-man configuration
add channel=channels-laci-2.4 country=hungary datapath=datapath-caps-laci installation=any name=caps-laci-2.4 rates=rates-laci-2.4 ssid=lacinet
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=security-caps-laci passphrase=abcd12345678
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes upgrade-policy=suggest-same-version
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=caps-laci-2.4 name-format=identity
There's no point in using 40MHz channels with 2.4GHz. You are a lot better off reducing that. Also, FYI, the bridge=bridge in your datapath settings doesn't do anything since you are using local forwarding, so it doesn't really have to be set at all (although it doesn't hurt anything).

I'm not sure why you have "caps-man rates" set at all. The default is completely blank and that I believe should use the MikroTik defaults, and I've never seen a need to hard set them like that. You might consider going into the rates tab and just disabling or deleting that entire line, and removing the reference to it from your "caps-man configuration".
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 8:56 pm

Hi, don't misunderstand me. I cannot explain that low performance with the information given. And I have no intend to start tests (I do have here a hAP Lite, mAP Lite, hAP ac Lite and HAP ac2)

Being very technical I just react on technical statements where I could be more specific about.
So again, don't take this wrong , the hAP ac2 performance given is low, and the hAP Lite performance is disappointing as it is only half of that already low performance.
(I get 290 Mbps real data rate single direction out of my hAP ac2 connected via a SXTsq chain in the field, on a 433Mbps/40MHz/2S/SGI connection on 5GHz, 802.11ac)

The mAP Lite and cAP Lite have a MIPSBE cpu, and 64MB of RAM.
Only the hAP Lite and hAP mini have this lower hardware: SMIPS cpu and 32 MB of RAM. (SMIPS seems to be a different instruction set as the RouterOS barely gets into the 16 MB ROM when SMIPS is used. There have been workarounds on the forum to squeeze it in.)

The ethernet MTU (1500 bytes) is a different animal than the aggregated packet size for wifi. For 802.11n the maximum A-MPDU is 65535bytes. For 802.11ac the maximum is even 1Mbyte!
And your max internet packet (1492 bytes) is not that much larger than this test with 1000byte packets.
Klembord-1.jpg
viewtopic.php?f=7&t=161295
viewtopic.php?f=2&t=145047&#p815855

Mikrotik has a rather poor aggregation implementation with smaller sizes and static settings. Other brands implement an intelligent adaptive algorithm and the full standard sizes.

And one more: most forum users know that the software "stable" channel is far from stable. The performance of the 6.48(.0) is unknown. Use LongTerm for operating Mikrotik devices.
You do not have the required permissions to view the files attached to this post.
 
mducharme
Trainer
Trainer
Posts: 1128
Joined: Tue Jul 19, 2016 6:45 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 9:24 pm

A setting suggestion I would have, if you don't already have it, is to try enabling "adaptive noise immunity" on the CAP device itself. This is done through the advanced tab of the wireless interface. You will have to temporarily switch off the CAP functionality in order to change this setting, otherwise it will forbid the change due to being managed by the CAPsMAN.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 10:06 pm

Just as additional information, my hAP Lite connection.
- Its used for SSTP tunnels to Mikrotik sites that must be managed, so speed never was an issue.
-The Internet ISP link is VDSL 30Mbps download, 6 Mbps upload
-Old Dell laptop, only has 2.4 GHz also.
-hAP Lite is in the garage near other AP , 3 brick walls to pass, more AP's in the house and from neighbors

Important, to be checked number, is the TX Rate in the AP (the PHY) . It fluctuates 72Mbps(65Mbps)/20MHz/1S/SGI for TX rate (download), it's 26 Mbps/20MHz/1S/(LGI) for upload.
20 MHz as normal setting, only 1 stream active (3 wall's!), -50dBm at PC, -57dBm at AP
Some co-channel interference, but worse some adjacent channel interference (damned ISP with their default "auto" setting @neighborgs !)
PC wrongly reports 144Mbps (that's what the interface could have as PHY when both streams were used).

Long range throughput test (including VDSL and ISP uplink delays) show 25.94Mps download. Well within the expected performance.
Directly connected to the ISP modem gives the same Speedtest.net result.
The hAP Lite is not the bottleneck.
.

Klembord-1.jpg
You do not have the required permissions to view the files attached to this post.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 10:28 pm

There's no point in using 40MHz channels with 2.4GHz. You are a lot better off reducing that.
Okay, I'll try that too.
Also, FYI, the bridge=bridge in your datapath settings doesn't do anything since you are using local forwarding, so it doesn't really have to be set at all (although it doesn't hurt anything).
Thanks for the tip. It was leftover from a previous config.
I'm not sure why you have "caps-man rates" set at all. The default is completely blank and that I believe should use the MikroTik defaults, and I've never seen a need to hard set them like that. You might consider going into the rates tab and just disabling or deleting that entire line, and removing the reference to it from your "caps-man configuration".
The idea came from Ron Touw, a professional who has 25 years of experience in wireless networks and RF systems in general. By removing support for 802.11 a,b and g and excluding all data rates below 12Mbps, more airtime can be spent with useful data transfer and much less time is used for transmitting beacons. Any wireless device that was manufactured after 2010 will only benefit from this. He is talking about this in this video https://www.youtube.com/watch?v=nCB4hL0f1VQ at 1:09.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 10:54 pm

The mAP Lite and cAP Lite have a MIPSBE cpu, and 64MB of RAM.
Only the hAP Lite and hAP mini have this lower hardware: SMIPS cpu and 32 MB of RAM. (SMIPS seems to be a different instruction set as the RouterOS barely gets into the 16 MB ROM when SMIPS is used. There have been workarounds on the forum to squeeze it in.)
I was only looking at the CPU. Both mAP lite and HAP Lite have QCA9533 CPU. But now that you drew my attention, I can see that they have different architectures. I'm confused! How can they have the same CPU but different architecture?
The ethernet MTU (1500 bytes) is a different animal than the aggregated packet size for wifi. For 802.11n the maximum A-MPDU is 65535bytes. For 802.11ac the maximum is even 1Mbyte!
And your max internet packet (1492 bytes) is not that much larger than this test with 1000byte packets.
Oh, I see. In that case, one phyisical 802.11n frame can contain up to 40 L2 frames. @bpwl just mentioned that CAPsMAN reduces the A-MSDU to 2048 by default. If that is true, then this also cannot explain the big difference in speed.

I wonder if A-MSDU can be configured in any way?
Mikrotik has a rather poor aggregation implementation with smaller sizes and static settings. Other brands implement an intelligent adaptive algorithm and the full standard sizes.
And why is that? Is it because of some hardware limitation? Or is it just because it was not implemented in software?
And one more: most forum users know that the software "stable" channel is far from stable. The performance of the 6.48(.0) is unknown. Use LongTerm for operating Mikrotik devices.
Thank you for the tip. I'm going to downgrade on all devices.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Fri Dec 25, 2020 11:45 pm

Oh, I see. In that case, one phyisical 802.11n frame can contain up to 40 L2 frames. @bpwl just mentioned that CAPsMAN reduces the A-MSDU to 2048 by default. If that is true, then this also cannot explain the big difference in speed.

I wonder if A-MSDU can be configured in any way?
A-MDPU is even more important right? (These are new things for me, I hope I'm not asking dumb questions.)
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sat Dec 26, 2020 12:47 am

A setting suggestion I would have, if you don't already have it, is to try enabling "adaptive noise immunity" on the CAP device itself. This is done through the advanced tab of the wireless interface. You will have to temporarily switch off the CAP functionality in order to change this setting, otherwise it will forbid the change due to being managed by the CAPsMAN.
This was another good suggestion. Turned on adaptive noise immunity mode on both devices. The HAP AC can now always do at least 75Mbps. (with bw reduced to 20MHz and no encryption). The HAP Lite is still at 30Mbps max.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sat Dec 26, 2020 1:07 am

What is in the wireless registration table of the AP? Looks like : TX rate= 144Mbps/40Mhz/1s/SGI
I'm trying to answer all questions, I hope we can find out what is causing the difference.

For HAP Lite, I see this: tx rate 144.4Mbps-20Mhz/2S/SGI rx rate=12Mbps Tx signal=0 Rx signal=-39 but if I look at the registration table while the test is running, then it goes down to 104Mbps, sometimes even 78Mbps-20MHz/2S

For HAP AC2, I also see tx rate 144.4Mbps-20Mhz/2S/SGI but the rx rate is different: tx 144.4Mbps-20Mhz/2S/SGI and the signal is -31. If I look at it while the test is running, then the tx rate usually stays at 144.4Mbps-20Mhz/2S/SGI , but down to 117Mbps-20MHz/2S for some seconds.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sat Dec 26, 2020 1:43 am

Many things at once ....

- A-MSDU is reduced for lower packet delay. Increasing it will help rise the max throughput. Normal (non CAPsMAN) value is 8192.The standard defined 7935 byte size is used then.
But this will not help much here. You are so far away from the normal expected throughput, that the fine tuning (minimum rate, basic rate, MSDU size etc) should be delayed until it's time to fine tune.

These AMSDU values are found in the HT tab.
All is priority 0 (unless you add some mangle rules in the Firewall to set the priorities. So A-MPDU should be used in your setup.
Klembord-1.jpg
.
Changing "adaptive noise immunity" which reduces the sensitivity of the receiver and getting better results points in the direction of interference or signal distortion.

The first simple basic check always is that TX Rate and RX Rate in wireless registration. If that does not give the expected max interface rate MCS7 (72Mbps, 144 Mbps, 300 Mbps, 150 Mbps .... see http://mcsindex.com/ you are in the orange HT table only with 2.4GHz 802.11n), then the wifi signal is not perfect. (Too strong? Reflections? Interference?) It also learns what you actually get as PHY (MCSindex,1Stream or 2Streams, short guard interval.) This must be checked first ( If the MCS7 is not reached the TX/RX CCQ gives what part of the transmissions were successful). You can expect 50% of the PHY as data rate in one direction. (25% if bidirectional). This 50% can become 70% with the fine tuning, but it depends .... (if there are very few AP's then basic rate doesn't matter, if you stay at the higher MCS rates then removing the lower rates doesn't matter, if A-MPDU is used then A-MSDU is not very important, etc etc...)

OK I see you added that rate information. 144.4Mbps-20Mhz/2S/SGI is the perfect value. But it's dropping under load. Keep other electronic devices, metal surfaces and the client away from the AP. Reading those rates can be tricky. When there is no traffic they tend to go low. But under load they should stay at the top level. Occasionally dropping to 130 is OK. 104 is yet one step lower and losing the short guard . 78 is a major step down to 16-QAM modulation, what indicates a strongly distorted signal. Something you should fix first. (Close to the AP the wifi signal is quite irregular in the different directions. Make sure the other AP is switched off.)
You do not have the required permissions to view the files attached to this post.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sat Dec 26, 2020 11:08 am

Thank you for your exhausting response! It will take a while for me to catch up and understand everything that you wrote. I'm going to come back later when I (hopefully) understand everything you write and tried all possible fixes.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sat Dec 26, 2020 11:21 am

OK Fine. Please also consider reducing the TX power of the AP. (It might be disturbed by its own reflected signal). I did not see what country (regulatory domain) you are in. For FCC (US,Canada, no-country-set) the max power is 30 dBm, for ETSI and most other places it is 20 dBm. You can see the used TX power in the Status tab (hAP Lite will be higher than hAP ac2 due to the reduction for the antenna gain). Smartphone is more 10 dBm. So for a smartphone public setting the TX power to 12 dBm or 15 dBm makes sense.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 1:32 pm

Here I'm again. I replaced my phone with my laptop. It can provide more information about the wifi network. It turned out that almost everybody is using channels 1,6 and 11 in the neighborhood. So I changed frequency and tried the speed with channel 1 (2412 Mhz) and 6 (2437 Mhz). I have also reduced the transmit power to 10, 13 and 15 dBm, and made some more tests.

https://imgur.com/a/eBXxgXW

Then I switched to channel 8, that is overlapping with many other APs and did some more tests.

https://imgur.com/a/vPqqOQ7

As you can see, 2.4GHz is really crowded here. The tx speed in the registration table was about 60Mbps for both channel 1 and 6, and I had terrible TX CCQ values. I could only achieve about 6Mbps on channels 1 and 6 with the HAP Lite and the laptop. I could do about 20Mbps on channel 8 with HAP Lite and my phone.

Channel 8 was a bit better. I quess the explanation is that it is overlapping with many other APs. Once they notice that something else is using the channel, they all shut up. They cannot decode the headers and don't know how much they have to wait before the cannel becomes free again. This gives me advantage. I might be wrong again, but I think this will give me more speed and take that away from others.

Registration table showed -30/-40 dBm for the phone and -40/-50 dBm for the laptop.

There are too many APs and there is too much interference. Previously I thought that because I'm indoors and the AP and the phone were very close to each other, and most of the other APs are under -70dBm, the conditions are close to ideal. But -70dBm is usable and it causes a lot of interference.

But the original question was about the difference between HAP AC2 and HAP Lite. I also tried the same things with HAP AC2. Same channels, same TX power, same placement of the AP, same distance from the phone/laptop etc. Powered off the HAP AC2 when I was testing the HAP Lite and vice versa.

On channel 8, the HAP AC2 can do 80-90Mbps reliably with my phone and 20-30Mbps with my laptop. (Registration table showed that my laptop always has lower signal level values. The same laptop could do 400Mbps+ on 5Ghz with Asus AX86AU so I think that the manufacturer did not think that 2.4Ghz was important and they put in a crappy antenna.)

I don't have the time to buy a cAP Lite, hAP mini or mAP lite just to test the speeds with those, but I believe I would get very similar (crappy) results. Until (if I ever) find out what is causing this huge difference, I'll stick to HAP AC2 and cAP AC.

Actually, I'm very happy with 80-90Mbps in this environment. But I still don't understand why the HAP Lite can only do about 1/3rd speed. Given the specifications, the CPU load and all other things that I have tested, there is no good explanation.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 4:05 pm

Thank you very much for sharing your experiments. Unfortunately it did not solve your problem.

But you are in a rather crowded 2.4GHz area. And that changes the tuning of every AP considerably. All you can find to optimize your AP throughput could be contra-productive in this situation. Actually just the opposite should be done. [ It's like tuning your car for a rally contest versus an off-road contest] On the other hand "2.4GHz is dead" (document from Divergent Dynamics disappeared from their website, and 1.9MB is too big for an attachment here.)

Still surprised about the poorer performance of the hAP Lite. The smaller antenna gain should have helped to avoid picking up neighbors.

Why tuning is a repeated PDCA cycle ... "plan, do, check, adjust" ... there is no magic setting that fixes it all. And there is no auto-tuning in MKT.

- setting the "Adaptive noise immunity" is good for reducing the receiver sensitivity. More traffic from AP and client will be seen as just noise. .
- The hAP Lite even has a "Noise floor threshold" parameter. It's not in the hAP ac2.
- Adjacent channel interference normally is worse than the co-channel wait. The nummer of SSID on a channel is not a good indication for how busy the channel is. In Mikrotik you have the "Freq usage" as indication. This value will in reality change is a split second and blur the experiment outcome. Not many go for channel 13 if you chose the adjacent-channel strategy.
-Fighting adjacent channel interference is the opposite of aiming for max clean site throughput. A-MPDU is preferred over A-MSDU aggregation here. Small AMSDU adds an extra checksum block per AMSDU, and only the affected parts have to be retransmitted. So smaller AMSDU here is better, like 1500bytes the max of a standard ethernet frame, but even smaller.
-"HW-retries" is standard on 7. Setting it on 15 will hold the interface longer on the fast MCS modulation (good for short bursts of interference), setting it to 2 or 3 will make the AP move down in MCS modulation faster, avoiding the useless retransmits needed to trigger the step-down. (good for continuous interference).
- If the MCS rate is almost never on the highest value then disabling MCS7 and MCS15 will stop the AP for trying and failing those.
- "HW protection mode" could help as well. (CTS self or RTS-CTS). As not everyone will see all players in the spectrum. "HW-protection threshold" will avoid this overhead for smaller packets.
- If adjacent channel interference is really bad, then even "HW Fragmentation threshold" should be considered to work with smaller packets.
-Not sure if the increased basic rate and supported rates for management traffic is not contra-productive with high interference.

The trial and error is up to you. But one day you will have to move up to 5GHz.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 4:41 pm

Thank you for your time! I'll experiment some more.
 
mkx
Forum Guru
Forum Guru
Posts: 5272
Joined: Thu Mar 03, 2016 10:23 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 5:39 pm

High level of interference actually explains the difference in achievable speeds on both units which initiated this thread: hAP lite has much lower Tx power (16-18 dBm at highest rates) compared to hAP ac2 (23-24 dBm at same high rates). 6dB makes quite some difference in SINR which at the end of the day governs max throughput over a radio channel.
Rx sensitivity is not so much different but hAP ac2 has advantage here as well, so uploads are likely higher as well.
BR,
Metod
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 6:12 pm

High level of interference actually explains the difference in achievable speeds on both units which initiated this thread: hAP lite has much lower Tx power (16-18 dBm at highest rates) compared to hAP ac2 (23-24 dBm at same high rates). 6dB makes quite some difference in SINR which at the end of the day governs max throughput over a radio channel.
Rx sensitivity is not so much different but hAP ac2 has advantage here as well, so uploads are likely higher as well.
Well, you forgot that I manually set the TX power in CAPsMAN config. I believe that they used the same TX power when I was doing the tests. (Unless the TX power setting is relative and not absolute?)
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1252
Joined: Mon Apr 08, 2019 1:16 am

Re: Inconsistent speed HAP AC2 vs HAP Lite

Sun Dec 27, 2020 10:05 pm

The power is absolute in dBm. However the antenna gain must be added for the emitted power (EIRP). So the signal of the hAP ac2 is 1.5dBm stonger than from the hAP Lite if you set the TX power=12.

I think we are missing something in this investigation. If the hAP Lite is bogged with interference so should the hAP ac2 at least get disturbed. It does seem to not be the case.
There probably are a lot of emitted SSID around, but not much traffic (Freq Usage). So even the tuning for "heavy interference" will not solve the difference between the 2 devices.

Starting to think "something" is fundamentally wrong with the hAP Lite. Like not working properly with 6.48 (see the forum topic, 6.48 is very far from stable!). But also suspecting the power supply.

Just did a quick and dirty test. (I did not want to remove my hAP Lite from its duty), nor moving closer to the unit.
I took a hAP ac Lite (2.4+5GHz device) and placed it closer to the hAP Lite. Connected to it via 5 GHz from my laptop, and made it "bridge station" connect to the hAP Lite with the 2.4GHz.
For monitoring I was also connected 2.4GHz to the hAP Lite.
The devices connected 144Mbps-20MHz/2S/SGI.
Then a bandwidth test between the 2 devices. (I know, it's wrong the 2 devices will die on CPU load, as I should use Btest on other devices), but still, what I get is the lowest possible value.
UDP unidirectional started from the hAP ac Lite to the hAP Lite was 85 Mbps
TCP unidirectional was only 50 Mbps, and the hAP Lite crashed on the heavy load.
Last edited by bpwl on Mon Dec 28, 2020 1:34 am, edited 1 time in total.
 
mkx
Forum Guru
Forum Guru
Posts: 5272
Joined: Thu Mar 03, 2016 10:23 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Mon Dec 28, 2020 12:07 am

As I wrote: hAP lite is capable of Tx power 16 dBm or 18 dBm when transmitting at high symbol rates. Your setting of 20 dBm does not override that. hAP ac2 did get slightly limited by your setting, but there's still difference of 2 to 4 dB.
Additionally: my gut feeling is that Rx signal strength of -30 to -40 dBm is simply too high for usual WiFi receivers, something around -50 dBm is more comfortable (but then some receivers are probably better behaving than others). When Rx signal is too high, the amplifier can not reduce its gain low enough and due to over-amplification it distorts received signal which severely reduces SINR.
Add that to high real interference and it's not surprising that wireless link performs poorly.
BR,
Metod
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Tue Dec 29, 2020 10:33 am

As I wrote: hAP lite is capable of Tx power 16 dBm or 18 dBm when transmitting at high symbol rates. Your setting of 20 dBm does not override that. hAP ac2 did get slightly limited by your setting, but there's still difference of 2 to 4 dB.
I manually set TX power to 10, 13 and 15dBm. I think it did override the hAP ac2.
Additionally: my gut feeling is that Rx signal strength of -30 to -40 dBm is simply too high for usual WiFi receivers, something around -50 dBm is more comfortable (but then some receivers are probably better behaving than others). When Rx signal is too high, the amplifier can not reduce its gain low enough and due to over-amplification it distorts received signal which severely reduces SINR.
It was -30/-40 dBm because the receiver (phone) was about 1 meter away from the AP. Even if you are right and the Rx signal is too high on the phone, it was (almost) the same for both APs. So even if it is disorted, it still does not explain the huge difference in speed.
Add that to high real interference and it's not surprising that wireless link performs poorly.
But that is also invariant, the two devices were compared under the same conditions.

I hope I'll some time time today to do more tests with RouterOs long term support version.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun May 26, 2019 2:08 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Tue Dec 29, 2020 10:40 am

But also suspecting the power supply.
The HAP Lite devices are brand new. I bought them to test and experiment with CAPsMAN before I do a bigger installation. I don't think that both of them have faulty (and brand new) power supplies.
 
mkx
Forum Guru
Forum Guru
Posts: 5272
Joined: Thu Mar 03, 2016 10:23 pm

Re: Inconsistent speed HAP AC2 vs HAP Lite

Tue Dec 29, 2020 4:36 pm

It was -30/-40 dBm
-30dBm is way different from -40dBm if the Rx sensitivity is too high. And for duplex link also Rx sensitivity in AP matters ... unless you're benchmarking using unidirectional UDP stream.

Anyway, morale of the story is that wireless devices, even if they seem to be similar from basic technical specifications, behave differently in harsh conditions. And harsh conditions are anything other than peer's signal strength outside interval of (-50dBm to -75dBm) and interference (either co-channel or adjacent channel) higher than -90dBm or higher than -30dB (relative to peer's signal strength).

Either do the tests in conditions which actually resemble real conditions (are normal wireless clients going to be not more than 1 metere away from wireless antennae?) or, if real installation will be experiencing harsh conditions, you'll have to find devices which perform best under those conditions. I guess you'll be surprised sometimes about how good/bad some device performs.
BR,
Metod

Who is online

Users browsing this forum: No registered users and 43 guests