Community discussions

MikroTik App
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

intermittent connection errors on RBSXTR

Mon Jan 18, 2021 11:11 pm

I have an SXT LTE kit, and a NAT-ed LAN behind it. There are intermittent connection errors. When somebody wants to load a website, then there is 50% chance that he will get a connection error. This is intermittent - if you try again, the it usually works. Or maybe you have to try two or three times, but eventually it works.

I have lowered the mtu of the lte interface (first lowered to 1942, then as low as 1360) but apparently that did not solve the problem.

Something else is happening here, I just don't know what. Tried to debug lte:
/system logging
add topics=lte,debug
/log print follow
But there is nothing happening there.

Here is a sample interface lte info (private ids hidden):
           pin-status: ok
  registration-status: registered
        functionality: full
         manufacturer: "MikroTik"
                model: "R11e-LTE"
             revision: "MikroTik_CP_2.160.000_v015"
     current-operator: Telekom HU
                  lac: 12345
       current-cellid: 123456
               enb-id: 1234
            sector-id: 3
           phy-cellid: 123
    access-technology: Evolved 3G (LTE)
       session-uptime: 3h54m43s
                 imei: 123456781234567
                 imsi: 123456781234567
                 uicc: 12345678123456781234
               earfcn: 6350 (band 20, bandwidth 20Mhz)
                 rsrp: -72dBm
                 rsrq: -8dB
                 sinr: 23dB
                  cqi: 14
Since I don't see anything strange happening in the lte logs, I guess locking the modem to a specific tower won't help. I might be wrong...

I can only access this device through ssh right now, I have no access to other computers on the LAN side. But here is a quick and dirty test that shows the connection problem on the router itself:

[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[user@router] > /system ssh [/resolve www.google.com] port=80

Welcome back!
[adm@router] >
So out of 6 connections, only one succeeded. The other five returned "no route to host" error.

Any idea what can cause this?

Thank you.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Mon Jan 18, 2021 11:27 pm

By the way, system uptime is 3d5h, and the number of link downtimes is 5:
 4  R  name="lte1" type="lte" mtu=1450 actual-mtu=1450 mac-address=AC:FF:FF:00:00:00 last-link-down-time=jan/18/2021 22:21:32
       last-link-up-time=jan/18/2021 22:21:41 link-downs=5
Most of them are because of manual MTU changes. So the connection to the cell tower is very stable.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Thu Jan 21, 2021 9:59 am

Locked band to B20, network-mode to lte. Locked modem to tower. Now testing again (but it does not look good)
Last edited by nagylzs on Thu Jan 21, 2021 12:28 pm, edited 1 time in total.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Thu Jan 21, 2021 11:04 am

Okay so I excluded all possible local errors:

* connected directly to a computer via ethernet/UTP cable
* set fixed lte band
* locked modem to tower

Signal strength is excellent ( never goes below -77 dBm), there is nothing in the logs, but it still does not work. Sometimes I'm not able to connect with TCP, and it is totally random. Sometimes there is no problem for 30 minutes. Then suddenly 50% of the connections fail. Literally, if I connect to the same host twice within 1 second, then I get this:
[gandalf@palfi] > /system telnet [/resolve www.google.com] 80
Connecting to 172.217.20.4
telnet: connect() failed:  No route to host

Welcome back!
[gandalf@palfi] > /system telnet [/resolve www.google.com] 80
Connecting to 172.217.20.4
Connected to 172.217.20.4
I'm not sure what is sending the "no route to host" message, and I'm not sure how to check that.
Last edited by nagylzs on Thu Jan 21, 2021 12:29 pm, edited 1 time in total.
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Thu Jan 21, 2021 11:43 am

I found out something. When there are lots for TCP connection errors, then ping gives back ICMP 3 / 10 "admin prohibited", something like this:
[gandalf@palfi] > /system telnet [/resolve telex.hu] 80
Connecting to 104.26.3.85
telnet: connect() failed:  No route to host

Welcome back!
[gandalf@palfi] > ping telex.hu                        
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                                                                                                              
    0 10.254.49.226                              56 126 35ms  admin prohibited                                                                                                                                    
    1 10.254.49.226                              56 126 25ms  admin prohibited                                                                                                                                    
    2 10.254.49.226                              56 126 25ms  admin prohibited                                                                                                                                    
    sent=3 received=0 packet-loss=100% 
It seems that these happen at the same time. E.g. when TCP connect fails, then ICMP ping also fails with "admin prohibited".

Does it mean that there is a problem on the ISP side?
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Thu Jan 21, 2021 12:39 pm

I'm almost sure this is a problem on the ISP side.
[gandalf@palfi] > /tool traceroute telex.hu
 # ADDRESS                          LOSS SENT    LAST     AVG    BEST   WORST STD-DEV STATUS                                               
 1                                  100%    8 timeout                                                                                      
 2 10.254.49.226                    85..    8 timeout    23.4    23.4    23.4       0                                                      
 3 10.254.49.226                    85..    7 timeout    18.6    18.6    18.6       0 packet filtered from 10.254.49.226                   
 4                                    0%    0     0ms                                                                                      

The "packet filtered from" message always appears for 10.254.49.226, but it randomly works. That address ( 10.254.49.226 ) must be an internal gateway of the mobile provider, because it is on a totally different subnet ( the modem gets its public address from 100.113.x.x ).
 
nagylzs
Member Candidate
Member Candidate
Topic Author
Posts: 131
Joined: Sun May 26, 2019 2:08 pm

Re: intermittent connection errors on RBSXTR

Fri Jan 22, 2021 8:17 pm

It turned out to be a problem on the ISP side. Although they don't admit this. But I change the SIM card (different ISP) and everything works, no problem whatsoever.

Who is online

Users browsing this forum: No registered users and 38 guests