Community discussions

MikroTik App
 
User avatar
TomjNorthIdaho
Forum Guru
Forum Guru
Topic Author
Posts: 1145
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

connect-list ( clients using connect-list with nv2 protocol )

Wed Jan 20, 2021 11:48 pm

connect-list ( clients using connect-list with nv2 protocol )
(( re forcing nv2 clients to connect to the strongest nv2 APs when many nv2 APs of many signal strengths are available ))

1'st: My WISP environment :
I have hundreds of Mikrotik nv2 APs on multiple towers and around 1-thousand Mikrotik nv2 clients.
All of my towers have give-or-take a dozen nv2 APs.
All of my nv2 APs use the same SSID.
On each tower, each nv2 AP is pointed in slightly different directions which then gives me a 360-degree coverage pattern.
All of my nv2 clients see an average of 4 to 12 nv2 APs per tower.
Some of my nv2 clients see multiple towers ( which results in some nv2 clients seeing up to 24 of my nv2 APs ).

I suspect that many/most of my nv2 clients connect to the first nv2 AP a nv2 clients finds ( usually the lower frequencies first ). If I am correct, that unlike 802.11 , nv2 does not background scan for better/stronger nv2 APs to connect to - which results in many clients not connecting to the strongest nv2 AP but rather the first nv2 AP a nv2 client finds.

I am considering configuring all of my nv2 clients to use a connect-list to force all nv2 clients to connect to the strongest nv2 AP ( instead of the first found nv2 AP ).
I'm thinking of a connect-list on my nv2 clients that has rules that are configures in this order:
- connect if AP is stronger than -50
- connect if AP is stronger than -55
- connect if AP is stronger than -60
- connect if AP is stronger than -65
- connect if AP is stronger than -70
- connect if AP is stronger than -75
* if none of the above connect-list rules match in the sequenct above , then the nv2 client Mikrotik will then continue and connect to anything as if the connect-list was not configured.

My questions:
- Does the connect-list on clients function correctly when using the nv2 protocol ?
- Does anybody else using the connect-list on client Mikrotiks use/have a connect-list doing something like what I am considering doing ?

Thank you for any input & ideas you may have.

North Idaho Tom Jones
 
User avatar
TomjNorthIdaho
Forum Guru
Forum Guru
Topic Author
Posts: 1145
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: connect-list ( clients using connect-list with nv2 protocol )

Thu Jan 21, 2021 4:14 am

FYI - here is my sample test code that appears to be working.

/interface wireless connect-list
add allow-signal-out-of-range=always interface=wlan1 signal-range=-40..-5
add allow-signal-out-of-range=always interface=wlan1 signal-range=-45..-35
add allow-signal-out-of-range=always interface=wlan1 signal-range=-50..-40
add allow-signal-out-of-range=always interface=wlan1 signal-range=-55..-45
add allow-signal-out-of-range=always interface=wlan1 signal-range=-60..-50
add allow-signal-out-of-range=always interface=wlan1 signal-range=-65..-55
add allow-signal-out-of-range=always interface=wlan1 signal-range=-70..-60
add allow-signal-out-of-range=always interface=wlan1 signal-range=-75..-65
add allow-signal-out-of-range=always interface=wlan1 signal-range=-80..-70
add allow-signal-out-of-range=always interface=wlan1 signal-range=-85..-75
add allow-signal-out-of-range=always interface=wlan1 signal-range=-120..-80

feed back is welcome

North Idaho Tom Jones

Who is online

Users browsing this forum: No registered users and 44 guests