Community discussions

MikroTik App
 
storrgie
just joined
Topic Author
Posts: 7
Joined: Mon Aug 10, 2020 12:34 am

CAPsMAN Channel Reselection with create-dynamic-enabled

Sun Jan 24, 2021 4:51 pm

I'm new to Mikrotik, sorry if this is obviously covered in documentation but I can't seem to find an explicit enough explanation for it to click with me.

My goal is I think fairly strait forward:
  • CRS328-24P-4S+ (current stable firmware 6.48)
  • 2 x Audience as CAP (current stable firmware 6.48)
  • Enumerate channels:
  • 2.4Ghz: 20Mhz channels 1,6,11 no extensions
  • 5Ghz: 80Mhz channels 5180,5260,5500,5580,5660,5745 with Ceee extension
  • Single SSID, handoff between CAPs (potentially I need to add a rule for signal strength to push clients off?)
  • Steering towards 5Ghz if possible (Ubiquiti called this "band steering")
  • CAP auto provision and auto select non-conflicting channels

I have everything working in the setup except that the audience CAPs select the same exact channels each time they boot up, they do not re-select non-conflicting channels after 1 hour. I'd certainly like to auto provision if I can because I may in the future add another CAP. This is in a large home far away from other homes so the spectrum is clear.

Realizing that the advice is often times to do an actual spectrum plan, I'm curious about doing manual assignment of channel sets to each CAP as well (this would be a good thing to have explained). I had found this gist which looks like it would be useful if you were going to manually assign channels to each CAP.

This is my current configuration:
/caps-man channel
add band=5ghz-onlyac control-channel-width=20mhz extension-channel=Ceee frequency=5180,5260,5500,5580,5660,5745 \
    name=5Ghz@80Mhz,Ceee reselect-interval=1h
add band=2ghz-onlyn control-channel-width=20mhz extension-channel=disabled frequency=2412,2437,2462 name=2Ghz \
    reselect-interval=1h
/caps-man configuration
add channel=2Ghz country="united states3" datapath.local-forwarding=yes datapath.vlan-id=10 datapath.vlan-mode=\
    use-tag name=WIFI-HOME-2 security.authentication-types=wpa2-psk security.passphrase=\
    longpassword ssid=test
add channel=5Ghz@80Mhz,Ceee country="united states3" datapath.local-forwarding=yes datapath.vlan-id=10 \
    datapath.vlan-mode=use-tag name=WIFI-HOME-5 security.authentication-types=wpa2-psk security.passphrase=\
    longpassword ssid=test
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes
/caps-man manager interface
add disabled=no interface=MANAGEMENT
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=WIFI-HOME-2
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=WIFI-HOME-5
Since this is my first real post on the forums it would also be nice if someone could point out anything that I might not be asking that I should be asking.
 
storrgie
just joined
Topic Author
Posts: 7
Joined: Mon Aug 10, 2020 12:34 am

Re: CAPsMAN Channel Reselection with create-dynamic-enabled

Thu Feb 04, 2021 11:44 pm

Bumping the post, is this thing I'm trying to do impossible?
 
İmposss
just joined
Posts: 11
Joined: Sat Jan 16, 2021 5:30 pm

Re: CAPsMAN Channel Reselection with create-dynamic-enabled

Fri Feb 05, 2021 2:12 am

Hello
I am using ''channel/save-selected'' in /caps-man configuration. İt saves the last picked frequency.
https://wiki.mikrotik.com/wiki/Manual:CAPsMAN
Last edited by İmposss on Sun Feb 07, 2021 8:18 pm, edited 1 time in total.
 
gotsprings
Forum Guru
Forum Guru
Posts: 1053
Joined: Mon May 14, 2012 9:30 pm

Re: CAPsMAN Channel Reselection with create-dynamic-enabled

Sat Feb 06, 2021 5:41 pm

As much as I hate to use it...
When I use caps-man... Create Enabled. Then I select the wireless channels for each radio manually.

I have a template for all the US channels and frequency. So I use that in the drop down menu.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain

Who is online

Users browsing this forum: Google [Bot] and 27 guests