Community discussions

MikroTik App
 
piku
newbie
Topic Author
Posts: 30
Joined: Sat Feb 10, 2018 10:59 am

DHCP client on wlan not getting address [solved]

Sat Feb 20, 2021 3:51 am

I'm using cAP ac as a wlan station which I fount it won't get ip address through dhcp server.
and found some same(?) issue here without clear soluction:
DHCP client - wlan as WAN not getting address viewtopic.php?t=128954
DHCP client on bridge does not work? viewtopic.php?t=133156
Wireless clients can't get an IP viewtopic.php?t=149949

after some dig, I found DHCP client fail only on 2.4G port, 5G port works fine (which is from the same ap)
config here:
/interface wireless
set [ find default-name=wlan1 ] allow-sharedkey=yes band=2ghz-b/g/n channel-width=20/40mhz-XX country=no_country_set disabled=no frequency=auto frequency-mode=superchannel ssid=CISCO station-roaming=\
    enabled wireless-protocol=802.11 wmm-support=enabled
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX country=no_country_set distance=indoors frequency=auto frequency-mode=superchannel ssid=CISCO station-roaming=enabled \
    wireless-protocol=802.11 wmm-support=enabled

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=some_password

/ip dhcp-client
add disabled=no interface=wlan1
add disabled=no interface=wlan2
as shown above, WLAN1 is 2.4G and WLAN2 is 5G. no bridge setted.
wlan1 keep searching but wlan2 can get a address from dhcp.

any ideas?
Last edited by piku on Sat Feb 20, 2021 2:53 pm, edited 1 time in total.
 
Cablenut9
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Jan 08, 2021 5:30 am

Re: DHCP client on wlan not getting address

Sat Feb 20, 2021 5:44 am

I had the same problem and the fix was to switch around the modes from b/g/n to g/n and to only-n, and that would eventually get it to connect. Also, make sure you've enabled tkip in the security profile. ROS WiFi tends to work best with other ROS devices, and that's probably why they're not officially WiFi-certified.
 
piku
newbie
Topic Author
Posts: 30
Joined: Sat Feb 10, 2018 10:59 am

Re: DHCP client on wlan not getting address

Sat Feb 20, 2021 2:52 pm

I had the same problem and the fix was to switch around the modes from b/g/n to g/n and to only-n, and that would eventually get it to connect. Also, make sure you've enabled tkip in the security profile. ROS WiFi tends to work best with other ROS devices, and that's probably why they're not officially WiFi-certified.
Thank you very much but for compatibility reasons, I cannot abandon 802.11b.
But it sounds a good thinking. So after I change channel width from 20/40 to 20, all works fine.
What's more, because aes has higher speed than tkip, I don't think enable tkip is a good idea.
 
mkx
Forum Guru
Forum Guru
Posts: 5416
Joined: Thu Mar 03, 2016 10:23 pm

Re: DHCP client on wlan not getting address [solved]

Sat Feb 20, 2021 4:24 pm

When using ROS device as wireless client, it doesn't matter what options you have enabled (e.g. tkip, b/g, ...) because client can not force AP to work in certain way, client has to follow AP's setup to certain degree and AP preferences overrule client's if both support same features. So if you disable a few things too many, it may happen client won't connect if AP doesn't support the limited options enabled on client.

Notable exception is using only 20MHz channels which forces communication to single 20MHz channel (which is mandatory to support for all 802.11 variations so far). If this setting helps (and keeping in mind that 5GHz seems to work fine), then this likely indicates lots of interference and using single 20MHz channel helps (because Tx power per megahertz is double compared to using 20+20MHz channels).
BR,
Metod

Who is online

Users browsing this forum: nsamuel, TomjNorthIdaho and 49 guests