Page 1 of 1

Added SSID in CAPsMAN - doesn't show up

Posted: Sat Jun 19, 2021 10:59 pm
by jgauthier
I added an SSID, "Alexa" to my CAPsMAN config. It doesn't show up on the APs though.
This the caps config
/caps-man channel
add band=2ghz-b/g/n control-channel-width=20mhz name=2.4Ghz
add band=5ghz-a/n/ac control-channel-width=20mhz frequency=5180 name=5.0Ghz
/caps-man datapath
add bridge=bridge local-forwarding=no name=datapath1
add bridge=bridge local-forwarding=no name=alexa_datapath vlan-id=90 vlan-mode=use-tag
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security1
add authentication-types=wpa2-psk encryption=tkip name=security2
/caps-man configuration
add channel=2.4Ghz country="united states3" datapath=datapath1 datapath.bridge=bridge name="2.4Ghz Config" security=security1 ssid=Gauthier
add channel=5.0Ghz country="united states3" datapath=datapath1 datapath.bridge=bridge name="5.0Ghz Config" security=security1 ssid="Gauthier 5Ghz"
add channel=5.0Ghz country="united states3" datapath=datapath1 datapath.bridge=bridge name=Alexa security=security1 ssid=Alexa
/caps-man access-list
add action=reject allow-signal-out-of-range=10s disabled=no signal-range=-120..-75 ssid-regexp=""
add action=accept allow-signal-out-of-range=10s disabled=no signal-range=-74..120 ssid-regexp=""
/caps-man manager
set enabled=yes
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration="2.4Ghz Config"
add action=create-dynamic-enabled hw-supported-modes=an master-configuration="5.0Ghz Config"
add action=create-dynamic-enabled hw-supported-modes=an master-configuration=Alexa
This is what shows on the wireless interfaces
 /interface wireless print
Flags: X - disabled, R - running 
 0 X  ;;; managed by CAPsMAN
      ;;; channel: 2447/20-eC/gn(27dBm), SSID: Gauthier, CAPsMAN forwarding
      name="wlan1" mtu=1500 l2mtu=1600 mac-address=48:8F:5A:AB:35:E6 arp=enabled interface-type=Atheros AR9300 mode=ap-bridge ssid="MikroTik-AB35E6" frequency=auto band=2ghz-b/g/n 
      channel-width=20/40mhz-XX secondary-channel="" scan-list=default wireless-protocol=802.11 vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no security-profile=default compression=no 

 1 X  ;;; managed by CAPsMAN
      ;;; channel: 5180/20-Ceee/ac(28dBm), SSID: Gauthier 5Ghz, CAPsMAN forwarding
      name="wlan2" mtu=1500 l2mtu=1600 mac-address=48:8F:5A:AB:35:E5 arp=enabled interface-type=Atheros AR9888 mode=ap-bridge ssid="MikroTik-AB35E5" frequency=auto band=5ghz-a/n/ac 
      channel-width=20/40/80mhz-XXXX secondary-channel="" scan-list=default wireless-protocol=802.11 vlan-mode=no-tag vlan-id=1 wds-mode=disabled wds-default-bridge=none 
      wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no security-profile=default 
      compression=no 

Once I do get it to show up, I am going to assign a VLAN to it, and segregate. Bur I don't understand why CAPsMAN isn't showing it.

Re: Added SSID in CAPsMAN - doesn't show up

Posted: Sat Jun 19, 2021 11:50 pm
by biomesh
If you are adding it to existing caps, you will need to set it (the new SSID config) as a slave config on the provisioning rule. You might also want to manually provision the cap/radio again as well.

Re: Added SSID in CAPsMAN - doesn't show up

Posted: Sun Jun 20, 2021 5:48 pm
by jgauthier
If you are adding it to existing caps, you will need to set it (the new SSID config) as a slave config on the provisioning rule. You might also want to manually provision the cap/radio again as well.
Yup, I figured it out after awhile! A slave config made it show up. Now I am having trouble getting to provbide DHCP through the VLAN. Gotta go find out if there's a document somewhere.