Community discussions

MikroTik App
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

KB: LTE by SiB

Tue Sep 07, 2021 7:28 pm

Content this thread/topic is a live documentation. It will be edited with new information becomes available.
@Mikrotik: Please create a M11G with m.2 slot for LTE/5G modules ! We wait for new line of 5G devices like SXTGR 5G, LHGGR 5G, LDFGR 5G - 1Gb and m.2 slot with 4x4 MIMO - we wait.

Table of Contents
  1. How to correctly diagnose & collect LTE logs for support
  2. Additional Scripts for LTE
  3. Antennas
  4. Acessories like m.2 adapters
  5. HowTo configure X LTE module
  6. About LTE, CA and MIMO
  7. Reserved
  8. Reserved

Remember fist do upgrade a RouterOS and separate a lte module upgrade.
List of latest version of firmware per lte module:
  • R11mL-RG502Q-EA (Chateau 5G) RG502QEAAAR11A04M4G <- first m.2 form factor
  • R11e-LTE12 (EG12-EA) EG12EAPAR01A10M4G
  • R11e-LTE6 v028
  • R11e-LTE MikroTik_CP_2.160.000_v018
  • R11e-LTE-4G v9
  • R11e-LTE-US R11eL_v16.02.183961 (R11eL_v05.04.193841 probably show wrong info at ros7)
  • SXT LTE 3-7 |-> chip:2.0 fw:0.1.2.4
Documentation: https://wiki.mikrotik.com/wiki/Manual:I ... re_upgrade
Try this:
# Check your and latest firmware version
/interface lte firmware-upgrade lte1
# Do upgrade by:
/interface lte firmware-upgrade lte1 upgrade=yes

1) How to correctly diagnose & collect LTE logs for support

1A) Enable logging of LTE, regular logs.
/system logging action remove [find where name=support]
/system logging action add name=support target=memory memory-lines=16384 
/system logging remove [find where topics~"lte"] 
/system logging add action=support topics=lte

1B) LteLogger2 - optional
Final script as job in loop will monitor current lte parameters and log them as warning, blue entry. Check picture below.
You will see when BTS/Tower/eBN will change, when ca-band is re-assign etc., very useful in diagnosis.

Download proper script file and drag&drop it to WinBox.
You see new scheduler and script items. Scheduler is a software watchdog who watches over a script job to be still running in loop.
Installation of that file is by /import in terminal, remember that TAB key do complements of syntax :
/import ros6-lteLogger2.rsc

Example:
left - show one lte down
right - filtered ca-band logs show flapping with 2CA.
fHPSP8g6JS.png

That give you better perspective to see if something is change or not with LTE general.
Now we will discuss about your case.

1C) Problem replication

We are waiting for your problem to occur. If you know what do to generate/replicate that problem, then do it now.
btw, You can restart the device to accumulate fresh logs.

1D) Generate supout.rif

To report case to MikroTik support team you need generate supout.rif file.
In terminal just type:
/system sup-output

or in WinBox use from left main menu a "Make Supout.rif" button > Start button.

In WinBox main menu, the "Files" button show you local files and you can use Right Mouse Button (know as RMB), select Download to save file to your computer.

Remember that you can do additional screenshot-s, take a movie etc.. of problem.

1E) Report case

Try contact with your local distributor first, they should help you in first place.
Case reported directly to MikroTik should be via support@mikrotik.com or support portal at http://help.mikrotik.com

P.S. If you want open .rif file you can do that at https://mikrotik.com/client/supout but this is a separed credentials, you must first register here.
You do not have the required permissions to view the files attached to this post.
Last edited by SiB on Fri Oct 01, 2021 5:49 pm, edited 15 times in total.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:29 pm

Last edited by SiB on Sun Sep 12, 2021 9:08 pm, edited 4 times in total.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:29 pm

Last edited by SiB on Tue Sep 07, 2021 8:21 pm, edited 1 time in total.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:30 pm

Works with 5G Quectel units, they are USB2.0 what limit us to 480Mbps.

https://ebay.us/U6yzf8 <- only option without SIM slot
https://aliexpress.com/item/32861939520.html
https://aliexpress.com/item/1005002374313940.html

Remember: M.2 KEY B only are for LTE
Last edited by SiB on Mon Sep 20, 2021 12:28 am, edited 2 times in total.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:30 pm

mPCIe:
Quectel EP06-E <- Full HowTo
Telit LM940/LM960 <- Full HowTo
Huawei ME909s-120 ussd codes

m.2:
Quectel EG12/EM12 CellLock
Quectel RM502Q-AE (Global with US) - RouterOS 7.x with MBIM - WinBox not show a 5G details, CLI and AT must be used
Quectel EM160R-GL (fw EM160RGLAUR02A08M4G_0.001.01.001) - --//--

General:
USB EndPoints Limits, why R11e-LTE-US/R11e-LTE6 not work as secondary card
Last edited by SiB on Mon Sep 13, 2021 10:07 am, edited 6 times in total.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:31 pm

About LTE, CA and MIMO

Content will be edited soon.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:32 pm

Reserved
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Tue Sep 07, 2021 7:36 pm

Reserved
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
brg3466
Member Candidate
Member Candidate
Posts: 126
Joined: Sat Aug 01, 2015 7:29 am

Re: KB: LTE by SiB

Fri Sep 24, 2021 2:15 am

Hello SiB,
Just find my LtAP mini LTE US kit, the modem version is newer than you mentioned above, see below.
But somehow, I can never update it to the newer version. Once you try to upgrade, the LTE lose its connection to internet.
brg3466, [23.09.21 16:08]
[brg3466@LtAP] > /interface/lte/firmware-upgrade lte1 once
  installed: R11eL_v05.03.183961
     latest: R11eL_v05.04.193841
[brg3466@LtAP] > /interface/lte/firmware-upgrade lte1 upgrade=yes
  status: checking
-- [Q quit|D dump|C-z pause]
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Fri Sep 24, 2021 10:22 am

the modem version is newer than you mentioned above, see below.
Thanks, forum search show that version too as latest. Corrected. Thanks for info.

But somehow, I can never update it to the newer version. Once you try to upgrade, the LTE lose its connection to internet.
-LTE and -LTE-US is know as module who cannot do upgrade from own internet. Those modules can only do upgrade by itself mobile connection.
Remember that this should be by your ethernet connection to unit, by wifi you can be disconnected because Win10 in offline disconnect wifi and you not have access to winbox... this can be problematic some times.

When you write to MikroTik directly then they:
  • grab logs and maybe they want connect to your unit to fix it internally in magic way
  • share you a firmware package with instruction and you can install new firmware by usb-mPCIe adapter. USB extension cable with usb adapter give you a way to not disconnect this antenna cables.
Summary, You must write to support. support@mikrotik.com or help.mikrotik.com

EDIT:
R11eL_v05.03.183961
R11eL_v05.04.193841
exist probably sometimes for ros7....
the Original source have still have the R11eL_v16.02.183961version as latest one.
R11e-LTE-US R11eL_v16.02.183961 (R11eL_v05.04.193841 probably show wrong info at ros7)

If you want know answer, write directly to MikroTik.
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
BillyVan
just joined
Posts: 19
Joined: Tue Sep 04, 2018 10:29 pm
Location: Greece

Re: KB: LTE by SiB

Sat Sep 25, 2021 5:11 pm

i try several times to import ros-7-lteLogger2.rsc
from terminal but i receive ...expected end of command (line6 column 13)

procedure
copy on files and from terminal
/import ros7-lteLogger2.rsc


ros version 7.1.rc4
 
User avatar
SiB
Forum Guru
Forum Guru
Topic Author
Posts: 1800
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: KB: LTE by SiB

Mon Sep 27, 2021 1:48 pm

ros7.1rc4 not work with importing a /system scheduler in general. viewtopic.php?f=1&t=178704&p=882451#p882451 SUP-61613
WorkARound for RouterOS 7.1rc4

Create a system scheduler with interval=00:01:00 and code:
#Script WatchDog for script name:
local ScriptName lteLogger2
local ScriptRuningInstances [:len [system script job find script=$ScriptName]]
if ( $ScriptRuningInstances = 0) do={/system script run $ScriptName};
if ( $ScriptRuningInstances = 1) do={};
if ( $ScriptRuningInstances >= 2) do={system script job remove [find script=$ScriptName]};

Next is to run this code in terminal who create you a final script.
/system script
remove [find name=lteLogger2]
add name=lteLogger2 source="#:local watchItems pin-status,functionality,registra\
    tion-status,current-cellid,enb-id,sector-id,phy-cellid,access-technology,primary-band,ca-band,rssi\r\
    \n:local watchItems current-cellid,enb-id,primary-band,ca-band\r\
    \n:local watchFreq 3s\r\
    \n:local lteInfo\r\
    \n:local prevLteInfo ({})\r\
    \n:while (true) do={\r\
    \n\t:do {:set lteInfo [/interface lte monitor lte1 once as-value]} on-error={}\r\
    \n\t:foreach m in=\$watchItems do={\r\
    \n\t\t:if ((\$lteInfo->\$m)!=(\$prevLteInfo->\$m)) do={\r\
    \n\t\t\t:put (\$m.\": \".(\$prevLteInfo->\$m).\" -> \".(\$lteInfo->\$m))\r\
    \n\t\t\t:log warning (\$m.\": \".(\$prevLteInfo->\$m).\" -> \".(\$lteInfo->\$m))\r\
    \n\t\t\tlocal mpprev (\$prevLteInfo->\$m);\r\
    \n\t\t\tlocal mpnext (\$lteInfo->\$m);\r\
    \n\t\t\t:set (\$prevLteInfo->\$m) (\$lteInfo->\$m)\r\
    \n\t\t\t}\r\
    \n\t\t}\r\
    \n\t:delay \$watchFreq\r\
    \n\t}\r\
    \n\r\
    \n"
MTCNA + MTCRE + MTCINE | ~800 users at ~150 RouterBoards in EMEA
Knowledge Base about LTE by SiB | Buy me a caffe | Telegram: http://t.me/SiB_PL
 
negge
newbie
Posts: 40
Joined: Fri Jul 10, 2009 11:05 am

Re: KB: LTE by SiB

Sun Oct 24, 2021 1:34 pm

Works with 5G Quectel units, they are USB2.0 what limit us to 480Mbps.
Do you mean that _all_ mini-PCIe -> M.2 adapters on the market are limited to USB 2.0 speeds? I'm not quite sure where USB 2.0 comes into the picture since the adapter is passive? I'm concerned that if I'd get an adapter + a Quectel 5G modem I could reach up to gigabit speeds on 5G.

Who is online

Users browsing this forum: Lukasl32 and 10 guests