Community discussions

MikroTik App
 
johnlaska
just joined
Topic Author
Posts: 11
Joined: Tue Jan 15, 2008 10:29 pm

ROS 2.9.50 & 3.x clients (possibly) incompatible?

Tue Jan 15, 2008 10:46 pm

Hey everyone.

We have a few clients using rb133s with an xr9. Had good success with 2.9.50 on all clients at the same time. Naturally, we tried out a few of the 3.0 rc's when they became available but they seemed to become unstable (random disconnect/reconnect) and slowed down the 2.9.50 clients. We brushed it aside as something that might be worked out later and downgraded back to 2.9.50.

However when we tried the full 3.0 version on a few people, the same thing happened - disconnects and general slowdown of the other clients.

Is anyone aware of 2.9.50 and 3.x not "playing nicely" together? I can provide other data about the configuration if necessary, but I just thought I'd see if anyone had something like this happen to them. Worst comes to worst, we'll happily stay at 2.9.50 for a while. Thanks!

John
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Wed Jan 16, 2008 12:32 am

You need to upgrade all 900mhz radios to 3.0. They don't play nice together.
 
johnlaska
just joined
Topic Author
Posts: 11
Joined: Tue Jan 15, 2008 10:29 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Wed Jan 16, 2008 1:52 pm

Great, thanks for the help.
 
ncrossley
newbie
Posts: 39
Joined: Tue Jul 17, 2007 10:36 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 21, 2008 3:23 pm

Whats the compatibility issue?
No way to resolve other then mass upgrade?
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 21, 2008 4:03 pm

From what I am seeing and hearing the answer is no.
 
ncrossley
newbie
Posts: 39
Joined: Tue Jul 17, 2007 10:36 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 21, 2008 5:11 pm

Thats unfortunate.
 
johnlaska
just joined
Topic Author
Posts: 11
Joined: Tue Jan 15, 2008 10:29 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 21, 2008 5:16 pm

Well there you have it folks - find a version that works/you like and stick with it!
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 21, 2008 7:49 pm

My experience is 3.0 runs the SR9/XR9 system much better...
 
mrxbgd
just joined
Posts: 3
Joined: Wed Oct 31, 2007 1:22 am

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Tue Jan 22, 2008 12:09 am

We have the same problem, but on both side we have OS 3.0 with XR5 cards. We send supout to MT last nigth. Very unstable, on 2.9.50 works nice with no problem.
 
hytanium
Member Candidate
Member Candidate
Posts: 201
Joined: Thu Jan 18, 2007 9:10 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Tue Jan 22, 2008 2:37 am

SR9 AP 3.0 with 2.46 clients seems to associate and move traffic fine.
 
User avatar
mwi
newbie
Posts: 36
Joined: Sat May 27, 2006 8:03 pm
Location: Mooreland, IN

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Tue Jan 22, 2008 4:51 am

Ran into the sorta same thing,
replaced out a 532 with a daughter card with 3 cm9s, it had a problem with one card when temperature outside was below freezing it would make the 532 reboot.
Replace it with one 333 runnin 3.0 and 1 new cm9 plus the 2 known good cards.
This resulted in a bad change of signals clients see the AP fine but the AP sees the clients at a -10 loss of signal example= before the change signals were -60tx and -60rx, Now it is -70tx and -60tx. All clients see the same difference.
I dont know what to try next except change back to the 532 setup?
clients are running 29.50
Advice Welcome!
Thanks!
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Tue Jan 22, 2008 4:37 pm

Try changing from antenna a to antenna b or vice versa
 
User avatar
mwi
newbie
Posts: 36
Joined: Sat May 27, 2006 8:03 pm
Location: Mooreland, IN

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Wed Jan 23, 2008 7:20 am

Already did that before, wish it was that easy! when I get back in town from a road trip I will try bumping up the client to 3.0 and see if it yield the same results. If it fixes the issue I will upgrade the rest. if not I will go back to the 532 setup again. This has been one of those pita situations. Time will tell!
 
ncrossley
newbie
Posts: 39
Joined: Tue Jul 17, 2007 10:36 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Thu Jan 24, 2008 8:40 pm

Any improvement with 3.1?
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1501
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Sat Jan 26, 2008 4:27 am

Improvement in regards to...?
 
ncrossley
newbie
Posts: 39
Joined: Tue Jul 17, 2007 10:36 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Jan 28, 2008 3:04 pm

Improvement in regards to...?
Cross compatibility with 2.9.50
 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Thu Jan 31, 2008 6:43 pm

The 900MHz band will not work unless all devices are 3.x or 2.9.xx. You can't mix and match in this band, I believe it's because they're using a newer wireless driver in 3.xx.

2.4GHz seems to be backwards compatible, I can connect to a 3.xx AP with 2.9.xx clients, with no apparent problems.

5GHz is also backwards compatible with 2.9.xx clients.

The only band that doesn't support backwards compatibility with 2.9.x is the 900Mhz.
EDIT: The test equipment I was using had a problem with the CM9 card, replaced and all was well. I retract the previous post.

5GHz seems to have the same problems as the 900MHz band. No backwards compatibility, I haven't tested this throughly, but I upgraded my test AP to 3.1 recently and now I can't connect with 2.9.xx clients to the 5GHz or 900MHz. Upgrading the 900MHz clients to 3.xx fixed this problem. Haven't tried upgrading the 5GHz clients, but I'm confident an upgrade would allow those devices to reassociate.
William Burnett
Network Engineer
 
hytanium
Member Candidate
Member Candidate
Posts: 201
Joined: Thu Jan 18, 2007 9:10 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Fri Feb 01, 2008 12:19 am

The 900MHz band will not work unless all devices are 3.x or 2.9.xx. You can't mix and match in this band, I believe it's because they're using a newer wireless driver in 3.xx.

2.4GHz seems to be backwards compatible, I can connect to a 3.xx AP with 2.9.xx clients, with no apparent problems.

5GHz is also backwards compatible with 2.9.xx clients.

The only band that doesn't support backwards compatibility with 2.9.x is the 900Mhz.
EDIT: The test equipment I was using had a problem with the CM9 card, replaced and all was well. I retract the previous post.

5GHz seems to have the same problems as the 900MHz band. No backwards compatibility, I haven't tested this throughly, but I upgraded my test AP to 3.1 recently and now I can't connect with 2.9.xx clients to the 5GHz or 900MHz. Upgrading the 900MHz clients to 3.xx fixed this problem. Haven't tried upgrading the 5GHz clients, but I'm confident an upgrade would allow those devices to reassociate.
I disagree; I am currently running Version 3 RC13 at the AP and use 2.9.46 for many of my 900 Clients. Seems to work well.
 
LaSolitaire
newbie
Posts: 44
Joined: Sun Nov 20, 2005 11:22 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Fri Feb 01, 2008 11:17 am

I have the same problem with RB532A and RB333 both with R52 cards (5GHz).
One site was v3.1 other side was 2.9.50.

They cannot see each other. After upgrading both to v3.1 I was able to make connection.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Fri Feb 01, 2008 1:30 pm

problem with SR9 on v3 with v2.9 AP will be fixed in v3.2
 
ncrossley
newbie
Posts: 39
Joined: Tue Jul 17, 2007 10:36 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Fri Feb 01, 2008 4:55 pm

3.2 Released, lets test :D
 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Feb 04, 2008 6:51 pm

ok, 3.2 now works to an extent.

If the client is ROS 3.2 it can see AP's that are 3.xx or 2.9.xx.

If the client is 2.9.xx it can only see 2.9.xx AP's.. At least that's what I recall from my tests on Friday. I could be wrong so someone may want to confirm that, or I may test again today.

This is for 900MHz only. The 2.4/5.8 bands seem to work regardless, although I haven't tested with Turbo/5/10MHz bands. They should work, but just to be sure it might be good to try.
William Burnett
Network Engineer
 
johnlaska
just joined
Topic Author
Posts: 11
Joined: Tue Jan 15, 2008 10:29 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Feb 04, 2008 9:42 pm

wildbill - thanks for sharing your information, any other posts with other results will always be welcomed! Maybe all these new versions over the last month will help everyone in the long run.
 
hytanium
Member Candidate
Member Candidate
Posts: 201
Joined: Thu Jan 18, 2007 9:10 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Feb 04, 2008 10:51 pm

ok, 3.2 now works to an extent.

If the client is ROS 3.2 it can see AP's that are 3.xx or 2.9.xx.

If the client is 2.9.xx it can only see 2.9.xx AP's.. At least that's what I recall from my tests on Friday. I could be wrong so someone may want to confirm that, or I may test again today.

This is for 900MHz only. The 2.4/5.8 bands seem to work regardless, although I haven't tested with Turbo/5/10MHz bands. They should work, but just to be sure it might be good to try.
If client is 2.9.xx it can see 3.2... I have a sector running this way. SR9 cards.

Could be Nstrem problem, as I don't run any Nstrem on the 900Mhz band.
 
wifreak
just joined
Posts: 3
Joined: Sat Feb 16, 2008 3:21 am

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Feb 18, 2008 5:49 pm

Just upgraded my Xr9 broadcast to 3.2
all 2.9.50 clients SLOWWWWWW
Trying to remotely upgrade all to 3.2 now....not going so well
do not mix versions.
 
hytanium
Member Candidate
Member Candidate
Posts: 201
Joined: Thu Jan 18, 2007 9:10 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Feb 25, 2008 1:32 am

OMG.

I upgraded all of my SR9 client stations to 3.2 and my AP is 3.2. on a RB333. On CPE side I use 133c boards with advanced-tools,routerboard,system,ppp,security and wireless packages.

This sector has 31 clients and the pings are triple digit!!!!!!
I can't downgrade to 2.9.x because the wireless interface will disable. Any suggestions???

What I'm starting to think is that the 133c boards don't react fast enough with the AP at 3.2 and is causing my wireless clients to collide....therefore high pings.

Noise floor is good, wireless registrations vary from -58 to -77.

Hardware retries at 4
No Nstrem
AP and clients don't scan channels have them hard coded to their freqency.

Funny thing is.....on the same AP I have an SR5 sector with 23 clients and it's running just fine.

Anyone... help!???
 
User avatar
Gunzoid
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Tue Jun 12, 2007 6:21 am
Location: New Hampshire, USA
Contact:

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Mar 03, 2008 5:15 pm

I have a 900Mhz AP on 2.9.50 running an XR9.
My original clients were 133c/XR9 running on 2.9.50.
I built some new CPE using 133c's which were pre-loaded with 3.2.
I FTP'd 2.9.50 to them to avoid any compatibility issues.
After reboot, both Winbox and terminal still reported them as running 3.2, but the log showed 2.9.50 as being installed.
Now I don't know if they are actually running on 3.2 or 2.9.50, but they seem to work fine with the AP.
Is there a way to downgrade and have them report that they are actually running on 2.9.50?
Or would it be better to upgrade the AP to 3.3 and then the clients as well?
Will the AP lose it's configs after the upgrade?
 
hytanium
Member Candidate
Member Candidate
Posts: 201
Joined: Thu Jan 18, 2007 9:10 pm

Re: ROS 2.9.50 & 3.x clients (possibly) incompatible?

Mon Mar 03, 2008 5:23 pm

Once you FTP the packages, you must run a /sys package downgrade and it will ask you to reboot, or from winbox go to packages choose routerboard and click downgrade.... then you will actually downgrade.... BUT BE WARNED, going from 3.x to 2.9.X will disable your wireless interface.

Who is online

Users browsing this forum: No registered users and 40 guests