Page 1 of 1

Wireless problem (disconnected, received disassoc: class 3)

Posted: Tue Jul 08, 2008 3:21 pm
by natanielklug
Hello all,

I am having a serius problem. I have a Mikrotik RouterOS box that runs v3.10. It has 4 wireless interfaces running on 2.4 Ghz, 802.11b, to serve my clients with broadband. This wireless nics are connected into 12 dBi, 90 degres, sector panel antennas one to each side of my tower.

They are set with this channel:

ant. 01 ---> ch 1
ant. 02 ---> ch 4
ant. 03 ---> ch 8
ant. 04 ---> ch 11

Ant. 01 and ant. 02 are back to back.

The problem is that my clients, from a week till now, are trying to connect into ant. 02 and receive this message:
Jul  8 08:31:59 ap.mk.elj.cnett.com.br wireless,info 00:0E:2E:76:23:03@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:00 ap.mk.elj.cnett.com.br wireless,info 00:0E:2E:CC:XX:A5@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:00 ap.mk.elj.cnett.com.br wireless,info 00:4F:62:09:XX:CF@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:00 ap.mk.elj.cnett.com.br wireless,info 00:0E:2E:76:XX:03@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:00 ap.mk.elj.cnett.com.br wireless,info 00:4F:62:0F:XX:27@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:01 ap.mk.elj.cnett.com.br wireless,info 00:0E:2E:CC:XX:A5@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:32:01 ap.mk.elj.cnett.com.br wireless,info 00:0E:2E:76:XX:03@elj02: disconnected, received disassoc: class 3 frame received (7)
They can't stay connected. To make things worse it have only into ant. 02 but, now, I starts to happen into ant. 4.

I already tryed to change wireless cards (using atheros 5212 and 5006X) but no solution.

In this network I have installed a Proxim AP2000 with Orinoco PCMCIA Card and the problem did not happend on this access point.

I am not using mac controls. A full log about this is:
Jul  8 08:45:10 ap.mk.elj.cnett.com.br system,info device changed by admin
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug Interface change
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     id=10
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     index=8
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     caps=3e6f
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     status=<LINK,UP,0xa040>
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     mtu=1500
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     lname=ath1
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event,debug     uname=elj02
Jul  8 08:45:12 ap.mk.elj.cnett.com.br system,info device changed by admin
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event Up
Jul  8 08:45:12 ap.mk.elj.cnett.com.br route,event     Interface=elj02
Jul  8 08:45:28 ap.mk.elj.cnett.com.br wireless,debug elj02: 00:4F:62:XX:XX:E9 attempts to associate
Jul  8 08:45:28 ap.mk.elj.cnett.com.br wireless,debug elj02: 00:4F:62:XX:XX:E9 not in local ACL, by default accept
Jul  8 08:45:28 ap.mk.elj.cnett.com.br wireless,info 00:4F:62:08:CF:E9@elj02: connected
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug Interface change
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     id=10
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     index=8
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     caps=3e6f
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     status=<LINK,LINKOK,UP,0xa040>
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     mtu=1500
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     lname=ath1
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event,debug     uname=elj02
Jul  8 08:45:29 ap.mk.elj.cnett.com.br wireless,info 00:4F:62:08:CF:E9@elj02: disconnected, received disassoc: class 3 frame received (7)
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event Link up
Jul  8 08:45:29 ap.mk.elj.cnett.com.br route,event     Interface=elj02
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug Interface change
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     id=10
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     index=8
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     caps=3e6f
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     status=<LINK,UP,0xa040>
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     mtu=1500
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     lname=ath1
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event,debug     uname=elj02
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event Link down
Jul  8 08:45:32 ap.mk.elj.cnett.com.br route,event     Interface=elj02
Jul  8 08:45:33 ap.mk.elj.cnett.com.br wireless,info elj02: data from unknown device 00:4F:62:08:CF:E9, sent deauth
Jul  8 08:45:38 ap.mk.elj.cnett.com.br wireless,info elj02: data from unknown device 00:4F:62:08:CF:E9, sent deauth
Jul  8 08:45:43 ap.mk.elj.cnett.com.br wireless,info elj02: data from unknown device 00:4F:62:08:CF:E9, sent deauth
Jul  8 08:45:48 ap.mk.elj.cnett.com.br system,info device changed by admin
Jul  8 08:45:48 ap.mk.elj.cnett.com.br route,event,debug Remove interface elj02
Jul  8 08:45:48 ap.mk.elj.cnett.com.br route,event,debug     id=10
Jul  8 08:45:48 ap.mk.elj.cnett.com.br route,event Down
See? The first client to get into the network already get the problem. The problem continues till I put the interface down.

If I change the channel of this wireless interface (like from channel 4 to channel 3) it starts to work for about 20~30 minutes and the problem came again.

Hope that someone can help me.


Att,

Nataniel Klug
gerente@cnett.com.br
Brazil