Community discussions

MUM Europe 2020
 
dconnrt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Mon Jul 28, 2008 10:53 pm

Force association by MAC address

Sat Nov 29, 2008 5:49 pm

Hi,

We have multiple APs with the same SSID.

How can I make a routerboard associate to a single AP by MAC address rather than allow it choose which AP it wants to associate with ? (routeros seems to pick a weak AP rather than a closer one).

I've tried adding the APs MAC as an Access List entry and then unticking "Default Authenticate" in the Wireless tab but then I don't seem to associate at all.

thanks for any information

Derek
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: Force association by MAC address

Sat Nov 29, 2008 7:20 pm

You should use connect-list for that.
 
dconnrt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Mon Jul 28, 2008 10:53 pm

Re: Force association by MAC address

Wed Dec 03, 2008 11:22 am

Hi mplsguy,

I still haven't worked it out.

I did add the remote AP MAC into the connect list but it'll still associating to the wrong AP.

Is there an option in router os somewhere along the lines of "Only connect to the APs specified in the connect list" ?

I tried switching on the "Default Authenticate" option on the Wireless tab but it just meant that it wouldn't associate to any AP (whether, or not, it was in the connect list)

thanks for the help

Derek
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: Force association by MAC address

Thu Dec 04, 2008 10:26 am

You should:

/interface wireless set wlan1 mode=station default-authentication=no disabled=no
/interface wireless connect-list add interface=wlan1 connect=yes mac-address=<mac_of_AP>

If this does not work, enable wireless,debug logs (both on AP and client) and see what is the reason of not connecting.

Who is online

Users browsing this forum: No registered users and 12 guests