Community discussions

 
rodolfo
Long time Member
Long time Member
Topic Author
Posts: 543
Joined: Sat Jul 05, 2008 11:50 am

high ping time

Mon Feb 09, 2009 12:50 pm

Hi all.
I have some problems of high ping from a cpe to a base station (all mikrotik+atheros+3.18):
the signal is good, the ccq is very good (95%) but the ping is 25ms.
Summing other latency, the telephone (and the fax) have a lot of problems.
Could some parameters be modified to try to speed up the ping ?
Which could I try ?

Thanks

This is the configurazion of my CPE wlan:

/interface wireless
set 0 ack-timeout=dynamic adaptive-noise-immunity=client-mode \
allow-sharedkey=no antenna-gain=17 antenna-mode=ant-a area="" arp=enabled \
band=5ghz basic-rates-a/g=6Mbps basic-rates-b=1Mbps burst-time=disabled \
comment=RadioSlave compression=no country=italy default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=\
yes dfs-mode=none disable-running-check=no disabled=no \
disconnect-timeout=3s frame-lifetime=0 frequency=5600 frequency-mode=\
regulatory-domain hide-ssid=yes hw-retries=4 mac-address=\
00:0C:4F:1F:FF:F2 max-station-count=2007 mode=station mtu=1500 name=wlan1 \
noise-floor-threshold=default on-fail-retry-time=100ms \
periodic-calibration=enabled periodic-calibration-interval=60 \
preamble-mode=short proprietary-extensions=post-2.9.25 radio-name=ran223 \
rate-set=default scan-list=\
5500,5520,5540,5560,5580,5600,5620,5640,5660,5680,5700 security-profile=\
WPA-PSK-MILLIWAY ssid=MILLIWAYhl_17 station-bridge-clone-mac=\
00:00:00:00:00:00 supported-rates-a/g=\
6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
1Mbps,2Mbps,5.5Mbps,11Mbps tx-power-mode=default update-stats-interval=\
disabled wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=\
100 wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled

/interface wireless manual-tx-power-table
set wlan1 comment=RadioSlave manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11\
Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:1\
7,54Mbps:17,HT20-1:0,HT20-2:0,HT20-3:0,HT20-4:0,HT20-5:0,HT20-6:0,HT20-7:0\
,HT20-8:0,HT40-1:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,HT40-7:0,H\
T40-8:0"

/interface wireless nstreme
set wlan1 comment=RadioSlave disable-csma=no enable-nstreme=yes \
enable-polling=yes framer-limit=3600 framer-policy=exact-size

/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
frames-per-second=25 receive-all=no ssid-all=no

/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
multiple-channels=no only-headers=no receive-errors=no streaming-enabled=\
no streaming-max-rate=0 streaming-server=0.0.0.0

/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
rodolfo
IZ0UQV
 
galaxynet
Long time Member
Long time Member
Posts: 648
Joined: Fri Dec 17, 2004 2:52 pm
Contact:

Re: high ping time

Mon Feb 09, 2009 3:52 pm

rodolfo -
/interface wireless nstreme
set wlan1 comment=RadioSlave disable-csma=no enable-nstreme=yes \
enable-polling=yes framer-limit=3600 framer-policy=exact-size
There are a couple of things - in the above config you can check mark disable-csma so it equals 'yes'. ( disable-csma=yes ). You can also change the framer-policy to 'none'. ( framer-policy=none ). You'll need to do this on both the AP and CPE where appropriate.

You see Nstreme waits until the 'frame' is full before transmitting it. It also follows your 'rule' of exact fit, so it won't transmit until it can fill the frame exactly......

The disable csma - csma is the 'standard' polling protocol for 802.11, so by disabling that and having the Nstreme polling enabled - you have only one polling 'protocol' to deal with, saves time and also does not 'care' about csma devices.

The other thing you can do is setup a few queues, and set the priority for ICMP protocol (ping) to a higher priority than other protocols.

R/
Thom Lawless
General Manager
RapidWiFi, LLC
thom.lawless [at] rapidwifi.com
 
dipson
newbie
Posts: 41
Joined: Fri Nov 07, 2008 7:05 pm

Re: high ping time

Fri Feb 13, 2009 9:18 pm

It is not advisable to use Nstreme when you enable CSMA. Follow the instructions by Thom.
Best Regards,
Oladipupo Salako
Double D Communications Engineering Services,
Lagos, Nigeria.
 
wireless12
Member Candidate
Member Candidate
Posts: 295
Joined: Fri Aug 31, 2007 10:49 am

Re: high ping time

Sat Feb 14, 2009 8:30 am

hmm.
right words

Who is online

Users browsing this forum: No registered users and 18 guests