Community discussions

MikroTik App
 
User avatar
GLR
just joined
Topic Author
Posts: 7
Joined: Fri Oct 23, 2009 1:27 pm
Location: Paris suburbs, France

Poor performance with a RB411A + R2N in N ap-bridge mode

Fri Oct 23, 2009 2:09 pm

Hello,

We are trying to set up simple indoor APs based on RB411A and R2N cards on the 2,4 Ghz frequency.

Currently the practical result is quite poor : in the best case, about 26 Mbps (ftp transfer to an ethernet connected PC) - like a quite good 802.11g connection :

Image

The CPU isn't overloaded :

Image

And sometimes we get even less, here 18,5 Mbps :

Image

Image Image

Also the bandwidth tester provides quite strange results : about 500 Mbps (!) :

Image

Although we don't see any traffic through the interfaces (Winbox, SNMP, Windows task manager) :

Image

How is it possible ?

The client PC has an Intel WiFi Link 5100AGN card and we also tested another laptop that uses an Intel WiFi Link 4965AGN card.
We also tested mounting a TP-Link TL-WN861N card in the RB411A, same result.

Here are our current wireless settings (quite the same as what is advised on the wiki) :
[admin@AP] > interface wireless export
# oct/23/2009 12:52:43 by RouterOS 4.1
# software id = XXXX-XXXX
#
/interface wireless security-profiles
set default authentication-types=wpa2-psk group-ciphers=aes-ccm group-key-update=2m interim-update=\
    0s management-protection=disabled management-protection-key="" mode=dynamic-keys name=default \
    radius-eap-accounting=no radius-mac-accounting=no radius-mac-authentication=no \
    radius-mac-caching=disabled radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=none static-key-0="" \
    static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
    static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=AP-SSID \
    tls-certificate=none tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" \
    wpa2-pre-shared-key=wpa2key
/interface wireless
set 0 ack-timeout=dynamic adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=5 \
    antenna-mode=ant-a area="" arp=enabled band=2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=\
    1Mbps comment="" compression=no country=no_country_set default-ap-tx-limit=0 \
    default-authentication=yes default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
    disable-running-check=no disabled=no disconnect-timeout=3s frame-lifetime=0 frequency=2452 \
    frequency-mode=manual-txpower hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 \
    ht-amsdu-threshold=8192 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 \
    ht-extension-channel=disabled ht-guard-interval=any ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-\
    1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15" \
    ht-txchains=0,1 hw-fragmentation-threshold=disabled hw-protection-mode=none \
    hw-protection-threshold=0 hw-retries=4 l2mtu=2290 mac-address=00:0C:42:51:B1:ED \
    max-station-count=10 mode=ap-bridge mtu=1500 name=wlan1 on-fail-retry-time=100ms \
    periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both \
    proprietary-extensions=post-2.9.25 radio-name=000C4251B1ED rate-set=default scan-list=default \
    security-profile=default ssid=AP-GLR-300 station-bridge-clone-mac=00:00:00:00:00:00 \
    supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
    1Mbps,2Mbps,5.5Mbps,11Mbps tx-power-mode=default update-stats-interval=30s wds-cost-range=\
    50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled \
    wmm-support=enabled
/interface wireless manual-tx-power-table
set wlan1 comment="" manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mb\
    ps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:0,HT20-1:0,HT20-2:0,HT20-3:0,HT20\
    -4:0,HT20-5:0,HT20-6:0,HT20-7:0,HT40-0:0,HT40-1:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,H\
    T40-7:0"
/interface wireless nstreme
set wlan1 comment="" disable-csma=no enable-nstreme=no enable-polling=no framer-limit=3200 \
    framer-policy=none
/interface wireless access-list
add ap-tx-limit=0 authentication=yes client-tx-limit=0 comment="" disabled=no forwarding=yes \
    interface=all mac-address=01:23:45:67:89:10 management-protection-key="" private-algo=none \
    private-key="" private-pre-shared-key="" signal-range=-120.120
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=\
    00:00:00:00:00:00 frame-size=300 frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no \
    only-headers=no receive-errors=no streaming-enabled=no streaming-max-rate=0 streaming-server=\
    0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
[admin@AP] > 
[admin@AP] > interface wireless info print
 0 interface-type=Atheros AR5416 chip-info="mac:0x80/0x2, phy:0xd0, a5:0xc0, a2:0x0, eeprom:0x0"
   pci-info="00:12.0" capabilities=tx-power-control,ack-timeout-control,virtual-ap,alignment-mode,
                                   scanning,nstreme,sniffing,power-channel,ht40-g,wmm
   default-periodic-calibration=enabled supported-bands=2ghz-b,2ghz-g,2ghz-10mhz,2ghz-5mhz,2ghz-11n
   2ghz-b-channels=2412:0,2417:0,2422:0,2427:0,2432:0,2437:0,2442:0,2447:0,2452:0,2457:0,2462:0
   2ghz-g-channels=2412:0,2417:0,2422:0,2427:0,2432:0,2437:0,2442:0,2447:0,2452:0,2457:0,2462:0
   2ghz-10mhz-power-channels=2412:0,2417:0,2422:0,2427:0,2432:0,2437:0,2442:0,2447:0,2452:0,2457:0,
                             2462:0
   2ghz-5mhz-power-channels=2412:0,2417:0,2422:0,2427:0,2432:0,2437:0,2442:0,2447:0,2452:0,2457:0,
                            2462:0
   2ghz-11n-channels=2412:0,2417:0,2422:0,2427:0,2432:0,2437:0,2442:0,2447:0,2452:0,2457:0,2462:0
   ht-chains=0:chain0,1:chain1
[admin@AP] > 
[admin@AP] > interface wireless monitor wlan1
                 status: running-ap
                   band: 2ghz-11n
              frequency: 2452MHz
            noise-floor: -115dBm
         overall-tx-ccq: 23%
     registered-clients: 0
  authenticated-clients: 0
    current-ack-timeout: 53
                nstreme: no
            wmm-enabled: yes
      current-tx-powers: 1Mbps:17(17/20),2Mbps:18(18/21),5.5Mbps:18(18/21),11Mbps:18(18/21),
                         6Mbps:20(20/23),9Mbps:20(20/23),12Mbps:20(20/23),18Mbps:20(20/23),
                         24Mbps:20(20/23),36Mbps:20(20/23),48Mbps:16(16/19),54Mbps:15(15/18),
                         HT20-0:17(17/20),HT20-1:17(17/20),HT20-2:17(17/20),HT20-3:17(17/20),
                         HT20-4:17(17/20),HT20-5:16(16/19),HT20-6:15(15/18),HT20-7:14(14/17)
    notify-external-fdb: no
[admin@AP] > 
[admin@AP] > interface print
Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                                                              TYPE             MTU   L2MTU
 0  R  ether1                                                            ether            1500  1526
 1     wlan1                                                             wlan             1500  2290
 2  R  bridge1                                                           bridge           1500  1526
[admin@AP] > 
[admin@AP] > interface ethernet export
# oct/23/2009 13:18:06 by RouterOS 4.1
# software id = XXXX-XXXX
#
/interface ethernet
set 0 arp=enabled auto-negotiation=yes comment="" disabled=no full-duplex=yes l2mtu=1526 \
    mac-address=00:0C:42:30:00:6E mtu=1500 name=ether1 speed=100Mbps
[admin@AP] > 
[admin@AP] > system routerboard print
       routerboard: yes
             model: "411A"
     serial-number: "1234567890"
  current-firmware: "2.23"
  upgrade-firmware: "2.23"
[admin@AP] > 
[admin@AP] > system package print
Flags: X - disabled
 #   NAME                               VERSION                               SCHEDULED
 0   system                             4.1
 1   dhcp                               4.1
 2   security                           4.1
 3   wireless                           4.1
 4   ntp                                4.1
 5   advanced-tools                     4.1
 6   routerboard                        4.1
Image

Image

Image

Image

Also is it normal that we don't see any N data rate in the winbox ?

Image

Can someone could help us to solve this performance problem ?
Finally is the 802.11n ap-bridge mode really supported in RouterOS 4.1 ?
Does anyone know a fine working 802.11n AP infrastructure ?

Thanks !
RB411A + MikroTik R2N 802.11b+g+n AR9223
RB192 + Compex WLM54AG-20 802.11a+b+g AR5414
 
cmarsot
just joined
Posts: 9
Joined: Wed Oct 28, 2009 5:43 pm

Re: Poor performance with a RB411A + R2N in N ap-bridge mode

Wed Oct 28, 2009 5:45 pm

Hello,

Nobody has idea ? I have same issue, with 4.2.

Who is online

Users browsing this forum: No registered users and 12 guests