Community discussions

MikroTik App
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

low performance mikrotik legacy 802.11N products

Thu Sep 02, 2010 10:55 am

problems with 802.11n legacy equipment
For a project of netbooks coverage on schools (formerly I have been using Mikrotik on 802.11g with good results) Our intention is use N . I tried difrentes Mikrotik equipment and is well below other Products.
My question is about 802.11N legacy clients ! Not Nstreme with other mikrotiks!
examples


-tp-link WRL-TP-1043ND(dd-wrt) wpa2 aes eap peap 20mhz
56mb real throughput
mikrotik rb411h radio r52n wpa2 aes eap peap 20mhz
30 mb throughput
LocoM2 Ap wpa2 aes eap peap 20mhz
42 mb throughput
no appreciable changes with no encription
the lan wireless card is usualy atheros N cards
only 1 chain
20mhz (we need cover over 300 users)

mikrotik config
name="wlan2" mtu=1500 mac-address=00:0C:42:61:9E:8E arp=enabled
interface-type=Atheros 11N mode=ap-bridge ssid="prov" frequency=2437
band=2ghz-onlyn channel-width=20mhz scan-list=default
wireless-protocol=802.11 wds-mode=disabled wds-default-bridge=none
wds-ignore-ssid=no default-authentication=yes default-forwarding=no
default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no
security-profile=profile3 compression=no
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: low performance mikrotik legacy 802.11N products

Thu Sep 02, 2010 12:06 pm

post the full config of the wireless card.
Try to use extension channel for the N card.
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

Re: low performance mikrotik legacy 802.11N products

Thu Sep 02, 2010 2:36 pm

Extension chanel is 40mhz? i need 20mhz, there is ap
per clasroom


set 1 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" \
arp=enabled band=2ghz-onlyn basic-rates-a/g=6Mbps basic-rates-b=1Mbps \
channel-width=20mhz compression=no country=no_country_set \
default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 \
default-forwarding=no dfs-mode=none disable-running-check=no disabled=no \
disconnect-timeout=3s distance=indoors frame-lifetime=0 frequency=2437 \
frequency-mode=manual-txpower frequency-offset=0 hide-ssid=no \
ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 \
ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 \
ht-extension-channel=disabled ht-guard-interval=any ht-rxchains=0 \
ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-\
9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15" ht-txchains=0 \
hw-fragmentation-threshold=disabled hw-protection-mode=none \
hw-protection-threshold=0 hw-retries=10 l2mtu=2290 mac-address=\
00:0C:42:61:9E:8E max-station-count=2007 mode=ap-bridge mtu=1500 name=wlan2 \
noise-floor-offset=default noise-floor-threshold=default nv2-qos=default \
nv2-queue-count=2 on-fail-retry-time=100ms periodic-calibration=default \
periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=\
post-2.9.25 radio-name=000C42619E8E rate-set=default scan-list=default \
security-profile=profile3 ssid=prov station-bridge-clone-mac=\
00:00:00:00:00:00 supported-rates-a/g=\
6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
1Mbps,2Mbps,5.5Mbps,11Mbps tdma-additional-txrxguard=0 tdma-debug=0 \
tdma-override-rate=disabled tdma-override-size=0 tdma-period-size=2 \
tx-power-mode=default update-stats-interval=disabled wds-cost-range=50-150 \
wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=\
/interface wireless manual-tx-power-table
set wlan2 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbp\
s:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:0,HT\
20-1:0,HT20-2:0,HT20-3:0,HT20-4:0,HT20-5:0,HT20-6:0,HT20-7:0,HT40-0:0,HT40-1\
:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,HT40-7:0"
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

Re: low performance mikrotik legacy 802.11N products

Fri Sep 03, 2010 6:21 pm

Hi, i founded another similar post.
Trying to post again.
Does anyone use a Mikrotik as an 802.11n access point? (I'm trying)
Do you get decent performance? (I don't) Did you have problems getting there? (Yes...I am)

Would like to co-commiserate and hopefully help others in the future.

Scott

any one can post the results with mikrotik ap N on legacy products?
 
bcrawfo2
newbie
Posts: 25
Joined: Thu May 08, 2008 7:12 pm

Re: low performance mikrotik legacy 802.11N products

Tue Sep 21, 2010 4:24 pm

Hi Calman. I am Scott from the post you quoted.
I opened a support ticket and had a good dialog with Uldis on my perf issue. I was using a RB532 and we believe we were running into CPU limits.
Just last night I unpacked a new RB433AH for this purpose and will pick up my testing.
I hope I don't regret spending more $ on this problem only to find there is something fundamentally wrong.

I am really surprised that nobody (besides you and me) want to use N as an access point instead of a long range radio.
 
Trisc
Member Candidate
Member Candidate
Posts: 242
Joined: Sat May 29, 2004 11:24 pm
Location: Glos, UK

Re: low performance mikrotik legacy 802.11N products

Thu Jan 27, 2011 2:27 pm

Hi

Any update on this thread? I have also posted questions about MT implementation of 802.11n and legacy clients which will not connect at more than 54Mbps.
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

Re: low performance mikrotik legacy 802.11N products

Thu Jan 27, 2011 7:20 pm

54mb? are you using correct encryption method Wpa2 aes...
I can connect to 65mb on 20mhz channel, but with mikrotik N has very poor results over 30mb, recently i'm testing Unifi Ubnt products on a college is working better.
I think right now mikrotik is not interested in improving N legacy products
 
tonym1975
just joined
Posts: 5
Joined: Mon Feb 07, 2011 10:48 pm

Re: low performance mikrotik legacy 802.11N products

Mon Feb 07, 2011 10:58 pm

ok i got a better connection rate after i upgraded to the 5.0 OS. the issue i have is the throuput id sttill real bad. I have a D-link dap-2590 (i hate by the way) and it get better throuput. im useing the RB411AH and a SR71-12 card. i'm real disapointed in the speeds im seeing. the dlink will pass 50-60megabits useing speedtest.net and the RB411 might see 15megabits i dont know what to do and have not found an answer anyware. i have many customers that i think i could puth this product in for if i could get it to work better then a POS off the best buy shelf. any help would be great!
 
pigster
just joined
Posts: 3
Joined: Tue Mar 15, 2011 11:27 pm

Re: low performance mikrotik legacy 802.11N products

Tue Mar 15, 2011 11:50 pm

Hi All

I have exactly same problem- RB411AH + R52n-M card+RouterOS 5.0rc11

I am trying to use this configuration with single antenna as indoor AP. I see actual throughput from notebook (wireless) to wired computer somewhere about 26Mbps. Extended channel is enabled. I have also tried to connect second antenna and turn on chain1 - the speed raised to somewhere around 40Mbps. (rarely, mostly around 35Mbps)

Also attaching screen shot of registration of wireless client and system resources during traffic test. Test was done using iperf. Notebook is Dell Latitude E6400 with Intel 5300 AGN Wireless Card.

Also, tests wad done using 2.4GHz b/g/n mode, 2.4GHz n only mode and 5GHz n only mode - same results. Encryption is set to WPA2 AES PSK.

Any suggestion will help.
You do not have the required permissions to view the files attached to this post.
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

Re: low performance mikrotik legacy 802.11N products

Tue Mar 15, 2011 11:58 pm

please, export your wireless config
 
pigster
just joined
Posts: 3
Joined: Tue Mar 15, 2011 11:27 pm

Re: low performance mikrotik legacy 802.11N products

Wed Mar 16, 2011 12:20 am

here is the wireless config (complete)
# jan/02/1970 00:04:01 by RouterOS 5.0rc11
#
/interface wireless security-profiles
set default authentication-types=wpa2-psk group-ciphers=aes-ccm \
    group-key-update=5m interim-update=0s management-protection=disabled \
    management-protection-key="" mode=dynamic-keys name=default \
    radius-eap-accounting=no radius-mac-accounting=no \
    radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-key-0="" static-key-1="" static-key-2="" static-key-3="" \
    static-sta-private-algo=none static-sta-private-key="" \
    static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=\
    none tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key=\
    "" wpa2-pre-shared-key=testtest
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" \
    arp=enabled band=2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=1Mbps \
    bridge-mode=enabled channel-width=20mhz compression=no country=\
    no_country_set default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
    disable-running-check=no disabled=no disconnect-timeout=3s distance=\
    dynamic frame-lifetime=0 frequency=2447 frequency-mode=manual-txpower \
    frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 \
    ht-amsdu-threshold=8192 ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-extension-channel=\
    above-control ht-guard-interval=any ht-rxchains=0 ht-supported-mcs="mcs-0,\
    mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12\
    ,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs\
    -23" ht-txchains=0 hw-fragmentation-threshold=disabled \
    hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 \
    mac-address=00:0C:42:67:8D:44 max-station-count=2007 mode=ap-bridge mtu=\
    1500 name=LAN noise-floor-threshold=default nv2-cell-radius=30 \
    nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default \
    nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms \
    periodic-calibration=default periodic-calibration-interval=60 \
    preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=\
    000C42678D44 rate-set=default scan-list=default security-profile=default \
    ssid=MikroTik station-bridge-clone-mac=00:00:00:00:00:00 \
    supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
    supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tdma-override-rate=disabled \
    tdma-override-size=0 tdma-period-size=2 tx-power-mode=default \
    update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=\
    none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled \
    wireless-protocol=unspecified wmm-support=disabled
/interface wireless manual-tx-power-table
set LAN manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbp\
    s:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17\
    ,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT4\
    0-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:\
    17"
/interface wireless nstreme
set LAN disable-csma=no enable-nstreme=no enable-polling=yes framer-limit=\
    3200 framer-policy=none
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
    00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
    frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
    multiple-channels=no only-headers=no receive-errors=no streaming-enabled=\
    no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
 
User avatar
calman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 61
Joined: Fri Feb 06, 2009 12:16 pm

Re: low performance mikrotik legacy 802.11N products

Wed Mar 16, 2011 12:31 am

try with hw-retries=4 and distance indoors
 
pigster
just joined
Posts: 3
Joined: Tue Mar 15, 2011 11:27 pm

Re: low performance mikrotik legacy 802.11N products

Wed Mar 16, 2011 12:37 am

no change at all

26Mbps average. I have returned to hw-retries 7 and distance dynamic to reconfirm and yes, no difference at all
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: low performance mikrotik legacy 802.11N products

Wed Mar 16, 2011 6:08 pm

Try to push UDP tests (download some torrents) or try to use FTP transfers.
Also contact support@mikrotik.com for a newer RouterOS test release.

Who is online

Users browsing this forum: No registered users and 27 guests