Page 1 of 1

Coffee shop wireless

Posted: Thu Oct 14, 2010 6:17 am
by Vaelen
Alright so I've searched around the forums and the wiki and I can't find what I'm looking for, so I apologize if this has been discussed before.

I administer the network of two coffee shops, one just hasn't been finished yet.
We recently put in a rb433AH at the first with an r2n as the AP card and i'm seeing a lot of lag and dropped clients, while not using anywhere near the available bandwidth. now I'm sure this has to do with the number of clients, since when there's just a few, ccq goes up to >90. When we're busy there can be ~35 clients. I've been playing with settings trying to get it higher to no avail, any advice would be helpful. Is there perhaps a way i could use another card simultaneously? or anything else.

thanks, wireless configs/status follow
/interface wireless> monitor wlan1 
                 status: running-ap
                   band: 2ghz-g
              frequency: 2422MHz
      wireless-protocol: 802.11
            noise-floor: -98dBm
         overall-tx-ccq: 49%
     registered-clients: 15
  authenticated-clients: 15
       current-distance: 17
      current-tx-powers: 1Mbps:19(19/19),2Mbps:19(19/19),5.5Mbps:19(19/19),11Mbps:19(19/19),
    current-ofdm-errors: 2273
     current-cck-errors: 29
    notify-external-fdb: yes

/interface wireless> pr
Flags: X - disabled, R - running 
 0  R ;;; Lestat's has better coffee.
      name="wlan1" mtu=1500 mac-address=00:0C:42:3A:B6:FD arp=enabled 
      interface-type=Atheros 11N mode=ap-bridge ssid="" 
      frequency=2422 band=2ghz-b/g channel-width=20mhz scan-list=default 
      wireless-protocol=802.11 wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no 
      default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 
      default-client-tx-limit=0 hide-ssid=no security-profile=default compression=no 
Sorry here's the full config
set 0 adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no antenna-gain=2 area="" \
    arp=enabled band=2ghz-b/g basic-rates-a/g=6Mbps basic-rates-b=1Mbps channel-width=20mhz \
    comment="" compression=no country="united states" \
    default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 \
    default-forwarding=yes dfs-mode=no-radar-detect disable-running-check=no disabled
    disconnect-timeout=6s distance=dynamic frame-lifetime=0 frequency=2422 frequency-
    regulatory-domain frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-
    8192 ht-amsdu-threshold=8192 ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-extension-channel=disabled \
    ht-guard-interval=any ht-rxchains=0 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs
    ,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15" ht-txchains=0
    hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-thresho
    hw-retries=6 l2mtu=2290 mac-address=00:0C:42:3A:B6:FD max-station-count=50 mode=\
    ap-bridge mtu=1500 name=wlan1 noise-floor-offset=default noise-floor-threshold=de
    nv2-cell-radius=30 nv2-qos=default nv2-queue-count=2 on-fail-retry-time=100ms \
    periodic-calibration=default periodic-calibration-interval=60 preamble-mode=short
    proprietary-extensions=post-2.9.25 radio-name=000C423AB6FD rate-set=default scan-
    default security-profile=default ssid="Lestat's has better coffee." \
    station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
    1Mbps,2Mbps,5.5Mbps,11Mbps tdma-debug=0 tdma-override-rate=disabled tdma-override
    tdma-period-size=2 tx-power-mode=default update-stats-interval=disabled wds-cost-
    50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=d
    wireless-protocol=802.11 wmm-support=disabled

Re: Coffee shop wireless

Posted: Thu Oct 14, 2010 11:08 pm
by Ibersystems
Irecomend you to fit in another minipci card, then the costumers will work "50%-50%" more or less. But the other problem is that you need to use different channels. If you use 2.4, use channel 1 and 9, for example. If possible, work with 5ghz!

Re: Coffee shop wireless

Posted: Fri Oct 15, 2010 4:45 am
by Vaelen
Is that to say i can just replicate the settings on the other card just on a different channel and clients will "balance" across them automatically?

Re: Coffee shop wireless

Posted: Fri Oct 15, 2010 8:31 am
by Ibersystems
Yes, more or less.. Use same card and same antena

Re: Coffee shop wireless

Posted: Fri Oct 15, 2010 9:12 pm
by Vaelen
Thanks a lot!