Community discussions

MUM Europe 2020
 
surfnetc
just joined
Topic Author
Posts: 3
Joined: Thu Sep 13, 2007 3:31 am

RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs tcp

Thu Jan 27, 2011 12:52 am

I just got the new RouterBOARD SXT 5HnD in hand. I have 2 setup on the bench and connected via bridge mode.

I can seem to get more than 40megs of tcp traffic
I get about 100megs of UPD traffic,

Is there something I need to set to get 200megs of real throughput?

Flags: X - disabled, R - running
0 R name="wlan1" mtu=1500 mac-address=00:0C:42:84:62:7F arp=enabled
interface-type=Atheros 11N mode=station ssid="MikroTik" frequency=5765
band=5ghz-onlyn channel-width=20mhz scan-list=default
wireless-protocol=nv2 wds-mode=disabled wds-default-bridge=none
wds-ignore-ssid=no default-authentication=yes default-forwarding=yes
default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no
security-profile=default compression=no
[admin@MikroTik] /interface wireless nstreme> print
0 name="wlan1" enable-nstreme=yes enable-polling=yes disable-csma=yes framer-policy=dynamic-size framer-limit=3200
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Thu Jan 27, 2011 9:24 am

you didn't explain how you made those tests - from where to where you were sending traffic, what bandwidth generator you used? Please post wireless registration details.
 
surfnetc
just joined
Topic Author
Posts: 3
Joined: Thu Sep 13, 2007 3:31 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Thu Jan 27, 2011 5:42 pm

Sorry, I was doing a test between 2 SXT5HnD board in bridge mode. I had them separated enough to have good signal but not too much. The test was using the b/w test in the MK.

here is the wireless reg stats
0 interface=wlan1 radio-name="000C4284627F" mac-address=00:0C:42:84:62:7F ap=no wds=no rx-rate="117.0Mbps" tx-rate="117.0Mbps"
packets=82856428,449977 bytes=611389557,501790444 frames=41605395,283510 frame-bytes=1350567321,504004870 hw-frames=42094631,303096
hw-frame-bytes=3783053740,514951609 tx-frames-timed-out=0 uptime=13h25m1s last-activity=150ms signal-strength=-64dBm@HT20-6
signal-to-noise=50dB signal-strength-ch0=-68dBm signal-strength-ch1=-66dBm
strength-at-rates=-58dBm@6Mbps 4s910ms,-58dBm@9Mbps 13h25m,-58dBm@12Mbps 13h24m56s,-59dBm@18Mbps 13h24m52s,-58dBm@24Mbps 13h24m48s,-
60dBm@36Mbps 13h24m47s530ms,-61dBm@48Mbps 13h24m45s990ms,-62dBm@54Mbps 13h24m40s650ms,-59dBm@HT20-4 13h24m34s,-61dBm@HT20-5
10h11m33s850ms,-64dBm@HT20-6 150ms,-66dBm@HT20-7 3s140ms
tx-signal-strength=-62dBm tx-ccq=92% rx-ccq=84% p-throughput=90584 distance=1 nstreme=no framing-mode=none routeros-version="4.14"
last-ip=192.168.251.2 802.1x-port-enabled=yes compression=no wmm-enabled=yes
 
InoX
Forum Guru
Forum Guru
Posts: 1964
Joined: Tue Jan 09, 2007 6:44 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Thu Jan 27, 2011 9:57 pm

with internal btest is normal 40mbp; you need to have two x86 computers connected to each end.
 
chemcat9
just joined
Posts: 7
Joined: Sat Mar 19, 2011 8:45 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Mon Mar 21, 2011 7:40 pm

Can you give the settings you used to put the two SXTs in bridge with each other? Thanks!
 
meno
Member Candidate
Member Candidate
Posts: 233
Joined: Sat Jul 19, 2008 4:45 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Sat Mar 26, 2011 7:40 pm

another thing update your NIC driver to the lastest try to not use the windows buildin driver (if you use windows) I guess for the btest.exe
 
User avatar
t3rm
Member Candidate
Member Candidate
Posts: 143
Joined: Sat Aug 04, 2007 1:57 pm
Location: Bandung - WJ - Indonesia

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed Mar 30, 2011 12:53 am

i need to know what is the maximum transfer of tcp data between 2 end-nodes such these topology:


PC ------------Wireless-SXT-Client --------------------WirelessAP--SXT------------PC

From PC to PC,
do SXT able to transfer max 100Mbps real throughput ?
 
hackac
just joined
Posts: 6
Joined: Tue Apr 19, 2011 11:17 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed Apr 20, 2011 11:52 am

Same as my measures. I set up a bridge by this howto: http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS
After that switch on the second chain and chose nv2 wireless protocol, 5ghz-a/n.

The devices distance about 100m. With the built in bandwith test tool 100 mbit/sec one direction UDP, 54 mbit/sec both direction UDP. 54 mbit/sec one direction TCP, 25-30 mbit/sec both direction TCP. Tx/Rx CCQ is about 98-100% so the link quality is ok.
The real full duplex UDP is a dream I think. On TCP test the processor usage was 100%.

Advices:
- try different spektrum, in my situation the default spectrum was so dirty
- nv2 protocol can give you some gain
- try nv2 TDMA change to xxx (I use 5 - better throughput and minimal increased latency)
- use short preamble
 
User avatar
roc-noc.com
Forum Veteran
Forum Veteran
Posts: 869
Joined: Sun Dec 02, 2007 3:27 am
Location: Rockford, IL USA
Contact:

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed Apr 20, 2011 12:16 pm

Same as my measures. I set up a bridge by this howto: http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS
After that switch on the second chain and chose nv2 wireless protocol, 5ghz-a/n.

The devices distance about 100m. With the built in bandwith test tool 100 mbit/sec one direction UDP, 54 mbit/sec both direction UDP. 54 mbit/sec one direction TCP, 25-30 mbit/sec both direction TCP. Tx/Rx CCQ is about 98-100% so the link quality is ok.
The real full duplex UDP is a dream I think. On TCP test the processor usage was 100%.

Advices:
- try different spektrum, in my situation the default spectrum was so dirty
- nv2 protocol can give you some gain
- try nv2 TDMA change to xxx (I use 5 - better throughput and minimal increased latency)
- use short preamble
Don't run the bandwidth test on the SXT or you will not see the maximum throughput that it is capable of. If the CPU on the SXT is busy than you cannot expect it to have enough time for 802.11n protocol.

For a more accurate bandwidth test, you must plug another device into the SXT on each end and run the bandwidth test on those.

Also, why not set the radio mode to 5GHz-only-N? For maximum speed, you don't use 802.11a.

Tom
-----------------------------------------------
http://www.roc-noc.com
Tom, CCNA, ISP, USA Mikrotik Distributor
888-762-5662
-----------------------------------------------
 
hackac
just joined
Posts: 6
Joined: Tue Apr 19, 2011 11:17 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed Apr 20, 2011 3:59 pm

I will test the bandwidth with PC-s and report.
I need 5Ghz frequency because the 2.4 GHz spectrum is really dirty in the heart of the city.
 
hackac
just joined
Posts: 6
Joined: Tue Apr 19, 2011 11:17 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed Apr 20, 2011 4:53 pm

Same speed with PC-s at the end (file copy)...
 
prashantguharoy
just joined
Posts: 4
Joined: Fri Jul 17, 2009 7:29 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Sun May 01, 2011 2:10 pm

Got 120 Mbps (Tcp) download & 52 mbps (Tcp) upload on SXT 5hnd.
Configured it using this link http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS
getting this result by keeping the devices 5 meters away from each other.
Will be testing the device on an outdoor link of 7.5 KM next week.
thanks
 
enuro12
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Apr 29, 2011 4:09 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Tue May 03, 2011 1:39 am

Interested in your long haul results
 
hackac
just joined
Posts: 6
Joined: Tue Apr 19, 2011 11:17 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed May 04, 2011 2:29 pm

I am also interested...
 
InoX
Forum Guru
Forum Guru
Posts: 1964
Joined: Tue Jan 09, 2007 6:44 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed May 04, 2011 6:05 pm

166mbps at 2km; TCP
You do not have the required permissions to view the files attached to this post.
 
enuro12
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Apr 29, 2011 4:09 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Wed May 11, 2011 3:57 am

How did your long distance tests work out?
 
elidoni
newbie
Posts: 25
Joined: Thu May 05, 2011 11:29 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 1:53 am

Got 120 Mbps (Tcp) download & 52 mbps (Tcp) upload on SXT 5hnd.
Configured it using this link http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS
getting this result by keeping the devices 5 meters away from each other.
Will be testing the device on an outdoor link of 7.5 KM next week.
thanks




Have you tested it ? Im interesed to connect it to a distance of max 6 km ..and I wonder if it works !!!!!????
 
enuro12
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Apr 29, 2011 4:09 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 1:55 am

I cant seem to get above 36mb on my link at .5km. Getting support for these products is like pulling teeth...
 
prashantguharoy
just joined
Posts: 4
Joined: Fri Jul 17, 2009 7:29 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 3:38 pm

At 5.17 KM the link is giving a signal strength of -81/-83 with both the channels enabled
& tx/rx ccq remains 36/12
:( :? literally pulling my hair as to why this is not working at all
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 3:39 pm

I cant seem to get above 36mb on my link at .5km. Getting support for these products is like pulling teeth...
have you emailed support? this forum is not a support forum
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 3:40 pm

At 5.17 KM the link is giving a signal strength of -81/-83 with both the channels enabled
& tx/rx ccq remains 36/12
:( :? literally pulling my hair as to why this is not working at all
signal is really bad. try to change alignment, make sure both units are correctly polarized and mounted, change frequencies of them, use spectral scan to see if there is a lot of interference or not
No answer to your question? How to write posts
 
prashantguharoy
just joined
Posts: 4
Joined: Fri Jul 17, 2009 7:29 am

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 3:55 pm

At 5.17 KM the link is giving a signal strength of -81/-83 with both the channels enabled
& tx/rx ccq remains 36/12
:( :? literally pulling my hair as to why this is not working at all
signal is really bad. try to change alignment, make sure both units are correctly polarized and mounted, change frequencies of them, use spectral scan to see if there is a lot of interference or not
this is the settings which we are using
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 20, 2011 3:59 pm

please follow my suggestions and see if situation changes
No answer to your question? How to write posts
 
sepehrava
just joined
Posts: 2
Joined: Fri Oct 31, 2008 1:08 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Sun May 22, 2011 5:11 pm

I test the SXT device in lab:
my config is this: NV2+VPLS Tunnel :
99Mpbs Download
150 Mbps Download+upload
Test tools : ipref.exe -c "server_ip" -t 100 -P 30
You do not have the required permissions to view the files attached to this post.
 
hackac
just joined
Posts: 6
Joined: Tue Apr 19, 2011 11:17 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Sat Dec 10, 2011 9:30 pm

A dummy question. Is needed WPA2 for security reason or VPLS is enough on a PtP tunnel?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Sun Dec 11, 2011 12:31 pm

A dummy question. Is needed WPA2 for security reason or VPLS is enough on a PtP tunnel?
if you are using Nv2 then the only option is the nv2-preshared-key:
http://wiki.mikrotik.com/wiki/Manual:Nv ... v2_network
 
whatda
just joined
Posts: 20
Joined: Sun Apr 15, 2012 2:05 pm

Re: RouterBOARD SXT 5HnD ptp bridge mode only passing 40megs

Fri May 10, 2013 3:53 pm

sepehrava any chance you can post your setting s for both ends

Who is online

Users browsing this forum: No registered users and 22 guests