Community discussions

MUM Europe 2020
 
tsmalam
just joined
Topic Author
Posts: 5
Joined: Wed Jan 16, 2008 2:00 pm

ASK: how to maximize R52HN

Tue Feb 22, 2011 12:36 pm

Hi all,

i have a problem, maybe any one knows about it
i have install Mikrotik RB433AH+ R52HN with software version 5.orc9, the distance about 1 km
the problem is i never get maximize troughput for 802.11N my troughput only get 40Mbps in one way.
before i use R52HN i use R52H and the troughput i can get 100Mbps in one way, any one can explain why?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: ASK: how to maximize R52HN

Tue Feb 22, 2011 2:23 pm

tell us your configuration.
What antennas you are using?
Are try dual polarized?
How you test the speed?
 
tsmalam
just joined
Topic Author
Posts: 5
Joined: Wed Jan 16, 2008 2:00 pm

Re: ASK: how to maximize R52HN

Wed Feb 23, 2011 9:53 am

this is my config

name="wlan1" mtu=1500 mac-address=00:0C:42:xx:xx:xx arp=enabled
disable-running-check=no interface-type=Atheros 11N
radio-name="xxx" mode=ap-bridge ssid="Dxxk" area=""
frequency-mode=manual-txpower country=no_country_set antenna-gain=0
frequency=5300 band=5ghz-a/n channel-width=20mhz scan-list=default
wireless-protocol=802.11 rate-set=configured
supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps
supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
basic-rates-b=1Mbps
basic-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
max-station-count=2007 distance=dynamic tx-power-mode=default
noise-floor-threshold=default nv2-noise-floor-offset=default
periodic-calibration=default periodic-calibration-interval=60
dfs-mode=none wds-mode=disabled wds-default-bridge=none
wds-default-cost=100 wds-cost-range=50-150 wds-ignore-ssid=no
update-stats-interval=disabled bridge-mode=enabled
default-authentication=yes default-forwarding=yes default-ap-tx-limit=0
default-client-tx-limit=0 proprietary-extensions=post-2.9.25
wmm-support=enabled hide-ssid=no security-profile=default
disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both
compression=no allow-sharedkey=no
station-bridge-clone-mac=00:00:00:00:00:00
ht-ampdu-priorities=0,1,2,3,4,5,6,7 ht-guard-interval=any
ht-extension-channel=above-control
ht-supported-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-
9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15
ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,
mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15
ht-txchains=0,1 ht-rxchains=0,1 ht-amsdu-limit=8192
ht-amsdu-threshold=8192 tdma-debug=0 tdma-override-rate=disabled
tdma-override-size=0 tdma-period-size=2 nv2-queue-count=2
nv2-qos=frame-priority nv2-cell-radius=30 nv2-security=disabled
nv2-preshared-key="" hw-retries=4 frame-lifetime=0
adaptive-noise-immunity=none hw-fragmentation-threshold=disabled
hw-protection-mode=none hw-protection-threshold=0 frequency-offset=0

i'm using antenna grid single polarisation

i'm using bandwidht test form the routerboard, bwtest wireless to wireless
 
stealth
just joined
Posts: 21
Joined: Fri May 26, 2006 4:55 pm

Re: ASK: how to maximize R52HN

Wed Feb 23, 2011 11:14 am

Hello, maybe I have the very same problem. Here is my story.

I'm looking for solution how to upgrade one old 600m long ptp lint with mikrotik+802.11n bridge.
Current hardware is old RB532A with .11a turbo. The real throughput is 32Mbps+.
I always use bridge ptp links as there are routers at the nodes running ospf.

About year ago I tried mikrotik with .11n, but the support was terrible, slowdowns, blackouts. So year later I tried again since mikrotik is advertising it's TDMA solution everywhere.

Configuration
2x RB433AH + R52N-M
setted on the desk, .11n, two streams, signal lowered. link quality 99-100%. channel bonding.

I configured the link as (AP-bridge) <-> (Client-pseudobridge). The wifi is bridged with the ether1 port and the link acts as transparent bridge.

When I do bandwidth test directly on both 433AHs the UDP speed is 200Mbps+ and tcp 70Mbps+ with 100% cpu utilization.

When I add two Linux boxes on each end and tests throughput on them through the bridge the speed is roughly 40Mbps at maximum.
I tried many simultaneous links but the speed increased only by few Mbps.
I tried direct connection of the Linux boxes, the speed is 99.5Mbps, also same in full-duplex.
I tried to reconfigure the bridge into routing link, so the interfaces on routerboards was routed. Even slower than bridged.
I replaced mikrotik with two ubnt rocket M bridge. the speed is 95Mbps.


What is the correct configuration and real life performance of mikrotik .11n bridge ?
I tried both v4 and v5. Maybe v5 has more blackouts.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: ASK: how to maximize R52HN

Wed Feb 23, 2011 1:26 pm

tsmalam, if you are using single antenna and using only one antenna connector (J4 which is the main) then you need to set the ht-txchains=0 ht-rxchains=0 as you enabled other chain which causes you the problem getting higher speed. also you can damage the power amp of the chain1 is you haven't connected anything there.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: ASK: how to maximize R52HN

Wed Feb 23, 2011 1:30 pm

stealth, what configuration you had in your setup?
If you used the Ubnt, then most likely their Airmax protocol was used.
You need to use Nv2 wireless-protocol.
Please upgrade to RouterOS v5.0rc10 and use ap-bridge on the AP and station-bridge on the client side and bridge them together.

Who is online

Users browsing this forum: Bing [Bot] and 35 guests