Community discussions

 
marklodge
Member Candidate
Member Candidate
Topic Author
Posts: 202
Joined: Sun Jun 21, 2009 6:15 pm

i need an Updated list of youtube ip addresses

Tue Dec 27, 2011 2:29 am

i have 3 wan links to the internet with around 25 clients.
i want to route all web video like youtube dailymotion etc to one specific WAN link OR a cahching server.
I tried to mark web video like .flv and .mp4 extension using layer7 but that did not work.
so i think it is best if i mark all traffic going to dst-address list: all-youtube-addresses, and then routing it to the caching server or to the WAN link.

i found this list
/ip firewall address-list
add address=208.117.224.0/24 list=Youtube
add address=208.117.225.0/24 list=Youtube
add address=208.117.228.0/24 list=Youtube
add address=208.117.229.0/24 list=Youtube
add address=208.117.232.0/24 list=Youtube
add address=208.117.233.0/24 list=Youtube
add address=208.117.234.0/24 list=Youtube
add address=208.117.238.0/24 list=Youtube
add address=208.65.152.0/24 list=Youtube
add address=208.65.153.0/24 list=Youtube
add address=208.65.154.0/24 list=Youtube
add address=64.15.112.0/20 list=Youtube
add address=208.117.236.0/24 list=Youtube
add address=74.125.96.0/19 list=Youtube
add address=72.14.221.0/24 list=Youtube
add address=84.53.128.0/18 comment=Redtube list=Youtube
add address=87.248.192.0/19 comment=Youporn list=Youtube
add address=216.155.128.0/19 comment=Redtube list=Youtube
add address=208.73.208.0/21 comment=Redtube list=Youtube
add address=66.55.140.0/23 comment=Redtube list=Youtube
add address=74.125.208.0/24 list=Youtube
But i think there are new youtube ip addresses because the above did not catch any traffic when i watched a youtube video.
 
User avatar
mramos
Member Candidate
Member Candidate
Posts: 230
Joined: Sun Nov 23, 2008 1:05 am
Location: S. B do Campo - SP - Brazil

Re: i need an Updated list of youtube ip addresses

Tue Dec 27, 2011 10:16 am

I use this:
;;; Youtube
     chain=prerouting action=add-dst-to-address-list protocol=tcp 
     address-list=Youtube address-list-timeout=10m in-interface=!(YOUR PUBLIC IFACE) 
     dst-port=80 content=youtube.com
Addresses will be added to Youtube address list and will be there for 10 minutes.

Regards;
Marcus Ramos
Electronics Technician
(Microwave HW, RF, antennas, propagation)
S.Paulo - Brazil
 
marklodge
Member Candidate
Member Candidate
Topic Author
Posts: 202
Joined: Sun Jun 21, 2009 6:15 pm

Re: i need an Updated list of youtube ip addresses

Tue Dec 27, 2011 2:59 pm

;;; Youtube
     chain=prerouting action=add-dst-to-address-list protocol=tcp 
     address-list=Youtube address-list-timeout=10m in-interface=!(YOUR PUBLIC IFACE) 
     dst-port=80 content=youtube.com
Thanks for that.
Does this work and and add all the ips that serve youtube videos to the address-list?
Because i see that it picks up from different ip addresses such as: v19.cache.googlevideo.com or v18.cache.googlevideo.com etc
 
rodolfo
Long time Member
Long time Member
Posts: 543
Joined: Sat Jul 05, 2008 11:50 am

Re: i need an Updated list of youtube ip addresses

Tue Dec 27, 2011 3:30 pm

add to the same list also googlevideo.com
rodolfo
IZ0UQV
 
marklodge
Member Candidate
Member Candidate
Topic Author
Posts: 202
Joined: Sun Jun 21, 2009 6:15 pm

Re: i need an Updated list of youtube ip addresses

Wed Dec 28, 2011 2:30 am

OK, well i tried what i wanted but did not get the results expected.
Problem is that some youtube videos dont work (error occured) and some dont load, and it takes longer than usual to load.

heres my config if anyone wants it
/ip firewall address-list
add address=208.117.224.0/24 disabled=no list=Youtube

/ip firewall mangle
add action=add-dst-to-address-list address-list=Youtube address-list-timeout=\
    10m chain=forward comment="Find youtube ip addresses and add it to list" \
    content=youtube.com disabled=no dst-port=80 in-interface=!ether2 protocol=\
    tcp
add action=add-dst-to-address-list address-list=Youtube address-list-timeout=\
    10m chain=forward comment=\
    "Find googlevideo ip addresses and add it to list" content=googlevideo.com \
    disabled=no dst-port=80 in-interface=!ether2 protocol=tcp
add action=mark-routing chain=prerouting comment=\
    "Mark Route for all Youtube traffic " disabled=no dst-address-list=Youtube \
    new-routing-mark="Youtube Traffic" passthrough=yes
add action=mark-packet chain=prerouting disabled=yes dst-address-list=Youtube \

/ip firewall nat
add action=masquerade chain=srcnat comment=\
    "NAT to allow Youtube traffic out of this WAN interface" disabled=no \
    dst-address-list=Youtube out-interface=WAN1
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out1 \
    src-address=192.168.9.0/24

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
    routing-mark=Group3 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=WAN1 \
    routing-mark="Youtube Traffic" scope=30 target-scope=10
add comment="Route Youtube traffic to WAN1" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=WAN1 routing-mark="Youtube Traffic" scope=30 \
    target-scope=10




the following is my mss rules and i am doing load balncing so i had to exclude the youtube list in my prerouting rule

add action=mark-routing chain=prerouting comment="Group 3" disabled=no \
    dst-address-list=!Youtube new-routing-mark=Group3 passthrough=no \
    src-address=192.168.9.0/24
add action=change-mss chain=forward comment="In interface" disabled=no \
    in-interface=ether2 new-mss=1452 passthrough=yes protocol=tcp tcp-flags=syn \
    tcp-mss=1453-65535
add action=change-mss chain=forward comment="Out interface" disabled=no \
    new-mss=1440 out-interface=ether2 passthrough=yes protocol=tcp tcp-flags=\
    syn tcp-mss=1441-65535
if anyone finds a better way of doing it please let me know
Thank you
 
adolfainsley8
just joined
Posts: 1
Joined: Tue Apr 19, 2016 2:27 pm

Re: i need an Updated list of youtube ip addresses

Tue Apr 19, 2016 2:28 pm

i am doing load balncing so i had to exclude the youtube list in my prerouting rule???
 
kaas
just joined
Posts: 19
Joined: Wed Mar 18, 2009 11:31 am

Re: i need an Updated list of youtube ip addresses

Mon Nov 07, 2016 10:41 am

I use a script to get the ip's

1st force users to use mikrotik dns
2nd use script to get ips from dns
just remove facebook

then i queue them, you can just route them

regards
Wolter

/ip firewall nat
add action=redirect chain=dstnat comment="DNS Dictator" dst-port=53 in-interface=!ether1-WAN protocol=udp

/system scheduler
add interval=2m name=facebookYoutube on-event=":foreach i in=[/ip dns cache all find where (name~\"youtube\" || name~\"facebook\" || name~\"fbcdn\" || nam\
e~\"video\" || name~\"youtu\" ) && (type=\"A\") ] do={\r\
\n :local tmpAddress [/ip dns cache get \$i address];\r\
\ndelay delay-time=10ms\r\
\n#prevent script from using all cpu time\r\
\n :if ( [/ip firewall address-list find where address=\$tmpAddress] = \"\") do={ \r\
\n :local cacheName [/ip dns cache get \$i name] ;\r\
\n :log info (\"added entry: \$cacheName \$tmpAddress\");\r\
\n /ip firewall address-list add address=\$tmpAddress list=queue timeout=23:59:59 comment=\$cacheName;\r\
\n\r\
\n}\r\
\n\r\
\n}" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/2016 start-time=00:00:00
 
borair
just joined
Posts: 18
Joined: Wed Mar 23, 2016 8:12 pm

Re: i need an Updated list of youtube ip addresses

Tue Nov 08, 2016 5:51 pm

i use the command : nslookup in CMD , to obtain the IP of youtube and create a list In firewall
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: i need an Updated list of youtube ip addresses

Wed Nov 09, 2016 9:52 am

Firewall address list accepts fqdn and builds ip address list dynamically. You can mangle and queue or route subsequently according to it.
 
lucas1990
just joined
Posts: 1
Joined: Sat Aug 11, 2018 8:16 am
Contact:

Re: i need an Updated list of youtube ip addresses

Sat Aug 18, 2018 12:31 pm

Hi, Here is a list of youtube IP addresses:
9.192.115.0/24
77.153.128.46
199.223.232.0/24
74.125.206.0/24
64.233.167.0/24
199.223.233.0/24
199.223.234.0/24
199.223.235.0/24
199.223.236.0/24
199.223.237.0/24
199.223.238.0/24
199.223.239.0/24
207.223.160.0/24
207.223.161.0/24
207.223.162.0/24
207.223.163.0/24
207.223.164.0/24
207.223.165.0/24
207.223.166.0/24
207.223.167.0/24
207.223.168.0/24
207.223.169.0/24
207.223.170.0/24
207.223.171.0/24
207.223.172.0/24
207.223.173.0/24
207.223.174.0/24
207.223.175.0/24
208.65.152.0/24
208.65.153.0/24
208.65.154.0/24
208.65.155.0/24
208.117.224.0/24
208.117.225.0/24
208.117.226.0/24
208.117.227.0/24
208.117.228.0/24
208.117.229.0/24
208.117.230.0/24
208.117.231.0/24
208.117.232.0/24
208.117.233.0/24
208.117.234.0/24
208.117.235.0/24
208.117.236.0/24
208.117.237.0/24
208.117.238.0/24
208.117.239.0/24
208.117.240.0/24
208.117.241.0/24
208.117.242.0/24
208.117.243.0/24
208.117.244.0/24
208.117.245.0/24
208.117.246.0/24
208.117.247.0/24
208.117.248.0/24
208.117.249.0/24
208.117.250.0/24
208.117.251.0/24
208.117.252.0/24
208.117.253.0/24
208.117.254.0/24
208.117.255.0/24
209.85.128.0/24
209.85.129.0/24
209.85.130.0/24
209.85.131.0/24
209.85.132.0/24
209.85.133.0/24
209.85.134.0/24
209.85.135.0/24
209.85.136.0/24
209.85.137.0/24
209.85.138.0/24
209.85.139.0/24
209.85.140.0/24
209.85.141.0/24
209.85.142.0/24
209.85.143.0/24
209.85.144.0/24
209.85.145.0/24
209.85.146.0/24
209.85.147.0/24
209.85.148.0/24
209.85.149.0/24
209.85.150.0/24
209.85.151.0/24
209.85.152.0/24
209.85.153.0/24
209.85.154.0/24
209.85.155.0/24
209.85.156.0/24
209.85.157.0/24
209.85.158.0/24
209.85.159.0/24
209.85.160.0/24
209.85.161.0/24
209.85.162.0/24
209.85.163.0/24
209.85.164.0/24
209.85.165.0/24
209.85.166.0/24
209.85.167.0/24
209.85.168.0/24
209.85.169.0/24
209.85.170.0/24
209.85.171.0/24
209.85.172.0/24
209.85.173.0/24
209.85.174.0/24
209.85.175.0/24
209.85.176.0/24
209.85.177.0/24
209.85.178.0/24
209.85.179.0/24
209.85.180.0/24
209.85.181.0/24
209.85.182.0/24
209.85.183.0/24
209.85.184.0/24
209.85.185.0/24
209.85.186.0/24
209.85.187.0/24
209.85.188.0/24
209.85.189.0/24
209.85.190.0/24
209.85.191.0/24
209.85.192.0/24
209.85.193.0/24
209.85.194.0/24
209.85.195.0/24
209.85.196.0/24
209.85.197.0/24
209.85.198.0/24
209.85.199.0/24
209.85.200.0/24
209.85.201.0/24
209.85.202.0/24
209.85.203.0/24
209.85.204.0/24
209.85.205.0/24
209.85.206.0/24
209.85.207.0/24
209.85.208.0/24
209.85.209.0/24
209.85.210.0/24
209.85.211.0/24
209.85.212.0/24
209.85.213.0/24
209.85.214.0/24
209.85.215.0/24
209.85.216.0/24
209.85.217.0/24
209.85.218.0/24
209.85.219.0/24
209.85.220.0/24
209.85.221.0/24
209.85.222.0/24
209.85.223.0/24
209.85.224.0/24
209.85.225.0/24
209.85.226.0/24
209.85.227.0/24
209.85.228.0/24
209.85.229.0/24
209.85.230.0/24
209.85.231.0/24
209.85.232.0/24
209.85.233.0/24
209.85.234.0/24
209.85.235.0/24
209.85.236.0/24
209.85.237.0/24
209.85.238.0/24
209.85.239.0/24
209.85.240.0/24
209.85.241.0/24
209.85.242.0/24
209.85.243.0/24
209.85.244.0/24
209.85.245.0/24
209.85.246.0/24
209.85.247.0/24
209.85.248.0/24
209.85.249.0/24
209.85.250.0/24
209.85.251.0/24
209.85.252.0/24
209.85.253.0/24
209.85.254.0/24
209.85.255.0/24
216.58.192.0/24
216.58.193.0/24
216.58.194.0/24
216.58.195.0/24
216.58.196.0/24
216.58.197.0/24
216.58.198.0/24
216.58.199.0/24
216.58.200.0/24
216.58.201.0/24
216.58.202.0/24
216.58.203.0/24
216.58.204.0/24
216.58.205.0/24
216.58.206.0/24
216.58.207.0/24
216.58.208.0/24
216.58.209.0/24
216.58.219.0/24
216.58.218.0/24
216.58.217.0/24
216.58.216.0/24
216.58.215.0/24
216.58.214.0/24
216.58.213.0/24
216.58.212.0/24
216.58.211.0/24
216.58.210.0/24
216.58.220.0/24
216.58.221.0/24
216.58.222.0/24
216.58.223.0/24
216.239.57.0/24
216.239.56.0/24
216.239.55.0/24
216.239.54.0/24
216.239.36.0/24
216.239.37.0/24
216.239.38.0/24
216.239.39.0/24
216.239.40.0/24
216.239.41.0/24
216.239.42.0/24
216.239.43.0/24
216.239.46.0/24
216.239.47.0/24
216.239.48.0/24
216.239.49.0/24
216.239.51.0/24
216.239.50.0/24
216.239.35.0/24
216.239.34.0/24
216.239.52.0/24
216.239.33.0/24
216.239.32.0/24
216.239.59.0/24
216.239.58.0/24
216.239.60.0/24
216.239.61.0/24
216.239.53.0/24
216.239.63.0/24
216.239.62.0/24
 
alinikyar
just joined
Posts: 4
Joined: Wed Aug 07, 2019 9:29 pm

Re: i need an Updated list of youtube ip addresses

Wed Aug 07, 2019 11:13 pm

I need a IP youtube site how can i get these IP updates

Who is online

Users browsing this forum: No registered users and 16 guests