Community discussions

MikroTik App
 
csohns
just joined
Topic Author
Posts: 23
Joined: Fri Aug 31, 2012 10:49 pm

RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Sun Sep 02, 2012 9:37 pm

I can not get the cell phone model, LG Optimus Elite, to connect to the 751U. Many other cell phones, tablets, laptops, etc have no problem. I've factory defaulted two separate units with the same result. I've tried ROS 5.12, 5.14, and 5.20. It will connect unencrypted and with WPA, just not WPA2. No wireless log events are recorded for the connection attempt. The cell phone will loop indefinitely "Connecting...", "Disconnected".

Community boards for the LG phone speak of this same problem with multiple AP vendors, but most of which speak of the problem when the SSID is hidden, I do not hide it. No solution is known for the visible SSID side of the problem.

Does anyone have suggestions for further troubleshooting on the MT side of things? My only known course of action at this point is to persuade the device's owner to root the phone so I can look at the Android wifi debug logs.

Below is my (mostly) default testing configuration:
/interface wireless security-profiles
add authentication-types=wpa-psk eap-methods=passthrough group-ciphers=\
    tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=wpa \
    supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=\
    testingtesting
add authentication-types=wpa2-psk eap-methods=passthrough group-ciphers=\
    tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=wpa2 \
    supplicant-identity="" unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=\
    testingtesting wpa2-pre-shared-key=testingtesting
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above country="united states" \
    disabled=no distance=indoors frequency=2462 ht-rxchains=0,1 ht-txchains=\
    0,1 l2mtu=2290 mode=ap-bridge security-profile=wpa2 wireless-protocol=\
    802.11
 
rlkollman
just joined
Posts: 4
Joined: Fri Jul 01, 2011 11:46 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Tue Sep 04, 2012 3:09 am

I have the same setup and my new Motorola Photon Q 4G with Android ICS is unable to connect - has the same loop (Connect .. Disconnected). Nothing shows up in the mikrotik logs as even being connected. I have successfully connected to other wireless APs (no other MikroTik APs) with similar configuration (WPA2-PSK - AES Encryption). I enabled TKIP for troubleshooting and that didn't work either. I've had to create a virtual wireless interface with WEP enabled to make a connection to my network at home. I've had other, older version, Android devices connected to my normal configuration (WPA2-PSK-AES) with no problem in the recent past. So, I don't know if it's an issue with the ICS or MT... or both?

Important to note that I am using an RB411-AH, not the 751U as you are, but I am having the same problem on MT hardware. I am running ROS 5.16 on that particular board. If you happen to find a solution, please pass it along to me and I'll do the same!

Thanks and good luck!!

EDIT:
I re-read your post and see you were able to connect with WPA... I can connect with WPA if WPA is only selected (not WPA2 as well). If both WPA and WPA2 are selected, it will fail as well. In fact, when I try connecting with WPA2, the phone actually indicates the signal to MT is poor. Prior to attempting to connect, the signal is perfect - but the entire time it attempts to connect it reports poor signal.
 
User avatar
YazzY
Member Candidate
Member Candidate
Posts: 140
Joined: Fri May 28, 2004 3:26 pm
Location: Norway, Østfold
Contact:

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Tue Sep 04, 2012 8:40 am

I've seen this too on Huawei U8800. There is a bug in (Android older than 2.3?) which makes it impossible to connect to encrypted networks. Create an unencrypted (open) virtual access point and it will connect.
 
csohns
just joined
Topic Author
Posts: 23
Joined: Fri Aug 31, 2012 10:49 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Thu Sep 06, 2012 10:23 pm

rlkollman, to clarify, I've also setup a VAP with WPA only, for it to work. As you said, if WPA and WPA2 are enabled, it will not connect.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Thu Sep 13, 2012 4:04 pm

So the reported problem is that few Android based phones do not connect to Mikrotik RouterOS if it is using WPA2-PSK (AES). If you use only WPA1-PSK (AES) it connects fine without problem?

Maybe all of you who sees that problem, could report what Android device you use and what Android OS version you use?
 
rlkollman
just joined
Posts: 4
Joined: Fri Jul 01, 2011 11:46 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Thu Sep 13, 2012 4:40 pm

yes- you summed it up nicely. I am running Android 4.0.4 on a Motorola Photon Q 4g lte.

Thanks for checking into this!
 
lunchboxrts
Member Candidate
Member Candidate
Posts: 144
Joined: Sat Aug 19, 2006 6:40 am
Location: United States

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Sun Sep 30, 2012 12:20 am

Any updates on this issue?

Evo 4g LTE with Android 4.0.4
 
richardhkirkando
just joined
Posts: 14
Joined: Mon Aug 25, 2008 9:11 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Wed Oct 17, 2012 4:39 pm

Also having this issue with the Motorola Photon Q, Android 4.0.4. No trouble at all with any other access points so far.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Mon Oct 22, 2012 3:43 pm

please contact support@mikrotik.com for a test release that will fix this problem.
 
rlkollman
just joined
Posts: 4
Joined: Fri Jul 01, 2011 11:46 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Mon Oct 22, 2012 6:40 pm

I applied the update and was able to successfully connect with Android 4.0.4. Thank you for working on this and getting an update quickly!! :D
 
User avatar
YazzY
Member Candidate
Member Candidate
Posts: 140
Joined: Fri May 28, 2004 3:26 pm
Location: Norway, Østfold
Contact:

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Sun Nov 18, 2012 8:06 pm

I thought it was the phone.
I can now confirm, my phone can finally connect to the access point running RouterOS 6.0rc3 on RB751G-2HnD.
But the connection is very unstable and times out frequently.
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 223
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Mon Nov 19, 2012 1:57 pm

I have the same problem: WPA-PSK works, WPA2-PSK don't. The mobile device is the HTC One S.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3439
Joined: Mon May 31, 2004 2:55 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Fri Nov 23, 2012 6:21 pm

please install the latest RouterOS (currently v5.22) and try again. Also we recommend you to remove the AP profile from the Android and make a new one before trying again.
 
richardhkirkando
just joined
Posts: 14
Joined: Mon Aug 25, 2008 9:11 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Wed Dec 12, 2012 7:12 pm

My Motorola Photon Q seems to be working properly now with WPA2 on RouterOS 6.0rc5.
 
DeN238
just joined
Posts: 1
Joined: Tue Mar 27, 2012 10:53 pm

Re: RB751U-2HnD (AR5008) + LG Optimus Elite WPA2-PSK

Sun Jan 27, 2013 2:18 pm

I have the same problem: WPA-PSK works, WPA2-PSK don't. The mobile device is the HTC One S.
+1
2011UAS-2HnD, FW 3.0, ROS 5.22
Desire S, Android 4.0.4

Who is online

Users browsing this forum: kamild1996, mixig and 95 guests