Community discussions

 
jisunza
just joined
Topic Author
Posts: 5
Joined: Thu Oct 18, 2012 7:41 am

Help! Sierra MC5727 Issues with RB411U v5.6

Thu Oct 18, 2012 7:50 am

Hi and thanks in advanced.
I am having to setup a Mikrotik RB411U v5.6 with a Sierra MC5727 3G Card.
I looked at the hardware supported by Mikrotik and it said it supported the Sierra MC5727.
However, I tried to initialize it and nothing comes up.
Steps i took.

1. [admin@MikroTik] > /system serial-terminal usb2 channel=2
(nothing comes up on this step or with a different channel like 0 or 3)

2. [admin@MikroTik] > /interface ppp-client info ppp-out1
status: ERROR
pin-status:
functionality: ERROR
gprs-class:
manufacturer: Sierra Wireless, Inc.
model: MC5727 Rev 2.0 (2)
revision: p2416700,52866 [Mar 11 2009 15:14:00]QCOM:
SWI6800V2_FD.00.35 BOOT: SWI6800V2_FP.01.67 2009/03/20
13:55:25APPL: SWI6800V2_FP.01.67 2009/03/20
13:55:25USBD: SWI6800V2_GENERIC.00.01USB VID: 0x1199
PID: 0x0024
serial-number: 0x60E3C714
current-operator:
access-technology:
signal-strengh: 0
frame-error-rate:
------------------------------------------------------------------------------
The command brings up Status: Error and Functionality: Error.
Any help would be greatly appreciated.
 
jisunza
just joined
Topic Author
Posts: 5
Joined: Thu Oct 18, 2012 7:41 am

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Mon Oct 22, 2012 2:05 am

Anyone? Mikrotik?
 
bertj
newbie
Posts: 27
Joined: Tue Sep 14, 2010 3:46 pm

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Tue Oct 30, 2012 4:04 pm

Hi
I have the same problem, just try use other usb channel.
This modem has 0-7 channel for data and voice.
I used 3 for data channel and 4 for info channel.
Regards
 
jisunza
just joined
Topic Author
Posts: 5
Joined: Thu Oct 18, 2012 7:41 am

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Mon Nov 19, 2012 1:15 am

bertj,
Thanks for your help, but changing the channels did not help. The only channels i can get info from are 0-2. The info i get is shown at the first post. Mikrotik does not even initialize the modem.
 
JorgeAmaral
Trainer
Trainer
Posts: 199
Joined: Wed Mar 04, 2009 11:53 pm
Location: /ip route add type=blackhole

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Tue Nov 20, 2012 12:30 am

Seems that your modem starts with airplane mode enabled.
In modem-init set at+cfun=1 and enable the interface.
Now the info should work.
 
el berto
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Sep 26, 2007 10:53 am

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Thu Nov 22, 2012 7:30 pm

Hi, when you start serial-terminal and then you type AT (then press enter), do you have answer from card (it should be OK)?
Do you have "echo" from card (when you type AT on the keyboard, do you see "AT" on the console)?
Or does it seem dead at all?
 
jisunza
just joined
Topic Author
Posts: 5
Joined: Thu Oct 18, 2012 7:41 am

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Fri Nov 23, 2012 2:44 am

@JorgeAmaral, That i have tried, and it doesn't work.

@ el berto, This is what i get on channel=0 which is what you where asking. All other channels do not respond. Thanks for the help. I need all that i can get.
[admin@MikroTik] > /system serial-terminal usb2 channel=0

[Ctrl-A is the prefix key]

AT
OK

[Q - quit connection]
[A - send Ctrl-A prefix] [R - autoconfigure rate]
Welcome back!

UPDATE: I got some info from typing ATi or ATi5
[admin@MikroTik] > /system serial-terminal usb2 channel=0

[Ctrl-A is the prefix key]


ATi5
Manufacturer: Sierra Wireless, Inc.
Model: MC5727 Rev 2.0 (2)
Revision: p2416700,52866 [Mar 11 2009 15:14:00]
QCOM: SWI6800V2_FD.00.35
BOOT: SWI6800V2_FP.01.67 2009/03/20 13:55:25
APPL: SWI6800V2_FP.01.67 2009/03/20 13:55:25
USBD: SWI6800V2_GENERIC.00.01
USB VID: 0x1199 PID: 0x0024
ESN: 0x60E3C714
+GCAP: +CIS707-A, CIS-856, CIS-856-A, +MS, +ES, +DS, +FCLASS
SKU: 0x12BA7

OK
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Fri Nov 23, 2012 6:05 pm

esable the async,debug loggging and post what you see when you enable the ppp-client.
 
bbs2web
Member Candidate
Member Candidate
Posts: 201
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: Help! Sierra MC5727 Issues with RB411U v5.6

Tue Dec 04, 2012 10:30 pm

Upgrade RouterOS, we had the exact same problem with early releases of RouterOS 5.

We are currently running a RB411U with a Sierra MC8792V 3G module on RouterOS 5.21.

Herewith a copy of our own internal notes, they were build up last festive season when we first starting playing with the stuff (Our MikroTik re-seller initially tried to convince us that the channel selections had something to do with the base station and network we were wanting to connect to... :lol: ):

We've experienced problems with some Sierra 3G mini-PCI modules but this appears to have been fixed in releases of RouterOS 5.10+. SimTech SIM5220 has been our staple. Most modules allow concurrent access on different channels, this enables status information retrieval whilst the unit is connected.

Try communicate on each of the available channels ('/port print' reported 5 available channels so the channels are 0, 1, 2, 3 & 4):
/sys serial-terminal usb2 channel=0
    Send: at<enter>
If nothing happens, close the connection at try the next channel (to get out of the serial interface: <ctrl>-A, q)

Example with RouterOS 5.14, RB411U and Sierra Wireless MC8705:
Channel 3 and 4 work but 4 doesn't echo back input (even with ATE1), appears to be for status commands only:
  /sys serial-terminal usb2 channel=3
    at
    OK
    at+cpin?
    +CPIN: READY
    OK
  /sys serial-terminal usb2 channel=4

    OK

    OK
    +CPIN: READY
    OK
Ok, so we create a 'ppp-client' interface (if RouterOS didnt already create a template for us) and set the data channel to 3 and the info channel to 4. And... voila, working...

Who is online

Users browsing this forum: No registered users and 26 guests