Community discussions

 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 4:28 am

So I recently got a RB411AR and a 52Hn card and got it all configured with a 2.GHz B/G network and a 5GHz N network.

The N network is great. I have two external antennas for it and the range and speed are good.

The B/G network however, I can't really connect to it with any device unless I'm standing 5 feet from it so I'm wondering if I have anything configured incorrectly. There is an aux antenna connector, but I would assume that in its stock state, it should be able to cover a few rooms with wireless reliably (maybe that assumption is the issue though).

Configuration notes:
- I did a wireless scan and picked a channel where there was nothing else. Ended up with channel 5 - 2432 MHz
- Set to AP Bridge Mode
- Set to 2GHz B/G mode
- Wireless Protocol is unspecified
- Have a WPA2 aes security profile configured and assigned
- Frequency mode is manual txpower
- Country is USA
- Antenna mode is antenna a
- 0 dBi for Antenna Gain
- Rate selection is legacy
- tx power mode is default and the current Tx power table lists 20dBm for all rates up to 24Mbps



So is there anything specific I should try in the config to get this seen more than 5 feet away from the device?

Thanks!
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 4:32 am

You need an antenna connected, there is no internal antenna. How long did you run it with no antenna? You may have damaged it.
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 4:41 am

About a week. I just disabled that interface now. I'm pretty frustrated that none of the documentation that I've seen specifies that this requires an external antenna. The provider that I purchased it from didn't say anything either and despite purchasing the unit with 2x MMCX antennas, both were hooked to the N card.

If it makes any difference, I've only run the 411AR in "antenna mode a".

On the 411AR there is only one MMCX connector, which is labeled as "Aux".


Thanks for the help.
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 4:45 am

You could have been using 1 antenna per card.

I would say it is burnt up. You could disable chain1 on the r52hn and connect that antenna to the 411ar and double check.
C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 5:29 am

The provider (roc-noc) built it and connected both antenna to the N card, and I had to specify that I wanted to buy antennas. It by default came with no antenna despite being a pre-built solution (base was RB411ar + Case + power supply).

I hooked the antenna up tot he 411AR AUX antenna port and the reception did not get better. I then switched it to antenna b mode and was able to get a signal much further, but the data rate was extremely, extremely slow.
 
Zod
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Mon Apr 23, 2012 11:02 pm

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 2:58 pm

You need an antenna specific to the frequency you are using. You can't use an 'A mode' (5.x GHz) antenna on 'B Mode' (2.4Ghz) and expect it to propagate. There are A/B/G mode antenna but typically that's like a little rubby ducky type - and they do almost nothing other than adding a 50 ohm load to the transceiver. You should never run a card without a 50 ohm load on the antenna port. Not even for a few seconds. If you didn't fry it after a week like that I would be a rather amazed.

Z
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 3:11 pm

It is unclear why the seller connected both antennas to one card, this is not normal. But the RB4xx series are more "DIY" oriented devices, they are rarely sold as complete kits. The seller probably expected that you would connect your own antenna to the second card, or at least expected that you knew what has to be checked before using it.

For turnkey use, you would need the OmniTIK, SXT and RB75x (or RB95x) series devices.
No answer to your question? How to write posts
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 3:57 pm

I enjoy DIY, but it seems you always learn the most by blowing stuff up right? :(

Let's assume that the board is not fried (because if it is I'll replace it). I now have a "2.4GHz 7dBi Omnidirectional Rubber Duck style antenna" on its way to me for connecting to the RB411AR connector. On the R52Hn are two "2.4-5.8 GHz 2.5dBi/5.5dBi Omnidirectional Swivel Antennas."

Hardware wise that look ok?


That said, what is the typical configuration for the 2.4GHz network? From the post above, I gather that I need to put it into "B mode" to correspond with the 2.4GHz frequency.


Once the antenna arrives, how would I go about testing to see if the transmitter is fried? Just hook it up and see if it works?


Your patience and info are appreciated. I'm learning, I'm learning... :D
Thanks
 
User avatar
roc-noc.com
Forum Veteran
Forum Veteran
Posts: 869
Joined: Sun Dec 02, 2007 3:27 am
Location: Rockford, IL USA
Contact:

Re: RB411AR - Horrible range with built-in wireless card

Wed Oct 24, 2012 6:14 pm

The provider (roc-noc) built it and connected both antenna to the N card, and I had to specify that I wanted to buy antennas. It by default came with no antenna despite being a pre-built solution (base was RB411ar + Case + power supply).

I hooked the antenna up tot he 411AR AUX antenna port and the reception did not get better. I then switched it to antenna b mode and was able to get a signal much further, but the data rate was extremely, extremely slow.
This thread was just brought to my attention. This was not assembled correctly at our company and I apologize for the mistake. Any active radio should always have an antenna or a 50 ohm dummy load connected to the primary port or you risk damage. With a the 411AR and an R52Hn, we should have connected one antenna to the 411AR and one to the primary port of the R52Hn.

Fortunately, the RB411AR has a very low power radio (100mw) so it might have escaped damage. You corrected this mistake by moving one of the antennas to the RB411AR aux port.

I am not sure who you are or I would have called you. If you think there is still a problem, please call me and we will take care of it.

Many thanks,

Tom
-----------------------------------------------
http://www.roc-noc.com
Tom, CCNA, ISP, USA Mikrotik Distributor
888-762-5662
-----------------------------------------------
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Thu Nov 01, 2012 12:55 am

Alright, I'm back with the hardware setup properly, with the above described antenna on the onboard port of the 411AR.

I get about double the range, however, double 5 feet is only about 10 feet. D'OH! Tested with a laptop, android tablet, and iPhone. All worked well all over the apartment with the previous piece of junk Cisco Linksys.

I reset the config on the wireless interface and set it up again. About the only thing I changed was the SSID, the security profile, and the antenna setting (antenna b as described above).


Given that this is a "low power" device, is this kind of poor range expected? Or if it was damaged from running without an antenna would this be a symptom or would it just not work at all?


Starting to think that I should have gotten a multi card board (RB433 maybe) and two R52Hn's...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB411AR - Horrible range with built-in wireless card

Thu Nov 01, 2012 9:10 am

You have that "dubber ducky antenna"? Please post a photo of how it's all connected, and then output of this console command "/export compact". 10 feet is certainly not normal. When using a proper antenna, this device can go tens of miles.
No answer to your question? How to write posts
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Fri Nov 02, 2012 2:58 am

[admin@MikroWiFi] > /export compact
# nov/01/2012 20:55:38 by RouterOS 5.21
#
/interface bridge
add l2mtu=1526 name=bridge1
/interface wireless security-profiles
set [ find default=yes ] group-ciphers="" supplicant-identity=MikroTik \
    unicast-ciphers=""
add authentication-types=wpa2-psk eap-methods=passthrough \
    management-protection=allowed mode=dynamic-keys name=WiFi-N \
    supplicant-identity="" wpa2-pre-shared-key=PASSWORD
add authentication-types=wpa2-psk eap-methods=passthrough \
    management-protection=allowed mode=dynamic-keys name=WiFi-BG \
    supplicant-identity="" wpa2-pre-shared-key=PASSWORD
/interface wireless
set 0 antenna-mode=ant-b band=2ghz-onlyg disabled=no frequency=2452 l2mtu=\
    2290 mode=ap-bridge security-profile=WiFi-BG ssid=PEBMail-BG
set 1 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
    ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge rate-selection=\
    legacy security-profile=WiFi-N ssid=PEBMail-N
/ip dhcp-server
add interface=bridge1 name=dhcp1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
    permissions=owner signup-allowed=no time-zone=-00:00
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
/ip dhcp-client
add default-route-distance=0 disabled=no host-name=MikroWiFi interface=\
    bridge1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=\
    172.27.27.1,209.18.47.61
/ip dns static
add address=192.168.88.1 name=router
/ip neighbor discovery
set wlan1 disabled=yes
set wlan2 disabled=yes
/queue interface
set ether1 queue=ethernet-default
/system clock
set time-zone-name=EST5EDT
/system identity
set name=MikroWiFi
/system ntp client
set enabled=yes primary-ntp=172.27.27.1 secondary-ntp=64.90.182.55
[admin@MikroWiFi] > 
Last edited by BackwardsCire on Tue Nov 06, 2012 5:31 am, edited 1 time in total.
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Fri Nov 02, 2012 3:03 am

Image

Image

2.4GHz 7dBi Omnidirectional Rubber Duck style antenna" on the RB411AR port directly.

2x 2.4-5.8 GHz 2.5dBi/5.5dBi Omnidirectional Swivel Antennas on the R52Hn.


Thank you.
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Tue Nov 06, 2012 5:31 am

Hurray!

Well I completely reset the unit again and took advantage of the "quick set" feature to do the initial config and it now works! Great range of B/G and N. Whew.

[admin@PEBWiFi] > /export compact
# nov/05/2012 22:27:58 by RouterOS 5.21
#
/interface bridge
add l2mtu=1526 name=bridge1 protocol-mode=rstp
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
supplicant-identity=MikroTik wpa-pre-shared-key=PASSWORD \
wpa2-pre-shared-key=PASSWORD
add authentication-types=wpa2-psk eap-methods=passthrough \
management-protection=allowed mode=dynamic-keys name=N-WPA2 \
supplicant-identity="" wpa2-pre-shared-key=PASSWORD
add authentication-types=wpa2-psk eap-methods=passthrough \
management-protection=allowed mode=dynamic-keys name=BG-WPA2 \
supplicant-identity="" wpa-pre-shared-key=PASSWORD \
wpa2-pre-shared-key=PASSWORD
/interface wireless
set 0 band=2ghz-b/g country="united states" disabled=no frequency=2452 l2mtu=\
2290 mode=ap-bridge security-profile=BG-WPA2 ssid=PEBMail-BG \
wireless-protocol=802.11
set 1 band=5ghz-onlyn channel-width=20/40mhz-ht-above country="united states" \
disabled=no ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge \
security-profile=N-WPA2 ssid=PEBMail-N wireless-protocol=802.11
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
permissions=owner signup-allowed=no time-zone=-00:00
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan2
/ip dhcp-client
add disabled=no interface=bridge1
/ip neighbor discovery
set wlan1 disabled=yes
set wlan2 disabled=yes
/ip route
add disabled=yes distance=1 gateway=172.27.27.1
/system clock
set time-zone-name=America/New_York
/system identity
set name=PEBWiFi
/system ntp client
set enabled=yes primary-ntp=172.27.27.1
 
Ivoshiee
Member
Member
Posts: 471
Joined: Sat May 06, 2006 4:11 pm

Re: RB411AR - Horrible range with built-in wireless card

Tue Nov 06, 2012 6:06 am

RB411AR onboard radio is known to be with medicore sensitivity (MT when you'll fix it?), but 10 feet is not the ultimate range of it. Try to change the frequency channel.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: RB411AR - Horrible range with built-in wireless card

Tue Nov 06, 2012 8:23 am

RB411AR onboard radio is known to be with medicore sensitivity (MT when you'll fix it?), but 10 feet is not the ultimate range of it. Try to change the frequency channel.
I think he fixed it already:
Well I completely reset the unit again and took advantage of the "quick set" feature to do the initial config and it now works! Great range of B/G and N. Whew.
No answer to your question? How to write posts
 
gaz90
just joined
Posts: 3
Joined: Thu May 30, 2013 9:27 pm

Re: RB411AR - Horrible range with built-in wireless card

Thu May 30, 2013 9:36 pm

Firstly hello!

ok - silly question, I'm looking to get the same setup, why is the main antenna socket not used (it's not on the board reverse side)? For Antenna diversity that would require 4 antennas?

Thanks,
Gareth.
 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Re: RB411AR - Horrible range with built-in wireless card

Thu May 30, 2013 9:59 pm

Someone correct me if I'm wrong -- but I think his problem was setting the Antenna mode to ant-b when it should have been set to ant-a.

The 411AR's built in radio is a SISO, 802.11b/g device with only a single MMCX jack, so there is no ant-b present on the device.

Either way it's fixed -- and as for the low power. If you're in an apartment this is a perfect device to use. With the appropriate Omni and Line of Sight I have 411AR's covering 0.5-1mile radius.

Also your wireless-protocol should be set to 802.11 unless installing in a mikrotik only environment. This was probably corrected by QuickSet as well.
William Burnett
Network Engineer
 
BackwardsCire
just joined
Topic Author
Posts: 21
Joined: Tue Jun 26, 2012 3:19 pm

Re: RB411AR - Horrible range with built-in wireless card

Fri May 31, 2013 3:03 pm

I don't know exactly what combination of settings I had done incorrectly, but it was more than just antenna mode as I had tried multiple settings with no luck. I must have had some things set that forced something not to want to work right.

I do recommend something like this. It has been working great and now that I'm in a new house without many neighbors the range is great for residential use. I have some Ethernet cable running to the 2nd floor so I have the access point in the middle of the house and it covers the whole place and the surrounding outside well.

One of the other benefits is that though my "ordeal" I learned a ton about wireless that I as an IT guy never knew before. For instance, that the size and dB rating of the antenna is opposite of what you may expect (e.g. higher dB isn't necessarily mean that it will give you more range/stronger signal as it changes the shape of the signal radiation pattern. http://www.liveport.com/wireless-antenna-properties).

Anyway, if you get the RB411AR, you need one antenna to hook to the board itself (plus how ever many you need for the additional card). Ensure that you immediately upgrade it to the latest code and then do a factory reset. Then use the quickset to do the initial config before you start changing settings. That will get you up and running the easiest way.
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 655
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: RB411AR - Horrible range with built-in wireless card

Thu Jan 16, 2014 6:12 am

Configuration notes:
- Frequency mode is manual txpower
- Country is USA
- Antenna mode is antenna a
- 0 dBi for Antenna Gain
Note also that setting country to USA immediately reduces your power level well below the USA maximum due to miscalculation in ROS. So if you need more performance, avoid using "regulatory domain" and instead use this table to calculate power settings manually.

Who is online

Users browsing this forum: No registered users and 24 guests