Community discussions

 
Trackboy
Member Candidate
Member Candidate
Topic Author
Posts: 212
Joined: Mon Oct 31, 2011 11:19 am
Location: Hungary

Mikrotik Routerboard 751U-2HnD wireless problems

Mon Dec 10, 2012 9:58 pm

Hello everybody!I have got an RB 751 with 5.20,the wireless is unuseable.

I am using 802.11 N with 40 Mhz channel bandwith,and i want to connect my Lenovo G 580,my laptop get network configuration,but the Internet not working,only very slow.On my laptop running Ubuntu 12.04 Linux.I tried adjust the tx power but it could not help.

I know this device has 1 W super strong wifi.But i don't know what cause the problem.There is something wrong with my laptop wifi,incompatible?

I appreciate your help
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Mon Dec 10, 2012 10:21 pm

some things you can set. open the webfig, go to wireless menu, click "advanced mode" and set the following:

- channel width 20/40 above
- mode 2ghz b/g/n
- distance INDOORS
- tx chains ENABLE BOTH
- rx chains ENABLE BOTH

--> apply changes

check what you have in the Registration Table. if the signal is [-80 to -60] then it's ok. If the signal is [-60 to -30] then it's too strong. set tx-power-mode to "card rates" and change tx-power to "10" (lower is better!)
No answer to your question? How to write posts
 
Trackboy
Member Candidate
Member Candidate
Topic Author
Posts: 212
Joined: Mon Oct 31, 2011 11:19 am
Location: Hungary

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Tue Dec 11, 2012 4:52 am

Ok the result is with this setting,10dbm tx power:

Registrtation table:-39-50 dbm,CCQ:6%,Signal to noise:50-60 dB,that is happening now,i know this is bad result,but i tried reduced the tx power,but the results are same
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Tue Dec 11, 2012 7:36 am

try to move the device away from your PC. the signal is still too strong.
No answer to your question? How to write posts
 
Trackboy
Member Candidate
Member Candidate
Topic Author
Posts: 212
Joined: Mon Oct 31, 2011 11:19 am
Location: Hungary

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Tue Dec 11, 2012 4:46 pm

I tried another asus laptop,and with that working fine,maybe something problem with Lenovo wifi?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Wed Dec 12, 2012 7:42 am

Also possible that one of the laptops doesn't have two antennas (just one) or doesn't support 40MHz channel width. Or has weak wifi card.
No answer to your question? How to write posts
 
User avatar
nickshore
Member
Member
Posts: 472
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Wed Dec 12, 2012 12:25 pm

Sometimes the power saving mode when you run a laptop on batteries can cause very poor performance.

You can solve this by turning the power management off:
iwconfig wlan0 power off
See the blog I wrote about this: http://blog.linitx.com/fixing-slow-lapt ... -on-linux/

Hope this is useful

Nick
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
Trackboy
Member Candidate
Member Candidate
Topic Author
Posts: 212
Joined: Mon Oct 31, 2011 11:19 am
Location: Hungary

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Thu Dec 13, 2012 4:43 am

Seems to be had a problem with the laptop wifi driver,i solved the problem
 
hngjared
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu Dec 01, 2011 8:36 pm
Location: NYC USA

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Wed Apr 03, 2013 11:31 pm

I have issues with different laptops that are using power saving modes being unable to use the wifi from the MikroTik APs. I don't have any problems with Ruckus, Dlink or Panoptic.

Is there any way MikroTik can fix this?! This is very inconvenient as the majority of laptops come pre-configured with the power saving option enabled.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Thu Apr 04, 2013 9:23 am

MikroTik currently has not implemented power saving features, so we recommend turning it off. We will research how to solve this issue in RouterOS.
No answer to your question? How to write posts
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Mon Apr 08, 2013 9:21 am

I have issues with different laptops that are using power saving modes being unable to use the wifi from the MikroTik APs. I don't have any problems with Ruckus, Dlink or Panoptic.

Is there any way MikroTik can fix this?! This is very inconvenient as the majority of laptops come pre-configured with the power saving option enabled.
Can you specify exactly what laptops and what wireless chipsets they are using and what power-saving options they have enabled by default?

What version of the RouterOS you are using?
What are the symptoms when you use the power saving?
If you disable the powersaving on the client everything is working ok?
 
hngjared
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu Dec 01, 2011 8:36 pm
Location: NYC USA

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Fri Apr 19, 2013 11:35 pm

I'm away from the office and test laptops but I have one with me; Gateway. Wireless: Realtek RTL8192SE Wireless LAN 802.11n PCI-E NIC. All the power saving options are affected. Only way it works is if it is set to "Maximum Performance".

Also, I have a Lenovo with a Atheros AR9285 that works perfectly fine on all 3 models.

Symptoms. Connection will intermittently drop about 50% of packets for a minute or 2 before dropping all packets all together. However, it does stay connected to SSID from the MikroTik. As soon as the laptop is plugged in or power option is changed from power saving to Maximum Performance the packets begin responding again.

Router OS versions: I didn't document the exact versions (If needed I can grab those on Monday). I tried 3 different APs but don't have exact OS. I know it was 5.x and 6.12. All had the same outcome.

I've tried this on the RB411U, RB711UA-2HnD, RB951G-2HnD.

Yes, once power saving is disabled everything works great.

Let me know if there's anything else I can provide to help.
 
carragom
just joined
Posts: 1
Joined: Mon Feb 14, 2011 3:51 am

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Sat Oct 05, 2013 8:47 am

As stated by hngjared most devices now ship with power saving capabilities and it's normally activated when the device is not connected to a power outlet, which means most of the time for mobile devices. To make things worse on some devices this can't be disabled at all, effectively making the mikrotik router useless. Has there been any progress in this area at all?, I'm willing to test.
 
Trackboy
Member Candidate
Member Candidate
Topic Author
Posts: 212
Joined: Mon Oct 31, 2011 11:19 am
Location: Hungary

Re: Mikrotik Routerboard 751U-2HnD wireless problems

Tue Jan 14, 2014 8:31 pm

Hello everybody! I tested the wireless connection between my RB751 and Samsung Laptop:

On my PC running an Proftpd server under Ubuntu 12.04:connected to 751's eth2
Samsung laptop ( 40 Mhz support 1*1 MIMO 150 Mbit/sec ) connected to the 751's wlan port, i am not using bridge, only static routes.

The tcp bandwith very nice: around 80-90 Mbit/sec and the cpu load is 50-65%

I just would like to congratulations for the Mikrotik support, the new RouterOS 6 is working very well.

Anyway this RB has only 400 Mhz CPU with 32 MB Memory

Who is online

Users browsing this forum: No registered users and 10 guests