Community discussions

 
49er
Member
Member
Topic Author
Posts: 401
Joined: Tue Sep 27, 2011 7:55 am

Use as 3g hotspot?

Sat Jan 26, 2013 10:19 pm

Hi,
I have a mikrotik RB751U 2HnD
I have connected an Huawei E180 to the USB port.
Now how do I have to configure the mikrotik to use it as a 3g modem?
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: Use as 3g hotspot?

Sat Jan 26, 2013 11:21 pm

Go through these steps:

1) plug it in and check if ppp-out1 interface appears
2) set the correct data channel and info channel in ppp-out1 properties
3) set correct APN name in properties
4) add nat rule
/ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ppp-out1
further reading: http://mybroadband.co.za/vb/showthread. ... -3G-Modems
 
49er
Member
Member
Topic Author
Posts: 401
Joined: Tue Sep 27, 2011 7:55 am

Re: Use as 3g hotspot?

Sun Jan 27, 2013 2:17 pm

Hi,

The ppp-out1 is there and is running.
The nat rule I add.
But still can get internet connection from Interface 1, 2, 3, 4 or 5
So I must do more but what?
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: Use as 3g hotspot?

Sun Jan 27, 2013 4:55 pm

In ppp-out1 settings disable 'Dial On Demand', enable 'Add Defaul Route', enable 'Use Peer DNS'.

If it doesn't help, then please post output from this command:
interface ppp-client print
 
49er
Member
Member
Topic Author
Posts: 401
Joined: Tue Sep 27, 2011 7:55 am

Re: Use as 3g hotspot?

Sun Jan 27, 2013 5:31 pm

I have done settings below and now it is working.
Are ther security issues in it?

# Set system identity
/system identity set name=mt01

# Add bridges
/interface bridge add name=BR-LAN disabled=no

# Turn on WLAN
/interface wireless enable wlan1

# Hide SSID wlan1 (mikrotik)
/interface wireless set wlan1 hide-ssid=yes

# Set wireless mode
/interface wireless set mode=ap-bridge wlan1 band=2ghz-b/g/n ht-txchains=0,1 ht-rxchains=0,1

# Add a security profile
/interface wireless security-profile add name=LAN authentication-type=wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm wpa2-pre-shared-key="3gACCESS" mode=dynamic-keys

# Set wireless channel
/interface wireless set wlan1 channel-width=20/40mhz-ht-above

# Set wirless protocol
/interface wireless set wlan1 wireless-protocol=any

# Add virtual-ap
/interface wireless add master-interface=wlan1 ssid=3gLANAP security-profile=LAN name=VAP-LAN disabled=no

# Add ports to Bridge
/interface bridge port add interface=ether1 bridge=BR-LAN disabled=no
/interface bridge port add interface=ether2 bridge=BR-LAN disabled=no
/interface bridge port add interface=ether3 bridge=BR-LAN disabled=no
/interface bridge port add interface=ether4 bridge=BR-LAN disabled=no
/interface bridge port add interface=VAP-LAN bridge=BR-LAN disabled=no

# IP toewijzen aan BR-LAN
/ip address add address=192.168.1.254/24 interface=BR-LAN

# Add DHCP-Address-Pool
/ip pool add name=LAN range=192.168.1.1-192.168.1.253

# Add DHCP-Server BR-LAN
/ip dhcp-server add interface=BR-LAN name=DHCP-LAN address-pool=LAN lease-time=3d disabled=no
/ip dhcp-server network add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.254 netmask=255.255.255.0

# Set interface ppp-client settings
/interface ppp-client set 0 disabled=no dial-on-demand=no add-default-route=yes

# Add default Gateway
/ip route add gateway=192.168.1.254

# Add NAT
/ip firewall nat add chain=srcnat action=masquerade out-interface=ppp-out1

# Add NTP server
/system ntp client set primary-ntp=128.204.195.6 mode=unicast enabled=yes

# Enable Graphs
/tool graphing interface add interface=BR-LAN

# Set Admin password
/user set admin password=Password

Who is online

Users browsing this forum: No registered users and 36 guests