Community discussions

MUM Europe 2020
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Nstream is not suitable for 2x2 ?

Mon Apr 22, 2013 10:37 am

Hello. We have 1,5km 2x2 P2P link with dual parabolic antenas. All works fine with NV2, both sides have 5.24
Troughput is 55Mbit. CCQ and link uptime is good.
dual.jpg
But when I change protocol to Nstream, then periodic disconnect. Why?
Nstream 2x2.jpg
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
Requium
just joined
Posts: 19
Joined: Fri Jun 29, 2012 4:41 pm

Re: Nstream is not suitable for 2x2 ?

Mon Apr 22, 2013 3:27 pm

i have the same problem, its kinda unstable, i use Nv2 with some clientes, its more stable but it have problems with the througput behind de wireless equipment on TCP protocol :/ but Nstreme is stable on throughput :/, i think we have to wait for some fixes about the protocols.

BR
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: Nstream is not suitable for 2x2 ?

Tue Apr 23, 2013 12:46 am

They dont even work on this issue
 
0ldman
Forum Guru
Forum Guru
Posts: 1446
Joined: Thu Jul 27, 2006 5:01 am

Re: Nstream is not suitable for 2x2 ?

Wed Apr 24, 2013 7:17 pm

Typically, if I have a problem with nstreme it is usually related to local noise, another AP on my tower or something similar.
 
Insider
Member Candidate
Member Candidate
Posts: 200
Joined: Mon Jun 27, 2005 4:51 pm
Location: Czech
Contact:

Re: Nstream is not suitable for 2x2 ?

Wed May 01, 2013 12:10 pm

Nstreme is kind of unstable. We tried it on several dozen links in laboratory, but it behaves like a monkey with a granade in the hand. It drops thruput instantly for 70Mbit and then returns etc.. maybe it needs some re work, as it bring very good latency results..
Frequency microwave transvertors, design, development, manufacture
http://Pojitko.cz
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: Nstream is not suitable for 2x2 ?

Thu May 02, 2013 11:45 am

Nstreme is kind of unstable. We tried it on several dozen links in laboratory, but it behaves like a monkey with a granade in the hand. It drops thruput instantly for 70Mbit and then returns etc.. maybe it needs some re work, as it bring very good latency results..
This is happening because your data rate is drooping to lower speed (if u tested in lab that mean its not noise or interference problem) dont know why in my case most common it is happening when the link is on high load
when u do disable/enable on wlan interface it is going back to normal
U can fix that in data rate u can select best rate - but always its not working like it should be (not for me)
also I hate disconnect/reconnect problem
nstreme definitely need makeup
 
Insider
Member Candidate
Member Candidate
Posts: 200
Joined: Mon Jun 27, 2005 4:51 pm
Location: Czech
Contact:

Re: Nstream is not suitable for 2x2 ?

Thu May 02, 2013 12:09 pm

My feel is it is matter of speed set function fail. For example NV2 is made by small speed step ups , step downs in slow decissions, so it takes a time to get on operating speed quite some time, but then it is really robust. Nstreme is like to switch speed immediately, once it looses several pacakges and then it is very hesitative to get back on former speed (same as by AirMax), like it wont resend only demaged packages in lower speed.. it is like monkey on steroids.

Take speed select from NV2 and give it to Nstreme..
Frequency microwave transvertors, design, development, manufacture
http://Pojitko.cz
 
mars
Member Candidate
Member Candidate
Posts: 228
Joined: Sun Mar 14, 2010 1:43 pm

Re: Nstream is not suitable for 2x2 ?

Thu May 02, 2013 8:33 pm

nstreme use to work fine on all links until nv2 was developed
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: Nstream is not suitable for 2x2 ?

Tue May 07, 2013 5:50 am

I really wish they would improve the performance with Nstreme and 2X2. I use Mtik for most of my backhauls, and the latency has increased on each PtP to now 3-8ms. With good old Nstreme, it was a solid 1ms MOST of the time!!!

I have to use NV2 now, because I get more throughput, like 40% more. It would be nice if they could have an option to lower latency on NV2, in exchange for a little lower throughput, or fix Nstreme to work more effeciant with 2X2.
 
Insider
Member Candidate
Member Candidate
Posts: 200
Joined: Mon Jun 27, 2005 4:51 pm
Location: Czech
Contact:

Re: Nstream is not suitable for 2x2 ?

Thu May 09, 2013 2:24 pm

Any comments from Latvia?
Frequency microwave transvertors, design, development, manufacture
http://Pojitko.cz
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: Nstream is not suitable for 2x2 ?

Thu May 09, 2013 2:29 pm

if you have problems with Nstreme wireless protocol with lot of disconnection "too many poll timeouts" please write to support and also provide us remote access to both ends so we could check why it is disconnecting so frequency.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: Nstream is not suitable for 2x2 ?

Thu May 09, 2013 3:40 pm

Nstreme is kind of unstable. We tried it on several dozen links in laboratory, but it behaves like a monkey with a granade in the hand. It drops thruput instantly for 70Mbit and then returns etc.. maybe it needs some re work, as it bring very good latency results..
The problem could be that you are testing the link in the laboratory - the devices are too close to each other, the signal is too strong, you could also experience some misconfiguration. How are you measuring the throughput?
 
Insider
Member Candidate
Member Candidate
Posts: 200
Joined: Mon Jun 27, 2005 4:51 pm
Location: Czech
Contact:

Re: Nstream is not suitable for 2x2 ?

Thu May 09, 2013 5:34 pm

if you have problems with Nstreme wireless protocol with lot of disconnection "too many poll timeouts" please write to support and also provide us remote access to both ends so we could check why it is disconnecting so frequency.
I can do that, but it is common problem of thruput stability met by the others as well. Try it your self , I am completely other stuff, we are operating polution free enviroment on 9GHz with your equipment, and it behaves diametrically other way then NV2, which stability is fine, even with speed rising, but during high rate transmitions (180Mbit thruput TCP + on radio) it behaves really strange. Espesially during traffic pattern changes. You should get same reusult once you will make line on your table.. I tested more than couple hundreds of units during last several week and it is all the same.
Frequency microwave transvertors, design, development, manufacture
http://Pojitko.cz
 
Insider
Member Candidate
Member Candidate
Posts: 200
Joined: Mon Jun 27, 2005 4:51 pm
Location: Czech
Contact:

Re: Nstream is not suitable for 2x2 ?

Thu May 09, 2013 5:55 pm

Nstreme is kind of unstable. We tried it on several dozen links in laboratory, but it behaves like a monkey with a granade in the hand. It drops thruput instantly for 70Mbit and then returns etc.. maybe it needs some re work, as it bring very good latency results..
The problem could be that you are testing the link in the laboratory - the devices are too close to each other, the signal is too strong, you could also experience some misconfiguration. How are you measuring the throughput?

Simply not.. The feedbacks are from customers in real live testing as well, so there is some -65dBm on RX and range is in several hundreds m. Even in laboratory are radios some 2-3 meters away from each other. Power is set on 2 dBm, and there is 65dB attenuator on cable connections between them - it is not lab issue.
OK, I can get some pieces which are just wonderfull until next reset :) But this is not deal.
Frequency microwave transvertors, design, development, manufacture
http://Pojitko.cz
 
ropeba
Member Candidate
Member Candidate
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: Nstream is not suitable for 2x2 ?

Wed Jun 26, 2013 6:29 pm

True, nstream no longer works ok. The last 15 days I have commissioned 10 new links based on the RB911 and JRC duplex 24 antennas. Signals on the links are -50 to -60 but none of the links with active NSTREAM has no uptime higher than 2h. Log on the client side says "lost connection, not polled for too long" and log the AP side "disconnected, too many poll timeouts". Please note that the area is absolutely without interference. On RouterBOARD is OS version 6.1 and version 3.07 firmware. So, 10 links on 10 different places, interference-free area. With NV2 everything works ok but with big jitter, ping varies 4-50 ms.
 
sup5
Member
Member
Posts: 322
Joined: Sat Jul 10, 2010 12:37 am

Re: Nstream is not suitable for 2x2 ?

Thu Jun 27, 2013 12:29 am

I found out RouterOS 5.14 works stable with NSTREME on two chains,
where RouterOS 5.25 or 6.1 wont't work stable in the same situation.
Tested on several real life production links of varying distance and rf-"crowdiness".
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Thu Jun 27, 2013 10:21 am

Normis. You say - it is known bug. Why you don´t fix it?
http://forum.mikrotik.com/viewtopic.php ... 69#p375069

It is old bug and very serious.
Thanks
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24315
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Nstream is not suitable for 2x2 ?

Thu Jun 27, 2013 10:30 am

Normis. You say - it is known bug. Why you don´t fix it?
http://forum.mikrotik.com/viewtopic.php ... 69#p375069

It is old bug and very serious.
Thanks
I did not say it's a known bug. it is a simple error message (poll timeout). it can indicate all kinds of things.
No answer to your question? How to write posts
 
sup5
Member
Member
Posts: 322
Joined: Sat Jul 10, 2010 12:37 am

Re: Nstream is not suitable for 2x2 ?

Thu Jun 27, 2013 6:32 pm

normis, but what do you say about my findings?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: Nstream is not suitable for 2x2 ?

Fri Jun 28, 2013 11:06 am

normis, but what do you say about my findings?
could you test if this problem effects AP, Client or Both.
Could you test in which cases you have problems?
1. AP v5.14, Client v6.1
2. AP v6.1, Client v5.14
3. AP v6.1, Client v6.1

Then tell us in which of those three cases the nstreme is working fine and in which not.
After the findings maybe you could provide us with remote access to this link where you have the above problems.
 
Wavelan
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Fri Sep 01, 2006 10:23 am

Re: Nstream is not suitable for 2x2 ?

Fri Jun 28, 2013 2:21 pm

normis, but what do you say about my findings?
could you test if this problem effects AP, Client or Both.
Could you test in which cases you have problems?
1. AP v5.14, Client v6.1
2. AP v6.1, Client v5.14
3. AP v6.1, Client v6.1

Then tell us in which of those three cases the nstreme is working fine and in which not.
After the findings maybe you could provide us with remote access to this link where you have the above problems.
Dear all,

i can reconfirm that :

in mikrotik version from 5.22 and 5.25 combination from :
- nstreme
- dual chain
- rb911g-5hnD or rb711-5hnD
- 802.11n dual chain

is very unstable, have many disconnection because poll timeout.

16:31:39 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, too many poll timeouts
16:33:24 wireless,info D4:CA:6D:5B:2D:65@wlan0: connected
16:44:24 system,info,account user admin logged out from 10.31.64.36 via winbox
17:27:11 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, extensive data loss
17:27:32 wireless,info D4:CA:6D:5B:2D:65@wlan0: connected
17:27:46 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, extensive data loss
17:28:04 wireless,info D4:CA:6D:5B:2D:65@wlan0: connected
17:33:11 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, too many poll timeouts
17:33:28 wireless,info D4:CA:6D:5B:2D:65@wlan0: connected
17:34:22 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, extensive data loss
17:37:23 wireless,info D4:CA:6D:5B:2D:65@wlan0: connected
17:45:25 wireless,info D4:CA:6D:5B:2D:65@wlan0: disconnected, extensive data loss

We had to change many things :
- disable periodic calibration
- change frequency

Even we're using good antenna (solid parabolic) and in multiple location both noisy and clean,
the sytomp is the same.

I can't downgrade to 5.14 and 4.16 because rb911g can't use 4.xx or even 5.14.

Thx
//Rudi
 
dada
Member Candidate
Member Candidate
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: Nstream is not suitable for 2x2 ?

Sun Jun 30, 2013 12:14 pm

My experience with nstreme is that it doesn't work with 2x2 MIMO and it has problems with even 1x1 802.11N. If the 802.11N (1x1 or 2x2) is used with Nstreme than the link quality is poor and the modulation speeds tends to show random behavior.
The last test case was before few days. PtP link with 2xRB411AH, ROS5.25, DBII wifi cards, 2x Jirous JRC-24 Extreme parabolic antennas, rx level in each chain better than -59dBm. Initially the 802.11N with 2x2 MIMO enabled and nstreme was used. The link throughput was very bad and unstable. CCQ anywhere between 20-60 and the modulation speed deep under 130mbps. When the link was switched to NV2 the CCQ level raised to 90+ and the modulation speed holds on 130mbps
 
Ivoshiee
Member
Member
Posts: 471
Joined: Sat May 06, 2006 4:11 pm

Re: Nstream is not suitable for 2x2 ?

Sun Jun 30, 2013 6:17 pm

Interesting. I've experiencing similar issues with my nstream links - links are going down despite strong signal level. I've suspected interference etc. Now I'll try nv2 to see if it will make a change.
 
dada
Member Candidate
Member Candidate
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: Nstream is not suitable for 2x2 ?

Sun Jun 30, 2013 9:48 pm

Interesting. I've experiencing similar issues with my nstream links - links are going down despite strong signal level. I've suspected interference etc. Now I'll try nv2 to see if it will make a change.
or you can try to switch (temporarily) to 802.11A (one end is enough - select the nearer one). You will run on one chain and max modulation will be 54mbps but you will see of the link is good or not (assuming that you have chain0 on both ends in the same polarisation - if not you will see significant RX signal drop or the link will not connect at all)
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Nstream is not suitable for 2x2 ?

Tue Jul 02, 2013 3:35 pm

Ticket #2013070266000658

SXTG 5HnD <-----> SXTG 5HnD
600meter PtP link, clear LoS and clear fresnel zone.
nstreme with v6.1.
You do not have the required permissions to view the files attached to this post.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
Robinson
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Tue Nov 10, 2009 7:30 pm

Re: Nstream is not suitable for 2x2 ?

Wed Jul 03, 2013 5:37 pm

I have read all the posts related to similar problems but have not found anything concrete...

We have P2P link on cca 12km, jirous dish (MIMO 29 dBi) anthenna on bot sides. One side is RB433GL with R52HN card, other side RB711-5HnD.
Signal streinght is 60/60 ccq: 98/98...100/100
Spectrum is completely free and there is no interference on 5Ghz band and this channel.
Must use nstreme becouse I can not afford the high ping (nv2).
I thought it was a problem in nstreme and "5Ghz-n" wireless mode but now conf. is in "5Ghz-a" mode and it is the same...

Client side report ewery 30-60 min:lost connection, not polled for too long
Bridge: disconnected, too many poll timeouts

Station (RB433GL with R52HN) conf.:
# jul/03/2013 08:10:03 by RouterOS 5.24
# software id = *******
#
/interface wireless security-profiles
set [ find default=yes ] authentication-types="" eap-methods=passthrough group-ciphers=aes-ccm group-key-update=5m \
interim-update=0s management-protection=disabled management-protection-key="" mode=none name=default \
radius-eap-accounting=no radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled \
radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=\
none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=none tls-mode=\
no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=""
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" arp=proxy-arp band=5ghz-a basic-rates-a/g=\
6Mbps basic-rates-b=1Mbps bridge-mode=enabled channel-width=20mhz compression=no country=croatia \
default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
disable-running-check=no disabled=no disconnect-timeout=3s distance=14 frame-lifetime=0 frequency=5580 \
frequency-mode=manual-txpower frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 \
ht-amsdu-threshold=8192 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=any \
ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mc\
s-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" ht-txchains=0,1 \
hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 \
mac-address=xx:xx:xx:xx:xx:xx max-station-count=2007 mode=station-bridge mtu=1500 multicast-helper=default name=\
wlan1 noise-floor-threshold=default nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=\
default nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms periodic-calibration=default \
periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=xxxxxxxxxxxx \
rate-selection=advanced rate-set=default scan-list=default security-profile=default ssid=SOME-LINK \
station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-power=18 tx-power-mode=card-rates \
update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no \
wds-mode=disabled wireless-protocol=nv2-nstreme-802.11 wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan1 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps\
:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0:17,HT4\
0-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan1 disable-csma=no enable-nstreme=yes enable-polling=yes framer-limit=3200 framer-policy=none
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 \
frame-size=300 frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no receive-errors=no \
streaming-enabled=no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
Bridge RB711-5HnD conf. :
# jan/11/1970 17:00:02 by RouterOS 5.24
# software id = *******
#
/interface wireless security-profiles
set [ find default=yes ] authentication-types="" eap-methods=passthrough group-ciphers="" group-key-update=5m \
interim-update=0s management-protection=disabled management-protection-key="" mode=none name=default \
radius-eap-accounting=no radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled \
radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=\
none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=none tls-mode=\
no-certificates unicast-ciphers="" wpa-pre-shared-key="" wpa2-pre-shared-key=""
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" arp=proxy-arp band=5ghz-a/n \
basic-rates-a/g=6Mbps bridge-mode=enabled channel-width=20/40mhz-ht-above compression=no country=croatia \
default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
disable-running-check=no disabled=no disconnect-timeout=3s distance=dynamic frame-lifetime=0 frequency=5580 \
frequency-mode=manual-txpower frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 \
ht-amsdu-threshold=8192 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=any \
ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mc\
s-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" ht-txchains=0,1 \
hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 \
mac-address=XX:XX:XX:XX:XX:XX max-station-count=2007 mode=bridge mtu=1500 multicast-helper=default name=wlan1 \
noise-floor-threshold=default nv2-cell-radius=13 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default \
nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms periodic-calibration=default \
periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=XXXXXXXXXX \
rate-selection=advanced rate-set=default scan-list=default security-profile=default ssid=SOME-LINK \
station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
tdma-period-size=3 tx-power=22 tx-power-mode=card-rates update-stats-interval=disabled wds-cost-range=50-150 \
wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=nstreme \
wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan1 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps\
:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0:17,HT4\
0-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan1 disable-csma=no enable-nstreme=yes enable-polling=yes framer-limit=3200 framer-policy=best-fit
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 \
frame-size=300 frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no receive-errors=no \
streaming-enabled=no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
 
Robinson
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Tue Nov 10, 2009 7:30 pm

Re: Nstream is not suitable for 2x2 ?

Sat Jul 06, 2013 10:34 am

It would be good if someone from Mikrotik offer a solution for this general problem.
Or just prompt answers on support.
When our users is dissatisfied then there is no time for waiting.. How do we explain them that connection is drop but we don't now how?

In my case link work stable until we update routers with some of new version of RoS. We can not exactly say which version, because it's been a while since first user reports a problems.

Did someone noticed which version works OK on 802.11n and 2*2 MIMO??
 
dada
Member Candidate
Member Candidate
Posts: 245
Joined: Tue Feb 21, 2006 1:44 pm

Re: Nstream is not suitable for 2x2 ?

Sat Jul 06, 2013 11:46 pm

In my case link work stable until we update routers with some of new version of RoS. We can not exactly say which version, because it's been a while since first user reports a problems.

Did someone noticed which version works OK on 802.11n and 2*2 MIMO??
on our local ISP forum somebody said that 5.14 is the version...
 
Robinson
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Tue Nov 10, 2009 7:30 pm

Re: Nstream is not suitable for 2x2 ?

Sun Jul 07, 2013 1:19 am

In my case link work stable until we update routers with some of new version of RoS. We can not exactly say which version, because it's been a while since first user reports a problems.

Did someone noticed which version works OK on 802.11n and 2*2 MIMO??
on our local ISP forum somebody said that 5.14 is the version...
Now I'm looking other PtP link ver. 5.20, nstreme, 2*2MIMO 802,11n link active 5 days. Not the best, but ok :-/

# INTERFACE RADIO-NAME MAC-ADDRESS AP SIGNAL-STRENGTH TX-RATE UPTIME
0 wlan1 000------------ xxxxxxxxxxxxxxxxxx yes -64dBm@6Mbps 117.... 5d15h37m47s

EDIT:

Tested that link works stable with nv2 802.11n 2*2 MIMO, but ping :-/ 4-10 ms. I must temp. use that config to hawe stable connection :-(
 
mperdue
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Jun 30, 2004 8:18 pm

Re: Nstream is not suitable for 2x2 ?

Wed Jul 24, 2013 5:27 am

You know what drives me crazy? After reading this? I can only get N-stream 2xmimo links to work. Nv2 will not stay connected. Using 6.1. RB711 with the built in radio's.
(on any of my 14 5.8Mhz point to point links)
-Michael
 
marcin21
Member Candidate
Member Candidate
Posts: 188
Joined: Tue May 04, 2010 4:50 pm

Re: Nstream is not suitable for 2x2 ?

Thu Jul 25, 2013 1:06 pm

hmm, i just wanted to confirm 5.14 to be the right version having in mind one of my rb433
that because of nice uptime I didn't upgraded. It's right now running nstreme
link uptime 43d15h, 100/100ccq, latency 0/0/2 ms in kind of noisy environment! but what
astonished me that it's 4.14 ROS :)
Back to the first steps in 802.11n i had long long working ( 1,5year ) link in nstreme 2x2 with ROS 4.3,
just when i started to play with new releases i've never get back the stability of 4.3.
maybe unroll some changes in driver and gain at least temporary solution.
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Wed Feb 05, 2014 11:57 pm

From ROS 6.7 it works. Uptime 32days and no dissconnect
LAN, FTTx, Wireless. ISP operator
 
SalimLeb
just joined
Posts: 17
Joined: Tue Jan 29, 2013 1:55 pm

Re: Nstream is not suitable for 2x2 ?

Fri Oct 17, 2014 4:29 pm

I have the latest ROS verion 6.21rc8 and I have the same issue. trying all recommendation by mikrotik support, but still have the same problems,
The link performance is more than the expectation, but it drops or have low data rate frequently.
Mikrotik recommend to enable wireless FP package, reset resting and reconfigure, upgrade to the latest test version of ROS.. nothing solve the problem.

note that after upgrading to the latest version, now I have no logs with the error I have before the upgrade such as (management protection failure. / ether1 link down, ether1 link up. / no network that satisfies connect-list, by default choose with strongest signal. / failed to select netwrok. / delaying scanning... must select a netwok... empty. / wlan1: failed to set bridge port for wlan1, reason: device already added as bridge port (6)...

Now I don't have any of these logs, but the same problem with the same occurrence frequency.
restarting the one of the RB was solving the problem when the link drops.

after upgrading the link doesn't drop, but it have very low performance most of the time..
new.png
You do not have the required permissions to view the files attached to this post.
 
und3ath
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 23, 2009 7:01 pm

Re: Nstream is not suitable for 2x2 ?

Fri Oct 17, 2014 4:39 pm

I have the latest ROS verion 6.21rc8 and I have the same issue. trying all recommendation by mikrotik support, but still have the same problems,
The link performance is more than the expectation, but it drops or have low data rate frequently.
Mikrotik recommend to enable wireless FP package, reset resting and reconfigure, upgrade to the latest test version of ROS.. nothing solve the problem.

note that after upgrading to the latest version, now I have no logs with the error I have before the upgrade such as (management protection failure. / ether1 link down, ether1 link up. / no network that satisfies connect-list, by default choose with strongest signal. / failed to select netwrok. / delaying scanning... must select a netwok... empty. / wlan1: failed to set bridge port for wlan1, reason: device already added as bridge port (6)...

Now I don't have any of these logs, but the same problem with the same occurrence frequency.
restarting the one of the RB was solving the problem when the link drops.

after upgrading the link doesn't drop, but it have very low performance most of the time..
new.png

What are your signal levels?
I have these same problem, but I found out that when I have signal better than -55dBm (cca), eveyrthing works ok.
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Fri Oct 17, 2014 6:01 pm

For test, can you try ROS 6.7?
LAN, FTTx, Wireless. ISP operator
 
SalimLeb
just joined
Posts: 17
Joined: Tue Jan 29, 2013 1:55 pm

Re: Nstream is not suitable for 2x2 ?

Fri Oct 17, 2014 6:12 pm

Reading in the forum and other forums.. I found that NV2 may solve the problem. but if you are using he NV2 and you have the problem.. so it's not the solution.

here is what I found:
The key differences between Nv2 and Nstreme:
Reduced polling overhead - instead of polling each client, Nv2 AP broadcasts uplink schedule that assigns time to multiple clients, this can be considered "group polling" - no time is wasted for polling each client individually, leaving more time for actual data transmission. This improves throughput, especially in PtMP configurations.


I'm currently using Nstreme!
Any recommendation from NV2 users?
 
User avatar
kapulan
Member Candidate
Member Candidate
Posts: 110
Joined: Tue Feb 07, 2006 7:48 pm
Location: Hungary

Re: Nstream is not suitable for 2x2 ?

Sat Oct 18, 2014 2:05 pm

For test, can you try ROS 6.7?
Hi !

Are use only 2x2 or 1x1 chain ? My test resolution 1x1 work fine nstream on 64QAM modulation , but change the settings to dual chain random disconnection and slow speed !
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Sat Oct 18, 2014 3:06 pm

For test, can you try ROS 6.7?
Hi !
Are use only 2x2 or 1x1 chain ? My test resolution 1x1 work fine nstream on 64QAM modulation , but change the settings to dual chain random disconnection and slow speed !
After 6.7 we have no problem with 2x2 nstream. This is P2P link. 2x2, hw retries 15, 2,3km distance.
No problem with speed and disconnect. Works well from 6.7. Now with 6.18. Uptime is only 9days because - power outage
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
lucky79
Member Candidate
Member Candidate
Posts: 127
Joined: Sat Sep 27, 2014 1:24 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Mon Oct 20, 2014 4:58 pm

For test, can you try ROS 6.7?
Hi !
Are use only 2x2 or 1x1 chain ? My test resolution 1x1 work fine nstream on 64QAM modulation , but change the settings to dual chain random disconnection and slow speed !
After 6.7 we have no problem with 2x2 nstream. This is P2P link. 2x2, hw retries 15, 2,3km distance.
No problem with speed and disconnect. Works well from 6.7. Now with 6.18. Uptime is only 9days because - power outage

Are you using wireless or wireless-fp?

Thanks
 
User avatar
kapulan
Member Candidate
Member Candidate
Posts: 110
Joined: Tue Feb 07, 2006 7:48 pm
Location: Hungary

Re: Nstream is not suitable for 2x2 ?

Thu Oct 23, 2014 9:57 am

For test, can you try ROS 6.7?
Hi !
Are use only 2x2 or 1x1 chain ? My test resolution 1x1 work fine nstream on 64QAM modulation , but change the settings to dual chain random disconnection and slow speed !
After 6.7 we have no problem with 2x2 nstream. This is P2P link. 2x2, hw retries 15, 2,3km distance.
No problem with speed and disconnect. Works well from 6.7. Now with 6.18. Uptime is only 9days because - power outage
And the speed udp or tcp ?

Thank you.
 
User avatar
honzam
Forum Guru
Forum Guru
Topic Author
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Nstream is not suitable for 2x2 ?

Thu Oct 23, 2014 2:03 pm

Are you using wireless or wireless-fp?Thanks
wireless
LAN, FTTx, Wireless. ISP operator

Who is online

Users browsing this forum: No registered users and 49 guests